Subject: [AAA-WG]: Issue 208: Peer State Machine incorrect in case of election

From: Pat Calhoun <[email-masked]>
Date: Thu, 25 Oct 2001 17:30:11 -0700

Submitter name: Pat Calhoun
Submitter email address: [email-masked] 
Date first submitted: 25-Oct-01 
Reference:  
Document: base 
Comment type: Technical 
Priority: 1
Section: 5.6
Rationale/Explanation of issue: 

The last state machine statement is incorrect.
Wait-Returns     Win-Election     I-Disc,R-Snd-CEA R-Open
                 I-Rcv-DPR        I-Snd-DPA,       R-Open
                                  R-Snd-CEA
                 I-Rcv-CEA        R-Snd-DPR        I-Open

If a CEA is returned with the proper error code, there is no reason
to send a DPR. Add the Result-Code value, and remove the DPR here.

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 30 Oct 2001 04:12:30 -0800

All,

I wish to reject this issue. If you look closely at the line in the state
machine in question, it causes a CEA to be sent on the Receiver socket, while
the DRP is sent on the Initiator socket. This is the result of an election.

Could the folks that originally wanted this fixed please speak up. Perhaps 
I missed something.

PatC

---

From: Don Zick <[email-masked]>
Date: Tue, 30 Oct 2001 09:53:42 -0500

I think when the issue was brought up a request was made to either remove the DPR
from the state machine during the election process or add a Disconnect-Cause that
would be appropriate for this DPR.  Is there a Disconnect-Cause appropriate for
this DPR?

Thanks,
Don

---

From: "Bob Kopacz" <[email-masked]>
Date: Tue, 30 Oct 2001 15:05:24 -0500

Hi,

My recollection was that we talked about adding a DPR cause code,
but later decided not to send DPRs during the election process,
only in Open state.

But my recollections are often wrong, and this wasn't my issue.

Bob K.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Steve Rich
> Sent: Tuesday, October 30, 2001 2:58 PM
> To: Pat Calhoun
> Cc: [email-masked]
> Subject: Re: [AAA-WG]: Issue 208: Peer State Machine incorrect in case
> of election
>
>
> Pat Calhoun writes:
>  > All,
>  >
> I think the discussion came around to adding a DPR cause code
> appropriate for closing the socket.
>
> sjr
>
>  >

---

From: Steve Rich <[email-masked]>
Date: Tue, 30 Oct 2001 14:57:32 -0500

sjr

---

From: Steve Rich <[email-masked]>
Date: Tue, 30 Oct 2001 15:59:16 -0500

Hi, Bob.

It was my issue. :)

I, for one, don't see the dropping one of the two sockets opened
during a glare condition and subsequent election as a ``Peer
Disconnection'', per se, but that could just be my interpretation.

sjr

---

From: Tony Johansson <[email-masked]>
Date: Wed, 31 Oct 2001 10:06:41 -0800

I agree. I think we said that a CEA with a new result-code set
"Disconnect peer" on the loosing connection instead of DPR/DPA. And only
use DPR's on open state connections.

/Tony