Subject: [AAA-WG]: Issue 205: Should AVPs be ordered?

From: Pat Calhoun <[email-masked]>
Date: Thu, 25 Oct 2001 17:28:58 -0700

Submitter name: Pat Calhoun
Submitter email address: [email-masked] 
Date first submitted: 25-Oct-01 
Reference:  
Document: base 
Comment type: Technical 
Priority: 3
Section: 3.2
Rationale/Explanation of issue: 

The base protocol spec command code ABNF doesn't specify that mandatory
AVPs don't necessarily need to appear before the optional ones. Add a 
sentence making this clearer.

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 30 Oct 2001 04:01:38 -0800

All,

I am not quite sure where the best place to fix this particular issue is, so
here is my recommendation:

3.2 Command Code ABNF

[...]

      required         = [qual] "{" avp-spec "}"
                         ; The AVP MUST be present and can appear 
                         ; anywhere in the message.

      optional         = [qual] "[" avp-name "]"
                         ; The avp-name in the 'optional' rule cannot 
                         ; evaluate to any AVP Name which is included
                         ; in a fixed or required rule. The AVP can
                         ; appear anywhere in the message.              

Comments welcomed,

PatC