Subject: [AAA-WG]: Issue 207: AAA URI inconsistent

From: Pat Calhoun <[email-masked]>
Date: Thu, 25 Oct 2001 17:29:47 -0700

Submitter name: Pat Calhoun
Submitter email address: [email-masked] 
Date first submitted: 25-Oct-01 
Reference:  
Document: base 
Comment type: Technical 
Priority: 1
Section: various
Rationale/Explanation of issue: 

Some examples of the URI in the spec does not include the aaa:// 
prefix. Add it to the examples.

The ABNF definition doesn't include the scheme name (aaa://). Add
that as well.

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 30 Oct 2001 04:08:39 -0800

All,

Here is my proposed text:

4.4 Derived AVP Data Formats

[...]
      Diameter-Identity  = "aaa://" fqdn [ port ] [ transport ]
                           [ protocol ] [ security ]

[...]

and changed:
      host.abc.com;transport=tcp
      host.abc.com:6666;transport=tcp
to:
      aaa://host.abc.com;transport=tcp
      aaa://host.abc.com:6666;transport=tcp

Comments welcomed,

PatC