Subject: [AAA-WG]: Which case AAA server provide Only Accounting Service to MN?

From: [email-masked]
Date: Fri, 19 Oct 2001 10:14:05 +0900

I have tried to think the following case : 
 
If MN shares statically the pre-established Security Association with FA
and HA, 
AAA server provides only an Accounting Service to MN.
 
Is that possible scenario?
 
Final question : 
	 at MIP network, I want to know which case AAA server provide Only
Accounting Service ? 
 
   Mobile Node   Foreign Agent 	  AAAF 		 AAAH 	 Home Agent
   ------------------   --------------------- 	------------- 	  ----------
----------
				 Advertisement &
		<--------- Challenge
 
		 Reg-Req  -------->
							 Reg-Req  ----------
-------------------------------------->
								<-----------
------------------------------------------ Reg-Reply
		  <---------- Reg-Reply

							  ACR --------------
-->
					  (Session-Id = foo)
	
ACR ----------------->
	
(Session-Id = foo)
	
<------------------- ACA
	
(Session-Id = foo)
 
							   <----------------
-- ACA
	
(Session-Id = foo)

---

From: "Kevin Purser" <[email-masked]>
Date: Fri, 19 Oct 2001 10:37:59 -0700

All,

We have added a small section at the end of the test specification for the
upcoming bakeoff.  This addendum serves to identify additional parameters or
modifications that have been discussed to consensus on the AAA WG mailing
list subsequent to the release of the alpha versions of the drafts.  This
section is intended solely to facilitate better interoperability during this
event, and in no way constitutes formal modifications to the alpha drafts.
Please feel free to email us with any additional items which may have been
omitted.

-Kev

---

From: "Kevin Purser" <[email-masked]>
Date: Fri, 19 Oct 2001 11:13:37 -0700

The link to the test spec is:
http://standards.ericsson.net/diameter-bake-off/diameter_testspec.html

----- Original Message -----
From: "David Frascone" <[email-masked]>
To: "Kevin Purser" <[email-masked]>
Sent: Friday, October 19, 2001 11:21 AM
Subject: Re: [AAA-WG]: Addendum to test specification

> A link would be nice :)
>
> On Fri, Oct 19, 2001 at 10:37:59AM -0700, Kevin Purser wrote:
> > All,
> >

---

From: Pat Calhoun <[email-masked]>
Date: Sat, 20 Oct 2001 13:42:12 -0700

> Is that possible scenario?

sure is. The MN doesn't include the MN-AAA auth ext, but the HA is configured
to send accounting messages.

> 	 at MIP network, I want to know which case AAA server provide Only

sorry, don't understand the question enough to provide an answer :(

PatC

---

From: "Bob Kopacz" <[email-masked]>
Date: Sun, 21 Oct 2001 13:07:27 -0400

Hi Kevin,

A couple minor questions:

1. At the bakeoff, for the values of the MIP-Replay-Mode AVP, should
we be using the incorrect 0/1/2 values (0=None, 1=Timestamps,
2=Nonces) from draft-ietf-aaa-diameter-mobileip-08-alpha01, or the
correct 1/2/3 (1=None, 2=Timestamps, 3=Nonces) values from the
upcoming draft-ietf-aaa-diameter-mobileip-08?

2. At the bakeoff, should the Accounting messages be carrying
Acct-Input-Octets, Acct-Output-Octets, Acct-Input-Packets, and
Acct-Output-Packets as 32-bit integers or 64-bit integers?

Thanks,
Bob K.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of Kevin Purser
> Sent: Friday, October 19, 2001 1:38 PM
> To: [email-masked]
> Subject: [AAA-WG]: Addendum to test specification
> 
> 
> All,
>

---

From: "Kevin Purser" <[email-masked]>
Date: Sun, 21 Oct 2001 14:41:25 -0700

Bob,

> upcoming draft-ietf-aaa-diameter-mobileip-08?

I remember this one being discussed and agreed that it should be 1/2/3, so
I'll go ahead and add this one to the test spec.

> Acct-Output-Packets as 32-bit integers or 64-bit integers?

Did we ever reach a concensus on this one?

-Kev

---

From: "Bob Kopacz" <[email-masked]>
Date: Mon, 22 Oct 2001 10:12:06 -0400

Hi Kevin,

> From: Kevin Purser [mailto:[email-masked]]
> Sent: Sunday, October 21, 2001 5:41 PM
> To: Bob Kopacz; [email-masked]

I don't know.  An issue (#182) was posted to make these attributes 32-bits,
as they are existing RADIUS attributes.  The issue hasn't been discussed
or rejected.  The issue is posted, though, in the "resolved" section
rather than the "open issues" section, so I took that to mean that
it has either been quietly accepted or is leaning that way.

Given that, I'd guess we'll be seeing these attributes as 64-bits at the
bakeoff, per the draft-08-alpha01's.  

I just want to set up my dictionary correctly for the bakeoff; that's
why I asked the question.

Bob K.

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 22 Oct 2001 08:09:28 -0700

> it has either been quietly accepted or is leaning that way.

the fix was obvious, so I just cleaned up the document. If you believe that the
fix is not correct, please let me know.

PatC