Subject: [AAA-WG]: Issue: wdRecoveryCount used for triggering failover procedures

From: "Fredrik Johansson" <[email-masked]>
Date: Wed, 10 Oct 2001 12:27:58 +0200

Submitter name: Fredrik Johansson
Submitter email address: [email-masked]
Date first submitted: 10-Oct-01
Reference:
Document: base-08-alpha
Comment type: technical
Priority: 1
Section: 5.5.3
Rationale/Explanation of issue:
  The wdRecoveryCount is used for both taking us from SUSPECT to OKAY and
for triggering failover procedures.

Requested change:
add new counter to trigger failover procedures

OnTimerElapsed(pcb)
      {
           if pcb->Status = OKAY
                SendWatchdog(pcb)
                pcb->Status = WAIT_DWA
                T = Tw
           else if pcb->Status = WAIT_DWA
                pcb->Status = SUSPECT
                T = Td
           else if pcb->Status = SUSPECT
     ---->>>    if pcb->noDWRSentInSuspect++ == 2
      	       StopConnection(pcb)
                   FailoverProcedures(pcb)
                else SendWatchdog(pcb)
      }

---

From: Barney Wolff <[email-masked]>
Date: Wed, 10 Oct 2001 09:26:57 -0400

I agree that the counter is needed, but I think it should be
++pcb->xxx rather than xxx++, as there has already been one timeout
taking us from WAIT_DWA to SUSPECT.  Also, the counter has to be
initialized, at the timeout in WAIT_DWA.

Why is SendWatchdog called again in SUSPECT?  I thought with reliable
transport only one watchdog was sent.

Barney Wolff

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 10 Oct 2001 07:37:11 -0700

All,

As I previously noted, all of this text will be pushed into the AAA transports
draft. I believe that this draft will soon be available with the latest transport
text, and I believe it does include this fix.

I will log it, but against the aaa transport draft.

PatC