Subject: [AAA-WG]: Issue 189

From: "Glen Zorn" <[email-masked]>
Date: Mon, 1 Oct 2001 07:32:23 -0700

Henry,

I contributed some text a couple of weeks ago (see below) that I think deals
w/these concerns.

NAS-Session-Key ::= < AVP Header: 408 >
                    { NAS-Key-Direction }
                    { NAS-Key-Type }
                    { NAS-Key-Binding }
                    { NAS-Key-Data }
                    [ NAS-Key-Lifetime ]
                    [ NAS-IV ]
                  * [ AVP ]
<...>
The NAS-IV AVP (AVP Code 410) is of type OctetString.  Its contents
MAY be used as an initialization vector (IV) by cryptographic algorithms
(e.g., block ciphers).

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 1 Oct 2001 07:27:28 -0700

yes, these changes didn't make it into the alpha last week, but will be in the
next revision. If Glen's changes addresses this problem, then I'd like to close 189.

PatC