Subject: [AAA-WG]: Issue 216: Home Agent MUST support home address allocation

From: Pat Calhoun <[email-masked]>
Date: Thu, 25 Oct 2001 17:32:57 -0700

Submitter name: Pat Calhoun
Submitter email address: [email-masked] 
Date first submitted: 25-Oct-01 
Reference:  
Document: MIP
Comment type: Technical 
Priority: 1
Section: 1.2
Rationale/Explanation of issue: 

The draft doesn't actually state that the Home Agent MUST support
home address allocation, but the draft does state that the AAAH MAY
do it. The lack of a MUST can cause interoperability problems

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 30 Oct 2001 04:35:32 -0800

All,

I modified some text to make this clearer. Specifically, the last two
sentences in the paragraph below have been changed.

1.2 Inter-Realm Mobile IP

[...]
The AAAH then sends an Home-Agent-MIP-Request (HAR), which contains the 
Mobile IP Registration Request message data encapsulated in the 
MIP-Reg-Request AVP, to the assigned or requested Home Agent. The AAAH 
MAY allocate a home address for the mobile node, while the Home Agent MUST
support home address allocation. In the event the AAAH handles address
allocation, it includes it in a MIP-Mobile-Node-Address AVP within the HAR.
The absence of this AVP informs the Home Agent to perform the allocation.

Comments welcomed,

PatC

---

From: Tony Johansson <[email-masked]>
Date: Wed, 31 Oct 2001 12:00:58 -0800

Looks good to me.

/Tony