Subject: RE: [AAA-WG]: Issue 212: How does the AAAH know the Destination-Host of a previously assigned foreign HA?

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Fri, 26 Oct 2001 11:53:16 -0500

Pat,

The GNAIE I-D is in the process of being deprecated as a WG document.
So refering to the GNAIE as a way to fix it may not be the solution. As
I
have pointed out to you and the other authors of the GNAIE I-D, the I-D
that needs a specific NAI extension ought to define it rather than
having a
placeholder for extensions I-D which is reference by others.
The FA-NAI specified in GNAIE should (or can) be specified in the
reg-tun
I-D i MIP WG and the HA-NAI can be specified in this Diameter-MIPv4
I-D. So far the HA-NAI has not been really shown as a requirement by any
other I-Ds in the Mobile IP WG.

-Basavaraj

> 
> 
> Submitter name: Pat Calhoun
> Submitter email address: [email-masked] 
> Date first submitted: 25-Oct-01 
> Reference:  
> Document: MIP
> Comment type: Technical 
> Priority: 1
> Section: 
> Rationale/Explanation of issue: 
> 
> Once a mobile has been assigned a home agent, if a subsequent 
> HAR is to
> be sent, a new AAAH has no way to map the IP address in the 
> registration
> request to a Destination-Host AVP of the Home Agent.
> 
> Fix
> 
> The GNAIE ID is being updated to reflect comments of the IESG. In this
> document we will specify that the HA may include its NAI in the 
> Registration Reply, and if so, the mobile node must include 
> the same extension
> in subsequent registration requests. This will require some 
> Mobile IP WG
> involvement.
>

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 30 Oct 2001 04:21:37 -0800

I guess I missed the conclusion ofthe GNAIE spec. The extension mentioned
below has many benefits, and it would be even better if it was in an FQDN
format than an NAI. This extension really will be required to the proper
operation of MobileIP+AAA. Are you stating that the AAA WG should include
the definition of the extension in one of it's documents?

PatC

---

From: "Fredrik Johansson" <[email-masked]>
Date: Wed, 31 Oct 2001 16:09:26 +0100

if we are specifying the new extension in the MIPv4 Application for
diameter, can we then make it a URI instead, that way we will have all
information we'll ever need, such as port and transport.

/Fredrik

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>Pat Calhoun
>Sent: den 30 oktober 2001 13:22
>To: Patil Basavaraj (NET/Dallas)
>Cc: 'ext Pat Calhoun'; [email-masked]; 'Mobile IP'
>Subject: Re: [AAA-WG]: Issue 212: How does the AAAH know the
>Destination-Host of a previously assigned foreign HA?
>
>