Subject: RE: [AAA-WG]: Re: AAAH must be stateful

From: "Bob Kopacz" <[email-masked]>
Date: Thu, 4 Oct 2001 15:37:25 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Joe Lau
> Sent: Thursday, October 04, 2001 3:28 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [AAA-WG]: Re: AAAH must be stateful
> 
> I am very interested on learning how to achieve this w/o requiring the 
> AAAh to maintain session states because I am facing such a problem right
> now.  Can you give more details on how you can achieve your last statement?
> 
> 	 "Thus you can extract it for the next amr and use it."
> 
> 
> Please use the following example.
> 
>         AMR(session_id_1) -------------------+
>                                              |
>                                              +------------> AAAh (stateless)
>                                              |              |  |
>         AMR(session_id_2) -------------------+              |  |
>                                                             |  |
>                                                   HAR(sid_3)|  | HAR(sid_4)
>                                                             |  |
>                                                             v  v
>                                                             Home Agent
> 
> The two AMR's came from different FA's, so session_id_1 != session_id_2
> But the draft says sid_3 must equal sid_4 on the HAR's.

It seems like the HA must be able to deal with receiving different
session-id's for the same session anyway, since the AMRs may go to
different AAAH's.  (Section 1.3 "Support for Mobile-IP Handoffs" says
that "it is quite likely the AMR for a handoff will be received by
a different AAAH".)

> Thank you.
> Joe Lau

---

From: Joe Lau <[email-masked]>
Date: Thu, 4 Oct 2001 12:27:57 -0700 (PDT)

Mark,

>  > > Are there any reasons a server MUST maintain state?
>  > 
>  > What about this one (as stated on draft 8, alpha)?
>  > 
>  >    During the creation of the HAR, the AAAH MUST use a different session
>  >    identifier than the one used in the AMR/AMA (see figure 2). Of
>  >    course, the AAAH MUST use the _same_ session identifier for _all_ HARs
>  >    initiated on behalf of a given mobile node's session. 
> 
> If you send back the Session identifier that you created for the HAR
> as a class attribute in the AMA, the FA MUST return it in subsequent
> authentications.  Thus you can extract it for the next amr and use it.

Thank you.

Joe Lau

---

From: Pat Calhoun <[email-masked]>
Date: Sun, 7 Oct 2001 14:50:52 -0700

> But the draft says sid_3 must equal sid_4 on the HAR's.

Right, and this is already handled in the protocol. We added such provisions
in the protocol to handle handoffs across foreign agents.

PatC