Subject: RE: [AAA-WG]: Abort-Session-Request and User-Name AVP

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Tue, 9 Oct 2001 12:47:30 -0500

Jaakko,

I would guess that once you've seen a Session-Id AVP with a User-Name AVP
(in a session initiation command, e.g.), you probably wouldn't need to
retransmit the User-Name in a subsequent session command (like STR/A,
ASR/A), as the other side should (or at least could) have associated
Session-Id with characteristics like User-Name.  If you wanted to sacrifice
local memory in favor of a narrower bandwidth, that might be a good way to
go.

-Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 12:41 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [AAA-WG]: Abort-Session-Request and User-Name AVP
> 
> 
> Hi,
> 
> Right, however I was mainly thinking of the base protocol 
> commands which are
> part of the user session like Session-Termination, Abort-Session and
> Re-auth. Those are defined differently with regard to User-Name AVP. 
> 
> Best Regards, Jaakko
> > -----Original Message-----
> > From: ext Pat Calhoun [mailto:[email-masked]]
> > Sent: 08 October, 2001 0:54
> > To: Rajaniemi Jaakko (NET/Espoo)
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [AAA-WG]: Abort-Session-Request and User-Name AVP
> > 
> > 
> > > After this long talk my question here is that, is there a 
> > specific reason
> > > why the User-Name AVP is included into some of the base 
> > protocol commands as
> > > a mandatory AVP and some of them don't have it? 
> > 
> > because some messages have nothing to do with specific users 
> > (e.g. watchdog
> > messages).
> > 
> > PatC
> > 
>

---

From: [email-masked]
Date: Wed, 10 Oct 2001 19:55:24 +0300

Hi Brian,

That's one way. If the bandwidth is not the concern then you could include
the User-Name AVP to those messages because of some benefits which it may
bring to you (see my previous mail dated 04.10). For some other commands
e.g. Accounting, which may be used real-time, the bandwitdh may be bigger
concern.

Best Regards, Jaakko 

> From: ext Cain Brian-BCAIN1 [mailto:[email-masked]]
> Sent: 09 October, 2001 20:48
> To: Rajaniemi Jaakko (NET/Espoo); [email-masked]
> Cc: [email-masked]