Subject: [AAA-WG]: non-issue issue: MIME encoding in CMS

From: Stephen Farrell <[email-masked]>
Date: Wed, 24 Oct 2001 19:24:36 +0100

Folks,

It doesn't have an issue number, but the suggestion to drop 
the MIME encoding step was raised on the list, was supported
and wasn't opposed.
(see: http://www.merit.edu/mail.archives/aaa-wg/msg02431.html)

I think the changes listed below would be what needs to be 
done (based on draft-ietf-aaa-diameter-cms-03.alpha01.txt).

I'm for making this change - I haven't found a toolkit 
for which it causes a problem. (OTOH, I'm also ok with 
not making the change if it causes someone a problem.)

Stephen.

1. Replace this bit at the end of 6.0:
   "All MIME encoded data in this specification MUST use the
   "application/pkcs7-mime" MIME type."

   with:

   "No MIME encoding of binary data is required for this specification.
   This is different from the use of CMS in S/MIME but is ok since 
   Diameter is a binary protocol and investigation has not shown this
   to causes problems when using existing CMS & S/MIME toolkits."

2. Delete this bit from the start of 6.1:

   "...and
   MUST then be encoded according to MIME encoding rules specified in
   [16,17]."

3. Delete this line from top of page 24 (section 6.2):

   "   - MIME encoded (according to the rules specified in [16,17]),"

4. Replace this bit from 6.3:

   "      - MIME(x) represents the MIME encoding of x"

  with 

   "      - The "|" character represents catenation"

5. Replace this bit of 6.3 (MIME->"|" and formating)

  "The resulting message will look like:
      AVP1='P is set',   EnvelopedData-fnc(MIME(s,t,e),P) AVP2='P is
      set',   EnvelopedData-fnc(MIME(s,e,p,h),A) AVP3='P is set',   e'
      AVP4='P is clear', n AVP5='P is clear', SignedData(T)"

   with:

   "The resulting message will look like:
      AVP1='P is set',   EnvelopedData-fnc(s|t|e,P) 
      AVP2='P is set',   EnvelopedData-fnc(s|e|p|h,A) 
      AVP3='P is set',   e'
      AVP4='P is clear', n 
      AVP5='P is clear', SignedData(T)"

Stephen.

-- 
____________________________________________________________
Stephen Farrell         				   
Baltimore Technologies,   tel: (direct line) +353 1 881 6716
39 Parkgate Street,                     fax: +353 1 881 7000
Dublin 8.                mailto:[email-masked]
Ireland                             http://www.baltimore.com

---

From: "Jari Arkko" <[email-masked]>
Date: Thu, 25 Oct 2001 07:11:04 +0300

> not making the change if it causes someone a problem.)

I support making this change.

Jari