Subject: RE: [AAA-WG]: Issue 212: How does the AAAH know the Destination-Host of a previously assigned foreign HA?

From: "Patil Basavaraj (NET/Dallas)" <[email-masked]>
Date: Tue, 30 Oct 2001 23:30:13 -0600

>(The problem has to do with re-registrations. Since the AAAH is
stateless,
>it may not know the FQDN of the Home Agent assigned. All it has is the
IP
>address, and folks felt that IP->FQDN translation may not be reliable
in
>certain environments. 

Possibly. But are there are any real requirements or example scenarios
where the FQDN of the HA is required and how the AAAH utilises this
info? 
Also why would re-registrations utilize the AAA network elements? The
MN can directly send subsequent registrations to the HA that has been
previously assigned to it via AAAH (maybe in a foreign domain). 

>So if the mobile could state the HA's FQDN, that would
>solve all of the problems.

Not sure if we really have a strong argument for having the MN send
the FQDN of the HA to the AAAH here yet. 

>PatC

-Basavaraj

On Tue, Oct 30, 2001 at 04:18:10PM -0600, Patil Basavaraj (NET/Dallas)
wrote:
> 
> Comments below:
> 
> >I guess I missed the conclusion ofthe GNAIE spec. The extension
> mentioned
> >below has many benefits, and it would be even better if it was in an
> FQDN
> >format than an NAI. This extension really will be required to the
> proper
> >operation of MobileIP+AAA. Are you stating that the AAA WG should
> include
> >the definition of the extension in one of it's documents?
> >
> >PatC
> 
> Pat,
> 
> I was alluding to having the HA-NAI being specified in the AAA WG, but
> it does not look like that makes much sense. So lets ignore that.
> 
> Why is the HA-NAI absolutely required for proper operation of MIP+AAA?
> I do realize the HA can be assigned in a foreign domain (as mentioned
> in the MIP-Diameter I-D), but fail to see how you really use the
> HA-NAI . Maybe I am misunderstanding the problem here.
> 
> Once a MN has been assigned an HA (Home or Foreign), would'nt the MN
> send subsequent registrations to the HA via its IP address? A new HAR
> at a new AAAH is a result of a reg-req from the MN. Why would this new
> reg-req not include the address of the HA if it had been previously
> assigned unless it wants a new HA (in which case it is equivalent to
> initial registration).
> 
> -Basavaraj
> 
> >On Fri, Oct 26, 2001 at 11:53:16AM -0500, Patil Basavaraj
(NET/Dallas)
> wrote:
> >> 
> >> Pat,
> >> 
> >> The GNAIE I-D is in the process of being deprecated as a WG
document.
> >> So refering to the GNAIE as a way to fix it may not be the
solution.
> As
> >> I
> >> have pointed out to you and the other authors of the GNAIE I-D, the
> I-D
> >> that needs a specific NAI extension ought to define it rather than
> >> having a
> >> placeholder for extensions I-D which is reference by others.
> >> The FA-NAI specified in GNAIE should (or can) be specified in the
> >> reg-tun
> >> I-D i MIP WG and the HA-NAI can be specified in this Diameter-MIPv4
> >> I-D. So far the HA-NAI has not been really shown as a requirement
by
> any
> >> other I-Ds in the Mobile IP WG.
> >> 
> >> -Basavaraj
> >> 
> >> > 
> >> > 
> >> > Submitter name: Pat Calhoun
> >> > Submitter email address: [email-masked] 
> >> > Date first submitted: 25-Oct-01 
> >> > Reference:  
> >> > Document: MIP
> >> > Comment type: Technical 
> >> > Priority: 1
> >> > Section: 
> >> > Rationale/Explanation of issue: 
> >> > 
> >> > Once a mobile has been assigned a home agent, if a subsequent 
> >> > HAR is to
> >> > be sent, a new AAAH has no way to map the IP address in the 
> >> > registration
> >> > request to a Destination-Host AVP of the Home Agent.
> >> > 
> >> > Fix
> >> > 
> >> > The GNAIE ID is being updated to reflect comments of the IESG. In
> this
> >> > document we will specify that the HA may include its NAI in the 
> >> > Registration Reply, and if so, the mobile node must include 
> >> > the same extension
> >> > in subsequent registration requests. This will require some 
> >> > Mobile IP WG
> >> > involvement.
> >> > 
> 
> 
> > -----Original Message-----
> > From: ext Pat Calhoun [mailto:[email-masked]]
> > Sent: Tuesday, October 30, 2001 6:22 AM
> > To: Patil Basavaraj (NET/Dallas)
> > Cc: 'ext Pat Calhoun'; [email-masked]; 'Mobile IP'
> > Subject: Re: [AAA-WG]: Issue 212: How does the AAAH know the
> > Destination-Host of a previously assigned foreign HA?
> > 
> > 
> > I guess I missed the conclusion ofthe GNAIE spec. The 
> > extension mentioned
> > below has many benefits, and it would be even better if it 
> > was in an FQDN
> > format than an NAI. This extension really will be required to 
> > the proper
> > operation of MobileIP+AAA. Are you stating that the AAA WG 
> > should include
> > the definition of the extension in one of it's documents?
> > 
> > PatC
> > On Fri, Oct 26, 2001 at 11:53:16AM -0500, Patil Basavaraj 
> > (NET/Dallas) wrote:
> > > 
> > > Pat,
> > > 
> > > The GNAIE I-D is in the process of being deprecated as a WG 
> > document.
> > > So refering to the GNAIE as a way to fix it may not be the 
> > solution. As
> > > I
> > > have pointed out to you and the other authors of the GNAIE 
> > I-D, the I-D
> > > that needs a specific NAI extension ought to define it rather than
> > > having a
> > > placeholder for extensions I-D which is reference by others.
> > > The FA-NAI specified in GNAIE should (or can) be specified in the
> > > reg-tun
> > > I-D i MIP WG and the HA-NAI can be specified in this
Diameter-MIPv4
> > > I-D. So far the HA-NAI has not been really shown as a 
> > requirement by any
> > > other I-Ds in the Mobile IP WG.
> > > 
> > > -Basavaraj
> > > 
> > > > 
> > > > 
> > > > Submitter name: Pat Calhoun
> > > > Submitter email address: [email-masked] 
> > > > Date first submitted: 25-Oct-01 
> > > > Reference:  
> > > > Document: MIP
> > > > Comment type: Technical 
> > > > Priority: 1
> > > > Section: 
> > > > Rationale/Explanation of issue: 
> > > > 
> > > > Once a mobile has been assigned a home agent, if a subsequent 
> > > > HAR is to
> > > > be sent, a new AAAH has no way to map the IP address in the 
> > > > registration
> > > > request to a Destination-Host AVP of the Home Agent.
> > > > 
> > > > Fix
> > > > 
> > > > The GNAIE ID is being updated to reflect comments of the 
> > IESG. In this
> > > > document we will specify that the HA may include its NAI in the 
> > > > Registration Reply, and if so, the mobile node must include 
> > > > the same extension
> > > > in subsequent registration requests. This will require some 
> > > > Mobile IP WG
> > > > involvement.
> > > > 
> >

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 31 Oct 2001 07:26:19 -0800

> where the FQDN of the HA is required and how the AAAH utilises this

yes, without it the protocol doesn't work (hope that's a good enough requirement :)

> previously assigned to it via AAAH (maybe in a foreign domain). 

this can occur in two circumstances:

1. Mobile moves to a new foreign agent (once the fast handoff/CT work is complete
   perhaps the FAs in a domain will be able to share keys, but for now this isn't
   possible)
2. Once #1 is resolved, when the mobile uses a foreign agent in a new domain

> the FQDN of the HA to the AAAH here yet. 

Well, as I mentioned, without this info, MIP+AAA doesn't work. When an AAAH receives
a registration request, it doesn't know the identity of the Home Agent. It does have
an IP address, but it needs to know how to route the message via Diameter, and 
this is based on FQDN (to provide inter domain message routing). So if the AAAH
only gets an IP address, it would have to map it to FQDN via DNS, and some folks
are arguing that this is the wrong approach.

If others feel that this is sufficient, please speak up. All I have is data from
the parties implying this is not a workable solution.

PatC