Subject: [AAA-WG]: Issue 213: MN-AAA SPI must be included in the HAR message

From: Pat Calhoun <[email-masked]>
Date: Thu, 25 Oct 2001 17:31:55 -0700

Submitter name: Pat Calhoun
Submitter email address: [email-masked] 
Date first submitted: 25-Oct-01 
Reference:  
Document: MIP
Comment type: Technical 
Priority: 1
Section: 
Rationale/Explanation of issue: 

The Home Agent needs to have access to the MN-AAA SPI in order to create
the Mobile AAA key extensions. This information is not sent by the AAAH
to the home agent. Therefore the AAAH must include the MIP-MN-AAA-SPI
AVP in the HAR to the HA.

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 30 Oct 2001 04:25:30 -0800

All,

Here are my fixes for this particular issue (which is the inclusion of the
MN-AAA SPI in the AVP):

6.5 MIP-MN-to-FA-Key AVP

[...]
      MIP-MN-to-FA-Key ::= < AVP Header: 325 >
                           { MIP-Algorithm-Type }
                           { MIP-Key-Material }
                           { MIP-MN-AAA-SPI }
                         * [ AVP ]
[...]

6.6 MIP-MN-to-HA-Key AVP

[...]
MIP-MN-to-HA-Key ::= < AVP Header: 331 >
                     { MIP-Algorithm-Type }
                     { MIP-Replay-Mode }
                     { MIP-Key-Material }
                     { MIP-MN-AAA-SPI }
                   * [ AVP ]

Comments welcomed,

PatC