Subject: [AAA-WG]: Order of Members of MIP-XX-to-YY-Key AVPs

From: "Bob Kopacz" <[email-masked]>
Date: Fri, 12 Oct 2001 10:18:27 -0400

Hi Pat,

In earlier drafts of Diameter, the Grouped AVPs had fixed member AVPs
in a fixed order.

Now the Grouped AVPs have a more flexible
  
  "header [ *fixed] [ *required] [ *optional] [ *fixed]" format.

Question: At the time this change was made, did you intend the
existing grouped AVPs, such as MIP-MN-AAA-Auth AVP and the
MIP-XX-to-YY-Key AVPs, to retain the fixed order of their members, or
did you intend the order of the required members to be arbitrary?

e.g. if the fixed order was to be retained, should the MIP-MN-AAA-Auth
AVP description have had the editing change

from:

      MIP-MN-AAA-Auth ::= < AVP Header: 322 >
                          { MIP-MN-AAA-SPI }
                          { MIP-Auth-Input-Data-Length }
                          { MIP-Authenticator-Length }
                          { MIP-Authenticator-Offset }
                        * [ AVP ]

to:

      MIP-MN-AAA-Auth ::= < AVP Header: 322 >
                          < MIP-MN-AAA-SPI >
                          < MIP-Auth-Input-Data-Length >
                          < MIP-Authenticator-Length >
                          < MIP-Authenticator-Offset >
                        * [ AVP ]

Bob K.

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 12 Oct 2001 07:27:44 -0700

Bob,

I don't see why ordering is required for this AVP. Did you have any
specific concerns that would require ordering?

PatC

---

From: "Bob Kopacz" <[email-masked]>
Date: Fri, 12 Oct 2001 10:44:55 -0400

Hi Pat,

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Pat Calhoun
> Sent: Friday, October 12, 2001 10:28 AM
> To: Bob Kopacz
> Cc: Pat Calhoun; aaa-wg
> Subject: Re: Order of Members of MIP-XX-to-YY-Key AVPs
> 
> 
> Bob,
> 

No.  I was just wondering if removing the ordering requirement was
intended or an editing oversight.

Thanks,
Bob K.

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 12 Oct 2001 10:45:19 -0700

not sure I understand the question, but if I do, my answer would be that I
intentionally removed ordering.

PatC