Subject: RE: [AAA-WG]: Issue 357: Inappropriate UTF-8 encoding (fwd)

From: <[email-masked]>
Date: Fri, 13 Sep 2002 13:09:26 +0300

Hi!

John Loughney wrote:
> Do you seen any interoperability problems with the text Bernard 
> has suggested?

I'm sorry, but I'm not sure what exactly is the current proposal
for the format of DiameterIdentity.

Are we mandating that all Diameter-boxes must support IDNs
and the encodings described in IDNA-draft?

What is the status of IDNA-draft and the related drafts? Can we
reference to them from Diameter Base RFC?

Then a simple question, just to make sure if I have interpretet
all this correctly:

Is it still ok to put, for example, host.abc.com ASCII encoded
to Origin- and Destination-Host AVPs?

I guess it wouldn't hurt to put couple examples of valid
contents of DiameterIdentity to the draft.

BR,
Mikko

> -----Original Message-----
> From: ext [mailto:[email-masked]]
> Sent: 13 September, 2002 12:17
> To: Aittola Mikko (NET/Helsinki); [email-masked]
> Cc: [email-masked]
> Subject: RE: [AAA-WG]: Issue 357: Inappropriate UTF-8 encoding (fwd)
> 
> 
> Hi Mikko,
> 
> > Bernard Aboba wrote:
> > > 1. Change the following AVPs that use UTF8String to type 
> > > DiameterIdentity:
> > > 
> > > Origin-Realm AVP (6.4)
> > > Destination-Realm AVP (6.6)
> > > 
> > > 2. Change the definition of DiameterIdentity to OctetString.
> > 
> > 
> > Shouldn't DiameterIdentity, i.e. fqdn still be considered "text"?
> > 
> > If the fqdn is not UTF-8 encoded I think it should be ASCII encoded.
> > Data contained in AVP-type derived from OctetString does not 
> > necessarily contain ASCII encoded data.
> > 
> > Or am I missing something here?
> 
> From the original message:
> 
>  FQDNs are to be encoded as specified by the 
> Internationalized Domain Name 
>  (IDN) specification, not UTF-8. For example, see:
> 
>  http://www.ietf.org/internet-drafts/draft-ietf-idn-idna-11.txt
> 
> and also below are comments from the IESG.
> 
> Do you seen any interoperability problems with the text Bernard 
> has suggested?
> 
> John

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 13 Sep 2002 04:55:43 -0700 (PDT)

> and the encodings described in IDNA-draft?

That's not a requirement for Diameter per se. But if you want to use an
FQDN that's incompatible with the IDN encoding, then there will be
problems. For example, FQDNs encoded with UTF-8 may not be valid.

> reference to them from Diameter Base RFC?

They're Internet drafts (work in progress). We can't have normative
references to them without holding up the documents -- and I don't think
we need to.

> to Origin- and Destination-Host AVPs?

Sure. The question is what you'd put into those AVPs if you had registered
a machine <"host" translated into Chinese>.abc.com.

> contents of DiameterIdentity to the draft.

I think that that would require wading into the IDN swamp. The point is
that AVPs of type DiameterIdentity need to be valid FQDNs.