Subject: RE: [AAA-WG]: Need more specifics on list of AVPs

From: <[email-masked]>
Date: Mon, 2 Sep 2002 09:43:49 +0300

Hi All,

I have seen no comments on this issue.  As it is a request for debugging
purposes - I feel that at this late date, we cannot change the spec
to meet this request.  We need to get Diameter out to IESG for
review.

best regards,
John

> -----Original Message-----
> From: ext Yoshihiro Ohba [mailto:[email-masked]]
> Sent: 24 August, 2002 00:50
> To: [email-masked]
> Subject: [AAA-WG]: Need more specifics on list of AVPs
> 
> 
> Need more specifics on list of AVPs
> Submitter name: Yoshihiro Ohba
> Submitter email address: [email-masked]
> Date first submitted: August 23, 2002
> Document: base
> Comment type: T
> Priority: S
> Section: 4
> Rationale/Explanation of issue:
> 
> In section 4 it is descibred that:
> 
>    Some AVPs MAY be listed more than once. The effect of such 
> an AVP is
>    specific, and is specified in each case by the AVP description.
> 
> But the specification is not clear on whether each AVP in the list of
> AVPs of the same type can be dispersely located in the message payload
> (e.g, a Host-IP-Address AVP, then an Origin-Realm AVP,
>  and then a Host-IP-Address AVP again) or must be located back to back
>  (e.g, two Host-IP-Address AVPs, and then an Origin-Realm AVP).
> 
> From the debugging point of view, the latter would be prefered since
> it makes easier to find out where AVPs of a specific type are in the
> payload.
> 
> Requested change:
> 
> Each AVP in a list of AVPs of the same type must be located back to
> back in the message payload.
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 04 Sep 2002 15:35:00 +0300

> to meet this request.  We need to get Diameter out to IESG for

I agree with the reject for this issue.

(But this isn't strictly for debugging. Its also an interoperability
issue for the receiver of be able to decode the messages correctly.
Still, if the spec doesn't say which order is allowed then any order
is legal. Implementations should take this into account.)

Jari

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 4 Sep 2002 14:42:40 -0400

> is legal. Implementations should take this into account.)

OK.  In fact, my current implementation supports the any-order
processing to provide interoperability.

Yoshihiro Ohba