Subject: [AAA-WG]: Issue 361: Support for TLS compression

From: Bernard Aboba <[email-masked]>
Date: Tue, 10 Sep 2002 18:03:22 -0700 (PDT)

Issue 361: Support for TLS compression
Submitter: Bernard Aboba
Submitter email address: [email-masked]
Date first submitted: September 9, 2002
Reference:
Document: BASE-12
Comment type: T
Priority: 2
Section: 9.2
Rationale/Explanation of issue:

TLS compression is more efficient than IP compression, since TCP
is stateful. As a result, it makes sense to use TLS compression
where TLS is negotiated and it is desired to reduce the network
bandwidth used for Diameter accounting.

Replace the last paragraph of Section 9.2 with the following:

"Each Diameter Accounting protocol message MAY be compressed, in order
to reduce network bandwidth usage. If IPsec and IKE are used to
secure the Diameter session, then IP compression [IPComp] MAY be used and
IKE [IKE] MAY be used to negotiate the compression parameters. If TLS
is used to secure the Diameter session, then TLS compression [TLS] MAY
be used."

---

From: Jari Arkko <[email-masked]>
Date: Thu, 12 Sep 2002 00:20:08 +0300

> is used to secure the Diameter session, then TLS compression [TLS] MAY

Sounds good.

Jari