Subject: Re: [AAA-WG]: Issue 357: Inappropriate UTF-8 encoding (fwd)

From: Bernard Aboba <[email-masked]>
Date: Tue, 10 Sep 2002 12:39:38 -0700 (PDT)

---------- Forwarded message ----------
Date: Tue, 10 Sep 2002 10:44:32 -0400
From: Eric Brunner-Williams in Portland Maine <[email-masked]>
To: Bernard Aboba <[email-masked]>
Cc: [email-masked]
Subject: Re: [AAA-WG]: Issue 357: Inappropriate UTF-8 encoding

Bernard,

As an alternative, I suggest the DiameterIdentity type can be left
simply as an OctetString AVP, and reference to any charset dropped.
If you want to add details to how the DiameterIdentity value is to
be used, e.g., case-insensitive character comparison for octets in
the range 0-127, that would be consistent with 10[34/35].

The same issue came up recently in dnsext (unknown RDATA formats).

The same issue has been present in provreg (character encodings other
than UTF-8 (and UTF-16) are allowed by XML, if an encoding attribute,
or a byte order mark, or both is present, EPP is specified in XML
Schema notation, and is silent on the use of character encodings other
than UTF-8 except "in environments where parser encoding support
incompatibility might have an impact on interoperability", in which
case UTF-8 is RECOMMENDED).

Eric

---

From: <[email-masked]>
Date: Fri, 13 Sep 2002 12:16:42 +0300

Hi Mikko,

> Bernard Aboba wrote:
> > 1. Change the following AVPs that use UTF8String to type 
> > DiameterIdentity:
> > 
> > Origin-Realm AVP (6.4)
> > Destination-Realm AVP (6.6)
> > 
> > 2. Change the definition of DiameterIdentity to OctetString.
> 
> 
> Shouldn't DiameterIdentity, i.e. fqdn still be considered "text"?
> 
> If the fqdn is not UTF-8 encoded I think it should be ASCII encoded.
> Data contained in AVP-type derived from OctetString does not 
> necessarily contain ASCII encoded data.
> 
> Or am I missing something here?

From the original message:

 FQDNs are to be encoded as specified by the Internationalized Domain Name 
 (IDN) specification, not UTF-8. For example, see:

 http://www.ietf.org/internet-drafts/draft-ietf-idn-idna-11.txt

and also below are comments from the IESG.

Do you seen any interoperability problems with the text Bernard 
has suggested?

John

---------- Forwarded message ----------
Date: Tue, 10 Sep 2002 10:44:32 -0400
From: Eric Brunner-Williams in Portland Maine <[email-masked]>
To: Bernard Aboba <[email-masked]>
Cc: [email-masked]
Subject: Re: [AAA-WG]: Issue 357: Inappropriate UTF-8 encoding

Bernard,

Eric

---

From: <[email-masked]>
Date: Fri, 13 Sep 2002 15:55:54 +0300

Hi Bernard,

I think the text you proposed is sufficient for these purposes.  If
anyone disagrees, please supply exact text.

thanks,
John

> -----Original Message-----
> From: ext Bernard Aboba [mailto:[email-masked]]
> Sent: 13 September, 2002 14:56
> To: Aittola Mikko (NET/Helsinki)
> Cc: Loughney John (NRC/Helsinki); [email-masked]
> Subject: RE: [AAA-WG]: Issue 357: Inappropriate UTF-8 encoding (fwd)
> 
> 
> > I'm sorry, but I'm not sure what exactly is the current proposal
> > for the format of DiameterIdentity.
> >
> > Are we mandating that all Diameter-boxes must support IDNs
> > and the encodings described in IDNA-draft?
> 
> That's not a requirement for Diameter per se. But if you want 
> to use an
> FQDN that's incompatible with the IDN encoding, then there will be
> problems. For example, FQDNs encoded with UTF-8 may not be valid.
> 
> > What is the status of IDNA-draft and the related drafts? Can we
> > reference to them from Diameter Base RFC?
> 
> They're Internet drafts (work in progress). We can't have normative
> references to them without holding up the documents -- and I 
> don't think
> we need to.
> 
> > Then a simple question, just to make sure if I have interpretet
> > all this correctly:
> >
> > Is it still ok to put, for example, host.abc.com ASCII encoded
> > to Origin- and Destination-Host AVPs?
> 
> Sure. The question is what you'd put into those AVPs if you 
> had registered
> a machine <"host" translated into Chinese>.abc.com.
> 
> > I guess it wouldn't hurt to put couple examples of valid
> > contents of DiameterIdentity to the draft.
> 
> I think that that would require wading into the IDN swamp. 
> The point is
> that AVPs of type DiameterIdentity need to be valid FQDNs.
> 
> 
>

---

From: <[email-masked]>
Date: Fri, 13 Sep 2002 16:18:16 +0300

Hi!

Thanks for clarification. The proposed text is fine.

BR,
Mikko