Subject: [abfab] agenda

From: Leif Johansson <[email-masked]>
Date: Tue, 08 Mar 2011 11:22:58 +0100

Folks,

Here is the proposed agenda. The basic idea is that we do use cases and
architecture and general interest in the first session and hard-core
and new documents in the second session.

Bash away!

	Leif & Klaas

abfab1 (monday - 1 hr)

- - Agenda bashing and Note Well (5min)
- - Core non-normative status (30 min)
  - draft-lear-abfab-arch-xx
  - draft-abfab-usecases
- - Moonshot implementation status (25 min)

abfab2 (thursday - 2.5hrs)

- - Agenda bashing and Note Well (5min)
- - Core normative status (60min)
  - draft-ietf-abfab-gss-eap-xx
  - draft-ietf-abfab-gss-eap-naming-xx
  - draft-ietf-abfab-aaa-saml-xx
- - New documents (40 min)
  - abfab diameter draft
  - draft-howlett-radsec-knp
  - draft-adamson-nfsv4-multi-domain-access (tentative)
- - Administrativia and AOB (15 min)
  - OID management

---

From: Josh Howlett <[email-masked]>
Date: Tue, 8 Mar 2011 10:59:50 +0000

Hi Leif,

Thanks for pulling this together. However I'm wondering if it's really necessary to devote nearly 50% of the first session to discussion of an ABFAB implementation. I would be more inclined to spend this time on discussion of the architecture and use-case documents.

Sam will have a better sense of this than I, but I suspect that the things we've discovered in the course of implementation can be conveyed more efficiently during the actual document discussions.

If the WG is interested in a 'general interest' item, we could do a presentation on our implementation's UI/UX design; we're expecting to feed our implementation experience and usability analysis into the 'Usability considerations' document. We're unlikely to have running UI code by this point, but we'll have mock-ups.

Having said all that, if there really is strong interest from the WG in a Moonshot implementation status, then we'll be very happy to oblige.
 
Josh.

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAk12A34ACgkQ8Jx8FtbMZndYRQCdE77kQBGNcwk1eeTrACNZE7hr
> O3QAoMNg0gw/SJy8JUWTDm3vO79muPxR
> =l6Dx
> -----END PGP SIGNATURE-----
> _______________________________________________
> abfab mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/abfab

JANET(UK) is a trading name of The JNT Association, a company limited
by guarantee which is registered in England under No. 2881024 
and whose Registered Office is at Lumen House, Library Avenue,
Harwell Oxford, Didcot, Oxfordshire. OX11 0SG

---

From: Klaas Wierenga <[email-masked]>
Date: Tue, 08 Mar 2011 12:09:21 +0100

On 3/8/11 11:59 AM, Josh Howlett wrote:

Josh,

> Thanks for pulling this together. However I'm wondering if it's
> really necessary to devote nearly 50% of the first session to
> discussion of an ABFAB implementation. I would be more inclined to
> spend this time on discussion of the architecture and use-case
> documents.

Well, one way of saying it is "nearly 50%", the other is "only 25
minutes" ;-) Do you really think you can do with much less than that?

Klaas

> 
> Sam will have a better sense of this than I, but I suspect that the
> things we've discovered in the course of implementation can be
> conveyed more efficiently during the actual document discussions.
> 
> If the WG is interested in a 'general interest' item, we could do a
> presentation on our implementation's UI/UX design; we're expecting to
> feed our implementation experience and usability analysis into the
> 'Usability considerations' document. We're unlikely to have running
> UI code by this point, but we'll have mock-ups.
> 
> Having said all that, if there really is strong interest from the WG
> in a Moonshot implementation status, then we'll be very happy to
> oblige.
> 
> Josh.
> 
>> - - Agenda bashing and Note Well (5min) - - Core normative status
>> (60min) - draft-ietf-abfab-gss-eap-xx -
>> draft-ietf-abfab-gss-eap-naming-xx - draft-ietf-abfab-aaa-saml-xx -
>> - New documents (40 min) - abfab diameter draft -
>> draft-howlett-radsec-knp - draft-adamson-nfsv4-multi-domain-access
>> (tentative) - - Administrativia and AOB (15 min) - OID management 
>> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.10 (GNU/Linux) 
>> O3QAoMNg0gw/SJy8JUWTDm3vO79muPxR =l6Dx -----END PGP SIGNATURE----- 
>> _______________________________________________ abfab mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/abfab
> 
> JANET(UK) is a trading name of The JNT Association, a company
> limited by guarantee which is registered in England under No. 2881024
> _______________________________________________ abfab mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/abfab

---

From: Josh Howlett <[email-masked]>
Date: Tue, 8 Mar 2011 11:20:50 +0000

Klaas,

> minutes" ;-) Do you really think you can do with much less than that?

Well, I'm questioning whether a Moonshot update is appropriate given the demands on time.

We would be very happy to do an update, but I wouldn't want to consume time that could be better spent discussing ABFAB documents.

Do Eliot and Rhys, as editors of the other two documents, have a view on this? I was assuming that discussion of these two docs alone could take 60 minutes, but perhaps not.

Josh.

---

From: Leif Johansson <[email-masked]>
Date: Tue, 08 Mar 2011 12:34:46 +0100

> Do Eliot and Rhys, as editors of the other two documents, have a view on this? I was assuming that discussion of these two docs alone could take 60 minutes, but perhaps not.

I think we could slim the moonshot update a bit if you like but I
also think there should interest from the community in seeing that
abfab isn't just an intellectual exercise.

How about we give you guys a 15 minute slot at least for an update
on the implementation work and devote a 15 minute slot to technical
discussion and feedback on the topics covered during the session?

In planning this we've looked at a model which has been successful
in the yang WG which also separate work into a first session which
is more accessible to people who are not deeply involved in the
core protocol work and a second session which assumes more deep
involvement from participants.

---

From: Josh Howlett <[email-masked]>
Date: Tue, 8 Mar 2011 11:52:29 +0000

> abfab isn't just an intellectual exercise.

Sure, if you think that would be helpful. As it happens we'll have materials and demo kit from the developer meeting, so we'll have something tangible to demo.

Josh.

---

From: Sam Hartman <[email-masked]>
Date: Tue, 08 Mar 2011 07:35:04 -0500

Remember that we'll have spent a day testing and working on things just
before our meeting.

I think things will go one of two ways.

1) The sorts of issues we run into will not be related to the ABFAB
specs. We'll be discussing how to get code working, how to do
application integration.  If this happens we'll probably  not have more
than five minutes of "Hey, here's some code, join our mailing list."

2) The infrastructure works well enough that we actually do a lot of
testing. While I think the ABFAB specs are doing well, I also have
enough familiarity with the IETF to believe that any first testing event
will produce 25 minutes of discussion of the specs that is very
on-target and will be well worth our time.

Who knows. another implementation may pop up and make things
really useful on the spec front.

--Sam

---

From: Josh Howlett <[email-masked]>
Date: Tue, 8 Mar 2011 12:52:32 +0000

Leif, Klaas,

Seems like I am completely out-voted. We'll take the 25 minutes if it's still on the table; thank you again :-)

Josh.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 08 Mar 2011 14:02:10 +0100

Hi Josh,

Here is what I would rather not have happen: we do an update on Moonshot
/ implementation AND THEN repeat the same issues in document review (or
visa versa).  So long as that doesn't happen, talking about running code
is a good thing.

Eliot

---

From: Leif Johansson <[email-masked]>
Date: Wed, 09 Mar 2011 15:02:06 +0100

> and new documents in the second session.

Last call... this gets published tomorrow.

	Cheers Leif