Subject: [abfab] Issue 12 - AAA vs RADIUS vs DIAMETER terms

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Sat, 17 Dec 2011 17:20:37 +0200

Hi Jim, 

thank you for your detailed review.

In issue 12 http://trac.tools.ietf.org/wg/abfab/trac/ticket/12 you
wrote:

"
We have defined a IdP as containing a radius server. 
Issue #1 <http://trac.tools.ietf.org/wg/abfab/trac/ticket/1>  is should
radius always be capitalized?
Issue #2 <http://trac.tools.ietf.org/wg/abfab/trac/ticket/2>  At this
point - should we say that we use the term RADIUS as being either RADIUS
or DIAMETER?
"

Yes, RADIUS should be capitalized. Diameter is not capitalized. 

Regarding item #2 we have two options:

a)	We could instead of using the term RADIUS use AAA to refer to
both RADIUS and Diameter.
b)	We could, as you indicate, state that we use the term RADIUS
without any loss of generality. 

I think the question ultimately boils down to what our audience better
understands.
I don't really know but I prefer (a) since that's what I have done in
other docs.

Ciao
Hannes

---

From: "Jim Schaad" <[email-masked]>
Date: Sat, 17 Dec 2011 13:00:56 -0800

Given that to date we have very explicitly designed things to work w/ RADIUS
and  have not taken on the work for Diameter, but that we all say that it
should work just fine w/ Diameter.   I think that making a statement the
first time we use RADIUS that it does not preclude the use of Diameter and
then always using RADIUS is fine.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tschofenig, Hannes (NSN - FI/Espoo)
Sent: Saturday, December 17, 2011 7:21 AM
To: [email-masked]
Subject: [abfab] Issue 12 - AAA vs RADIUS vs DIAMETER terms

Hi Jim, 

In issue 12  <http://trac.tools.ietf.org/wg/abfab/trac/ticket/12>
http://trac.tools.ietf.org/wg/abfab/trac/ticket/12 you wrote:

"

Issue #2 <http://trac.tools.ietf.org/wg/abfab/trac/ticket/2>  At this point
- should we say that we use the term RADIUS as being either RADIUS or
DIAMETER?

"

a)      We could instead of using the term RADIUS use AAA to refer to both
RADIUS and Diameter.

b)      We could, as you indicate, state that we use the term RADIUS without
any loss of generality. 

I don't really know but I prefer (a) since that's what I have done in other
docs.

Ciao

Hannes

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Sun, 18 Dec 2011 11:55:24 +0200

Hi Jim, 

I thought that the chairs will re-issue a call for the Diameter part and
then make a decision. 

Am I wrong? 

Ciao
Hannes

From: ext Jim Schaad [mailto:[email-masked]] 
Sent: Saturday, December 17, 2011 11:01 PM
To: Tschofenig, Hannes (NSN - FI/Espoo); [email-masked]
Subject: RE: [abfab] Issue 12 - AAA vs RADIUS vs DIAMETER terms

Given that to date we have very explicitly designed things to work w/
RADIUS and  have not taken on the work for Diameter, but that we all say
that it should work just fine w/ Diameter.   I think that making a
statement the first time we use RADIUS that it does not preclude the use
of Diameter and then always using RADIUS is fine.

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Tschofenig, Hannes (NSN - FI/Espoo)
Sent: Saturday, December 17, 2011 7:21 AM
To: [email-masked]
Subject: [abfab] Issue 12 - AAA vs RADIUS vs DIAMETER terms

Hi Jim, 

In issue 12 http://trac.tools.ietf.org/wg/abfab/trac/ticket/12
<http://trac.tools.ietf.org/wg/abfab/trac/ticket/12>  you wrote:

"

"

Ciao

Hannes

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Dec 2011 10:11:06 +0100

On 12/18/2011 10:55 AM, Tschofenig, Hannes (NSN - FI/Espoo) wrote:
> Hi Jim,
> 
> 
> 
> I thought that the chairs will re-issue a call for the Diameter
> part and then make a decision.
> 
> Am I wrong?

Yes :-) and no.

We did issue a call to adopt draft-jones-diameter-abfab-00 on 4/8 and
got 0 (zero) replies.

I don't think we can take silence as acceptance in this case ;-)

If we get reactions to this issue we'll re-issue the call.

	Cheers Leif

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 19 Dec 2011 11:31:13 +0200

Hi Leif, 

I am afraid that I missed the call as well and quite likely the DIME
group wasn't aware of it either. 

Ciao
Hannes

> -----Original Message-----
> Of ext Leif Johansson
> Sent: Monday, December 19, 2011 11:11 AM
> To: [email-masked]
> Subject: Re: [abfab] Issue 12 - AAA vs RADIUS vs DIAMETER terms
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAk7u/6kACgkQ8Jx8FtbMZneabACguHfFRnbGSRsXL7Of/SBznjrN
> jEEAn05SNIxkon9uGCRmwwXnRmlT2i6s
> =JEoS
> -----END PGP SIGNATURE-----
> _______________________________________________
> abfab mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/abfab

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Dec 2011 15:48:13 +0100

On 12/19/2011 10:31 AM, Tschofenig, Hannes (NSN - FI/Espoo) wrote:
> Hi Leif,
> 
> I am afraid that I missed the call as well and quite likely the
> DIME group wasn't aware of it either.
> 
> Ciao Hannes

Well we sort-of assumed you were all for it ;-)

I'm more worried that nobody else in the WG chimed in. I'm not sure
why we should involve DIME in this work though.

	Cheers Leif

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 19 Dec 2011 17:02:22 +0200

> why we should involve DIME in this work though.

Well. That is where the guys are who work on Diameter. 

In general, it is worthwhile to reach out to other communities with
regard to the generic ABFAB idea. 

Currently, we seem to be focusing on the education / research community
only. Diameter is not widely used in those areas but rather in the
telecommunication space, i.e. fixed and mobile operators. 

Ciao
Hannes

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Dec 2011 16:03:42 +0100

On 12/19/2011 04:02 PM, Tschofenig, Hannes (NSN - FI/Espoo) wrote:
>> I'm more worried that nobody else in the WG chimed in. I'm not
>> sure why we should involve DIME in this work though.
> 
> In general, it is worthwhile to reach out to other communities
> with regard to the generic ABFAB idea.
> 
> Currently, we seem to be focusing on the education / research
> community only. Diameter is not widely used in those areas but
> rather in the telecommunication space, i.e. fixed and mobile
> operators.

I'm still worried that nobody answered.

Should we do another call?

---

From: Sam Hartman <[email-masked]>
Date: Mon, 19 Dec 2011 10:04:59 -0500

I also prefer AAA to RADIUS.
I think a couple of places for clarity we should say RADIUS or Diameter
to indicate common AAOA protocols.
If a specific example involves one technology it's fine to use that.

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Mon, 19 Dec 2011 17:18:47 +0100

> If a specific example involves one technology it's fine to use that.

Coming from the academic community and being part of the telco sector right now, I cannot but fully agree with Sam and Hannes on this.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:      +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Sam Hartman <[email-masked]>
Date: Mon, 19 Dec 2011 12:15:02 -0500

FWIW, I kind of missed the call too.  I'd say that if Diameter is going
to be used, it would be desirable to use ABFAB with Diameter.  I have no
current plans to implement ABFAB technology for Diameter.  However if
people are willing to write the document, I'm happy to review it.  If we
have enough authors and reviewers, I think the WG should adopt the
document
I don't think the Diameter document should block other work.

--Sam