Subject: [abfab] I-D Action: draft-ietf-abfab-usability-ui-considerations-02.txt

From: [email-masked]
Date: Mon, 06 Jul 2015 09:04:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Application Bridging for Federated Access Beyond web Working Group of the IETF.

        Title           : Application Bridging for Federated Access Beyond web (ABFAB) Usability and User Interface Considerations
        Author          : Rhys Smith
	Filename        : draft-ietf-abfab-usability-ui-considerations-02.txt
	Pages           : 21
	Date            : 2015-07-06

Abstract:
   The real world use of ABFAB-based technologies requires that any
   identity that is to be used for authentication has to be configured
   on the ABFAB-enabled client device.  Achieving this requires software
   on that device (either built into the operating system or a
   standalone utility) that will interact with the user, managing their
   identity information and identity-to-service mappings.  All designers
   of software to fulfil this role will face the same set of challenges.
   This document aims to document these challenges with the aim of
   producing well-thought out UIs with some degree of consistency
   between implementations.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-abfab-usability-ui-considerations/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-abfab-usability-ui-considerations-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-abfab-usability-ui-considerations-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rhys Smith <[email-masked]>
Date: Mon, 6 Jul 2015 16:10:23 +0000

Hi all,

I've updated the UI draft, finally. I think it’s now complete. Have written the security considerations section and the error handling section (the last two that needed doing), and tidied up some other bits and pieces.

Would still welcome all feedback and some more comprehensive suggested text for both of those (security considerations & error handling), but if none is forthcoming then in the interests of getting this done and dusted I think it’s good to go. No more TODOs left in the document at least :-)

Best,
Rhys.
--
Dr Rhys Smith
Chief Technical Architect, Trust & Identity
Jisc

T: +44 (0) 1235 822145
M: +44 (0) 7968 087821
Skype: rhys-smith
GPG: 0x4638C985
Lumen House, Library Avenue, Harwell Oxford, Didcot, OX11 0SG

jisc.ac.uk

Jisc is a registered charity (number 1149740) and a company limited by guarantee which is registered in England under Company No. 5747339, VAT No. GB 197 0632 86. Jisc’s registered office is: One Castlepark, Tower Hill, Bristol, BS2 0JA. T 0203 697 5800.

> On 6 Jul 2015, at 17:04, [email-masked] wrote:
> 
> 
> _______________________________________________
> abfab mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/abfab
>

---

From: Leif Johansson <[email-masked]>
Date: Mon, 06 Jul 2015 21:05:46 +0200

> https://tools.ietf.org/html/draft-ietf-abfab-usability-ui-considerations-02

Thx - I have a record of Ken volunteering to do a review of this once it
was updated.

If you two (and others) could do a review we could move to WGLC this.

	Cheers Leif

---

From: Alejandro Pérez Méndez <[email-masked]>
Date: Tue, 7 Jul 2015 10:32:57 +0200

> If you two (and others) could do a review we could move to WGLC this.

I'll do a review as well.

Regards,
Alejandro

---

From: "Leif Johansson" <[email-masked]>
Date: Tue, 7 Jul 2015 14:07:34 +0200

> 7 jul 2015 kl. 10:33 skrev Alejandro Pérez Méndez <[email-masked]>:
> 
> 
> 

thx!

---

From: Alejandro Pérez Méndez <[email-masked]>
Date: Wed, 15 Jul 2015 11:11:03 +0200

Hi,

here is my review of draft-ietf-abfab-usability-ui-considerations-02.txt.
In general, I've found no difficulties reading it, as it is very clear 
and complete. I have only a few minor comments some nits:

  * Section 5.1: s/internet/Internet
  * Section 5.1: A reference to Microsoft Cardspace would be nice.
  * Section 6: s/will need to managed/will need to manage
  * Section 6.1: s/user to authenticate themselves/users to authenticate
    themselves
  * Section 7: Does user-driven manual association take precedence over
    automated one? E.g.: when the user decides that a particular IMAP
    server will use ID2 instead of the rule "all IMAP servers will use
    ID1". If so, it might be useful to state it somewhere.
  * Section 11 and 12: Should these sections be moved to the end of the
    document, right before references section?
  * Section 13: A reference to DANE would be nice.

Regards,
Alejandro

El 07/07/15 a las 10:32, Alejandro Pérez Méndez escribió:
>>> I've updated the UI draft, finally. I think it’s now complete. Have 
>>> written the security considerations section and the error handling 
>>> section (the last two that needed doing), and tidied up some other 
>>> bits and pieces.
>>>
>>> Would still welcome all feedback and some more comprehensive 
>>> suggested text for both of those (security considerations & error 
>>> handling), but if none is forthcoming then in the interests of 
>>> getting this done and dusted I think it’s good to go. No more TODOs 
>>> left in the document at least :-)
>>>