Subject: Fwd: Query Regarding SNMP Communication

From: Randy Presuhn <[email-masked]>
Date: Mon, 4 Feb 2002 10:26:03 -0800 (PST)

Hi -

I'm forwarding a non-subscriber posting to the agentx
working group mailing list from [email-masked].
Subscription instructions are available at
http://www.ietf.org/html.charters/agentx-charter.html

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id FAA10797
> 	for <[email-masked]>; Mon, 4 Feb 2002 05:23:29 -0800 (PST)
> Received: from mx-us-hou-1-int.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with ESMTP id g14DLr006555
> 	for <[email-masked]>; Mon, 4 Feb 2002 07:21:53 -0600 (CST)
> Received: from web9908.mail.yahoo.com (unknown [216.136.129.251])
> 	by mx-us-hou-1-int.bmc.com (Postfix) with SMTP id 808E320EFC1
> 	for <[email-masked]>; Mon,  4 Feb 2002 07:24:55 -0600 (CST)
> Message-ID: <[email-masked]>
> Received: from [202.89.67.69] by web9908.mail.yahoo.com via HTTP; Mon, 04 Feb 2002 05:24:55 PST
> Date: Mon, 4 Feb 2002 05:24:55 -0800 (PST)
> From: gangadhar sabat <[email-masked]>
> Subject: Query Regarding SNMP Communication
> To: [email-masked]
> MIME-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> 
> Sir,
>    I have some query regarding Master-agent Subagent
> communication. If it possible please guide me
> regarding following questions:-
> 
> 1. As you know some tool kits are available in market
> to generate SNMP agent stub code. But some of them are
> providing SNMP interface instead of Agentx or SMUX to
> communicate between Master-Agent & Sub-Agent. Is there
> any problem to go for SNMP interface instead of
> Agentx?
> 
> 2. In our case we want to develop a SNMP Master-Agent,
> Sub-Agent architecture where Master-Agent will situate
> in one card & Sub-Agent will situate in other card
> with all these cards having different processor. In
> our case which communication is better? If we choose
> SNMP interface is there any problem between
> Master-agent & Sub-Agent communication.
> 
>                   Thanks in advance
> Regards
> Gangadhar Sabat
> 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Great stuff seeking new owners in Yahoo! Auctions! 
> http://auctions.yahoo.com
>

---

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Mon, 4 Feb 2002 13:57:53 -0500

Hi,

> any problem to go for SNMP interface instead of

AgentX is the IETF standard protocol for SNMP agent
extensibility.

AgentX defines operations (e.g., registration for
MIB/group/table/row/object/instance responsibility,
index [de-]allocation, connection management, etc.)
that are essential for an extensible SNMP agent
environment that are "meta-operations" from the
perspective of SNMP itself.

AgentX facilitates (and hopefully economizes) the
process of acquiring and employing independently
developed sub-agents (from multiple sources).

The AgentX protocol for master/sub(s) interoperation
is generally considered to be lighter-weight (wrt
learning curve, processing cycles, and "on the wire"
overhead) than an SNMP equivalent.
> Master-agent & Sub-Agent communication.

AgentX is the IETF standard solution for the generic
application you describe.  Particular circumstances
can define special cases where a non-standard approach
might be preferable.  Nothing in your description
indicates that you have specialized application
requirements here -- unless you might want to use
a specialized communication protocol between the
master and the sub-agents (but while AgentX defines
some standard master/sub communication interfaces,
it does not preclude offering any others that might
work better in a given situation).

An SNMP-only approach is almost always feasible --
i.e., can be made to work -- but (1) would need to
"re-invent the wheels" in areas where AgentX was
designed to roll from the ground up and (2) would
most likely incur costs exceeding the cost of an
AgentX solution.

>                   Thanks in advance

You're welcome...I hope my comments address your
questions in a helpful manner...if they are unclear
or raise new questions, please let me know.

> Gangadhar Sabat

Cordially,

BobN
AgentX WG Chair