Subject: Re: Algorithm for comparing two email addresses (draft-ietf-smime-3850bis)?

From: Barry Leiba <[email-masked]>
Date: Thu, 08 Jan 2009 14:11:36 -0500

I'm with Paul on the DISCUSS question.  The proper method for comparing addresses 
has to be specified somewhere (I'm not sure your algorithm is even complete; what 
about RFC 2047 encodings; what about Unicode issues when we go to EAI?), but it's 
not here, and this shouldn't be held up for it.  At the most, I'd ask that they 
put in a notation that the right side SHOULD be treated as ASCII-case-insensitive.

As to where such a document belongs, I suggest EAI: since it's changing the 
rules, it should probably document them.

[For what it's worth, I think this is related to the issue of mail loops in 
sieve-notify-mailto, and sieve-vacation, along with other instances in other 
places.  There may be a need for a BCP about certain aspects of dealing with 
email, and it needs to be tackled.  But we can't just pick some unfortunate 
victim that happens to mention the problem and say, basically, "You touched it; 
you fix it."]

Barry

_______________________________________________
Apps-Discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: <[email-masked]>
Date: Fri, 9 Jan 2009 11:51:58 +0200

Hi all,
I agree with the previous speakers on EAI.
But, I feel that IDNA should be taken into account, too. 

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Barry Leiba
Sent: 08 January, 2009 21:12
To: Chris Newman; [email-masked]
Cc: Tim Polk; [email-masked]; [email-masked]
Subject: Re: Algorithm for comparing two email addresses (draft-ietf-smime-3850bis)?

I'm with Paul on the DISCUSS question.  The proper method for comparing addresses has to be specified somewhere (I'm not sure your algorithm is even complete; what about RFC 2047 encodings; what about Unicode issues when we go to EAI?), but it's not here, and this shouldn't be held up for it.  At the most, I'd ask that they put in a notation that the right side SHOULD be treated as ASCII-case-insensitive.

As to where such a document belongs, I suggest EAI: since it's changing the rules, it should probably document them.

[For what it's worth, I think this is related to the issue of mail loops in sieve-notify-mailto, and sieve-vacation, along with other instances in other places.  There may be a need for a BCP about certain aspects of dealing with email, and it needs to be tackled.  But we can't just pick some unfortunate victim that happens to mention the problem and say, basically, "You touched it; you fix it."]

Barry