Subject: host-meta comments

From: Breno de Medeiros <[email-masked]>
Date: Wed, 18 Feb 2009 08:23:52 -0800

While /host-meta is intended to be parsed by machines and not human-readable
content, it is often the case that users eyeball such content for clues. For
instance:

1. Developer is writing and debugging a library to parse host-meta files.
2. Developer is looking at /host-meta examples to get clues on how to write
one for his site.

Being able to add human-readable comments on site-meta can be useful for
such tasks. It also helps to preserve 'institutional memory' by
documentation in place, which is often the only one that developers can
locate.

Should there be a simple mechanism for line comments in site-meta?

-- 
--Breno

+1 (650) 214-1007 desk
+1 (408) 212-0135 (Grand Central)
MTV-41-3 : 383-A
PST (GMT-8) / PDT(GMT-7)

---

From: Dirk Balfanz <[email-masked]>
Date: Wed, 18 Feb 2009 08:54:48 -0800

On Wed, Feb 18, 2009 at 8:23 AM, Breno de Medeiros <[email-masked]> wrote:

> While /host-meta is intended to be parsed by machines and not
> human-readable content, it is often the case that users eyeball such content
> for clues. For instance:
>

+1 for comments.

I propose that any line that starts with # (possibly preceded by whitespace)
is a comment.

Dirk.

---

From: Breno de Medeiros <[email-masked]>
Date: Thu, 19 Feb 2009 18:38:20 -0800

Good point. Sounds good to me.

On Thu, Feb 19, 2009 at 4:00 PM, Mark Nottingham <[email-masked]> wrote:

>
> The problem is that this will make it impossible to use an existing HTTP
> header parser (e.g., in Python, Perl, Ruby, whatever's standard library), a
> goal that's guided a lot of the design.
>
> Why not just use
>
> Link: </foo>; rel="something"
> Comment: This one is for you, Joe!
> Link </bar>; rel="joes-link"
>
> ?
>
>
>
> On 19/02/2009, at 3:54 AM, Dirk Balfanz wrote:
>
>
>>
>> 2. Developer is looking at /host-meta examples to get clues on how to
>> write one for his site.
>>
>> I propose that any line that starts with # (possibly preceded by
>> whitespace) is a comment.
>>
>> Dirk.
>>
>
>
> --
> Mark Nottingham       [email-masked]
>
>
>

-- 
--Breno

+1 (650) 214-1007 desk

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 20 Feb 2009 11:00:25 +1100

The problem is that this will make it impossible to use an existing  
HTTP header parser (e.g., in Python, Perl, Ruby, whatever's standard  
library), a goal that's guided a lot of the design.

Why not just use

?

On 19/02/2009, at 3:54 AM, Dirk Balfanz wrote:

> While /host-meta is intended to be parsed by machines and not human- 
> readable content, it is often the case that users eyeball such  
> content for clues. For instance:
>
> 2. Developer is looking at /host-meta examples to get clues on how  
> to write one for his site.
>
> Being able to add human-readable comments on site-meta can be useful  
> for such tasks. It also helps to preserve 'institutional memory' by  
> documentation in place, which is often the only one that developers  
> can locate.
>