Subject: Re: Re: Solicitation for a discussion on Keyword-based addressing

From: "张国强" <[email-masked]>
Date: Thu, 09 Apr 2009 10:08:09 +0800

�����������������ᵽ:
>From: "Randy Presuhn" <[email-masked]>
>Reply-To: 
>To: <[email-masked]>
>Subject: Re: Re: Solicitation for a discussion on Keyword-based addressing
>Date:Wed, 8 Apr 2009 16:26:47 -0700
>
>Hi -
>
>> From: "zhangguoqiang" <[email-masked]>
>> To: "St�phaneBortzmeyer" <[email-masked]>
>> Cc: <[email-masked]>; <[email-masked]>
>> Sent: Tuesday, April 07, 2009 11:59 PM
>> Subject: Re: Re: Solicitation for a discussion on Keyword-based addressing
>...
>> For two level keywords, different countries may have different writing
>> conventions. Western people often write the most significant part in
>> the rightmost portion,
>
>This is the second time I've seen this assertion.
>It rings false, so I'd like to know just what is
>being claimed here.
>
>The existence of "Western" languages in which adjectives follow
>nouns (e.g. Spanish), precede them (e.g. German) and occur on
>both sides (e.g. French), as well as the widespread convention
>of writing numbers most-significant portion first, all seem
>to contradict the assertion that there is some sort of "western bias"
>towards putting the most significant part rightmost.

What I mean is domain name like writing convention, or the post mail address
writing convention. For example, "pku.edu.cn", but in Chinese writing convention,
"cn.edu.pku" is more preferable. 

>Randy
>
>
>_______________________________________________
>Apps-Discuss mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/apps-discu

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 8 Apr 2009 19:30:57 -0700

Hi -

> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Sent: Wednesday, April 08, 2009 7:08 PM
...
> "cn.edu.pku" is more preferable. 

There's nothing "western" about the order of elements in a domain name.

I also do not see how "western" postal conventions are like domain names - 
Postal codes in the US, to the extent that they even *have* a structure,
definitely put the most significant part on the left.  When writing a
street address, it's a mixture - in the US we write the building number
first, then the street name, and then the apartment number, which means
the "most significant part" is in the middle.  In Germany, one writes
Country code, then postal code, then the city name, which means the most
significant part is on the left, and the least significant part is in the
middle.  The claim that domain names have some sort of "western" bias
just does not hold water.

Randy

---

From: "zhangguoqiang" <[email-masked]>
Date: Thu, 9 Apr 2009 10:43:00 +0800

Thanks for your clarification. I will remove the "western" word from my statement. 

Your mentioned facts is a good message. It proves the diversity of writing conventions all across the world, which should be respected in keyword like services.

2009-04-09 

zhangguoqiang 

发件人： Randy Presuhn 
发送时间： 2009-04-09  10:29:06 
收件人： [email-masked] 
抄送： 
主题： Re: Re: Solicitation for a discussion on Keyword-based addressing 
 
Hi -

> From:  <[email-masked] >
> To:  <[email-masked] >;  <[email-masked] >
..

Randy

_______________________________________________
Apps-Discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 10 Apr 2009 11:39:13 +0200

On Thu, Apr 09, 2009 at 10:08:09AM +0800,
 <[email-masked]> wrote 
 a message of 60 lines which said:

> What I mean is domain name like writing convention, or the post mail
> address writing convention. For example, "pku.edu.cn", but in
> Chinese writing convention, "cn.edu.pku" is more preferable.

Not just the Chinese, after all, the British wrote domain names in
big-endian form for many years... Every Janet user fondly remembers it
(and it is another proof that the West is not specially
little-endian.)

But isn't it just a UI issue? Could it be solved by the UI swapping
between the "network label order" and the "host label order"?

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 10 Apr 2009 11:36:35 +0200

On Wed, Apr 08, 2009 at 07:30:57PM -0700,
 Randy Presuhn <[email-masked]> wrote 

> There's nothing "western" about the order of elements in a domain

Indeed, saying that the West is little-endian (least significant
first) and the East big-endian (most significant first) is clearly
false. 

To Randy's examples, you can add the way dates are displayed, the
French and British conventions are little-endian but ISO 8601 is
big-endian and the US is mixed.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 10 Apr 2009 19:30:23 +0900

> (and it is another proof that the West is not specially

I think I seem to remember that I once heard Tim Berners-Lee saying that 
it might have been better to invert the domain name label ordering when 
creating URIs. But that may have been somebody else.

Anyway, currently URIs are part Big-endian (scheme and path) and part 
little-endian (domain name), which we might call a "fair compromize".

> between the "network label order" and the "host label order"?

If it were only for personal computers, where personal means "this is 
mine", then maybe. But domain names have to work on billboards,..., 
where a per-viewer switching is slightly difficult to implement.

Regards,   Martin.

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Sat, 11 Apr 2009 12:40:07 -0400

--On Friday, April 10, 2009 11:39 +0200 Stephane Bortzmeyer
<[email-masked]> wrote:

> Not just the Chinese, after all, the British wrote domain
> names in big-endian form for many years... Every Janet user
> fondly remembers it (and it is another proof that the West is
> not specially little-endian.)
> 
> But isn't it just a UI issue? Could it be solved by the UI
> swapping between the "network label order" and the "host label
> order"?

Since you cite the JANET experience, I would refer you back to
it for the answer to this question.  Identifiers, whether domain
names or otherwise, are handed to others, embedded in text, etc.
When someone (or some software) cannot tell by looking which
order something is in, we have a bad problem.  Contemplate
au.co.ac.uk and tell me whether it is left-to-right or right to
left.

This is one of several reasons why keyword systems should not
look like domain names.  One can think of many ways to do that
and still retain an optional location-qualifier or
system-qualifier.  For example, if the keyword is "foo" and the
location qualifier is "bar", then "foo.bar" and "bar.foo" are
equally undesirable -- they get tied up with the ordering
problem, then look like domain names, and one can't tell which
is which except by position.  However consider the following as
just four of many examples, each of which has a precedent
elsewhere:

   foo                     (the short form)
   foo[bar] or [bar]foo    (order-independent, does not look
                         like a domain name, but the 
                         delimiters may not be i18n-optimal)
   <keyword system="bar">foo</keyword>
   /country=bar/keyword=foo  (in either order)

> You're playing with words: if there is a system to allow
> people not to type the country-code of the keyword, for
> instance because a korean has a default country-code of "kr",
> then, the same system can be applied to domain names and ".kr"
> can be appended automatically (many Web browsers do it for
> ".com", for instance).

Certainly true as long as the keywords look like domain names,
but see above.

Where I imagine we are in agreement is that keyword systems are
hardly worth the trouble if they do not offer very significant
advantages over a flat-hierarchy DNS with labels expressed in a
different order.  For example, I'd hope to see more language
sensitivity, including in matching rules, than the DNS can offer
and perhaps strong alias and/or referral mechanisms, a mechanism
for dealing with replicated versions of the same object that
doesn't raise the URI-related problems of URNs, or similar
capabilities.

   john