Subject: Re: Solicitation for a discussion on Keyword-based addressing

From: "张国强" <[email-masked]>
Date: Tue, 07 Apr 2009 10:27:43 +0800

�����������������ᵽ:
>From: Andrew Sullivan <[email-masked]>
>Reply-To: 
>To: [email-masked]
>Subject: Re: Solicitation for a discussion on Keyword-based addressing
>Date:Thu, 2 Apr 2009 11:17:21 -0400
>
>On Wed, Apr 01, 2009 at 11:16:36AM +0800, zhangguoqiang wrote:
> 
> >  webpage, while IDN is used to access a web site. Second, keyword
> >  eases user's experience by eliminating the need to remember
> >  potentially great number of suffixes. 
> 
> That argument is a little odd: instead of the user needing to remember
> a bounded number of suffixes, the user has to remember a completely
> unbounded number of keywords.  Moreover, the user has to guess just
> the right keyword for the particular site desired, since if keywords
> are to be an addressing technology then the words in question have to
> be unique to a destination.

I think you misunderstood the idea. Keywords eliminates the need to remember
suffixes. Compared with Keywords, domain names require users to remember not only
the unbounded number of names itself( for example, "hp" part in the "hp.com"), but
also the bounded number of suffixes("com" part in the "hp.com"). It is a K:1
problem where K is the number of possible suffixes. 

> 
> This is not to dismiss the arguments for keywords, but I don't think
> that it actually makes a user's experience any easier except in
> peculiar cases.
> 
> A
> 
> -- 
> Andrew Sullivan
> [email-masked]
> Shinkuro, Inc.
> _______________________________________________
> Apps-Discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 10 Apr 2009 11:30:51 +0200

On Tue, Apr 07, 2009 at 10:27:43AM +0800,
 <[email-masked]> wrote 
 a message of 64 lines which said:

> I think you misunderstood the idea. Keywords eliminates the need to
> remember suffixes.

You're playing with words: if there is a system to allow people not to
type the country-code of the keyword, for instance because a korean
has a default country-code of "kr", then, the same system can be
applied to domain names and ".kr" can be appended automatically (many
Web browsers do it for ".com", for instance).