Subject: Re: Solicitation for a discussion on Keyword-based addressing

From: "张国强" <[email-masked]>
Date: Thu, 02 Apr 2009 09:57:25 +0800

�����������������ᵽ:
>From: Stephane Bortzmeyer <[email-masked]>
>Reply-To: 
>To: zhangguoqiang <[email-masked]>
>Subject: Re: Solicitation for a discussion on Keyword-based addressing
>Date:Wed, 1 Apr 2009 10:48:23 +0200
>
>On Wed, Apr 01, 2009 at 11:16:36AM +0800,
>  zhangguoqiang <[email-masked]> wrote 
>  a message of 156 lines which said:
> 
> > Different from search engines, keyword-based addressing is an
> > addressing technology. Based on whether a keyword is registered or
> > not, the resolution result is determinstic for any given keyword, 
> 
> Then it will have all the problems of the domain names, including
> bureaucratic registration rules, UDRP, lawyers, ICANN, etc.
> 
> > For example, if you are a blogger of a portal blog website,
> > typically, you are assigned a URL that identifies your blog. It is
> > usually composed of two parts: a domain name and an ID(typically a
> > magic number). So how can you advertise your blog to your friends? 
> 
> tinyurl.com
> 
> But it is simpler to buy a domain name and redirect.
> 
> > So, we think keyword-based addressing is a very useful technique,
> > especially for non-english speaking countries. Even for english
> > speaking countries, the above example also illustrates its
> > practicability. To internationalize this service and provide cross
> > resolution capability, we highly recommend a standard being
> > developped. 
> 
> I'm very skeptical but I'll read your draft.
> 
> > Our keyword-based addressing draft is available at
> > http://tools.ietf.org/html/draft-zhang-keyword-ddds-00, which
> > specifies keyword-based addressing as a DDDS application.
> 
> You apparently do not mention RFC 2345 (keywords are a very old idea
> which keep popping up from time to time).

Yes,I will read that RFC. But you should read my draft too.

---

From: John C Klensin <[email-masked]>
Date: Wed, 01 Apr 2009 23:53:27 -0400

--On Thursday, April 02, 2009 09:57 +0800 张国强
<[email-masked]> wrote:

>...
>> You apparently do not mention RFC 2345 (keywords are a very
>> old idea which keep popping up from time to time).
> 

In my capacity as lead author of 2345 (and without consulting my
co-authors),...

-- It had not occurred to me until I read Stephane's note that
this was actually one of the first published descriptions of the
keyword approach although, in retrospect, it probably was.

-- The "keep it as simple as possible" approach taken in that
document would put DDDS and NAPTR records, neither of which
existed at the time, in the same category as the other more
complex database mechanisms and query techniques that it
describes with disfavor.

-- While it could be updated, probably in obvious ways (but
don't expect me to do it), some of the technology suggestions
are clearly those of an experimental 1998 protocol, not a
production 2009 one: no provision for non-ASCII strings, single
points of failure, no authentication of responses, etc.

-- Please don't bother trying to look for the test programs and
examples.  I should try to find them sometime and put them
somewhere stable for historical reasons even though the odds of
their running on contemporary operating systems is just about
zero, but my recollection is that the domain shown for those
materials was effectively retired in 1999 or thereabouts.

regards,
    john