Subject: Registration timing of new URI schemes

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 Aug 2009 11:31:57 -0700

While working on a new protocol we (might have) identified a need for a new URI scheme. The problem is that the protocol and use cases are still in their early stage, and will require multiple iterations and experimentation to figure out. At the same time, this effort has failed over the past two years because of attempts to find the 'ideal' solution prior to real work experimentations. We are trying something different now by building a couple of live services offered by some large web players.

The proposed new URI scheme is not yet well defined. We only have small bits of information about how it should work, whether it could/should be resolvable, and if it should be bound to a specific protocol. But we are only going to figure it out by experimentation.

The question is, at what point should we request a provisional registration of the new URI scheme? How much running code and actual deployment is appropriate? We might end up using an existing scheme instead or decide that the new scheme is indeed required.

I am asking this because I have no desire to spend time and energy discussing a new URI scheme (and provisional at that) when we clearly don't have all the answers. But at the same time, I don't want to cause problems by using a new scheme that is not at all registered.

Any guidelines? BCP 35 does not provide guidelines as to *when* should a new URI scheme be registered and how much experimentation is allowed.

EHL

---

From: Tim Bray <[email-masked]>
Date: Wed, 19 Aug 2009 11:36:18 -0700

> While working on a new protocol we (might have) identified a need for a new URI scheme. The problem is that the protocol and use cases are still in their early stage, and will require multiple iter…

Well, one thing that has historically happened is that when you put in
the new-scheme request, a bunch of grumpy old Web-heads want to have
an argument as to whether you really need a new one, when there are
lots of other perfectly good ones out there and quite a bit of benefit
from re-use.

You might save some time and irritation by having that argument first,
and it might help you progress your thinking about the problem in
general.   -Tim

---

From: Mark Baker <[email-masked]>
Date: Wed, 19 Aug 2009 16:19:40 -0400

> Any guidelines? BCP 35 does not provide guidelines as to *when* should a new URI scheme be registered and how much experimentation is allowed.

I think the "when" is "when you meet the requirements of section 3",
and I doubt you'd have any trouble meeting them, even if the
referenced specification was a work in progress.  The provisional
registry exists in large part for situations like the one you
describe.

Mark.

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 19 Aug 2009 21:33:45 +0200

* Eran Hammer-Lahav wrote:
>I am asking this because I have no desire to spend time and energy
>discussing a new URI scheme (and provisional at that) when we clearly
>don't have all the answers. But at the same time, I don't want to cause
>problems by using a new scheme that is not at all registered.

When people come up with new schemes, the main problem I'd have is that
they are usually not properly documented with little evidence of intent
to do that and properly register them. Those concerns would be addressed
if you e.g. keep your thoughts on them in an Internet Draft and keeping
it from expiring, while you would not be dragged into arguments over it
prematurely. Picking a reasonably verbose and specific name for it would
also mitigate concerns over interference with other efforts.

As for timing, if you have multiple independent implementations that are
likely to be maintained for the next few years, that would be too late;
you would need to start discussion when there is still an opportunity to
make possibly substantive changes to those implementations in response
to feedback. In doubt name it "for-experimental-use-only-<schemename>:";
your desire to put it up for discussion should increase alongside your
desire to simply name it "schemename" instead.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/