Subject: Feasibility research request: POP3 and IMAP4 extension to send mail

From: Ravi shankar <[email-masked]>
Date: Thu, 13 Aug 2009 16:26:44 +0530

Hi All,

Need your valuable inputs on the subject of ability to extend the POP3 and
IMAP4 to send mails, in addition to retrieving mails.

I'm currently doing a research on this topic and would like to have your
valuable feedbacks on the possibility and probably hinderance in terms of
any step in the process.

Appreciate your help!

Regards,
Ravi

---

From: "Al Costanzo" <[email-masked]>
Date: Thu, 13 Aug 2009 09:02:24 -0500

Ravi,

Your email does not give us much to go with to respond. I worked on one or two  RFC in my day.

Why would you want to extend protocols that are not intended for this purpose?

Have a look at the RFCs for SMTP and explain why you would want to do this so the IETP could respond to you.

Regards,

Al Costanzo
  ----- Original Message ----- 
  From: Ravi shankar 
  To: [email-masked] 
  Sent: Thursday, August 13, 2009 5:56 AM
  Subject: Feasibility research request: POP3 and IMAP4 extension to send mail

  Hi All,

  Need your valuable inputs on the subject of ability to extend the POP3 and IMAP4 to send mails, in addition to retrieving mails. 

  I'm currently doing a research on this topic and would like to have your valuable feedbacks on the possibility and probably hinderance in terms of any step in the process.

  Appreciate your help!

  Regards,
  Ravi 

------------------------------------------------------------------------------

  _______________________________________________
  Apps-Discuss mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Tony Hansen <[email-masked]>
Date: Thu, 13 Aug 2009 09:26:04 -0400

There was a non-standard extension made to POP3 many years ago to do 
this. It fell on the wayside and no one uses XTND XMIT any more. People 
are expected to use the Submission protocol these days (RFC 4409).

	Tony Hansen
	[email-masked]

Ravi shankar wrote:
> Need your valuable inputs on the subject of ability to extend the POP3 
> and IMAP4 to send mails, in addition to retrieving mails.
>  
> valuable feedbacks on the possibility and probably hinderance in terms 
> of any step in the process.

---

From: Ravi shankar <[email-masked]>
Date: Thu, 13 Aug 2009 19:19:01 +0530

Hi Al,

Much appreciate your reply. I have been doing this feasibility study to
see how blocking port25 from client computers would affect botnets and their
dynamics.

Before i jump in to the pool, thought if someone had similar ideas and their
thoughts of how practical it is.

Regards,
Ravi

On Thu, Aug 13, 2009 at 7:32 PM, Al Costanzo <[email-masked]> wrote:

> *From:* Ravi shankar <[email-masked]>
> *To:* [email-masked]
> *Sent:* Thursday, August 13, 2009 5:56 AM
> *Subject:* Feasibility research request: POP3 and IMAP4 extension to send
> mail
>
> Hi All,
>
> ------------------------------
>

---

From: Ravi shankar <[email-masked]>
Date: Fri, 14 Aug 2009 02:59:53 +0530

Leif,

Actually botnets spread on the end-user computers and they inturn are used
for spreading spam mails.

Spammers still use IRC servers as C & C servers and spread the payload or
commands to the bot malware.

If you can share any documents regarding port 25 blocking by ISPs would  be
helpful for me in my work.
Regards,
Ravi
On Fri, Aug 14, 2009 at 1:50 AM, Leif Johansson <[email-masked]> wrote:

> On Thursday 13 August 2009 15.49.01 Ravi shankar wrote:
> > Hi Al,
> >
> > see how blocking port25 from client computers would affect botnets and
> > their dynamics.
> >
>
> Given that botnets seem to use twitter now the answer is probably "not
> much". ISPs do block port 25 which is why SMTP submission with SMTP
> aiuth on port 587 is a good solution which both exists and is widely
> deployed
> afaik.
>
>        Cheers Leif
>
>
>
>

---

From: Leif Johansson <[email-masked]>
Date: Fri, 14 Aug 2009 13:17:16 +0200

> commands to the bot malware.

or twitter as it turns out :) I thought you were talking about mail-based c&c, 
hence the twitter reference. 

> helpful for me in my work.

Don't have any docs but its a fairly common practice so google should 
be able to give you something...

	Cheers Leif

---

From: "tom.petch" <[email-masked]>
Date: Fri, 14 Aug 2009 18:44:40 +0200

You might also want to consider the archives of the asrg list, where botnets,
port 25 blocking and means of limiting damage have been a regular occurrence.

Tom Petch

----- Original Message -----
From: "Ravi shankar" <[email-masked]>
To: "Al Costanzo" <[email-masked]>; <[email-masked]>
Sent: Thursday, August 13, 2009 3:49 PM
Subject: Re: Feasibility research request: POP3 and IMAP4 extension to send mail

> > valuable feedbacks on the possibility and probably hinderance in terms of

--------------------------------------------------------------------------------

---

From: Alessandro Vesely <[email-masked]>
Date: Sat, 15 Aug 2009 07:40:32 +0400

> of any step in the process.

The server I'm now using has this possibility configured, as 
described in http://www.courier-mta.org/install.html#imapsend

I found no conceptual nor practical difficulty with it, but use 
it seldom.