Subject: Re: [apps-discuss] WGLC: draft-faltstrom-5892bis-04.txt

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 4 May 2011 17:26:34 +0800

Reminder. The WG last call will end soon. If you still have any comments, pls
kindly give it before the deadline.

Best regards,
Jiankang Yao(as a co-chair of APPSAWG)

  ----- Original Message ----- 
  From: Jiankang Yao 
  To: [email-masked] 
  Cc: [email-masked] 
  Sent: Sunday, April 24, 2011 12:25 AM
  Subject: [apps-discuss] WGLC: draft-faltstrom-5892bis-04.txt

  Dear colleagues,

  This message starts a two-week WGLC on the draft
  draft-faltstrom-5892bis-04.txt.  We did formally
  adopt this I-D as a WG document a few months ago.
  There has a lot of discussion and an informal last call for comments about
  this draft in the IDNAbis list [email-masked].  
  The editors/authors of this draft believe that this draft has been in a very good shape.

  Please review the draft.  If you support publication, please state as
  much on the list.  If you are opposed to publication, please state
  that on the list as well.  It is more/only helpful if you give your reasons for
  your position as part of your statement.  

  Since this draft is the WG item of APPSAWG, we favor that the comments to this draft are sent to the list [email-masked]. 

  The WGLC will end on May 08, 2011 at 23:00 UTC.

  Note: This draft is a document that updates an earlier RFC by stating nothing is to be updated. 

  Best regards,
  Jiankang Yao(as a co-chair of APPSAWG)

------------------------------------------------------------------------------

  _______________________________________________
  apps-discuss mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Simon Josefsson <[email-masked]>
Date: Wed, 04 May 2011 11:33:24 +0200

> kindly give it before the deadline.

Could you please clarify the last sentence in the WGLC?  As I asked
before, is the intention that this document will be marked as updating
any earlier RFC or not?  Right now the document does not include any
"Update:" tags, so I'm confused by your statement that the document
updates an earlier RFC.

Thanks,
/Simon

>   Since this draft is the WG item of APPSAWG, we favor that the
> comments to this draft are sent to the list [email-masked].
>

---

From: John C Klensin <[email-masked]>
Date: Wed, 04 May 2011 09:47:33 -0400

--On Wednesday, May 04, 2011 11:33 +0200 Simon Josefsson
<[email-masked]> wrote:

>> Reminder. The WG last call will end soon. If you still have
>> any comments, pls kindly give it before the deadline.
> 
> Could you please clarify the last sentence in the WGLC?  As I
> asked before, is the intention that this document will be
> marked as updating any earlier RFC or not?  Right now the
> document does not include any "Update:" tags, so I'm confused
> by your statement that the document updates an earlier RFC.

Simon,

Personal opinion, speaking for myself only.

This is a judgment call.  If the document were _changing_ the
5892 specification, e.g., by adding an exception rule, it would
clearly be updating 5892.  But it doesn't.  It has no effect
whatsoever other than to document our decision to not do
anything.   So, if we had the requirement (one that I've often
advocated) that any document that says "updates XXX" must
describe what was changed and why, it would have to say
something like "despite the claim that this updates 5892, it
changes absolutely nothing about the spec even though it lets
the expected changes in derived tables with Unicode changes
happen".

Similarly, if 5892 contained a comprehensive explanation of when
we do or do not add exceptions, or this 5892bis document did, it
would be updating 5892.  But 5892 essentially says "judgment
call on a case-by-case basis" and 5892bis doesn't change that
either == we are just making that call.   Our intent, from the
original discussions, was that we accumulate that experience and
then see if we set out clear rules.  I don't think we are much
more ready to do that now than we were 18 months ago.

At the same time, the document doesn't exist without 5892 and we
don't have a category other than "updates" for "hangs off 5892
somehow".

My recommendation to the WG is that we not waste time on this.
The WG Chairs (or other shepherd) should attach a note to the
IESG pointing out the difficulty (borrowing text from your notes
and the above if it would be useful) and leaving it to the IESG
and RFC Editor to decide whether an "updates" header is
appropriate.  They will need to decide anyway and the issue is
really a procedural and editorial one, not one on which the
AppsAWG needs to decide.

Sorry Peter and Pete :-)

best,
     john

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 4 May 2011 06:59:57 -0700

+1 to all of John's logic, and to his suggestion that we punt the decision to the IESG.

--Paul Hoffman

---

From: Joseph Yee <[email-masked]>
Date: Wed, 4 May 2011 17:27:19 -0400

I read the draft and support its publication.

Regards,
Joseph

2011/5/4 Jiankang YAO <[email-masked]>:
> Since this draft is the WG item of APPSAWG, we favor that the comments to
> this draft are sent to the list
> [email-masked].
> ________________________________
>
> Idna-update mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/idna-update
>
>

---

From: "Jiankang YAO" <[email-masked]>
Date: Thu, 5 May 2011 09:13:30 +0800

----- Original Message ----- 
From: "Simon Josefsson" <[email-masked]>
To: "Jiankang YAO" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 04, 2011 5:33 PM
Subject: Re: [apps-discuss] WGLC: draft-faltstrom-5892bis-04.txt

> Could you please clarify the last sentence in the WGLC?  
>

That sentence tries to express the meaning that the authors/editors try to deliver to the WG.
John C Klensin, the contributor of this document, has given the explanation of this sentense in response to your message, and Paul Hoffman, the co-editor/author of this document has confirmed it.

Thanks.

Jiankang Yao

>As I asked
> any earlier RFC or not?  

John has suggested that we should leave it to be decided by IESG.
Personally, I agree with his suggestion.

>
>Right now the document does not include any

---

From: Pete Resnick <[email-masked]>
Date: Wed, 4 May 2011 18:03:39 -0700

On 5/4/11 8:47 AM, John C Klensin wrote:
> Sorry Peter and Pete:-)

Of things the IESG is asked to deal with, this seems not the worst.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 05 May 2011 08:52:39 +0200

"Jiankang YAO" <[email-masked]> writes:

> John C Klensin, the contributor of this document, has given the
> explanation of this sentense in response to your message, and Paul
> Hoffman, the co-editor/author of this document has confirmed it.
>
> Thanks.
>
> Jiankang Yao
>
>>As I asked

Thanks for response -- this seems fine to me as well.

/Simon

---

From: Joseph Yee <[email-masked]>
Date: Thu, 5 May 2011 08:27:27 -0400

Regards,
 Joseph