Subject: [apps-discuss] Fwd: I-D Action: draft-nottingham-http-browser-hints-01.txt

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 May 2011 15:07:38 +1000

FYI.

This draft adds two new hints: chunk-req-bodies and omit-cookies, at the suggestion of Patrick McManus and Poul-Henning Kamp respectively (thanks).

Another question Poul brought up was making it possible to have some hints be more fine-grained. omit-cookies would be a good example for this; instead of applying to the entire server, it could look something like:

'omit-cookies': {'/images/': true, '/images/user_special': false}

I'm a bit wary of making the file too verbose or complex, but the specific use case seems attractive. It could also be useful for the referer-related directives.

Thoughts? One approach to this would be to make the entire file some sort of map to the site, but my initial reaction is that this raises the bar for parsing too high.

Cheers,

Begin forwarded message:

> From: [email-masked]
> Date: 27 May 2011 3:03:08 PM AEST
> To: [email-masked]
> Subject: I-D Action: draft-nottingham-http-browser-hints-01.txt
> Reply-To: [email-masked]
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : HTTP Browser Hints
> 	Author(s)       : Mark Nottingham
> 	Filename        : draft-nottingham-http-browser-hints-01.txt
> 	Pages           : 8
> 	Date            : 2011-05-26
> 
>   Over time, Web browsers have adapted how they use HTTP based upon
>   common server configurations and behaviours.  While this is necessary
>   in the common case, it can be detrimental for performance and
>   interoperability.
> 
>   This document establishes a mechanism whereby origin servers can make
>   available hints for browsers about their preferences and
>   capabilities, without imposing overhead on their interactions or
>   requiring support for them.
> 
>   This is intended to allow browsers to safely optimise connections to
>   servers.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-http-browser-hints-01.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-nottingham-http-browser-hints-01.txt
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

--
Mark Nottingham   http://www.mnot.net/

---

From: Dzonatas Sol <[email-masked]>
Date: Fri, 27 May 2011 01:09:57 -0700

If the values for "omit-cookies" are (already) of environmental scope 
then I think CSS is the solution. One use-case is the web-browser scans 
the CSS for elements and namespaces that relate or are relative to the 
context (cookies can further be enabled/disabled/sent/not-sent in 
content sensitive manner in optimization). That avoids unintentional 
redundancy. If there is intentional difference in scope between global 
and environmental access then that is what I think "raises the bar". We 
can assume one intentional use-case of global access with URL fragments:

'omit-cookies': {'/images/': true, '/images/#!/user_special': false }

...begs the question on who processes.

On 05/26/2011 10:07 PM, Mark Nottingham wrote:
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>    

-- 
--- https://twitter.com/Dzonatas_Sol ---
Web Development, Software Engineering, Virtual Reality, Consultant