Subject: [apps-discuss] draft-saintandre-xdash-considered-harmful

From: Mark Nottingham <[email-masked]>
Date: Fri, 3 Jun 2011 13:13:12 +1000

<http://tools.ietf.org/html/draft-saintandre-xdash-considered-harmful-01>

Will this be progressing? I, for one, would like to see this as an BCP.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 02 Jun 2011 21:22:12 -0600

> Will this be progressing? I, for one, would like to see this as an BCP.

I'd be happy to bring it back to life, although I admit that I've mostly
forgotten about it and that I haven't yet addressed some of the feedback
I received last year. Also, I think "harmful" might be a bit strong --
"considered-useless" perhaps?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 3 Jun 2011 13:24:56 +1000

On 03/06/2011, at 1:22 PM, Peter Saint-Andre wrote:

> I'd be happy to bring it back to life

Please do. Happy to help.

> , although I admit that I've mostly

Not *quite* strong enough. "considered bad practice?"

Or just change the title to something more generic like "Appropriate use of X-".

Cheers,

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Fri, 03 Jun 2011 09:58:22 +0300

> Please do. Happy to help.
Maybe the document may be adopted as APPSAWG document; but the author 
should finally decide on this.
>> "considered-useless" perhaps?
Writing "considered harmful" RFCs is a current practice; see 
https://datatracker.ietf.org/doc/search/?name=harmful&rfcs=on.  So I 
think having the title "X-" Considered Harmful is fine.

Mykyta Yevstifeyev
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: "J.D. Falk" <[email-masked]>
Date: Thu, 9 Jun 2011 18:49:12 -0700

> Or just change the title to something more generic like "Appropriate use of X-".

+1

--
J.D. Falk
the leading purveyor of industry counter-rhetoric solutions

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 10 Jun 2011 15:15:17 +0200

On 3 June 2011 05:22, Peter Saint-Andre wrote:

> I haven't yet addressed some of the feedback
> I received last year. Also, I think "harmful"
> might be a bit strong -- "considered-useless"
> perhaps?

No, "harmful" is clearer.  Some days ago I wasted
hours trying to explain the fine points of MIME
types image/vnd.microsoft.icon vs. image/x-icon
in the Wikipedia favicon article and on my blog.

The worst about it is that I'm far from sure that
I got it right, because I can't test IE7 oddities
on my boxes (and wouldn't be eager to test IE7
even if I could).

If your not yet incorporated feedback covers MIME
x-types please include it.

Cheers,
 Frank