Subject: [apps-discuss] Fwd: I-D Action: draft-yevstifeyev-ftp-iri-00.txt

From: Mykyta Yevstifeyev <[email-masked]>
Date: Fri, 15 Jul 2011 07:26:55 +0300

Hello,

I have uploaded the separate draft regarding i18n of 'ftp' URIs:

http://tools.ietf.org/html/draft-yevstifeyev-ftp-iri-00

It is a supplement to my other draft concerning 'ftp' URI scheme, and it 
intends to update it.  I'd like to ask people to comment the document.  
Please send your comments to [email-masked].

Mykyta Yevstifeyev

P.S. If somebody if confused that I managed to upload the draft after 
cut-off date, I've already sent a message to tools-discuss list :-)  Mykyta

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Fri, 15 Jul 2011 07:29:51 +0300

> Please send your comments to [email-masked].
Sorry, [email-masked].

Mykyta

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 16 Jul 2011 03:57:00 +0200

> http://tools.ietf.org/html/draft-yevstifeyev-ftp-iri-00

That makes no sense.  There should be "i18n considerations"
in your FTP URI draft as mandated by the IETF charset policy
(BCP 18).

This section can mainly consist of a pointer to RFC 3987,
because copying stuff for FTP IRIs already explained for
any IRIs is either redundant, or in the worst case it could
introduce incompatibilities or bugs.

It is good that your IRI draft has a reference to RFC 5198,
but you can get the same effect in i18n considerations of
your URI draft - and as far as I'm concerned that should be
be normative, not only informative.

If you seriously wish to discuss "FTP IRIs" in these i18n
considerations you'd be forced to admit that many legacy FTP
servers use only legacy charsets, and therefore legacy URIs
for resources on such servers are certainly no IRIs.  Worse,
equivalent FTP IRIs would not work with legacy FTP servers.

The more you talk about "FTP IRIs", the worse this gets, so
just don't, and let RFC 3987 (and 3987bis) clean up the mess
for *all* URI schemes (not only FTP).

-Frank