Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-malformed-mail-00.txt

From: Mykyta Yevstifeyev <[email-masked]>
Date: Tue, 09 Aug 2011 17:32:50 +0300

26.07.2011 20:09, Murray S. Kucherawy wrote:
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
>> Sent: Tuesday, July 26, 2011 9:12 AM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: I-D Action: draft-ietf-appsawg-malformed-mail-00.txt
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories. This draft is a work item of the Applications Area Working
>> Group Working Group of the IETF.
>> [...]
> No changes here other than the transition to being a WG document.
>
> Barry and I talked to IANA about a possible path forward with them.  We'll report about that soon.

Murray,

Should this document describe the situation when the message's line is 
longer that 998 characters?  Also, should it describe the situation when 
the headers part contains one or more line breaks, e.g.

> Header: value
> Header1: value1
> Header2: value2
> Header3: value3
> Body

Mykyta Yevstifeyev

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 9 Aug 2011 10:19:12 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Mykyta Yevstifeyev
> Sent: Tuesday, August 09, 2011 7:33 AM
> To: [email-masked]
> Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-malformed-mail-00.txt
> 

Sure, we could cover those cases if there's consensus to do so.  I'd support discussion of both.

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 10 Aug 2011 07:49:56 +0200

On 9 August 2011 19:19, Murray S. Kucherawy wrote:

> we could cover those cases if there's consensus to do so.  I'd support
> discussion of both.

Just in case, I think "line too long" can only happen in <obs-body> (if
at all), otherwise this could be considered as "malformed wrt RFC 5322".

Strange foldings are covered by <obs-FWS> in RFC 5322, so if you dare
say that this is "malformed" I'll need lots of popcorn while watching
what happens.

-Frank