Subject: [apps-discuss] Fwd: Fwd: Civil suit; ftp shutdown; mailing list shutdown

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 07 Oct 2011 08:24:51 +0900

Forwarded to the IETF because we are also affected, and we may also be 
able to help out.
http://blog.joda.org/2011/10/today-time-zone-database-was-closed.html 
seems to have some more information.

Regards,    Martin.

-------- Original Message --------
Subject: Fwd: Civil suit; ftp shutdown; mailing list shutdown
Date: Thu, 06 Oct 2011 08:38:59 -0700
From: Deborah Goldsmith <[email-masked]>
To: Unicode Core List

Can we set up a temporary replacement mailing list and publicize it?

Debbie

Begin forwarded message:

> Resent-From: [email-masked]
> From: "Olson, Arthur David (NIH/NCI) [E]" <[email-masked]>
> Subject: Civil suit; ftp shutdown; mailing list shutdown
> Date: October 6, 2011 8:16:02 AM PDT
> To: "[email-masked]'" <[email-masked]>
> Reply-To: [email-masked]
>
> A civil suit was filed on September 30 in federal court in Boston; I'm a defendant; the case involves the time zone database.
>
> The ftp server at elsie.nci.nih.gov has been shut down.
>
> The mailing list will be shut down after this message.
>
> Electronic mail can be sent to me at [email-masked].
>
> I hope there will be better news shortly.
>
> 				--ado
>

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 7 Oct 2011 05:08:14 +0200

On 7 October 2011 01:24, "Martin J. Dürst" wrote:

> Forwarded to the IETF because we are also affected, and we
> may also be able to help out.

Hi, so far I thought that the TZ database will be hosted by
IANA - same idea as for similar IANA registries such as the
charsets or the langtags.

Obviously there should be some kind of "expert" mailing list,
again the same idea as for similar IANA registries.  If the
old TZ mailing list was closed I guess the IETF could create
a new list.  Maybe somebody can donate their private archive
of the old list, but IIRC GMaNe already has a public archive.

The new list should be added to the "IETF non-WG" page, in
essence somebody enters the required info into a Web form
and picks a responsible AD for the confirmation.  If that AD
(Peter or Pete) confirmed it the IETF secretary adds the info
on the "non-WG list" page.  Fairly simple, but I have no idea
how it is supposed to work if the list does not yet exist.

With this ugly lawsuit business one of the I* Chairs has to
inform the legal counsel, because it might be a case for the
I* insurance.  (They are protected, including IAB, ADs, and
WG chairs; excluding authors.)

The TZ database is precious.  This problem should be tackled
by the IESG + Trust + IAB; trying it here is not good enough.

-Frank

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 07 Oct 2011 14:21:01 +0900

[I sent this to Unicode (where people are concerned because many of them 
are involved with localization, date formats, and so on, which quickly 
involves time zones), but think it may be of interest here, too.]

In terms of practical matters, two points seem important to me:

First, to ask the judge for a temporary permission (there's a better 
legal term, but IANAL) to keep the database up until the law suit is 
settled (because the database is probably down now due to a temporary 
order from the judge to that effect) because of its high practical 
importance.

Second, what seems to be in dispute is data about old history. While 
this is important for some applications, in most applications, present 
and new data is much more important, so one way to avoid problems would 
be to publish only new data at some new place until the case is settled. 
That would mean that applications would have to be checked for whether 
they need the old data or not. Or to only publish diffs (which would be 
about new, present-day data not from the source under litigation).

Regards,   Martin.

On 2011/10/07 8:24, "Martin J. Dürst" wrote:
>> A civil suit was filed on September 30 in federal court in Boston; I'm
>> a defendant; the case involves the time zone database.
>>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: Eliot Lear <[email-masked]>
Date: Fri, 07 Oct 2011 08:48:48 +0200

Everyone:

As the co-author of the draft in question who is NOT a party to this
suit, let me say this:

1.  The authors are aware of the suit;
2.  The IESG is aware of the suit;
3.  ICANN and IANA is aware of the suit;
4.  The IASA is aware of the suit.
5.  Lawyers are involved.

Please give us just a little while to sort a response.

Eliot

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 7 Oct 2011 22:35:01 +0200

On 7 October 2011 08:48, Eliot Lear wrote:

> As the co-author of the draft in question who is NOT a
> party to this suit, let me say this:
[...everybody is aware of the issue...]
> Please give us just a little while to sort a response.

<http://tools.ietf.org/html/draft-lear-iana-timezone-database>

The legal side will move at its usual glacial speed, but
IANA will need your I-D in the state known as "approved"
before they can create the registry.  And for that we'd
need a non-WG Last Call (~ 4 weeks); hopefully somebody
creates a fork until the IANA version exists.

In essence your I-D says "PD" instead of "IETF Trust".
It is an interesting idea, but it could be at odds with
the legal insurance.  And apparently your draft invents
its own "PD" version of "Note Well" for the mailing list,
I'm not sure that this is a good idea.

Suggestion, allow the list to adopt "Note Well" later,
when the dust settles.  Even the stubborn subscribers
should get the idea that an appeal chain consisting of
the IESG and the IAB (and in theory ISOC) working for
hundreds of IETF lists (including IANA expert lists) is
no "patent nonsense" (pun intended).

-Frank

---

From: Cyrus Daboo <[email-masked]>
Date: Fri, 07 Oct 2011 22:49:35 +0200

Hi Frank,

> creates a fork until the IANA version exists.

Please check the data tracker. This document has already been approved and 
is in the RFC ed queue waiting on IANA activity.

<https://datatracker.ietf.org/doc/draft-lear-iana-timezone-database/>

-- 
Cyrus Daboo

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 7 Oct 2011 23:09:55 +0200

On 7 October 2011 22:49, Cyrus Daboo wrote:

> Please check the data tracker. This document has already been
> approved and is in the RFC ed queue waiting on IANA activity.

> <https://datatracker.ietf.org/doc/draft-lear-iana-timezone-database/>

Thanks for info, obviously I missed the Last Call and forgot to
click on the "tracker" link in the tools.ietf page of the draft.

With an approved draft IANA could create the new registry when
they feel like it -- with web servers in reach of US marshals
this could be more interesting than usual.  And the IESG could
expedite the RFC publication:  In discussions like this RFC xxxx
is clearer than "approved I-D.lear-iana-timezone-database".

Hopefully the new TZ mailing list will adopt "Note Well" later.

-Frank