Subject: Re: [apps-discuss] New Version Notification for draft-amundsen-item-and-collection-link-relations-04.txt

From: mike amundsen <[email-masked]>
Date: Sun, 9 Oct 2011 13:14:26 -0400

I modified the examples of include Frank Ellermann's suggestion
regarding Link Header reference in the text.

http://tools.ietf.org/html/draft-amundsen-item-and-collection-link-relations-04

I will submit this I-D to the rfc-editor within 24 hrs. Anyone who
would like to volunteer as a potential reviewer, feel free to post on
this thread or contact me directly and I'll include your name/contact
info in the submission.

Thanks to all for the assistance.

mca
http://amundsen.com/blog/
http://twitter.com@mamund
http://mamund.com/foaf.rdf#me

>
>
>
>
> ---------- Forwarded message ----------
> From:  <[email-masked]>
> Date: Sun, Oct 9, 2011 at 12:52
> Subject: New Version Notification for
> draft-amundsen-item-and-collection-link-relations-04.txt
> To: [email-masked]
> Cc: [email-masked]
>
>
> A new version of I-D,
> draft-amundsen-item-and-collection-link-relations-04.txt has been
> successfully submitted by Mike Amundsen and posted to the IETF
> repository.
>
> Filename:        draft-amundsen-item-and-collection-link-relations
> Revision:        04
> Title:           The Item and Collection Link Relations
> Creation date:   2011-10-09
> WG ID:           Individual Submission
> Number of pages: 5
>
> Abstract:
>   RFC 5988 [RFC5988] standardized a means of indicating the
>   relationships between resources on the Web. This specification
>   defines a pair of reciprocal link relation types that may be used to
>   express the relationship between a collection and its members.
>
> Editorial Note (To be removed by RFC Editor)
>
>   Distribution of this document is unlimited.  Comments should be sent
>   to the IETF Apps-Discuss mailing list (see
>   &lt;https://www.ietf.org/mailman/listinfo/apps-discuss&gt;).
>
>
>
>
> The IETF Secretariat
>

---

From: Cyrus Daboo <[email-masked]>
Date: Sun, 09 Oct 2011 13:36:14 +0200

Hi mike,

> Thanks to all for the assistance.

Has any thought been given to scalability. I know of web applications where 
the number of "items" can be in the 1000's or more. Returning 1000+ Link 
headers seems inappropriate in that case. Perhaps what is needed is an 
"item-list" link which points to another resource where the full "item" 
listing can be retrieved in some suitable fashion?

-- 
Cyrus Daboo

---

From: mike amundsen <[email-masked]>
Date: Sun, 9 Oct 2011 14:03:26 -0400

Cyrus:

The I-D does not mandate how the link-relation type is to be used.

Authors can use these values in message bodies only if they like;
there is no requirement to use Link headers. They can create "paged"
output that emits as many (or as few) links as desired.

Basically, this does not change the number of links, just adds the
possibility of a shared understanding of the rel value used to
decorate those links.

mca