Subject: [apps-discuss] Fwd: I-D Action: draft-sparks-genarea-mailarch-00.txt

From: Marc Blanchet <[email-masked]>
Date: Tue, 15 Nov 2011 12:26:31 +0800

- great doing this. completly agree. please!
- I would really like to add anonymous IMAP capabilities: Cyrus Daboo while having his own company selling a mail client (Mulberry) set up email mailing list available via IMAP anonymous. That was great to use, and then all the search capabilities are within the IMAP client.
- cc: apps area for the above IMAP suggestion.

Marc.

Début du message réexpédié :

> De : [email-masked]
> Objet : I-D Action: draft-sparks-genarea-mailarch-00.txt
> Date : 15 novembre 2011 12:18:29 UTC+08:00
> À : [email-masked]
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : IETF Email List Archiving and Search Tool Requirements
> 	Author(s)       : Robert Sparks
> 	Filename        : draft-sparks-genarea-mailarch-00.txt
> 	Pages           : 7
> 	Date            : 2011-11-14
> 
>   The IETF makes heavy use of email lists to conduct its work.
>   Participants frequently need to search and browse the archives of
>   these lists, and have asked for improved search capabilities.  The
>   current archive mechanism could also be made more efficient.  This
>   memo captures the requirements for improved email list archiving and
>   searching systems.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-sparks-genarea-mailarch-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-sparks-genarea-mailarch-00.txt
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Cyrus Daboo <[email-masked]>
Date: Tue, 15 Nov 2011 10:17:12 -0500

Hi,

--On November 15, 2011 12:26:31 PM +0800 Marc Blanchet 
<[email-masked]> wrote:

> - I would really like to add anonymous IMAP capabilities: Cyrus Daboo
> while having his own company selling a mail client (Mulberry) set up
> email mailing list available via IMAP anonymous. That was great to use,
> and then all the search capabilities are within the IMAP client. - cc:
> apps area for the above IMAP suggestion.

Yes a public IMAP server with mailboxes for each mailing list would be a 
fine option. In fact, I still read several IETF mailing lists that way. In 
addition to the benefits Marc cites, the other major benefit is that it is 
trivial to reply to mailing list messages because you are already in your 
email client.

One downside of an anonymous service would be the lack of of per-user seen 
state. It would be much more convenient if users had accounts on the IMAP 
server just for reading the public archives - that way each user would have 
their own seen flag status on the email messages, making it easier to keep 
track of what has been read. I would guess that hooking into the existing 
IETF accounts infrastructure would be ideal.

-- 
Cyrus Daboo

---

From: Ned Freed <[email-masked]>
Date: Tue, 15 Nov 2011 08:30:18 -0800 (PST)

+1 on all of Cyrus' points here.

				Ned

> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Barry Leiba <[email-masked]>
Date: Tue, 15 Nov 2011 18:40:59 -0500

> +1 on all of Cyrus' points here.

For me, too.  In fact, I accumulate what amounts to an IMAP-based
archive of the lists I care about.  If I had this, I could turn off
message delivery on my subscriptions, and just use the archive
instead.

Barry