Subject: [apps-discuss] Webfinger & acct: draft

From: Goix Laurent Walter <[email-masked]>
Date: Fri, 18 Nov 2011 12:34:20 +0100

Paul, all,

Thank you for starting addressing this standardization topic within IETF. Webfinger (and acct:) indeed are being increasingly used and the whole community would benefit from a well-referenced specification for it.

Here are some comments on the draft:

-          At this stage acct: scheme is needed from a formal point of view only I guess, so there may not be the need for a full addr-spec support.

-          I also support the point raised by Mykyta around i18n.  I guess as we are targeting user addressing more than resource addressing in general, and given the rise of Internet & social networks in non-ascii countries it would be important to target a dual URI/IRI scheme (following the path of the mailto rfc6068bis draft)

-          If no other spec is currently using the acct: scheme then it may be kept in the webfinger spec, but some existing specifications may be interested in referencing it as primary/preferred addressing mechanism (independently from webfinger), e.g. Opensocial, activitystrea.ms

-          From a more structural point of view it may be useful to better distinguish the sections related to the scheme from the ones relates to webfinger. Right now 4.1 and 4.2 are very different in purpose and may become 4 and 5. Current section 5 could become a subsection of webfinger (say 5.2)

-          It may also be good to distinguish the behavior on the server side (creating/exposing the descriptor and its content) from the actual discovery behavior from the client.

-          Webfinger further uses specific link "rels", which now are referenced under webfinger.net domain. I guess some of these rels would need to be registered as pure tokens (no URI), e.g. "avatar", "profile-page" and specified in this spec.

-          Reference 8 can now be updated to rfc6415

Cheers
Walter

------------------------------------------------------------------
Telecom Italia
Laurent-Walter Goix
Innovation & Industry Relations, Research & Prototyping, Future Internet
Piazza Einaudi 8 - 20124 Milano (Italy)
Tel. +39 026213445
Mob. +39 3356114196
Fax +39 0641869055

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non ? necessario.

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 18 Nov 2011 18:08:11 -0500

Walter,

Thanks for your feedback on the text.  I’ll be revising the document
accordingly.  Based on comments from you and others, section 4 will likely
undergo heavy restructuring :-)

For the webfinger link relations under webfinger.net, are those that should
go into the existing IANA registry for link relations that was defined by
RFC 5988?  (See
http://www.iana.org/assignments/link-relations/link-relations.xml)  In any
case, registration of link relations can certainly be done as a part of this
specification or it could be done separately.  My own opinion is that it
would be better to define link relations separately, but I’m willing to
follow the group opinion on this one.  Even I don’t know what those
webfinger.net relations are :-)

Paul

From: [email-masked] [mailto:[email-masked]]
On Behalf Of Goix Laurent Walter
Sent: Friday, November 18, 2011 6:34 AM
To: [email-masked]
Subject: [apps-discuss] Webfinger & acct: draft

Paul, all,

Thank you for starting addressing this standardization topic within IETF.
Webfinger (and acct:) indeed are being increasingly used and the whole
community would benefit from a well-referenced specification for it.

-          At this stage acct: scheme is needed from a formal point of view
only I guess, so there may not be the need for a full addr-spec support. 

-          I also support the point raised by Mykyta around i18n.  I guess
as we are targeting user addressing more than resource addressing in
general, and given the rise of Internet & social networks in non-ascii
countries it would be important to target a dual URI/IRI scheme (following
the path of the mailto rfc6068bis draft)

-          If no other spec is currently using the acct: scheme then it may
be kept in the webfinger spec, but some existing specifications may be
interested in referencing it as primary/preferred addressing mechanism
(independently from webfinger), e.g. Opensocial, activitystrea.ms

-          From a more structural point of view it may be useful to better
distinguish the sections related to the scheme from the ones relates to
webfinger. Right now 4.1 and 4.2 are very different in purpose and may
become 4 and 5. Current section 5 could become a subsection of webfinger
(say 5.2)

-          It may also be good to distinguish the behavior on the server
side (creating/exposing the descriptor and its content) from the actual
discovery behavior from the client.

-          Webfinger further uses specific link “rels”, which now are
referenced under webfinger.net domain. I guess some of these rels would need
to be registered as pure tokens (no URI), e.g. “avatar”, “profile-page” and
specified in this spec.

Cheers

Walter

Mob. +39 3356114196 

Fax +39 0641869055

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
persone indicate. La diffusione, copia o qualsiasi altra azione derivante
dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora
abbiate ricevuto questo documento per errore siete cortesemente pregati di
darne immediata comunicazione al mittente e di provvedere alla sua
distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged
information intended for the addressee(s) only. Dissemination, copying,
printing or use by anybody else is unauthorised. If you are not the intended
recipient, please delete this message and any attachments and advise the
sender by return e-mail, Thanks. 

rispetta l'ambienteRispetta l'ambiente. Non stampare questa mail se non è
necessario.

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Fri, 18 Nov 2011 18:53:47 -0500

I agree. Both the notion of registering link relations and the possibility of a broader usage of the acct: URI beyond Webfinger really require some group discussion to help us decide if the draft remains self-contained as a single document or gets broken into several.

Regards,

Gonzalo

On Nov 18, 2011, at 6:08 PM, Paul E. Jones wrote:

> Walter,
>  
> Thanks for your feedback on the text.  I’ll be revising the document accordingly.  Based on comments from you and others, section 4 will likely undergo heavy restructuring :-)
>  
> For the webfinger link relations under webfinger.net, are those that should go into the existing IANA registry for link relations that was defined by RFC 5988?  (See http://www.iana.org/assignments/link-relations/link-relations.xml)  In any case, registration of link relations can certainly be done as a part of this specification or it could be done separately.  My own opinion is that it would be better to define link relations separately, but I’m willing to follow the group opinion on this one.  Even I don’t know what those webfinger.net relations are :-)
>  
> Paul
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Goix Laurent Walter
> -          Webfinger further uses specific link “rels”, which now are referenced under webfinger.net domain. I guess some of these rels would need to be registered as pure tokens (no URI), e.g. “avatar”, “profile-page” and specified in this spec.
> Rispetta l'ambiente. Non stampare questa mail se non è necessario.
>  
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Blaine Cook <[email-masked]>
Date: Sat, 19 Nov 2011 06:58:27 +0000

+1; defining the actual link relations should be done outside the webfinger
spec, most likely as part of RFC 5988 as Paul mentioned.

The relations are perhaps the trickiest bit of webfinger to standardise,
but thankfully 5988 offers guidance; new relations should be defined as
specifically as possible, with obvious relation overlap being aggregated
into more general identifiers, and eventually being submitted to the
registry once sufficient deployment mandates it.

b.

On 18 November 2011 23:53, Gonzalo Salgueiro <[email-masked]> wrote:

>  I agree. Both the notion of registering link relations and the
> possibility of a broader usage of the acct: URI beyond Webfinger really
> require some group discussion to help us decide if the draft remains
> self-contained as a single document or gets broken into several.
>
> Regards,
>
> Gonzalo
>
>
>
>  Walter,****
> ** **
> undergo heavy restructuring :-)****
> ** **
> For the webfinger link relations under webfinger.net, are those that
> should go into the existing IANA registry for link relations that was
> defined by RFC 5988?  (See
> http://www.iana.org/assignments/link-relations/link-relations.xml)  In
> any case, registration of link relations can certainly be done as a part of
> this specification or it could be done separately.  My own opinion is that
> it would be better to define link relations separately, but I’m willing to
> webfinger.net relations are :-)****
> ** **
> Paul****
> ** **
>  *From:* [email-masked] [mailto:
> [email-masked]] *On Behalf Of *Goix Laurent Walter
> *Sent:* Friday, November 18, 2011 6:34 AM
> *To:* [email-masked]
> *Subject:* [apps-discuss] Webfinger & acct: draft****
> ** **
> Paul, all,****
> ** **
> community would benefit from a well-referenced specification for it.****
> ** **
> Here are some comments on the draft:****
> -          At this stage acct: scheme is needed from a formal point of
> view only I guess, so there may not be the need for a full addr-spec
> support.****
> -          I also support the point raised by Mykyta around i18n.  I
> guess as we are targeting user addressing more than resource addressing in
> the path of the mailto rfc6068bis draft)****
> -          If no other spec is currently using the acct: scheme then it
> may be kept in the webfinger spec, but some existing specifications may be
> (independently from webfinger), e.g. Opensocial, activitystrea.ms****
> -          From a more structural point of view it may be useful to
> better distinguish the sections related to the scheme from the ones relates
> to webfinger. Right now 4.1 and 4.2 are very different in purpose and may
> (say 5.2)****
> discovery behavior from the client.****
> referenced under webfinger.net domain. I guess some of these rels would
> need to be registered as pure tokens (no URI), e.g. “avatar”,
> “profile-page” and specified in this spec.****
> -          Reference 8 can now be updated to rfc6415****
> ** **
> Cheers****
> Walter****
> ** **
> *Telecom Italia
> *Laurent-Walter Goix****
> Innovation & Industry Relations, Research & Prototyping, Future Internet *
> ***
> Tel. +39 026213445****
> Mob. +39 3356114196****
> Fax +39 0641869055****
> ** **
> ** **
> distruzione, Grazie.****
> *This e-mail and any attachments** is **confidential and may contain
> privileged information intended for the addressee(s) only. Dissemination,
> copying, printing or use by anybody else is unauthorised. If you are not
> the intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks.*****
> *Rispetta l'ambiente. Non stampare questa mail se non è
> necessario.*****
> ** **

---

From: "Mykyta Yevstifeyev (М. Євстіфеєв)" <[email-masked]>
Date: Sat, 19 Nov 2011 09:03:04 +0200

19.11.2011 8:58, Blaine Cook wrote:
> +1; defining the actual link relations should be done outside the 
> webfinger spec, most likely as part of RFC 5988 as Paul mentioned.
>
> The relations are perhaps the trickiest bit of webfinger to 
> standardise, but thankfully 5988 offers guidance; new relations should 
> be defined as specifically as possible, with obvious relation overlap 
> being aggregated into more general identifiers, and eventually being 
> submitted to the registry once sufficient deployment mandates it.

How many of them will we have to define?  Can we at all predict how will 
Webfinger be used?

Mykyta Yevstifeyev

>
> b.
>
> On 18 November 2011 23:53, Gonzalo Salgueiro <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     possibility of a broader usage of the acct: URI beyond Webfinger
>     really require some group discussion to help us decide if the
>     draft remains self-contained as a single document or gets broken
>     into several.
>
>     Regards,
>
>     Gonzalo
>
>
>
>>     Thanks for your feedback on the text.  I’ll be revising the
>>     document accordingly.  Based on comments from you and others,
>>     section 4 will likely undergo heavy restructuring :-)
>>     For the webfinger link relations underwebfinger.net
>>     <http://webfinger.net>, are those that should go into the
>>     existing IANA registry for link relations that was defined by RFC
>>     5988? 
>>     (Seehttp://www.iana.org/assignments/link-relations/link-relations.xml) 
>>     In any case, registration of link relations can certainly be done
>>     as a part of this specification or it could be done separately. 
>>     My own opinion is that it would be better to define link
>>     relations separately, but I’m willing to follow the group opinion
>>     on this one.  Even I don’t know what thosewebfinger.net
>>     <http://webfinger.net>relations are :-)
>>     Paul
>>     *From:[email-masked]
>>     <mailto:[email-masked]>[mailto:[email-masked]
>>     <mailto:[email-masked]>]*On Behalf Of*Goix Laurent
>>     Walter
>>     *Sent:*Friday, November 18, 2011 6:34 AM
>>     *To:[email-masked] <mailto:[email-masked]>
>>     *Subject:*[apps-discuss] Webfinger & acct: draft
>>     Paul, all,
>>     Thank you for starting addressing this standardization topic
>>     within IETF. Webfinger (and acct:) indeed are being increasingly
>>     used and the whole community would benefit from a well-referenced
>>     specification for it.
>>     -At this stage acct: scheme is needed from a formal point of view
>>     -I also support the point raised by Mykyta around i18n.  I guess
>>     as we are targeting user addressing more than resource addressing
>>     in general, and given the rise of Internet & social networks in
>>     non-ascii countries it would be important to target a dual
>>     URI/IRI scheme (following the path of the mailto rfc6068bis draft)
>>     -If no other spec is currently using the acct: scheme then it may
>>     be kept in the webfinger spec, but some existing specifications
>>     may be interested in referencing it as primary/preferred
>>     addressing mechanism (independently from webfinger), e.g.
>>     Opensocial, activitystrea.ms <http://activitystrea.ms>
>>     -From a more structural point of view it may be useful to better
>>     distinguish the sections related to the scheme from the ones
>>     relates to webfinger. Right now 4.1 and 4.2 are very different in
>>     purpose and may become 4 and 5. Current section 5 could become a
>>     subsection of webfinger (say 5.2)
>>     -It may also be good to distinguish the behavior on the server
>>     side (creating/exposing the descriptor and its content) from the
>>     actual discovery behavior from the client.
>>     -Webfinger further uses specific link “rels”, which now are
>>     referenced underwebfinger.net <http://webfinger.net>domain. I
>>     guess some of these rels would need to be registered as pure
>>     tokens (no URI), e.g. “avatar”, “profile-page” and specified in
>>     this spec.
>>     -Reference 8 can now be updated to rfc6415
>>     Cheers
>>     Walter
>>     *Laurent-Walter Goix
>>     Tel. +39 026213445 <tel:%2B39%20026213445>
>>     Mob. +39 3356114196 <tel:%2B39%203356114196>
>>     Fax +39 0641869055 <tel:%2B39%200641869055>
>>     Questo messaggio e i suoi allegati sono indirizzati
>>     esclusivamente alle persone indicate. La diffusione, copia o
>>     qualsiasi altra azione derivante dalla conoscenza di queste
>>     informazioni sono rigorosamente vietate. Qualora abbiate ricevuto
>>     questo documento per errore siete cortesemente pregati di darne
>>     immediata comunicazione al mittente e di provvedere alla sua
>>     distruzione, Grazie.
>>
>>     /This e-mail and any attachments// is //confidential and may
>>     contain privileged information intended for the addressee(s)
>>     only. Dissemination, copying, printing or use by anybody else is
>>     unauthorised. If you are not the intended recipient, please
>>     delete this message and any attachments and advise the sender by
>>     return e-mail, Thanks./
>>
>>     *Rispetta l'ambiente. Non stampare questa mail se
>>     non è necessario.*
>>
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Blaine Cook <[email-masked]>
Date: Sat, 19 Nov 2011 12:24:24 +0000

2011/11/19 "Mykyta Yevstifeyev (М. Євстіфеєв)" <[email-masked]>

> How many of them will we have to define?  Can we at all predict how will

We don't know, and no. :-)

We can make educated guesses, but it would be folly to start defining
shared, generic terminology before implementation. The XMPP specs are a
great example of too much definition stifling actual implementations from
growing and evolving.

b.

---

From: Goix Laurent Walter <[email-masked]>
Date: Mon, 21 Nov 2011 11:14:19 +0100

Da: [email-masked] [mailto:[email-masked]] Per conto di Blaine Cook

2011/11/19 "Mykyta Yevstifeyev (М. Євстіфеєв)" <[email-masked]<mailto:[email-masked]>>
19.11.2011 8:58, Blaine Cook wrote:
+1; defining the actual link relations should be done outside the webfinger spec, most likely as part of RFC 5988 as Paul mentioned.

The relations are perhaps the trickiest bit of webfinger to standardise, but thankfully 5988 offers guidance; new relations should be defined as specifically as possible, with obvious relation overlap being aggregated into more general identifiers, and eventually being submitted to the registry once sufficient deployment mandates it.

How many of them will we have to define?  Can we at all predict how will Webfinger be used?

We can make educated guesses, but it would be folly to start defining shared, generic terminology before implementation. The XMPP specs are a great example of too much definition stifling actual implementations from growing and evolving.

[walter] from what i’ve seen most webfinger implementations use the “profile-page” and “avatar” link rels to help better identify when subscribing to that user, i.e. after inserting the acct: URI of that user, typically a “confirmation” page is displayed to the user prior to actually subscribe to that user, that shows its avatar and a link to its profile-page. But of course the “describedby” rel may also be used in that context: depending on its type it may suggest whether this is a depiction of that user (more than the “icon” rel) rather than a web page pointing to his profile. Anyway from the webfinger spec perspective it may be good to suggest some specific type of information and update the examples consistently. Then we may discuss further possible values for this, at least their semantics in the webfinger context.

walter

b.