Subject: [apps-discuss] FW: Liason statement from OMA CD WG to IETF - Mobile Social Networking

From: Likepeng <[email-masked]>
Date: Fri, 16 Dec 2011 01:33:49 +0000

Hello Alexey, Barry, Jiankang and all,

I forward you one LS (as attached) from OMA and hope to get your feedback on this.

In OMA CD, there is a Work Item named Mobile Social Network, and we are trying to reuse one of the I-D in this WG: http://tools.ietf.org/html/draft-jones-appsawg-webfinger

Here are the questions we hope to get feedback from you:

IETF APPSAWG Working Group is kindly invited to provide feedback on the following points:

1)       consideration and tentative timeframe of [draft-jones-appsawg-webfinger] as WG document and future RFC publication;

2)       support for Unicode characters in the "acct:" scheme (URI/IRI);

3)       registration of an ENUM service type for "acct:" scheme;

4)       consideration of other OStatus-related specifications (e.g. Salmon, PubSubHubbub, ActivityStreams) as IETF specifications

5)       tentative generic scope, list and roadmap of the Social Networking-related activities and output documents within the group;

6)       areas of potential overlap, complementarities or interest with the OMA MobSocNet activities based on the referred information;

If you need any more information, please let me know.

Thanks,
Kind Regards
Kepeng Li
Da: OMA-CD Mailing List [mailto:[email-masked]] Per conto di Victoria Gray
Inviato: mercoledì 14 dicembre 2011 9.46
A: [email-masked]
Oggetto: Liason statement from OMA CD WG to IETF - Mobile Social Networking

To: IETF
CC: OMA-CD, OMA-LIAISON, OMA-PLENARY

Dear IETF,

Please find attached a liaison statement from the OMA CD (Content Delivery) WG providing you with information regarding their activity on Mobile Social Networking.

Best regards,
Victoria

Victoria Gray
BA (Hons) International Business
Document Support Officer
FORApolis
Tel +33 (0)4 92 94 49 23
GSM +33 (0)6 73 99 62 90
[email-masked]<mailto:[email-masked]>

MSN: [email-masked]<mailto:[email-masked]>   Yahoo!: bluevicci
Skype: victoria-gray  Google: [email-masked]<mailto:[email-masked]>

P Please consider the environmental impact before printing this e-mail

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 16 Dec 2011 23:02:26 -0500

Kepeng,

While I cannot offer an official answer for the group, I can provide
comments on a few points:

1) I would certainly hope we could complete the work in 2012.  I personally
think the next meeting is a bit ambitious, but if folks want to move forward
quickly, we could make an effort to do that or perhaps the following
meeting.

2) I definitely want Unicode support.  I have a preference, specifically,
for using UTF-8 when transmitting an “acct” URI via a GET request.  Is that
acceptable?

3) I don’t recall this being mentioned before.  You want to map phone
numbers to acct URIs?  That is certainly possible, but has not been a focus
of our draft.  I would think we should do that as a separate draft, and I’d
be happy to work on that.

I’ll defer to others for the rest, as this is probably a series of questions
best answered by the group (or at least those leading the architecture work
in the app area).

Paul

From: [email-masked] [mailto:[email-masked]]
On Behalf Of Likepeng
Sent: Thursday, December 15, 2011 8:34 PM
To: Alexey Melnikov; Barry Leiba; [email-masked]
Subject: [apps-discuss] FW: Liason statement from OMA CD WG to IETF - Mobile
Social Networking

I forward you one LS (as attached) from OMA and hope to get your feedback on
this.

In OMA CD, there is a Work Item named Mobile Social Network, and we are
trying to reuse one of the I-D in this WG:
http://tools.ietf.org/html/draft-jones-appsawg-webfinger

IETF APPSAWG Working Group is kindly invited to provide feedback on the
following points:

1)       consideration and tentative timeframe of
[draft-jones-appsawg-webfinger] as WG document and future RFC publication;

2)       support for Unicode characters in the “acct:” scheme (URI/IRI);

3)       registration of an ENUM service type for “acct:” scheme;

4)       consideration of other OStatus-related specifications (e.g. Salmon,
PubSubHubbub, ActivityStreams) as IETF specifications

5)       tentative generic scope, list and roadmap of the Social
Networking-related activities and output documents within the group;

6)       areas of potential overlap, complementarities or interest with the
OMA MobSocNet activities based on the referred information;

Thanks,

Kind Regards

Kepeng Li 

Da: OMA-CD Mailing List [mailto:[email-masked]] Per
conto di Victoria Gray
Inviato: mercoledì 14 dicembre 2011 9.46
A: [email-masked]
Oggetto: Liason statement from OMA CD WG to IETF - Mobile Social Networking

To: IETF

Dear IETF,

Please find attached a liaison statement from the OMA CD (Content Delivery)
WG providing you with information regarding their activity on Mobile Social
Networking.

Best regards,

Victoria

Victoria Gray

Document Support Officer

FORApolis

Tel +33 (0)4 92 94 49 23

GSM +33 (0)6 73 99 62 90

[email-masked]

MSN:  <mailto:[email-masked]> [email-masked]
Yahoo!: bluevicci

Skype: victoria-gray  Google: [email-masked]

---

From: SM <[email-masked]>
Date: Fri, 16 Dec 2011 22:56:52 -0800

>I forward you one LS (as attached) from OMA and hope to get your 

The charter of the APPSAWG is at 
http://tools.ietf.org/wg/appsawg/charters  Social Networking is not 
listed as one of the topics that historically fall within the 
Applications Area.  I suggest that the person responsible for the OMA 
CD Liaison Statement contact the IETF OMA Liaison to discuss about 
the working groups where the work might be in scope.

Regards,
-sm

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Sat, 17 Dec 2011 16:08:23 +0200

Hi SM, Hi Likepeng, 

The problem is that certain organizations do their work around high
level application concepts. Some of these concepts are contributed by
innovation in the area of marketing. Examples: cloud computing,
machine-to-machine communication, smart grid, etc. 

Since the IETF follows a different approach for doing their work it is
difficult to map any of these concepts directly to IETF working groups.

If one thinks about Mobile Social Networking then a number of IETF
technologies come to my mind that could be relevant, such as HTTP, TLS,
OAuth. 

Ciao
Hannes

> -----Original Message-----
> From: [email-masked] [mailto:apps-discuss-
> [email-masked]] On Behalf Of ext SM
> Sent: Saturday, December 17, 2011 8:57 AM
> To: Likepeng
> Cc: [email-masked]
> Subject: Re: [apps-discuss] FW: Liason statement from OMA CD WG to
IETF
> - Mobile Social Networking
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sat, 17 Dec 2011 20:41:51 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Saturday, December 17, 2011 6:08 AM
> To: ext SM; Likepeng
> Subject: Re: [apps-discuss] FW: Liason statement from OMA CD WG to IETF - Mobile Social Networking
> 

I am fairly certain that the "Social Networking" part of this either (a) falls squarely within the Applications Area, or (b) falls clearly outside of the IETF altogether.  It depends on which aspect of it we're discussing.

The "Mobile" part is less obvious.  Depending on what we're talking about, that can spread across several areas (SEC, RAI and RTG come to mind), or might be the realm of the GSMA and OMA.

For the specific details of this request, I suspect APPSAWG was the wrong recipient.  The specific I-D they named is not currently an APPSAWG item and there's no guarantee it will be, and most of the other topics listed are things I haven't heard discussed anywhere at IETF yet.

I imagine the OMA Liaison (i.e., me) and the Applications Area ADs would be the right place to start to form a response.  Other ADs might also need to be tapped.  I'll get that ball rolling shortly.

-MSK

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Sun, 18 Dec 2011 11:53:55 +0200

Hi Murray, 

I believe the OMA just added the term "mobile" to social networking to
make it appear more relevant to their main constituency, i.e. vendors of
mobile phone equipment and cellular operators. So, I wouldn't give this
too much consideration.

Ciao
Hannes

> [email-masked]] On Behalf Of ext Murray S. Kucherawy
> Sent: Sunday, December 18, 2011 6:42 AM
> To: [email-masked]
> IETF- Mobile Social Networking
> 
> [email-masked]] On Behalf Of Tschofenig, Hannes (NSN - FI/Espoo)
> IETF - Mobile Social Networking
> >
> I am fairly certain that the "Social Networking" part of this either
(a)
> falls squarely within the Applications Area, or (b) falls clearly
> outside of the IETF altogether.  It depends on which aspect of it
we're
> discussing.
> 
> The "Mobile" part is less obvious.  Depending on what we're talking
> about, that can spread across several areas (SEC, RAI and RTG come to
> mind), or might be the realm of the GSMA and OMA.
> 
> For the specific details of this request, I suspect APPSAWG was the
> wrong recipient.  The specific I-D they named is not currently an
> APPSAWG item and there's no guarantee it will be, and most of the
other
> topics listed are things I haven't heard discussed anywhere at IETF
yet.
> 
> I imagine the OMA Liaison (i.e., me) and the Applications Area ADs
> would be the right place to start to form a response.  Other ADs might
> also need to be tapped.  I'll get that ball rolling shortly.
> 
> -MSK

---

From: Goix Laurent Walter <[email-masked]>
Date: Mon, 19 Dec 2011 11:28:44 +0100

Hello all,

I'm glad to see that this triggered a first debate quickly.

>From OMA perspective an end-to-end approach is being considered that intends to reference/profile external specs as much as possible whenever it make sense and covers the requirements. The idea is to limit isolation and reuse "popular" specs when applicable, also liaising to discuss possible extensions that are not necessarily mobile-specific but that could potentially benefit the whole spec.
The OMA spec is also defining some specific behaviors, which are internal to the mobile device, and which does not impact apis/protocols.

That said, wrt IETF, the "mobile" aspect is not the focus as Hannes anticipated. Several IETF specs are mentioned indeed as background information only. At this stage the appsawg seems to be the "best" group within IETF to address some "application-level" SN data formats and protocols. I agree that in the large, "Social Networking" covers many protocol layers and features, but this liaison is indeed targeted to get feedback from this specific group only at first, but of course could be extended upon evident interest.

Wrt Paul's early answers on his draft (although not (yet?) a group's draft), there is truly some intention to map phone numbers to acct: IRI/URIs. I would be available for working at a separate draft as well.

Walter

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Tschofenig, Hannes (NSN - FI/Espoo)
Inviato: domenica 18 dicembre 2011 10.54
A: ext Murray S. Kucherawy; [email-masked]
Oggetto: Re: [apps-discuss] FW: Liason statement from OMA CD WG to IETF-Mobile Social Networking

Hi Murray,

Ciao
Hannes

(a)
we're
other
yet.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.