Subject: [apps-discuss] APPSDIR review of draft-shafranovich-mime-sql-03.txt

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 6 Feb 2013 16:42:40 +0800

I have been selected as the Applications Area Directorate reviewer for this 
draft (for background on appsdir, please see 
http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorate ).

Please resolve these comments along with any other comments you 
may receive.  
Document: draft-shafranovich-mime-sql-03.txt
Title: The application/sql Media Type
Reviewer: Jiankang Yao 
Review Date: 6 MAR. 2013
Summary:  This draft is almost ready for publication as an Informational RFC.

Major Issues: none
Minor Issues: none
Discussion Issue:

In section 2, which said "Person & email address to contact for further information:
Yakov Shafranovich <[email-masked]>"

Is it good to list the persional email address [email-masked] as the permanent contact address?

Nits: 

In section 3, which said  "After approval, IANA is asked to register the media type application/
sql in the Standards tree using the application provided in Section 2
of this document."

I suggest to improve the meaning of "after approval" or remove the "after approval".
If "after approval" means RFC publication, we do need to repeat it here.
If "after approval" means other kind of approval, pls specify it here.

Jiankang Yao

---

From: Barry Leiba <[email-masked]>
Date: Fri, 8 Feb 2013 19:21:02 -0500

Thanks for the review, Jiankang.

> Is it good to list the persional email address [email-masked] as the permanent

It's done all the time.  I always prefer to list an organization or
mailing list, but for individual submissions it's often the case that
the individual is really the sensible contact point.  I have no issue
with it for this document.

> I suggest to improve the meaning of "after approval" or remove the "after approval".

Nah, there's no issue here either.  While this is technically
ungrammatical, it really is perfectly fine as worded, and IANA knows
what to do: they will make the registration when the IESG approves the
document.  The RFC Editor will change it to say, "IANA has registered
[...]" when they publish the RFC.

Barry

---

From: Yakov Shafranovich <[email-masked]>
Date: Sat, 9 Feb 2013 23:03:02 -0500

Thanks for the review