Subject: [apps-discuss] Apps Review of draft-ietf-xrblock-rtcp-xr-burst-gap-discard-10

From: Eric Burger <[email-masked]>
Date: Mon, 18 Mar 2013 10:59:22 -0400

In general, this document is ready to go. I have one editorial suggestion. In order to understand this document, I had to read draft-ietf-xrblock-rtcp-xr-discard-11 and draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-05 to figure out where this draft fits into the jitter reporting ecosystem. I get why these are all small, separate drafts. However, I could not easily find an overarching document tying things together. draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-05 does a decent job in the Introduction of describing the relationship between xr-burst-gap-discard and xr-discard. However, that is in the context of why we have a third draft on what on first read looks like the same metrics.

The three drafts cover three facets of jitter metrics. What is missing is a roadmap for implementors that does two things. The first is it makes it clear where to go to do what. I can easily imagine an implementor wanting to do jitter measurements, finding just one of these drafts, and think they need to do a proprietary extension because the IETF 'forgot' to include something in the jitter reporting. Another issue is I found myself reading xr-discard and xr-burst-gap-discard in parallel. They made a whole lot more sense reading them that way than one at a time. Moreover, I found I had to read them in parallel to understand xr-burst-gap-discard. Therefore, it would be helpful to either have a separate roadmap document or a paragraph or two in each document referring the reader to the other documents. That way the reader knows they exist, knows there may be a better / more coverage for reporting than a single document implies, and they can find the other documents. I would offer this will improve the readability and ultimate interoperability of the resulting implementations.

---

From: Qin Wu <[email-masked]>
Date: Thu, 21 Mar 2013 19:49:49 +0800

Hi,Eric:
Thank for your careful review.
Both Section 1.1 and Section 3.3 of this draft have already referred the readers to the relevant documents by
 pointing to disard draft. Burst gap discard and discard don't need to be coupled with RLE discard draft. 
So I think it will be more useful to have a separate roadmap document and go into details to discuss how to
 implement them in different use cases.

Regards
-Qin