Subject: [apps-discuss] RFC 6570: what is the dot for in section 3?

From: Francis Galiegue <[email-masked]>
Date: Fri, 15 Mar 2013 14:23:59 +0100

Hello,

The grammar for a variable name reads as such:

     varspec       =  varname [ modifier-level4 ]
     varname       =  varchar *( ["."] varchar )
     varchar       =  ALPHA / DIGIT / "_" / pct-encoded

I fail to see any mention of the dot anywhere else in the document
when it appears in this context and I don't see any example either,
not even in appendix A. And the "varchar" grammar token adds to the
confusion since it seems to indicate the dot has a special role.

If, for example I have a variable foo defined as:

{ "bar": 1, "baz": 2 }

what is "foo.bar"? Does it refer to another variable entirely, or is
it value of key "bar" in associate array "foo"?

--
Francis Galiegue, [email-masked]
JSON Schema in Java: http://json-schema-validator.herokuapp.com

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Mar 2013 11:01:16 +1100

It's there as a convenience to implementations, so they can model data structures (e.g., dictionaries) easily.

On 16/03/2013, at 12:23 AM, Francis Galiegue <[email-masked]> wrote:

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

--
Mark Nottingham   http://www.mnot.net/