Subject: [apps-discuss] Remember the MX 0 . draft?

From: "John Levine" <[email-masked]>
Date: 25 Jun 2013 03:38:46 -0000

The question came up on another list about how you can tell the world
that a domain handles no mail, and do it more efficiently than by
running a dummy SMTP server that rejects everything.  It's
particularly an issue when a domain has an A or AAAA record and no
SMTP server, so attempts to send mail take a week to time out before
they fail.

Everyone seems to agree that this is what you do:

  nomailhere.example. MX 0 .

but the only place that's documented is an expired I-D from 2005.

Since it is (as far as I can tell) useful and uncontroversial, would
it be worth reviving the I-D here, tidying it up, and sending it along
as a standards track RFC?

R's,
John

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 25 Jun 2013 07:21:06 -0700

> as a standards track RFC?
Never heard of this before.  Are there implementations?

-MSK

---

From: Dave Cridland <[email-masked]>
Date: Tue, 25 Jun 2013 16:07:42 +0100

> Never heard of this before.  Are there implementations?

It's a direct mirror of the technique documented for SRV records, which is
certainly deployed. As such, this seems reasonable to formalize for MX.

---

From: "John Levine" <[email-masked]>
Date: 25 Jun 2013 15:53:09 -0000

>Never heard of this before.  Are there implementations?

Here's the draft, by Mark Delany of domainkeys fame:

http://tools.ietf.org/html/draft-delany-nullmx-00

It is my impression that a fair number of MTAs do implement it but I
haven't collected any statistics.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 25 Jun 2013 20:42:39 -0000

>Never heard of this before.  Are there implementations?

I did some experiements:

Yahoo: mail fails immediately

Gmail, AOL: doesn't fail immediately, will report back next week

Hotmail/Outlook.com: some attempts fail with an odd error message, some succeed

qmail: fails immediately (code unchanged since 1998)

So I'd say there are some implementations but we have a way to go.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 25 Jun 2013 21:37:16 -0000

>qmail: fails immediately (code unchanged since 1998)

postfix: fails immediately, not due to special case code, but Wietse
agrees that's the correct thing for it to do.

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 25 Jun 2013 20:41:56 -0400

> agrees that's the correct thing for it to do.

When this was first seen in the wild, it did surface a bug in postfix:

20061227

	Bugfix (introduced with Postfix 2.3): the MX hostname syntax
	check was skipped with reject_unknown_helo_hostname and
	reject_unknown_sender/recipient_domain, so that Postfix
	would still accept mail from domains with a zero-length MX
	hostname.  File: smtpd/smtpd_check.c.

(from the history file)

I remember when this came up.  It was due to mx 0 ., so it did, at least in 
2006, have enough deployment that a related bug got reported and fixed.

Scott K

---

From: Tony Finch <[email-masked]>
Date: Wed, 26 Jun 2013 11:48:18 +0100

> agrees that's the correct thing for it to do.

Exim will immediately reject too. (Logic shared with SRV implementation;
i.e. null targets are special cased to avoid bogus queries against the
root name servers.)

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Forties, Cromarty: East, veering southeast, 4 or 5, occasionally 6 at first.
Rough, becoming slight or moderate. Showers, rain at first. Moderate or good,
occasionally poor at first.

---

From: Alessandro Vesely <[email-masked]>
Date: Fri, 28 Jun 2013 11:16:12 +0200

>>>>>   nomailhere.example. MX 0 .

I've been too lazy to do it, because there's actually no mx record
labeled nomailhere.example.  Would it be too much of a burden to publish
it, there or at some other example domain?

(www.example.org not only has an address, but also an http server:
* Connected to www.example.org (192.0.43.10) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.29.0
> Host: www.example.org
> Accept: */*
* HTTP 1.0, assume close after body
< HTTP/1.0 302 Found
< Location: http://example.iana.org
< Server: BigIP
* HTTP/1.0 connection set to keep alive!
< Connection: Keep-Alive
< Content-Length: 0
)

---

From: "John R. Levine" <[email-masked]>
Date: 29 Jun 2013 13:32:39 -0400

> Hotmail/Outlook.com: some attempts fail with an odd error message, some succeed

Gmail, AOL, and Hotmail all failed eventually with complaints about bad 
DNS records.  So there is room for more consistent implementations.

The only objection I've heard was from someone who expected it wouldn't 
work because there might be A records at ".".  Other than that, it still 
seems uncontroversial.

Do I formally ask appsarea to take it up, or what?

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly