Subject: [apps-discuss] Editorial comments on draft-ietf-appsawg-rfc5451bis-07

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 13 Jun 2013 16:11:00 +0200

Hi,

  In http://tools.ietf.org/html/draft-ietf-appsawg-rfc5451bis-07 I think
it would be helpful to spell out the name of the header field in the ab-
stract. It should probably also be in the Introduction.

There should be syntax examples near the ABNF grammar for the header. As
it is, examples are only in Appendix C, so you don't get to see any use
of the header until after you read through the Acknowledgements and Re-
ferences.

The "[other names]" in Appendix A is probably not intentional.

regards,
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Franck Martin <[email-masked]>
Date: Sat, 15 Jun 2013 21:39:09 -0500 (CDT)

There is no specification for exposing the result of an SMTP TLS transaction, and the certificates used?

What I have seen so far in the wild did not see particularly formatted nor useful and attached mainly with auth= which is one narrow use of SMTP TLS certificates.

Printed on recycled paper!

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 23 Jun 2013 01:33:08 -0700

On Sat, Jun 15, 2013 at 7:39 PM, Franck Martin <[email-masked]>wrote:

> What I have seen so far in the wild did not see particularly formatted nor
> useful and attached mainly with auth= which is one narrow use of SMTP TLS
> certificates.
>
>
There has not to date been any demand for adding that to the list of
supported mechanisms.   If you think it should be, it doesn't necessarily
need to be added here; rather, it could be added via the IANA registries
this document creates.

-MSK

---

From: Franck Martin <[email-masked]>
Date: Sun, 23 Jun 2013 16:24:41 -0500 (CDT)

----- Original Message -----

> From: "Murray S. Kucherawy" <[email-masked]>
> To: "Franck Martin" <[email-masked]>
> Cc: [email-masked]
> Sent: Sunday, June 23, 2013 1:33:08 AM
> Subject: Re: [apps-discuss] comments on draft-ietf-appsawg-rfc5451bis-07

> On Sat, Jun 15, 2013 at 7:39 PM, Franck Martin < [email-masked] >
> wrote:

> > There is no specification for exposing the result of an SMTP TLS
> > transaction,
> > and the certificates used?
> 

> supported mechanisms. If you think it should be, it doesn't necessarily need
> to be added here; rather, it could be added via the IANA registries this
> document creates.

Fair enough, it is just I do not have enough experience on it, to recommend something, but it seems to me it was a weird use so far. So if anyone can pitch in, on how SMTP+TLS should be indicated in the AR header, that would be useful.