Subject: [apps-discuss] Comments on draft-ietf-appsawg-json-merge-patch

From: Paul Hoffman <[email-masked]>
Date: Tue, 18 Jun 2013 09:39:08 -0700

Greetings again. This document mostly looks fine, and is pretty mature.

I'm still confused about why the following exists in the document:
       Any
       object member or array element contained in the provided data
       whose value is explicitly null is to be treated as if the member
       is undefined and MUST NOT appear within the result.
The wording has changed from draft to draft, but there is no explanation of why there should be something that exists in the patch document that should not exist in the result. Adding a paragraph about this design choice would clear things up. If that paragraph doesn't make enough sense, maybe remove this and all its friends from the document.

The test cases are great. Consider adding a few more whose result is "Invalid Patch".

--Paul Hoffman

---

From: James M Snell <[email-masked]>
Date: Tue, 18 Jun 2013 09:44:47 -0700

I will try to clarify in the doc but the main point is that null values in
the patch doc are used to indicate deletion. That is, something like
{"foo":null} means "delete foo from the result".

Thank you for reviewing the draft.
On Jun 18, 2013 9:40 AM, "Paul Hoffman" <[email-masked]> wrote:

> The wording has changed from draft to draft, but there is no explanation
> of why there should be something that exists in the patch document that
> should not exist in the result. Adding a paragraph about this design choice
> would clear things up. If that paragraph doesn't make enough sense, maybe
> remove this and all its friends from the document.
>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>