Subject: [apps-discuss] AppsDir review of draft-housley-ltans-oids-00

From: Carsten Bormann <[email-masked]>
Date: Thu, 25 Jul 2013 11:45:55 +0200

I have been selected as the Applications Area Directorate reviewer for
this draft (for background on appsdir, please see
http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorate).

Please resolve these comments along with any other Last Call comments
you may receive. Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document:  draft-housley-ltans-oids-00

Title: Object Identifier Registry for the
              Long-Term Archive and Notary Services (LTANS) Working Group

Reviewer: Carsten Bormann
Review Date: 2013-07-25
IESG Telechat Date: 2013-08-15
IETF Last Call Expires: 2013-07-31

* Summary: The document is almost ready for publication, but may need
the addition of some guidance for the IANA expert review.

The document nicely and accessibly summarizes the status of
ASN.1 OIDs assigned for LTANS and establishes IANA registration
policies for some arcs.

* Major:

As with all registries that specify Expert Review:
Is there any guidance for the designated expert?
I.e., what is the objective for the review?
What will be the grounds for acceptance or rejection of a registration?
(Such guidance is likely obvious to those closely involved with the work.
It is not obvious to someone newly approaching this document and
considering whether the registry is the right one to use.)

* Minor

One OID is described as obsolete, which is fine.  The ones designated
for LTAP are not described as obsolete, but it is not clear what the
disposition of this protocol is.  (It may not be the purview of this
document to make statements about this, but if the answer is obvious,
it should be given.)
(This is confounded by referencing a long dead I-D as "work in
progress" -- is it indeed in progress?  Again, maybe not for this
document to fix this longstanding issue about I-D citations.)

* Nits

Add period at end of section 1.
6: "it raise no new"

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Jul 2013 10:28:13 -0400

> considering whether the registry is the right one to use.)

I suggest adding this text:

Updates to the four new tables require Expert Review as defined in [RFC5226].  The expert is expected to ensure that any new values are strongly related to the work that was done by the LTANS WG.  Object identifiers for other purposes should not be assigned in this arc.

> document to fix this longstanding issue about I-D citations.)

It is clear that LTAP is not being worked on at the moment.  I am unsure whether someone will resume this work in the future.

> Add period at end of section 1.

Fixed.

Russ

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 26 Jul 2013 16:34:44 +0200

> Updates to the four new tables require Expert Review as defined in [RFC5226].  The expert is expected to ensure that any new values are strongly related to the work that was done by the LTANS WG.…

That is exactly the information I was hoping the document would provide.  Thanks.

Grüße, Carsten