Subject: [apps-discuss] RFC 2388 (multipart/form-data)

From: Ian Hickson <[email-masked]>
Date: Fri, 12 Jul 2013 17:39:43 +0000 (UTC)

Hi,

Do you know if there is anyone working on fixing RFC2388? People keep 
asking me to update the HTML spec to just define it all inline rather than 
deferring to the RFC since the RFC leaves a lot of stuff underdefined, but 
I don't have the bandwidth to spec all that myself at this point.

e.g.:
   https://www.w3.org/Bugs/Public/show_bug.cgi?id=16909
   https://www.w3.org/Bugs/Public/show_bug.cgi?id=19879

Other feedback:
   http://lists.w3.org/Archives/Public/public-whatwg-archive/2012Oct/0204.html
   http://lists.w3.org/Archives/Public/public-whatwg-archive/2012Jul/0037.html
   http://lists.w3.org/Archives/Public/public-whatwg-archive/2012May/0003.html

I asked Larry Masinter if he was still maintaining the RFC, but he said he 
wasn't, and suggested I ask here to find out who was maintaining it now.

Thanks in advance,
--
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

---

From: Larry Masinter <[email-masked]>
Date: Wed, 17 Jul 2013 11:02:28 -0700

If there is anyone interested in working on updating RFC 2388 and related
specs, please let me know.

I'm not convinced that RFC 2388 leaves more undefined than
it should, although there's clearly been some confusion about
what it said and certainly implementations now vary enough
that RFC 2388 is not a good implementation guide for any of
the roles (form creator, filled-form to form-data constructor,
form-data parser and interpreter).

See comments 
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16909#c8

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Ian Hickson
> Sent: Friday, July 12, 2013 10:40 AM
> To: [email-masked]
> Subject: [apps-discuss] RFC 2388 (multipart/form-data)
> 
> 
> Hi,
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: James M Snell <[email-masked]>
Date: Wed, 17 Jul 2013 11:38:10 -0700

Updating or refining RFC2388 is currently not on my agenda, however,
once HTTP/2 progresses a bit further down the road and matures I do
intend to explore using that binary framing model as a possible
replacement for multipart mime packaging and multipart form. I suspect
that work won't likely begin until next year, however.

---

From: "John Levine" <[email-masked]>
Date: 17 Jul 2013 19:16:58 -0000

>replacement for multipart mime packaging and multipart form. ...

Inevitably, multipart/form-data will be with us for at least a decade
after any improved replacement is defined.  It's definitely worth
updating the RFC to match existing practice, and to document where
existing practice is inconsistent.

Having written my share of CGI scripts that extracted files from
multipart/form-data with more or less success, I'm willing to provide
some help.

R's,
John

---

From: Larry Masinter <[email-masked]>
Date: Mon, 22 Jul 2013 07:45:53 -0700

the first step would be to get a few people familiar with multipart/form-data implementations
of various sorts to review my comments https://www.w3.org/Bugs/Public/show_bug.cgi?id=16909#c8 
I think there are three classes of implementors:
* those creating HTML forms with a submission type of multipart/form-data (and tools for form creators)
* those building servers/sites/processors that receive and process multipart/form-data
* browser makers whose code creates multipart/form-data

are there others? How can we get representatives of each kind of implementation
to work together on an agreement about what they should do?

Larry
--
http://larry.masinter.net

> From: James M Snell [mailto:[email-masked]]
> Sent: Wednesday, July 17, 2013 11:38 AM
> To: Larry Masinter
> Cc: Ian Hickson; [email-masked]
> Subject: Re: [apps-discuss] RFC 2388 (multipart/form-data)
>

---

From: Daniel Stenberg <[email-masked]>
Date: Tue, 23 Jul 2013 13:18:15 +0200 (CEST)

On Mon, 22 Jul 2013, Larry Masinter wrote:

> are there others? How can we get representatives of each kind of 
> implementation to work together on an agreement about what they should do?

I would categorize myself in a variation of this group. curl and libcurl offer 
multipart/form-data support but not necessarily/rarely for browsers, but for 
command line users and various programs who want to submit multipart data over 
HTTP.

-- 

  / daniel.haxx.se

---

From: Larry Masinter <[email-masked]>
Date: Wed, 24 Jul 2013 05:25:18 -0700

>    https://www.w3.org/Bugs/Public/show_bug.cgi?id=16909

see comments in bug

>    https://www.w3.org/Bugs/Public/show_bug.cgi?id=19879

this was marked a dup of 16909.  If there are MAY requirements in RFC 2388 which would be better as SHOULD or MUST, please identify them. (Beyond how to encode field names).

>  http://lists.w3.org/Archives/Public/public-whatwg-archive/2012Oct/0204.html

This doesn't mention multipart/form-data

>    http://lists.w3.org/Archives/Public/public-whatwg-archive/2012Jul/0037.html 

This mainly suggests updating 2388, which we will talk about.

>     http://lists.w3.org/Archives/Public/public-whatwg-archive/2012May/0003.html

This is about file names, not field names in multipart/form-data. In any case
the filename issue seems best addressed by 
http://www.rfc-editor.org/rfc/rfc5987.txt

> wasn't, and suggested I ask here to find out who was maintaining it now.

so far there are two volunteers to help, but please review proposed 
implementation guide in https://www.w3.org/Bugs/Public/show_bug.cgi?id=16909 

So far, the only problem which seems concrete is "how to deal with non-ascii field names in forms".
Is there anything else?