Subject: [apps-discuss] Preliminary IETF 87 APPSAWG/APPAREA agenda posted

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 17 Jul 2013 11:11:10 -0700

https://datatracker.ietf.org/meeting/87/agenda/appsawg/

Please submit any requests for changes as soon as possible.  Revisions are
due on 7/22 (Monday).

-MSK, APPSAWG co-chair

---

From: "Songhaibin (A)" <[email-masked]>
Date: Fri, 19 Jul 2013 01:16:26 +0000

Hi Murray,

I hope I can get a short slot (5 to 10 minutes) in Appsawg to introduce the problems described in the following draft. The draft is very short and I can improve it later.
http://tools.ietf.org/id/draft-song-appsawg-service-template-00.txt

BR,
-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Thursday, July 18, 2013 2:11 AM
To: IETF Apps Discuss
Subject: [apps-discuss] Preliminary IETF 87 APPSAWG/APPAREA agenda posted

https://datatracker.ietf.org/meeting/87/agenda/appsawg/
Please submit any requests for changes as soon as possible.  Revisions are due on 7/22 (Monday).
-MSK, APPSAWG co-chair

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 29 Jul 2013 09:23:08 +0200

On 7/19/13 3:16 AM, Songhaibin (A) wrote:
> Hi Murray,
> 
> I hope I can get a short slot (5 to 10 minutes) in Appsawg to
> introduce the problems described in the following draft. The draft
> is very short and I can improve it later.
> 

Hello Haibin,

As I mentioned at the mic just now, you might want to look at some of
the work that's been done about Automated Service Configuration:

https://datatracker.ietf.org/doc/draft-daboo-aggregated-service-discovery/

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Songhaibin (A)" <[email-masked]>
Date: Mon, 29 Jul 2013 08:03:38 +0000

Hi Peter,

Many thanks for the reference. I will look into the related documents to see whether there are overlaps. I do not want to do duplicate work either.

BR,
-Haibin

-----Original Message-----
From: Peter Saint-Andre [mailto:[email-masked]] 
Sent: Monday, July 29, 2013 3:23 PM
To: Songhaibin (A)
Cc: [email-masked]
Subject: service configuration (was: Re: [apps-discuss] Preliminary IETF 87 APPSAWG/APPAREA agenda posted)

On 7/19/13 3:16 AM, Songhaibin (A) wrote:
> introduce the problems described in the following draft. The draft is 
> very short and I can improve it later.
> 

Hello Haibin,

As I mentioned at the mic just now, you might want to look at some of the work that's been done about Automated Service Configuration:

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 29 Jul 2013 10:29:23 +0200

On 7/29/13 10:03 AM, Songhaibin (A) wrote:
> Hi Peter,
> 
> Many thanks for the reference. I will look into the related documents
> to see whether there are overlaps. I do not want to do duplicate work
> either.

If you have a chance to review the document from Cyrus this week, you
could probably chat with him in person (or with others -- I have been
tracking this work and I know several other people who have.

Peter

---

From: "Songhaibin (A)" <[email-masked]>
Date: Mon, 29 Jul 2013 12:21:09 +0000

I'm reading this document.

>From the description below:
" This specification defines a single protocol which will allow for retrieval of a variety of service configuration information in a single call, allowing developers to simplify the coding and user interface in client software, and in particular in multi-function client software such as a combined e-mail and calendar clients. Configuration is retrieved from a single document on a server, improving performance over per-service configuration mechanisms that require multiple network operations."

I think this document is very interesting and useful for client side configuration to communicate with different service providers. But it seems that it is a total different story from what I talked about this morning, especially for the software installation part, where for example, a home user installs a virtual home gateway in the provider's network, and chooses the features(software components) that he wants to install on that virtual gateway. 

For the service configuration part (we both call them service configuration, but we focus on different things), Cyrus's document could be complementary, if the software we moved to the provider's network has requirements to configure it for communication with other service provider servers. But it is also very common the configuration is for other purpose, for example, an enterprise user installs a virtual firewall in the provider's network, then it has to configure it for handling the traffic from/to the enterprise.

BR,
-Haibin

-----Original Message-----
From: Peter Saint-Andre [mailto:[email-masked]] 
Sent: Monday, July 29, 2013 4:29 PM
To: Songhaibin (A)
Cc: [email-masked]
Subject: Re: service configuration

> to see whether there are overlaps. I do not want to do duplicate work 

If you have a chance to review the document from Cyrus this week, you could probably chat with him in person (or with others -- I have been tracking this work and I know several other people who have.

Peter