Subject: [apps-discuss] Standardising Structure in URIs

From: Mark Nottingham <[email-masked]>
Date: Thu, 29 Aug 2013 14:03:17 +1000

I started this draft during the Berlin meeting, and since have had a lot of positive feedback.

Would the APPSAWG be interested in taking it on as a WG document?

Regards,

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-nottingham-uri-get-off-my-lawn-02.txt
> Date: 29 August 2013 2:01:29 PM AEST
> To: Mark Nottingham <[email-masked]>
> 
> 
> A new version of I-D, draft-nottingham-uri-get-off-my-lawn-02.txt
> has been successfully submitted by Mark Nottingham and posted to the
> IETF repository.
> 
> Filename:	 draft-nottingham-uri-get-off-my-lawn
> Revision:	 02
> Title:		 Standardising Structure in URIs
> Creation date:	 2013-08-29
> Group:		 Individual Submission
> Number of pages: 8
> URL:             http://www.ietf.org/internet-drafts/draft-nottingham-uri-get-off-my-lawn-02.txt
> Status:          http://datatracker.ietf.org/doc/draft-nottingham-uri-get-off-my-lawn
> Htmlized:        http://tools.ietf.org/html/draft-nottingham-uri-get-off-my-lawn-02
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-nottingham-uri-get-off-my-lawn-02
> 
> Abstract:
>   Sometimes, it is attractive to add features to protocols or
>   applications by specifying a particular structure for URIs (or parts
>   thereof).  This document cautions against this practice in standards
>   (sometimes called "URI Squatting").
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Mark Nottingham   http://www.mnot.net/

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Aug 2013 22:06:07 -0600

> Would the APPSAWG be interested in taking it on as a WG document?

I'd be in favor; this is helpful.

Peter

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Aug 2013 12:36:59 +0200

> Would the APPSAWG be interested in taking it on as a WG document?

With a whole new group of applications and standards developers going on board of REST in the CoRE space, this is a document that would be highly useful to be able to point to.

So here is my +1 for taking this on as an APPSAWG work item and document.

The difficulty in completing this is probably in section 3; this maybe needs to be expanded a bit before the document becomes fully convincing to people not yet entirely skilled in the art.  
I would be interested to hear how much you think this section can be or should be filled in.
But that can be done in the context of the APPSAWG work on it, it is not a prerequisite for adopting it.

Grüße, Carsten

PS.: It's too bad that the "get-off-my-lawn" will no longer be visible in the RFC...

---

From: Tim Bray <[email-masked]>
Date: Thu, 29 Aug 2013 09:43:48 -0700

I  support adoption of this draft. -T

On Wed, Aug 28, 2013 at 9:03 PM, Mark Nottingham <[email-masked]> wrote:

> > Subject: New Version Notification for
> draft-nottingham-uri-get-off-my-lawn-02.txt
> > URL:
> http://www.ietf.org/internet-drafts/draft-nottingham-uri-get-off-my-lawn-02.txt
> > Status:
> http://datatracker.ietf.org/doc/draft-nottingham-uri-get-off-my-lawn
> > Htmlized:
> http://tools.ietf.org/html/draft-nottingham-uri-get-off-my-lawn-02
> > Diff:
> http://www.ietf.org/rfcdiff?url2=draft-nottingham-uri-get-off-my-lawn-02
> >
> > Abstract:
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: Martin Thomson <[email-masked]>
Date: Thu, 29 Aug 2013 10:36:15 -0700

> Would the APPSAWG be interested in taking it on as a WG document?

I think that they should.

> PS.: It's too bad that the "get-off-my-lawn" will no longer be visible in the RFC...

Maybe that could become the abbreviated title.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 30 Aug 2013 10:32:04 +1000

> But that can be done in the context of the APPSAWG work on it, it is not a prerequisite for adopting it.

It's certainly not perfect. However, I don't think this should become a document about how to compose RESTful APIs; that's likely to be much more contentious, time-consuming and difficult to complete. That's not to say such a document shouldn't exist :)

Cheers,