Subject: [apps-discuss] APPSDIR review of draft-ietf-dime-overload-reqs-10

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 19 Aug 2013 10:31:14 -0500

I have been selected as the Applications Area Directorate reviewer for
this draft (for background on appsdir, please see ​
http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorate ).

Please resolve these comments along with any other Last Call comments
you may receive. Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-dime-overload-reqs-10
Title: Diameter Overload Control Requirements
Reviewer: Vijay K. Gurbani
Review Date: Aug-19-2013
IETF Last Call Date: Not known
IESG Telechat Date: Not known

Summary: This draft is ready for publication as an Informational
RFC; two minor issues follow.

Major comments: 0
Minor comments: 1
Nits: 1

Minor:
======
- Abstract - You may consider taking out the Section numbers in the
  Abstract. They really do not belong there, and you can impart the same
  information without using the section numbers (e.g., "Existing
  Diameter mechanisms are not sufficient for this purpose.  This
  document describes the limitations of the existing mechanisms and
  proposes requirements for new overload management mechanisms.")

Nits:
=====
- S3.2, first paragraph: "This document is a work in progress...",
  here, "This" refers to TR23.843 or does it refer to dime-overload-
  reqs-10?  Please clarify.  On further reading, there are more
  "this document" spread in the subsection with providing an adequate
  text that qualifies the "this".

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 19 Aug 2013 21:31:15 +0300

Thanks Vijay,

Regarding

> reqs-10?  Please clarify.  On further reading, there are more

"this document" is supposed to refer to TR23.843. We'll makes the
reference more clear.

- Jouni

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 22 Aug 2013 16:08:15 -0500

On 08/22/2013 03:45 PM, Eric McMurry wrote:
> we can clear this this up.  that should not be a problem :-)
>
> more specifically, for the first paragraph of 3.2, how about
> changing  "this document" to "this technical report".

Eric: Better yet, why not simply change it to TR23.843?

> We searched through the rest of the draft and all of the other
> instances of "this document" refer to the draft itself. Is that more
> clear when the instance in the first paragraph is addressed?

Yes, that should be fine.

Thanks for your attention to my comments.

- vijay

---

From: Eric McMurry <[email-masked]>
Date: Thu, 22 Aug 2013 15:45:54 -0500

Thanks Vijay!

Comments inline.

Eric

> proposes requirements for new overload management mechanisms.")

agree, those can be removed.

more specifically, for the first paragraph of 3.2, how about changing "this document" to "this technical report".

We searched through the rest of the draft and all of the other instances of "this document" refer to the draft itself.  Is that more clear when the instance in the first paragraph is addressed?

---

From: Eric McMurry <[email-masked]>
Date: Thu, 22 Aug 2013 16:09:15 -0500

works for me.  We'll change that and dereference the abstract in the next version, pending instructions from the shepherd.

Thanks!

Eric

---

From: Jouni Korhonen <[email-masked]>
Date: Sat, 24 Aug 2013 09:52:48 +0300

Authors,

The changes needed look rather straight forward and we also seem to have 
consensus among reviewers. Go ahead and submit a revised version as soon
as possible for you. You may, if you wish, circulate a diff before the
submission among us but that is IMHO not really needed.

- Jouni

---

From: Eric McMurry <[email-masked]>
Date: Mon, 26 Aug 2013 13:16:57 -0500

Thanks Jouni,

I have submitted the changes (I agree they were minor, and this way we have full tracking):

Filename:	 draft-ietf-dime-overload-reqs
Revision:	 11
Title:		 Diameter Overload Control Requirements
Creation date:	 2013-08-26
Group:		 dime
Number of pages: 28
URL:             http://www.ietf.org/internet-drafts/draft-ietf-dime-overload-reqs-11.txt
Status:          http://datatracker.ietf.org/doc/draft-ietf-dime-overload-reqs
Htmlized:        http://tools.ietf.org/html/draft-ietf-dime-overload-reqs-11
Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-dime-overload-reqs-11

Here is a diff.  The changes were small, but please let me know if I've botched something.

Thanks!

Eric