Subject: [apps-discuss] APPSDIR review of draft-petithuguenin-behave-turn-uris-05

From: S Moonesamy <[email-masked]>
Date: Sun, 04 Aug 2013 16:25:46 -0700

I have been selected as the Applications Area Directorate reviewer 
for this draft (for background on APPSDIR, please see 
http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorate ).

Please resolve these comments along with any other Last Call comments 
you may receive. Please wait for direction from your document 
shepherd or AD before posting a new version of the draft.

Document: draft-petithuguenin-behave-turn-uris-05
Title: Traversal Using Relays around NAT (TURN) Uniform Resource Identifiers
Reviewer: S. Moonesamy
Review Date: August 4, 2013
IETF Last Call Date: July 19, 2013

Summary: This document is nearly ready for publication as a Proposed Standard.

This document defines two URI schemes to provision the TURN 
Resolution Mechanism.

Major issues: None

Minor issues:

The Terminology Section is different from the usual RFC 2119 
boilerplate.  I am listing this as a minor issue for the attention of 
the Apps ADs.

This document restates the ABNF from RFC 3986.  I suggest including 
it by reference.  Please note that I read Appendix B.

Nits:

This review does not include editorial nits.

Regards,
S. Moonesamy

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 08 Aug 2013 07:47:49 -0700

Hi,

Thanks for your review.  After discussion between authors, we decided to keep
the ABNF as it is in the document, but to update the design note.  Here's a
first draft of the revised design note:

"o  The ABNF in this document duplicates the <IP-literal>,
    <IPv4address>, and <reg-name> productions and other dependent
    productions from [RFC3986], instead of referencing them.  This is
    because the definitions in RFC 3986 are for hierarchical URIs, so
    using these references in an opaque URI made reviewers think that
    a hierarchical URI parser could be used to parse the URIs defined
    in this document."

As for the RFC 2119 boilerplate, it follows the new boilerplate suggestion at
http://trac.tools.ietf.org/group/iesg/trac/wiki/Draft2119BoilerplateSuggestions,
minus the keywords not used in the document.

Thanks.

On 08/04/2013 04:25 PM, S Moonesamy wrote:
> I have been selected as the Applications Area Directorate reviewer for this
> draft (for background on APPSDIR, please see 
> Please resolve these comments along with any other Last Call comments you 
> may receive. Please wait for direction from your document shepherd or AD 
> before posting a new version of the draft.
> 
> Document: draft-petithuguenin-behave-turn-uris-05 Title: Traversal Using 
> Relays around NAT (TURN) Uniform Resource Identifiers Reviewer: S. 
> Moonesamy Review Date: August 4, 2013 IETF Last Call Date: July 19, 2013
> 
> This document defines two URI schemes to provision the TURN Resolution 
> Mechanism.
> 
> Major issues: None
> 
> Minor issues:
> 
> The Terminology Section is different from the usual RFC 2119 boilerplate. I
> am listing this as a minor issue for the attention of the Apps ADs.
> 
> This document restates the ABNF from RFC 3986.  I suggest including it by 
> reference.  Please note that I read Appendix B.
> 
> Nits:
> 
> Regards, S. Moonesamy

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: S Moonesamy <[email-masked]>
Date: Tue, 13 Aug 2013 04:13:30 -0700

Hi Marc,
>     a hierarchical URI parser could be used to parse the URIs defined

Thanks for addressing the comments.

Regards,
S. Moonesamy