Subject: [apps-discuss] Fwd: New Version Notification for draft-snell-more-link-relations-00.txt

From: James M Snell <[email-masked]>
Date: Thu, 29 Aug 2013 12:27:03 -0700

FYI... definitely a work-in-progress draft... as always,
comments/feedback are requested and welcomed.

- James

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Thu, Aug 29, 2013 at 12:25 PM
Subject: New Version Notification for draft-snell-more-link-relations-00.txt
To: "James M. Snell" <[email-masked]>

A new version of I-D, draft-snell-more-link-relations-00.txt
has been successfully submitted by James M Snell and posted to the
IETF repository.

Filename:        draft-snell-more-link-relations
Revision:        00
Title:           Additional Link Relations and the urn:social Namespace
Creation date:   2013-08-29
Group:           Individual Submission
Number of pages: 7
URL:
http://www.ietf.org/internet-drafts/draft-snell-more-link-relations-00.txt
Status:          http://datatracker.ietf.org/doc/draft-snell-more-link-relations
Htmlized:        http://tools.ietf.org/html/draft-snell-more-link-relations-00

Abstract:
   This specification defines a number of additional Link Relation Types
   that can used for a variety of purposes..

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: James M Snell <[email-masked]>
Date: Thu, 29 Aug 2013 12:52:58 -0700

That would be interesting but it breaks the model that anything in
urn:social:* identifies a contextual subset of the social graph.
On Aug 29, 2013 12:41 PM, "Markus Lanthaler" <[email-masked]>
wrote:

> Just a very quick question: Why do you register all those link relations
> instead of using the urn:social namespace for them? So "source" e.g. would
> become urn:social:source which would also mean you wouldn't need to
> register
> them.
>
>
> --
> Markus Lanthaler
> @markuslanthaler
>
>
>
> > -----Original Message-----
> > From: [email-masked] [mailto:apps-discuss-
> > [email-masked]] On Behalf Of James M Snell
> > Sent: Thursday, August 29, 2013 9:27 PM
> > To: IETF Apps Discuss
> > Subject: [apps-discuss] Fwd: New Version Notification for draft-snell-
> > more-link-relations-00.txt
> >
> > _______________________________________________
> > apps-discuss mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/apps-discuss
>
>

---

From: "Markus Lanthaler" <[email-masked]>
Date: Thu, 29 Aug 2013 22:04:53 +0200

On Thursday, August 29, 2013 9:53 PM, James M Snell wrote:
> That would be interesting but it breaks the model that anything
> in urn:social:* identifies a contextual subset of the social graph. 

Depends on how you define the context. The source of a message, e.g., could be seen as a subset of the social graph; just as the nodes referenced by "to". But perhaps you have something different in mind...

--
Markus Lanthaler
@markuslanthaler

On Aug 29, 2013 12:41 PM, "Markus Lanthaler" <[email-masked]> wrote:
Just a very quick question: Why do you register all those link relations
instead of using the urn:social namespace for them? So "source" e.g. would
become urn:social:source which would also mean you wouldn't need to register
them.

--
Markus Lanthaler
@markuslanthaler

---

From: James M Snell <[email-masked]>
Date: Fri, 30 Aug 2013 09:38:29 -0700

> Depends on how you define the context. The source of a message, e.g., could be seen as a subset of the social graph; just as the nodes referenced by "to". But perhaps you have something different i…

In this case, "source" is intended to be a general citation mechanism.
It may or may not have anything to do with any particular social
graph.

- James