Subject: [apps-discuss] RFC 6920 ni: URIs

From: Melvin Carvalho <[email-masked]>
Date: Sun, 27 Oct 2013 00:21:10 +0200

I was wondering if RFC 6920 has any deployments currently?

http://tools.ietf.org/html/rfc6920

I was thinking about reusing this, or doing something very similar in the
field of virtual currencies on the web and it would be good to see some
real world examples

RFC6920 seems to have everything we need, but in cryto currencies people
are used to dealing with base16 encoded, rather than, base64, so it would
be good to understand how this works in practice...

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 27 Oct 2013 14:45:45 +0000

Hiya,

> I was wondering if RFC 6920 has any deployments currently?

I'm not aware of deployments. There is code [1] that's
been used in various ICN experiments, and there'll be
a demo of a FF browser with ni support in Vancouver at
the ICNRG session on Sunday, that demo's not mine, so
not sure if its using the netinf code or not, I've cc'd
Börje who, being an ICNRG chair, knows more.

> be good to understand how this works in practice...

In the coding/testing we've done, base64 hasn't been an
issue at all.

Cheers,
S.

[1] http://sourceforge.net/projects/netinf/

> 
> 
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: Melvin Carvalho <[email-masked]>
Date: Sun, 27 Oct 2013 20:22:00 +0100

> In the coding/testing we've done, base64 hasn't been an

Thanks, I'm going to try and deploy some of these then (small scale)

The encoding wasnt too bad after working out the +/ becomes -_

The thing is the community I work with will probably not consider 64 bit
encodings "correct" but I guess there's no way to do 16bit right now
without making a new spec, which seems overkill ...

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 28 Oct 2013 16:16:07 +0000

> without making a new spec, which seems overkill ...

Cool. Be interested in how you get on. If changing our current code
in some way made it more useful for you then happy to chat about that.
(Though the URI handling is easy enough so I'm guessing you'll end
up with your own code for that.)

S.