Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-rrvs-header-field-04.txt

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 2 Dec 2013 19:41:59 -0800

Thanks, Alexey.

Any other feedback in support of or requesting changes to this version?  Is
it ready for WGLC?

On Thu, Nov 28, 2013 at 6:36 AM, Alexey Melnikov
<[email-masked]>wrote:

>  On 20/11/2013 08:02, Murray S. Kucherawy wrote:
>
> On Wed, Nov 20, 2013 at 12:00 AM, <[email-masked]> wrote:
>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>  This draft is a work item of the Applications Area Working Group Working
>> Group of the IETF.
>>
>>         Title           : The Require-Recipient-Valid-Since Header Field
>> and SMTP Service Extension
>>         Author(s)       : William J. Mills
>>                           Murray S. Kucherawy
>>         Filename        : draft-ietf-appsawg-rrvs-header-field-04.txt
>>         Pages           : 20
>>         Date            : 2013-11-19
>>
>> Abstract:
>>    This document defines an extension for the Simple Mail Transfer
>>    Protocol called RRVS, and a header field called Require-Recipient-
>>    Valid-Since, to provide a method for senders to indicate to receivers
>>    the time when the sender last confirmed the ownership of the target
>>    mailbox.  This can be used to detect changes of mailbox ownership,
>>    and thus prevent mail from being delivered to the wrong party.
>>
>>    The intended use of these facilities is on automatically generated
>>    messages that might contain sensitive information, though it may also
>>    be useful in other applications.
>>
>>
>  Incorporates a lot of suggestions from Ned, Alexey, and John.  Diff
> available from the datatracker.  Have at it!
>
> This version is much better and it addresses various issues related to
> mailing list and redirection. I am happy with it.
>
>

---

From: Bill Mills <[email-masked]>
Date: Tue, 3 Dec 2013 20:21:57 -0800

Section 3.1: is an explicit BNF syntax required for the IANA registration?  Or is "RRVS=" + date-time implicit from the definition in 5321?

Section 3.2 "CFWS" is defined but not referred to anywhere else?

Section 5.3:  I think #3 is only appropriate if #2 fired, should #3 actually be 2.1?

That's all I see.

-bill

--------------------------------
William J. Mills
"Paranoid" Yahoo!

On Monday, December 2, 2013 7:42 PM, Murray S. Kucherawy <[email-masked]> wrote:
 
Thanks, Alexey.

Any other feedback in support of or requesting changes to this version?  Is it ready for WGLC?

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 9 Dec 2013 08:07:26 -0800

On Tue, Dec 3, 2013 at 8:21 PM, Bill Mills <[email-masked]> wrote:

> Section 3.1: is an explicit BNF syntax required for the IANA
> registration?  Or is "RRVS=" + date-time implicit from the definition in
> 5321?
>

The other examples I've seen don't appear to require anything beyond what
we already have.

> Section 3.2 "CFWS" is defined but not referred to anywhere else?

Fixed in -05.

> Section 5.3:  I think #3 is only appropriate if #2 fired, should #3
There isn't a 5.3 in the -04 (current) version.  Can you clarify?

I'll post -05 shortly, unless this last point needs followup.

-MSK

---

From: Bill Mills <[email-masked]>
Date: Mon, 9 Dec 2013 08:14:40 -0800

That should have been 5.1 not 5.3.

-bill

On Monday, December 9, 2013 8:08 AM, Murray S. Kucherawy <[email-masked]> wrote:

The other examples I've seen don't appear to require anything beyond what we already have.

Fixed in -05.

-MSK

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 09 Dec 2013 16:57:07 +0000

> Thanks, Alexey.
Hi Murray,

> version?  Is it ready for WGLC?
I think it is ready for WGLC. I have one minor issue which I already 
raised, but I am trying to decide whether it is worth bringing up again. 
But anyway, it doesn't affect WGLC initiation.

> <[email-masked] <mailto:[email-masked]>> wrote:
>
>>     On Wed, Nov 20, 2013 at 12:00 AM, <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>
>>
>>         A New Internet-Draft is available from the on-line
>>         Internet-Drafts directories.
>>          This draft is a work item of the Applications Area Working
>>         Group Working Group of the IETF.
>>
>>                 Title           : The Require-Recipient-Valid-Since
>>         Header Field and SMTP Service Extension
>>                 Filename        :
>>         draft-ietf-appsawg-rrvs-header-field-04.txt
>>                 Pages           : 20
>>                 Date            : 2013-11-19
>>
>>         Abstract:
>>     Incorporates a lot of suggestions from Ned, Alexey, and John. 
>>     Diff available from the datatracker.  Have at it!
>     This version is much better and it addresses various issues
>     related to mailing list and redirection. I am happy with it.
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 9 Dec 2013 09:48:04 -0800

Actually #3 is only applied if #2 didn't fire.  If #2 fired, the message
has been rejected, and wouldn't make it to #3.