Subject: Re: [apps-discuss] Back to draft-ietf-appsawg-rrvs-header-field-05 (was Re: Scope of protocol authority)

From: Eric Burger <[email-masked]>
Date: Fri, 27 Dec 2013 13:12:33 -0500

Yes, and look at the use case. If you are the enterprise sending the message, you will upgrade all the MTAs under your control. If you are the massive, public MSP advertising RRVS on the receiving side,  not a problem. 

If it is b2b, then as Ned pointed out, even if you are sending to [email-masked], you most likely don't want the last one. 

Sent from my mobile device. Thanks be to LEMONADE: http://www.standardstrack.com/ietf/lemonade
S2ERC: http://s2erc.georgetown.edu/
GCSC: http://gcsc.georgetown.edu/
Me: http://www.cs.georgetown.edu/~ eburger

-------- Original message --------
From: Dave Crocker <[email-masked]> 
Date:12/27/2013  12:32 PM  (GMT-05:00) 
To: Eric Burger <[email-masked]>,[email-masked] 
Cc: The IESG <[email-masked]>,IETF Apps Discuss <[email-masked]> 
Subject: Re: [apps-discuss] Back to draft-ietf-appsawg-rrvs-header-field-05
  (was Re: Scope of protocol authority) 

On 12/27/2013 9:10 AM, Eric Burger wrote:
> As for the folks with this implemented, there is nothing to fear — how many MUA’a are more than two MTA’s away from the sending MUA?

Probably quite a bit of b2b mail.

Any enterprise with department-level servers introduces larger numbers 
of MTAs.  Even without 'department' servers, large organizations often 
distinguish internal mail handling from external, so that mail starts 
with an internal-facing MTA and exits through an external-facing MTA.[*]

There is a continuing myth that all Internet mail is now 'direct', but 
while it's true for a large amount of mail, it's also not true for a 
large amount.

d/

[*] By way of example -- Although I did have to search through the 
archive a bit, I did finally find an example on the apps-discuss mailing 
list of author-side, multi-MTA handling before a message hit the open 
Internet.

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Dave Crocker <[email-masked]>
Date: Sat, 28 Dec 2013 17:09:44 -0800

On 12/27/2013 10:12 AM, Eric Burger wrote:
> Yes, and look at the use case. If you are the enterprise sending the
> message, you will upgrade all the MTAs under your control. If you are
> the massive, public MSP advertising RRVS on the receiving side,  not a
> problem.
>
> If it is b2b, then as Ned pointed out, even if you are sending to
> [email-masked], you most likely don't want the last one.

Eric,

You've changed the argument.

I was responding to your claim that all mail was one-hop.

Now you are claiming that enterprises upgrade all their servers at the 
same time.  But of course, that's not the way operations in large 
organizations work.

Let's move back to the simple architectural and operational reality: 
Email is a distributed, multi-hop.  The fact that quite a bit of mail is 
essentially one-hop is a distraction from serious architectural discussions.

d/