Subject: [apps-discuss] well-known location for uuids

From: Melvin Carvalho <[email-masked]>
Date: Mon, 2 Dec 2013 12:15:11 +0100

Looking at

http://www.iana.org/assignments/well-known-uris/well-known-uris.xml

There seems to be a well known location for named instances (hashes) ni

And also skolemized bnodes : genid

Would it be a good idea to have one for uuids, do you think?

Currently there is urn:uuid: as a URN but not simple way to translate this
to a URL

Could we maybe just add /.well-known/uuid/  ?

Thoughts?

---

From: Julian Reschke <[email-masked]>
Date: Mon, 02 Dec 2013 12:23:14 +0100

On 2013-12-02 12:15, Melvin Carvalho wrote:
> Currently there is urn:uuid: as a URN but not simple way to translate
> this to a URL
>

What's the advantage of the urn:uuid notation? Do you plan to resolve it 
to a resource?

Best regards, Julian

---

From: Melvin Carvalho <[email-masked]>
Date: Fri, 6 Dec 2013 15:22:22 +0100

> What's the advantage of the urn:uuid notation? Do you plan to resolve it

I like to give every identifier a URI if possible.  I guessed from the
wikipedia urn aricle urn:uuid was a of the standard ways of doing this?

http://en.wikipedia.org/wiki/Uniform_resource_name

(See under examples)

As a background I'm writing a distributed task manager which I'd like to
give each task a unique identifier (e.g. UUID) but I dont necessarily want
to make it domain specific.

Ideally I'd like the tasks to be dereferancable, so my thought was that one
option could be a UUID.

So I'm trying to work out what notation represented good practice?

---

From: Julian Reschke <[email-masked]>
Date: Fri, 06 Dec 2013 20:11:03 +0100

On 2013-12-06 15:22, Melvin Carvalho wrote:
>
>
>
> On 2 December 2013 12:23, Julian Reschke <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>         http://www.iana.org/__assignments/well-known-uris/__well-known-uris.xml
>         <http://www.iana.org/assignments/well-known-uris/well-known-uris.xml>
>
>     What's the advantage of the urn:uuid notation? Do you plan to
>     resolve it to a resource?
>
>

Well, a urn:uuid *is* a URI already.

Best regards, Julian

---

From: Mikael Nordfeldth <[email-masked]>
Date: Mon, 09 Dec 2013 15:01:12 +0100

> Could we maybe just add /.well-known/uuid/   ?

If we're gonna make a HTTP resource anyway, why not just use the already specified WebFinger, which allows you to lookup any URI resource through https://example.com/.well-known/webfinger?resource=urn:uuid:myuniquehash

HTTPS without the S was of course dropped during WebFinger discussions for some reason, so this wouldn't solve unencrypted URL lookups though...

-- 
Mikael Nordfeldth
XMPP/mail: [email-masked]

---

From: Melvin Carvalho <[email-masked]>
Date: Sun, 15 Dec 2013 19:19:01 +0100

> Well, a urn:uuid *is* a URI already.

Thanks for the reply.  Thinking this over a bit more, it's great that
urn:uuid is A) a URI B) non colliding

But the same is also true of the ni:///sha256; URIs for example.

However the difference with ni: URIs is that they can be dereferenced via
the "well-known" pattern at /.well-known/ni/sha-256/base64encID

It's nice at times to have both features.  But it seems that ni: is more
easily dereferenced than uuid right now?

---

From: Melvin Carvalho <[email-masked]>
Date: Sat, 21 Dec 2013 20:29:58 +0100

> easily dereferenced than uuid right now?

Two possible suggestions, assuming this is not already standarized:

1) I put files in /.well-known/uuid/<id>

2) I put files in /.well-known/urn/uuid/<id>

(1) seems slightly more developer friendly, so, unless this is a bad idea,
I think that makes most sense right now ...