Subject: [apps-discuss] draft-dejong-remotestorage-02

From: "Markus Lanthaler" <[email-masked]>
Date: Wed, 18 Dec 2013 15:45:24 +0100

Hi Michiel,

I just had a look at the final version of draft-dejong-remotestorage-02. I
noticed that the draft says:

  A successful GET request to a folder SHOULD be responded to with a
  JSON-LD [JSON-LD] document (content type 'application/json'),

Is there any reason why you don't use JSON-LD's content type, i.e.,
application/ld+json?

You also use a "charset" parameter in your examples in section 12

  Content-Type: application/json; charset=UTF-8

.. but neither JSON nor JSON-LD have a charset parameter. You should thus
simply drop it.

Cheers,
Markus

--
Markus Lanthaler
@markuslanthaler

---

From: "Michiel B. de Jong" <[email-masked]>
Date: Mon, 30 Dec 2013 08:13:46 +0530

> .. but neither JSON nor JSON-LD have a charset parameter. You should 

ah ok, i didn't know that. thanks! we'll fix this in version -03 (github 
issue for it is here: https://github.com/remotestorage/spec/issues/55).

sorry for the late reply, i was offline for a while.

> 
> 
> Cheers,
> Markus
> 
> 
> --
> Markus Lanthaler
> @markuslanthaler
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss