Subject: [apps-discuss] JSON-Home and application/json-home

From: Jan Algermissen <[email-masked]>
Date: Sat, 11 Jan 2014 14:13:01 +0100

Mark,

might be obvious, but it just occurred to me that application/json-home is essentially a format to represent lists of links and/or link-templates.

(It occurred to me because I found that a discovery format that I am experimentally crafting actually looked like application/json-home :-)

This probably raises the question whether the application behind your JSON-Home I-D[1] should actually be reflected in the media type name?

Not that I am suggesting this change, but maybe it is stimulating to chew on the idea of renaming

  application/json-home

to

  application/links  or application/resourceinfo or whatever. You get the idea I guess.

Jan

[1] http://tools.ietf.org/html/draft-nottingham-json-home-03

---

From: Jan Algermissen <[email-masked]>
Date: Sat, 11 Jan 2014 14:22:08 +0100

> [1] http://tools.ietf.org/html/draft-nottingham-json-home-03

Forgot to say: this reusability of application/json-home is probably a good indicator to leave the format as is, forget about the somewhat open issues[1][2] and move the spec towards standard? And -1 your todo-pile :-)

[1] Would actually not break the above POV, so you could put it in.
Jan

[1] http://www6.ietf.org/mail-archive/web/apps-discuss/current/msg09101.html
[2] http://www.ietf.org/mail-archive/web/apps-discuss/current/msg09238.html

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Darrel Miller <[email-masked]>
Date: Sat, 11 Jan 2014 21:18:32 -0500

Hey Jan,

Be aware that json-home does not support two links that have the same
link relation type.   Initially I was convinced this was a
short-coming of the format, however, after stewing on it for a while,
I believe that instead of adding some mechanism to allow a user-agent
to discriminate between different links with the same link relation
type, an additional URI template parameter would be able to achieve
must the same capability.

Darrel

---

From: Jan Algermissen <[email-masked]>
Date: Sun, 12 Jan 2014 11:18:03 +0100

Hi Darrel,

On 12.01.2014, at 03:18, Darrel Miller <[email-masked]> wrote:

> link relation type.   

Yes, right. So not quite any link lists :-)

> Initially I was convinced this was a

Funny, same thought I have two days ago.

I then ended up solving a situation with more than one link of the same rel with another layer of "dscription document". When I designed the media type for that I realized I was re-doing application/json-home :-)

Jan