Subject: [apps-discuss] I-D Action: draft-ietf-appsawg-sieve-duplicate-03.txt

From: [email-masked]
Date: Mon, 03 Mar 2014 12:16:28 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Applications Area Working Group Working Group of the IETF.

        Title           : Sieve Email Filtering: Detecting Duplicate Deliveries
        Author          : Stephan Bosch
	Filename        : draft-ietf-appsawg-sieve-duplicate-03.txt
	Pages           : 13
	Date            : 2014-03-03

Abstract:
   This document defines a new test command "duplicate" for the "Sieve"
   email filtering language.  This test adds the ability to detect
   duplications.  The main application for this new test is handling
   duplicate deliveries commonly caused by mailing list subscriptions or
   redirected mail addresses.  The detection is normally performed by
   matching the message ID to an internal list of message IDs from
   previously delivered messages.  For more complex applications, the
   "duplicate" test can also use the content of a specific header or
   other parts of the message.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-appsawg-sieve-duplicate/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-appsawg-sieve-duplicate-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-appsawg-sieve-duplicate-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Stephan Bosch <[email-masked]>
Date: Mon, 03 Mar 2014 21:30:46 +0100

Hi,

>     other parts of the message.

This new draft addresses the comments received on the last -02 version 
and includes a few changes of my own. The changes are as follows:

- Formulated usage scenarios in the introduction with a bit less certainty (Tom Petch).
- Mentioned that Message-ID may not in fact be unique and that the "duplicate" test does nothing to deal with this (Tom Petch).
- Clarified that the "duplicate" test is best used as the first test to prevent unexpected behavior. (Arnt Gulbrandsen).
- Reduced the use of "multiple" (Arnt Gulbrandsen).
- Addressed small editorial comments (Tony Hansen, Robert Sparks, Ned Freed).
- Simplified the text about not modifying tracking list for failed script executions (S. Moonesamy).
- Added a note about the necessity of the :handle argument in certain cases. Also added an example to clarify. (Robert Sparks).
- Described preprocessing steps of header values explicitly, including UTF-8 conversion (Tom Petch) and header unfolding (me).
- Changed the example in Section 3 not to rely on a static value for the duplicate :uniqueid test (Ned Freed).
- Explicitly described the syntax rules of the :header and :uniqueid parameters (me)

Thanks for all the reviews. Reviewers, please indicate whether your comments were addressed adequately.

Regards,

Stephan.