Subject: Re: [apps-discuss] RFC for XMLObject Parsing

From: Brian Aberle <[email-masked]>
Date: Mon, 3 Mar 2014 12:57:40 -0700

Hi world,
It's me again.  I'll just be honest here.  Ive never took the time in my whole career to be on an IETF list - but don't count me out for that.  Isn't this the place where the old school masters kick it?  All .com aside this is about .edu - and sirs, mind you that is where all this Internet stuff came from.  Now I know a forum of Peacock's is not impressed by another colorful cool guy. We have moderators because we know that cock fighting is real.  I don't know if ya'll are shy, just not real chatty, or are too busy, maybe just didn't notice the new guy, I don't know.  I put together a very complete example and implementation.  Forgive me for not supplying this direct link in my first posting:
https://onedrive.live.com/redir?resid=D7EC275E76D295CF!923&authkey=!AAnvh0CKDY4nuho&ithint=file%2c.zip

World - Would it be helpful if I put all this together into an Internet Draft to obtain feedback?  That is the new question. This overview in HTML is rough and rogue and was not intended for IETF Gurus, Bosses, Admins, and Chiefs, but for programmers using this stuff. http://www.codeproject.com/Articles/37850/XMLFoundation
 
The OLD question was "Should we have an RFC for this?"
The NEW question is "Should this be put into an Internet Draft?"  Is that necessary? to get the attention of cocks that squawk in this spot? I asked the apps-discuss admins who said that it could be equally as effective to get good discussion going as it would an Internet Draft.  I believe them, so I turned up the color volume a bit.
 
World, can I have an ACK, NAK, Ping, anything?  Look at the numbers in the example program ExIndexObjects.  If numbers were to get in a cock fight id put all my money on 777.

From: [email-masked]
To: [email-masked]
Subject: RFC for XMLObject Parsing
Date: Thu, 27 Feb 2014 13:02:40 -0700

Hello World,

I am seeking community feedback regarding an official alternative to SAX and DOM.  I have put together several examples that show performance numbers which alone justify this alternative to SAX or DOM.  There are other reasons as well, primarily - the argument for "Object Oriented Design" in the application layer.  This issue in discussion here before the community is: Do we want an RFC for this?  Maybe not.  Maybe so.  We don't all want to keep inventing the wheel.  The concept is simple.  It is "XML Serialization".XMLObject Parsing?  We don't need to invent new words, but we must also note that "Serialization" includes neither Keyed XML Updates nor Object Instance Reference counting.  We also don't need fancy things that we just don't need, however I have prepared an example using CORBA that does need this(and we needed it on the $2B NCIS project).  This concept was identified quickly by Bjarne Stroustrup in this thread:  http://www.artima.com/forums/flat.jsp?forum=226&thread=204721          Most recent reply:    Feb 12, 2010 12:43 AM     by             Brian Aberle   
I recommend that this thread be continuation from that one, where we resolve to solve an identified need (for and RFC?)  That is the question. I have prepared a rough and rogue draft on this concept http://www.codeproject.com/Articles/37850/XMLFoundation-2 I have received much valuable feedback in the public forum at the bottom of that article over the past decade++;  The roughness of the draft HTML doc describing this stuff, should not reflect on the polished and refined all encompassing open source implementation.I had developed/co-developed 2 XML Parsers prior to the finalization of XML 1.0.  That is rather simple stuff in terms of implementation - fact backed by the "Yet Another" factor in available XML Parsers.  "XML Serialization" is perhaps slightly more complex in implementation.  We need to use the new word "XML Object Parsing" or perhaps "XML Serialization++" to describe the even more complex implementation which addresses the needs raised in the above two public threads over the past decade.Since the very purpose of IETF is designed to prevent us all from re-inventing the wheel when we collectively can identify a need for it, (each of us would create our own cool version no doubt) but collectively we would roll nowhere that way - Should we have an RFC for this?  That is the question.
 
World, what do you think?

---

From: Bill Mills <[email-masked]>
Date: Mon, 3 Mar 2014 17:21:36 -0800

EAGAIN

errno() returns ALL_RESOURCES_AT_IETF

On Monday, March 3, 2014 11:57 AM, Brian Aberle <[email-masked]> wrote:
 
Hi world,

 

________________________________
From: [email-masked]
To: [email-masked]
Subject: RFC for XMLObject Parsing
Date: Thu, 27 Feb 2014 13:02:40 -0700

Hello World,

I am seeking community feedback regarding an official alternative to SAX and DOM.  I have put together several examples that show performance numbers which alone justify this alternative to SAX or DOM.  There are other reasons as well, primarily - the argument for "Object Oriented Design" in the application layer.  This issue in discussion here before the community is: Do we want an RFC for this?  Maybe not.  Maybe so.  We don't all want to keep inventing the wheel.  The concept is simple.  It is "XML Serialization".
XMLObject Parsing?  We don't need to invent new words, but we must also note that "Serialization" includes neither Keyed XML Updates nor Object Instance Reference counting.  We also don't need fancy things that we just don't need, however I have prepared an example using CORBA that does need this(and we needed it on the $2B NCIS project).  This concept was identified quickly by Bjarne Stroustrup in this thread:  http://www.artima.com/forums/flat.jsp?forum=226&thread=204721
          Most recent reply:    Feb 12, 2010 12:43 AM     by Brian Aberle   

I recommend that this thread be continuation from that one, where we resolve to solve an identified need (for and RFC?)  That is the question. I have prepared a rough and rogue draft on this concept http://www.codeproject.com/Articles/37850/XMLFoundation-2 I have received much valuable feedback in the public forum at the bottom of that article over the past decade++;  The roughness of the draft HTML doc describing this stuff, should not reflect on the polished and refined all encompassing open source implementation.
I had developed/co-developed 2 XML Parsers prior to the finalization of XML 1.0.  That is rather simple stuff in terms of implementation - fact backed by the "Yet Another" factor in available XML Parsers.  "XML Serialization" is perhaps slightly more complex in implementation.  We need to use the new word "XML Object Parsing" or perhaps "XML Serialization++" to describe the even more complex implementation which addresses the needs raised in the above two public threads over the past decade.
Since the very purpose of IETF is designed to prevent us all from re-inventing the wheel when we collectively can identify a need for it, (each of us would create our own cool version no doubt) but collectively we would roll nowhere that way - Should we have an RFC for this?  That is the question.

_______________________________________________
apps-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Brian Aberle <[email-masked]>
Date: Mon, 3 Mar 2014 18:37:21 -0700

C:\Users\The one> ping www.ibm.com
Pinging e3062.x.akamaiedge.net [23.7.65.242] with 32 bytes of data:
Reply from 23.7.65.242: bytes=32 time=21ms TTL=58
Reply from 23.7.65.242: bytes=32 time=16ms TTL=58
Reply from 23.7.65.242: bytes=32 time=14ms TTL=58
Reply from 23.7.65.242: bytes=32 time=16ms TTL=58
Ping statistics for 23.7.65.242:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 14ms, Maximum = 21ms, Average = 16ms
C:\Users\The one>
 
OK, we're online.   :)
 
Date: Mon, 3 Mar 2014 17:21:36 -0800
From: [email-masked]
Subject: Re: [apps-discuss] RFC for XMLObject Parsing
To: [email-masked]; [email-masked]

EAGAIN

 
 
     On Monday, March 3, 2014 11:57 AM, Brian Aberle <[email-masked]> wrote:
    Hi world,It's me again.  I'll just be honest here.  Ive never took the time in my whole career to be on an IETF list - but don't count me out for that.  Isn't this the place where the old school masters kick it?  All .com aside this is about .edu - and sirs, mind you that is where all this Internet stuff came from.  Now I know a forum of Peacock's is not impressed by another colorful cool guy. We have moderators because we know that cock fighting is real.  I don't know if ya'll are shy, just not real chatty, or are too busy, maybe just didn't notice the new guy, I don't know.  I put together a very complete example and implementation.  Forgive me for not supplying this direct link in my first posting:https://onedrive.live.com/redir?resid=D7EC275E76D295CF!923&authkey=!AAnvh0CKDY4nuho&ithint=file%2c.zipWorld - Would it be helpful if I put all this together into an Internet Draft to obtain feedback?  That is the new question. This overview in HTML is rough and rogue and was not intended for IETF Gurus, Bosses, Admins, and Chiefs, but for programmers using this stuff. http://www.codeproject.com/Articles/37850/XMLFoundation The OLD question was "Should we have an RFC for this?"The NEW question is "Should this be put into an Internet Draft?"  Is that necessary? to get the attention
 of cocks that squawk in this spot? I asked the apps-discuss admins who said that it could be equally as effective to get good discussion going as it would an Internet Draft.  I believe them, so I turned up the color volume a bit. World, can I have an ACK, NAK, Ping, anything?  Look at the numbers in the example program ExIndexObjects.  If numbers were to get in a cock fight id put all my money on 777.  From: [email-masked]: [email-masked]: RFC for XMLObject ParsingDate: Thu, 27 Feb 2014 13:02:40 -0700

Hello World,I am seeking community feedback regarding an official alternative to SAX and DOM.  I have put together several examples that show performance numbers which alone justify this alternative to SAX or DOM.  There are other reasons as well, primarily - the argument for "Object Oriented Design" in the application layer.  This issue in discussion here before the community is: Do we want an RFC for this?  Maybe not.  Maybe so.  We don't all want to keep inventing the wheel.  The concept is
 simple.  It is "XML Serialization".XMLObject Parsing?  We don't need to invent new words, but we must also note that "Serialization" includes neither Keyed XML Updates nor Object Instance Reference counting.  We also don't need fancy things that we just don't need, however I have prepared an example using CORBA that does need this(and we needed it on the $2B NCIS project).  This concept was identified quickly by Bjarne Stroustrup in this thread:  http://www.artima.com/forums/flat.jsp?forum=226&thread=204721          Most recent reply:    Feb 12, 2010 12:43 AM     by             Brian Aberle   I recommend that this thread be continuation from that one, where we resolve to solve an identified need (for and RFC?)  That is the question. I have prepared a rough and rogue draft on this concept http://www.codeproject.com/Articles/37850/XMLFoundation-2 I have received much valuable feedback in the public forum at the bottom of that article over the past decade++;  The roughness of the
 draft HTML doc describing this stuff, should not reflect on the polished and refined all encompassing open source implementation.I had developed/co-developed 2 XML Parsers prior to the finalization of XML 1.0.  That is rather simple stuff in terms of implementation - fact backed by the "Yet Another" factor in available XML Parsers.  "XML Serialization" is perhaps slightly more complex in implementation.  We need to use the new word "XML Object Parsing" or perhaps "XML Serialization++" to describe the even more complex implementation which addresses the needs raised in the above two public threads over the past decade.Since the very purpose of IETF is designed to prevent us all from re-inventing the wheel when we collectively can identify a need for it, (each of us would create our own cool version no doubt) but collectively we would roll nowhere that way - Should we have an RFC for this?  That is the question. World, what do you think?  		 	   		   		 	   		   		 	   		   		 	   		   		 	   		  
_______________________________________________apps-discuss mailing [email-masked]://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Brian Aberle <[email-masked]>
Date: Tue, 4 Mar 2014 04:03:12 -0700

Here is a very short summary of the "XMLObject Parsing" concept: (not written by myself)
 
Note that this author uses a new term "XML Data Binding".  That is an interesting term: it's another new word for "XML Serialization".  God save us from slang and marketing rhetoric amid the need to invent new words.  Note that this author has also documented many other implementations of comparable design objectives, he seems to identify the industry need.  This is his summary found here:
http://www.rpbourret.com/xml/XMLDataBinding.htm#xmlfoundation
 
XMLFoundation is an XML data binding framework that can be used with C/C++ and Java objects, as well as COM, DCOM, and CORBA objects. It includes its own non-validating parser. 

 Objects that are bound to XML must derive from the XMLObject class and implement the MapXMLTagsToMembers method. This method maps XML attributes and elements to member variables, primarily by calling the MapAttribute and MapMember functions. MapAttribute is used to map XML attributes to member variables. MapMember is used to map XML elements to member variables and to link objects to sub-objects. The latter functionality is necessary when an XML element contains a child element that is mapped to a sub-object, rather than a member variable. 

 XML elements and attributes that are not mapped in MapXMLTagsToMembers can still be handled through a virtual method that is implemented by the application. The application passes a pointer to this method to XMLFoundation's object factory. When the object factory is reading XML and encounters an element or attribute that has not been mapped, it calls the method. 

 XMLObject keeps state data for each member variable, such as whether the variable's value has been changed, whether the variable's value has been set, and whether the variable's value should be serialized to XML. XMLObject maintains this state data when its methods (such as SetMember) are called. However, applications must maintain the state data themselves (such as by calling setMemberDirty) when setting member variables directly. 

 Applications transfer data between XML (as a string) and objects with the FromXML and ToXML methods in XMLObject. XMLFoundation has a number of options for serializing data as XML, including ordering child elements alphabetically or in their original order, only serializing data that has been updated by the application, excluding mapped or unmapped attributes, and including a DOCTYPE declaration. 

 XMLFoundation can cache objects that have an ID, which can be set directly by the application or from an oid attribute in XML. It also contains implementations of common classes (such as lists, hashtables, stacks, and trees) and utilities (such as sorts, performance times, and INI profiles). 

Date: Tue, 4 Mar 2014 08:44:10 +0000
Subject: Re: [apps-discuss] RFC for XMLObject Parsing
From: [email-masked]
To: [email-masked]

Any chance you could write a paragraph explaining what you're aiming to write a specification for? Either that, or sketch out an actual I-D. Without that, you appear to be using lots of new terms for which I have no definition, and asking me to read through a bunch of articles elsewhere. I'm simply lacking the background here.

 Something without quite as much slang and marketing rhetoric might help.
Also, as Bill says, most people are either at, or heavily engaged with, the IETF meeting in London, so expect a lag before response.

Dave.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 4 Mar 2014 11:37:45 +0000

Aren't the definitions of XML and its ilk within the purview of the W3C and
not us?

On Mon, Mar 3, 2014 at 7:57 PM, Brian Aberle <[email-masked]> wrote:

> Hi world,
> It's me again.  I'll just be honest here.  Ive never took the time in my
> whole career to be on an IETF list - but don't count me out for that.
> Isn't this the place where the old school masters kick it?  All .com aside
> this is about .edu - and sirs, mind you that is where all this Internet
> stuff came from.  Now I know a forum of Peacock's is not impressed by
> another colorful cool guy. We have moderators because we know that cock
> fighting is real.  I don't know if ya'll are shy, just not real chatty, or
> are too busy, maybe just didn't notice the new guy, I don't know.  I put
> together a very complete example and implementation.  Forgive me for not
> supplying this direct link in my first posting:
>
> World - Would it be helpful if I put all this together into an Internet
> Draft to obtain feedback?  That is the new question. This overview in HTML
> is rough and rogue and was not intended for IETF Gurus, Bosses, Admins, and
> Chiefs, but for programmers using this stuff.
> http://www.codeproject.com/Articles/37850/XMLFoundation
>
> The NEW question is "Should this be put into an Internet Draft?"  Is that
> necessary? to get the attention of cocks that squawk in this spot? I asked
> the apps-discuss admins who said that it could be equally as effective to
> get good discussion going as it would an Internet Draft.  I believe them,
> so I turned up the color volume a bit.
>
> World, can I have an ACK, NAK, Ping, anything?  Look at the numbers in the
> example program ExIndexObjects.  If numbers were to get in a cock fight id
> put all my money on 777.
>
>
> ------------------------------
> From: [email-masked]
> I am seeking community feedback regarding an official alternative to SAX
> and DOM.  I have put together several examples that show performance
> numbers which alone justify this alternative to SAX or DOM.  There are
> other reasons as well, primarily - the argument for "Object Oriented
> Design" in the application layer.  This issue in discussion here before the
> community is: Do we want an RFC for this?  Maybe not.  Maybe so.  We don't
> all want to keep inventing the wheel.  The concept is simple.  It is "XML
> Serialization".
>
> XMLObject Parsing?  We don't need to invent new words, but we must also
> note that "Serialization" includes neither Keyed XML Updates nor Object
> Instance Reference counting.  We also don't need fancy things that we just
> don't need, however I have prepared an example using CORBA that does need
> this(and we needed it on the $2B NCIS project).  This concept was
> identified quickly by Bjarne Stroustrup in this thread:
> <http://www.artima.com/forums/flat.jsp?forum=226&thread=204721>
> http://www.artima.com/forums/flat.jsp?forum=226&thread=204721
>
>           Most recent reply<http://www.artima.com/forums/flat.jsp?forum=226&thread=204721&start=15#366941>:
> Feb 12, 2010 12:43 AM by Brian Aberle<http://www.artima.com/profile.jsp?user=70450>
>
>
> I recommend that this thread be continuation from that one, where we
> resolve to solve an identified need (for and RFC?)  That is the question. I
> have prepared a rough and rogue draft on this concept
> http://www.codeproject.com/Articles/37850/XMLFoundation-2 I have received
> much valuable feedback in the public forum at the bottom of that article
> over the past decade++;  The roughness of the draft HTML doc describing
> this stuff, should not reflect on the polished and refined all encompassing
> open source implementation.
>
> I had developed/co-developed 2 XML Parsers prior to the finalization of
> XML 1.0.  That is rather simple stuff in terms of implementation -
> fact backed by the "Yet Another" factor in available XML Parsers.  "XML
> Serialization" is perhaps slightly more complex in implementation.  We need
> to use the new word "XML Object Parsing" or perhaps "XML Serialization++"
> to describe the even more complex implementation which addresses the needs
> raised in the above two public threads over the past decade.
>
> Since the very purpose of IETF is designed to prevent us all from
> re-inventing the wheel when we collectively can identify a need for it,
> (each of us would create our own cool version no doubt) but collectively we
> would roll nowhere that way - Should we have an RFC for this?  That is the
> question.
>

---

From: Dave Cridland <[email-masked]>
Date: Tue, 4 Mar 2014 11:54:31 +0000

Yes; unless there's a wire protocol involved, of course. But I get the
impression there isn't in this case.

On 4 March 2014 11:37, Murray S. Kucherawy <[email-masked]> wrote:

> Aren't the definitions of XML and its ilk within the purview of the W3C
> and not us?
>
>
>> World, can I have an ACK, NAK, Ping, anything?  Look at the numbers in
>> the example program ExIndexObjects.  If numbers were to get in a cock fight
>> id put all my money on 777.
>>
>>
>> http://www.codeproject.com/Articles/37850/XMLFoundation-2 I have
>> received much valuable feedback in the public forum at the bottom of that
>> article over the past decade++;  The roughness of the draft HTML doc
>> describing this stuff, should not reflect on the polished and refined all
>> encompassing open source implementation.
>>

---

From: Brian Aberle <[email-masked]>
Date: Tue, 4 Mar 2014 07:28:51 -0700

Correct - this is not a wire protocol, it's a design approach and an algorithm, initially created to add a native XML get() and set() to all CORBA objects.  Of course this discussion does not belong at OMG because it applies equally to COM/DCOM, and for that matter even MFC GUI objects are simplified with this design approach (using no SAX and no DOM and no W3C recognized approach) - see the XMLDialog example.
 
Date: Tue, 4 Mar 2014 11:54:31 +0000
Subject: Re: [apps-discuss] RFC for XMLObject Parsing
From: [email-masked]
To: [email-masked]
CC: [email-masked]; [email-masked]

Yes; unless there's a wire protocol involved, of course. But I get the impression there isn't in this case.

Aren't the definitions of XML and its ilk within the purview of the W3C and not us?

Hi world,

 

From: [email-masked]

Hello World,

 

[email-masked]

[email-masked]

---

From: Hector Santos <[email-masked]>
Date: Tue, 04 Mar 2014 12:16:11 -0500

I think we might be seeing what I have found is a new need just to 
document stuff in a structured simple manner with some level of 
"broad" industry and peer review, more importantly for all sizes of 
interest.

I personally believe the IETF should leverage this need and begin to 
include application level recommended design, implementation and 
deployment methods proposals.  Not everything has to be a "standard" 
and these days, we have so many argumentations and levels of 
communications, that yes, today XML is highly considered as a 
"client/server" and dynamic communications "wired" protocol. The 
increased speeds has allowed what was otherwise higher overhead "data" 
methods to be a non-issue and a natural part of an I/O protocol.

-- 
HLS

---

From: Brian Aberle <[email-masked]>
Date: Thu, 6 Mar 2014 18:48:34 -0700

Topic: Is this Concept/Design/Implementation a protocol?

This IS a wire protocol, I was mistaken.  It can be a wire protocol.  The very fast XML updates depend on the attribute tag name, "oid" - an extension to XML required for "XMLObject Parsing" if we call it that.  I created a simple example program that clearly shows the need for this.
 
I hope you can 'see' the answer yourself - as I made a makefile for Linux, VC6 and VS2012 that show the results in numbers.  The new example program is called "TheOIDProtocol". Find it here:
https://onedrive.live.com/redir?resid=D7EC275E76D295CF!923&authkey=!AAnvh0CKDY4nuho&ithint=file%2c.zip

Answer: Yes, it can be considered a protocol if you add some small constraints to "Standard XML".
         These additions, ALTHOUGH THEY ARE OPTIONAL, do define a protocol.  

This specialized "XML Object Parser" knows a special key word it is "oid"  It was designed to be brief, "oid" Stands for Object ID.
If the first attribute is "oid", (POSITIONAL and CASE SENSITIVE) exists, the parser acts different.
Putting "oid" as the 3rd attribute has no effect, this violates some thought on positional significance 
 of attribute order because this special optimization demands that "oid" be #1 in position as the attribute.
This is the protocol.  Yep.  Cant get around that.  The protocol also make provision for UpdateTime

This is why: Without this protocol - XML updates are SLOW.  This is how the world works with no "oid":
The tokenizer is getting fragments of data that it cannot possibly identify as an object until a
"Temporary Object" is built to contain all of the data.  Now this "DOM like" Temporary object might only be a  
 small subset of the actual object - for example a complex object may have many member variables and 
 the xml used to update it contains only the information necessary to update the object plus the changes.
This is a delta rather than an overwrite.  Since the key to the object instance exists within the data it becomes
'necessary' to create the temporary object because we have no information to associate the actual object instance.

 In the world with and "oid" (that must appear in just the right place and case) we do not need any temporary
 object to hold the data because the tokenizer peeks ahead one token to look for this special "oid"
 if it exists, we obtain the one and only object instance (via a unique key) and parse directly into it.  
 This is a major performance improvement utilizing much less memory and CPU when "oid"
 is the first attribute.  That is a protocol.  Speed is the reason.  
 
Why was ETag added to HTTP in 1.1?  
 HTTP 1.0 didnt cache - I remember when ETag support was added to ServerCore.cpp for HTTP 1.1
Caching was a nice and needed feature in HTTP, no less than the "oid" in XML.

There is already an example which shows the performance improvement gained by the "oid"
The ExIndexObjects example times an "Update" vs and "Update Faster" and you can see a difference
however that example was not designed to be a case to emphasize exactly how major the time 
 difference is.  The larger the temporary object the more magnified the time and memory in 
 dealing with it - The IndexObjects example uses very small objects and very many of them - 
with very small objects you can see it is a little faster - look how much faster larger complex object are
when you run the simple little example I just published.

Brian

> Date: Tue, 4 Mar 2014 12:16:11 -0500
> From: [email-masked]
> To: [email-masked]; [email-masked]
> CC: [email-masked]

---

From: Brian Aberle <[email-masked]>
Date: Thu, 20 Mar 2014 00:05:59 -0600

Hello World,
 
There was confusion about this being "A Protocol".  Initially, I had conceptually pictured it as an extra keyword in XML itself because it is handled by the XML tokenizer itself.  The tokenizer recognizes the special keyword attribute "oid" ONLY if it appears as the first attribute (because that is the only token we have parsed out yet in that element) Now the "Object ID" can be used to obtain the memory location (or application layer object instances) that the XML will parse directly into with no temporary memory copy into a tree like structure.  It's OVER twice as fast as the more traditional "memory copy design" naturally because the iterations to the temporary structure are eliminated, it goes beyond 2 times as fast because the tokenizer uses neither SAX nor DOM, but a more efficient alternative to SAX that avoids pushing a variable number of arguments depending on the token type via the SAX calls.  The non-SAX design only makes calls to getToken(token *p) to pull the data over a 1 argument call stack.  Data that SAX would push via too many argument that compile down to needless push's ands pop's
 
Since this new thing has a requirement of an attribute named "oid" it could equally conceptually be a protocol (A protocol that the XML tokenizer is aware of?)  There is no other way to implement "the protocol".  I have gone to much effort to try to communicate this clearly, and developed a simple little example that breaks it all down into numbers that you can see and understand.  The examples build on Linux and Windows, 
 
Polished Source:
https://onedrive.live.com/redir?resid=D7EC275E76D295CF!923&authkey=!AAnvh0CKDY4nuho&ithint=file%2c.zip
Rough and Rogue Draft article about the (open source) technology
http://www.codeproject.com/Articles/37850/XMLFoundation
 
SO Folks, 
 
I want to know what some smart internet savvy people think about this.  Am I in the right place?
 
Brian Aberle
_____________________________________________________________________________

>On Mon, Mar 3, 2014 at 7:57 PM,<[email-masked]> wrote:
>

> On Tue, 4 Mar 2014 12:16:11, Hector Santos<[email-masked]> wrote:
> 

Tue, 4 Mar 2014 11:37:45 +0000, Brian Aberle <[email-masked]> wrote:

---

From: "Rushforth, Peter" <[email-masked]>
Date: Thu, 20 Mar 2014 12:06:59 +0000

Hi Brian,

Although they can be a little snooty at times (you've been warned), xml-dev also has lots of smart people who know lots about xml,
who will likely also have an opinion although perhaps more informally than here.

Cheers,
Peter Rushforth

From: apps-discuss [mailto:[email-masked]] On Behalf Of Brian Aberle
Sent: March 20, 2014 02:06
To: Bill Mills; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [apps-discuss] RFC for XMLObject Parsing

Hello World,

Polished Source:

SO Folks,

Brian Aberle

>On Mon, Mar 3, 2014 at 7:57 PM,<[email-masked]<mailto:[email-masked]>> wrote:
>

> On Tue, 4 Mar 2014 12:16:11, Hector Santos<[email-masked]<mailto:[email-masked]>> wrote:
>
Tue, 4 Mar 2014 11:37:45 +0000, Brian Aberle <[email-masked]<mailto:[email-masked]>> wrote:

To: [email-masked]; [email-masked]<mailto:[email-masked]>
EAGAIN

On Monday, March 3, 2014 11:57 AM, Brian Aberle <[email-masked]> wrote:
Hi world,
It's me again.  I'll just be honest here.  Ive never took the time in my whole career to be on an IETF list - but don't count me out for that.  Isn't this the place where the old school masters kick it?  All .com aside this is about .edu - and sirs, mind you that is where all this Internet stuff came from.  Now I know a forum of Peacock's is not impressed by another colorful cool guy. We have moderators because we know that cock fighting is real.  I don't know if ya'll are shy, just not real chatty, or are too busy, maybe just didn't notice the new guy, I don't know.  I put together a very complete example and implementation.  Forgive me for not supplying this direct link in my first posting:
https://onedrive.live.com/redir?resid=D7EC275E76D295CF!923&authkey=!AAnvh0CKDY4nuho&ithint=file%2c.zip<https://onedrive.live.com/redir?resid=D7EC275E76D295CF%21923&authkey=%21AAnvh0CKDY4nuho&ithint=file%2c.zip>

          Most recent reply<http://www.artima.com/forums/flat.jsp?forum=226&thread=204721&start=15#366941>: Feb 12, 2010 12:43 AM by Brian Aberle<http://www.artima.com/profile.jsp?user=70450>

_______________________________________________
apps-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Brian Aberle <[email-masked]>
Date: Mon, 24 Mar 2014 07:35:20 -0600

Peter,
 
As you suggested, I posted a summary at xml-dev.  Thanks for the warning.  IAM [email-masked] on that thread.  You IETF folks are not chatty at all compared to them.  Yesterday was all about 'RFC for XML Object Parsing'.  I got some good feedback and got closer toward an official answer to what this concept is (Protocol, Implementation, or XML 2.0).  I know I showed up with polished code, somewhat described with 'bloggish' documentation here: http://www.codeproject.com/Articles/37850/XMLFoundation and no summary or even clear definition of this project is that represents 14 years of work.  I will put together such a 'White Paper' / 'Executive Summary' / 'Internet Draft' kind of paper once I have some community consensus on the various views of the basic concept which must define the definition.  I will re-post the beginning of this draft summary here (followed by a recap of this thread here):
 
Perhaps ya'll can help me refine this:
__________________
 
Hello World,
 
I need an XML expert to correct me if I have any terminology wrong here.  I wrote my first two XML parsers before W3C finalized XML 1.0 and I wrote my own XSLT - but I don't claim to know it all about XML even though folks with lesser study than me claim to know all about XML.  Maybe someone here can intelligently comment on this:
 
Lets start with getting terminology right.  "A Protocol" is a set of communication rules. When two parties agree on the specific use of a generic markup language like XML, they have agreed on a protocol.  Is everyone with me so far?  With this 'definition' of a protocol, your XML parser should be 'unaware' of any specific protocol as it deals with the general aspects of XML.
 
I propose adding a new keyword to XML, and I would like community feedback about it.  It would work like this:  
 
The tokenizer recognizes a special keyword attribute "oid" ONLY if it appears as the first attribute (because that is the only token we have parsed out yet in that element) Now the "Object ID" can be used to obtain the memory location (or application layer object instances) that the XML will parse directly into with no temporary memory copy into a tree or DOM structure.  This is not the syntax that my implementation uses but seems to convey the concept very well  (<foo @oid="123"/>)
 
It's OVER twice as fast as the more traditional "memory copy design" naturally because the iterations to the temporary structure are eliminated, it goes beyond 2 times as fast because the tokenizer uses neither SAX nor DOM, but a more efficient alternative to SAX that avoids pushing a variable number of arguments depending on the token type via the SAX calls.  The non-SAX design only makes calls to getToken(token *p) to pull the data over a 1 argument call stack.  Data that SAX would push via too many argument that compile down to needless push's ands pop's.  This implementation is about 3 times faster than the very best anyone can do with SAX, this makes it the most ideal solution for the massive sets used in a native BigData xml integration.
 
The first priority is to understand this concept clearly.  Once clearly understood, it becomes clear that you could call this A) a protocol.   B) an application implementation   C) an extension to XML along a similar thought that added ETag into HTTP 1.1
 
An interesting point of analogy with "oid"=="Etag" , is that there is a second keyword used with "oid" .  This is the ONLY other keyword used, it is "UpdateTime" and it is analogous to HTTP's "If-Modified-Since".  This HTTP analogy may help some with the conceptual summary of what we are attempting to summarize.

Since this thing has a requirement of an attribute named "oid" it could equally conceptually be a protocol (A protocol that the XML tokenizer is aware of?)  There is no other way to implement "the protocol".   If we call it  B) an implementation.  Now we have two XML's a fast one and a slow one.  A new one and an old one.  The new XML is 100% backwards compatible.  Again - this is all a matter of view.  The important thing is to understand the concept.
 
<Customer oid='1'>
      <CustomerID>1</CustomerID>
      .....
</Customer>

Normally we would call "oid" an attribute.  It is NOT Data in this case.  It's a positional keyword in the XML.  For example if an attribute named "oid" contains any upper case or the attribute is not in the 1st position - then it IS data - otherwise it is a key.
 
The "oid" == the DBMS Index.  Just as a DBMS index can be keyed over multiple columns - likewise the "oid" can be a concatenation of several columns that make it a unique Object ID.  An application using an ConfigFile.xml would most likely never use an "oid".  It's not designed to be used in all applications.  Many XML Documents, unless they are indexed in by a DBMS would not be candidate for "oid" use.

Finally, Suppose you have a list of "foos".  Suppose that list is very very long. 1 Terabyte. Suppose that you get updated XML source of that list every 15 minutes.  In the huge list, some "foos" are new, some foos() have been updated.  With an "oid" we can parse this entire update, and make no new memory allocations except of the new "foo's".  The XML Parser never needs to allocate any memory storage if it can make a connection between the cached instance and an "oid".
  
 Polished Source:
https://onedrive.live.com/redir?resid=D7EC275E76D295CF!923&authkey=!AAnvh0CKDY4nuho&ithint=file%2c.zip
 A Rough (and Rogue) Draft article about this (open source) technology
http://www.codeproject.com/Articles/37850/XMLFoundation

 Brian Aberle
__________________

 

From: [email-masked]
To: [email-masked]; [email-masked]
Subject: RE: [apps-discuss] RFC for XMLObject Parsing
Date: Thu, 20 Mar 2014 12:06:59 +0000

Hi Brian,

Cheers,
Peter Rushforth

From: apps-discuss [mailto:[email-masked]]
On Behalf Of Brian Aberle

 

Hello World,

There was confusion about this being "A Protocol".  Initially, I had conceptually pictured it as an extra keyword in XML itself because it is handled by the XML tokenizer itself.  The tokenizer recognizes the special keyword attribute "oid" ONLY if it appears
 as the first attribute (because that is the only token we have parsed out yet in that element) Now the "Object ID" can be used to obtain the memory location (or application layer object instances) that the XML will parse directly into with no temporary memory
 copy into a tree like structure.  It's OVER twice as fast as the more traditional "memory copy design" naturally because the iterations to the temporary structure are eliminated, it goes beyond 2 times as fast because the tokenizer uses neither SAX nor DOM,
 but a more efficient alternative to SAX that avoids pushing a variable number of arguments depending on the token type via the SAX calls.  The non-SAX design only makes calls to getToken(token *p) to pull the data over a 1 argument call stack.  Data that SAX
 would push via too many argument that compile down to needless push's ands pop's

Since this new thing has a requirement of an attribute named "oid" it could equally conceptually be a protocol (A protocol that the XML tokenizer is aware of?)  There is no other way to implement "the protocol".  I have gone to much effort to try to communicate
 this clearly, and developed a simple little example that breaks it all down into numbers that you can see and understand.  The examples build on Linux and Windows,

Polished Source:

SO Folks, 

Brian Aberle

 

 

EAGAIN

 

 

 

 

Hi world,

It's me again.  I'll just be honest here.  Ive never took the time in my whole career to be on an IETF list - but don't count me out for that.  Isn't this the place where the old school masters kick it?  All .com aside this is about .edu - and sirs, mind you
 that is where all this Internet stuff came from.  Now I know a forum of Peacock's is not impressed by another colorful cool guy. We have moderators because we know that cock fighting is real.  I don't know if ya'll are shy, just not real chatty, or are too
 busy, maybe just didn't notice the new guy, I don't know.  I put together a very complete example and implementation.  Forgive me for not supplying this direct link in my first posting:

World - Would it be helpful if I put all this together into an Internet Draft to obtain feedback?  That is the new question. This overview in HTML is rough and rogue and was not intended for IETF Gurus, Bosses, Admins, and Chiefs, but for programmers using
 this stuff. http://www.codeproject.com/Articles/37850/XMLFoundation

The NEW question is "Should this be put into an Internet Draft?"  Is that necessary? to get the attention of cocks that squawk in this spot? I asked the apps-discuss admins who said that it could be equally as effective to get good discussion going as it would
 an Internet Draft.  I believe them, so I turned up the color volume a bit.

 

From: [email-masked]

Hello World,

I am seeking community feedback regarding an official alternative to SAX and DOM.  I have put together several examples that show performance numbers
 which alone justify this alternative to SAX or DOM.  There are other reasons as well, primarily - the argument for "Object Oriented Design" in the application layer.  This issue in discussion here before the community is: Do we want an RFC for this?  Maybe
 not.  Maybe so.  We don't all want to keep inventing the wheel.  The concept is simple.  It is "XML Serialization".

XMLObject Parsing?  We don't need to invent new words, but we must also note that "Serialization" includes neither Keyed XML Updates nor Object Instance
 Reference counting.  We also don't need fancy things that we just don't need, however I have prepared an example using CORBA that does need this(and we needed it on the $2B NCIS project).  This concept was identified quickly by Bjarne Stroustrup in this thread: 
http://www.artima.com/forums/flat.jsp?forum=226&thread=204721

Most
 recent reply: Feb 12, 2010 12:43 AM by
Brian
 Aberle   

I recommend that this thread be continuation from that one, where
 we resolve to solve an identified need (for and RFC?)  That is the question. I have prepared a rough and rogue draft on this concept http://www.codeproject.com/Articles/37850/XMLFoundation-2 I
 have received much valuable feedback in the public forum at the bottom of that article over the past decade++;  The roughness of the draft HTML doc describing this stuff, should not reflect on the polished and refined all encompassing open source implementation.

I had developed/co-developed 2 XML Parsers prior to the finalization of XML 1.0.  That is rather simple stuff in terms of implementation - fact backed
 by the "Yet Another" factor in available XML Parsers.  "XML Serialization" is perhaps slightly more complex in implementation.  We need to use the new word "XML Object Parsing" or perhaps "XML Serialization++" to describe the even more complex implementation which
 addresses the needs raised in the above two public threads over the past decade.

Since the very purpose of IETF is designed to prevent us all from re-inventing the wheel when we collectively can identify a need for it, (each of us
 would create our own cool version no doubt) but collectively we would roll nowhere that way - Should we have an RFC for this?  That is the question.

 

[email-masked]

---

From: Hector Santos <[email-masked]>
Date: Tue, 25 Mar 2014 08:54:25 -0400

Brian,

I've a little (maybe a lot) unsure of what you are asking for.  Are 
you asking for permission to write an IETF-based I-D (individual 
draft) documenting your XML solution?  Which appears to be an "add-on" 
enhancement or optimizer? or it just a better parser?

If the later, thats software -- it sounds like you are trying to 
"sell, push, and/or market" a specific parser library called 
XMLFoundation.

I have no objection to seeing the IETF take on more documentation of 
"libraries" or reference guides in their particular IETF RFC format. 
But its rare to see this.   It generally has to be open-ended and 
generically beneficial to all.

XML Parser Libraries can vary tremendously and for us, the specific 
XML parser used depends on the application, tool or need. For example, 
if the development environment does not already have a built-in XML 
parser, then we might consider using PUGXML.H which is a very popular, 
C/C++ portable, lightweight, small footprint XML parser.  In general 
XML libraries are "fat" and huge, and pug comes in handy.  PUGXML is 
documented at Code Project and if you do a search, you can see it has 
evolved with "add-on" solutions as well:

http://www.codeproject.com/search.aspx?q=PugXML&doctypeid=1%3b2%3b3%3b13%3b14%3b9%3b10

So the rethorical queston is should the IETF begin documenting 
"pseudo-standard" coding  methods such as XML and specifically 
libraries like PugXML, XMLFoundation?

Finally, not getting into detail, it sounds like you want a specific 
"token" or attribute added to an XML node in order to improve or 
optimize the "finding" of nodes?

Again, thats sounds more like a specific software library issue. If 
the solution requires your "library"  that to me, isn't generally IETF 
material because its not something everyone can use. If you are 
suggesting that the method used in your functions be published as an 
open standard for other parsers to implement, then perhaps that may be 
of interest to XML parser developers.

--
HLS

On 3/24/2014 9:35 AM, Brian Aberle wrote:
> Peter,
>
> As you suggested, I posted a summary at xml-dev.  Thanks for the
> warning.  IAM [email-masked] <mailto:[email-masked]> on that
> thread.  You IETF folks are not chatty at all compared to them.
> Yesterday was all about 'RFC for XML Object Parsing'.  I got some good
> feedback and got closer toward an official answer to what this concept
> is (Protocol, Implementation, or XML 2.0).  I know I showed up with
> polished code, somewhat described with 'bloggish' documentation here:
> http://www.codeproject.com/Articles/37850/XMLFoundation and no summary
> or even clear definition of this project is that represents 14 years
> of work.  I will put together such a 'White Paper' / 'Executive
> Summary' / 'Internet Draft' kind of paper once I have some community
> consensus on the various views of the basic concept which must define
> the definition.  I will re-post the beginning of this draft summary
> here (followed by a recap of this thread here):
>
> I need an XML expert to correct me if I have any terminology wrong
> here.  I wrote my first two XML parsers before W3C finalized XML 1.0
> and I wrote my own XSLT - but I don't claim to know it all about XML
> even though folks with lesser study than me claim to know all about
> XML.  Maybe someone here can intelligently comment on this:
>
> Lets start with getting terminology right.  "A Protocol" is a set
> of communication rules. When two parties agree on the specific use
> of a generic markup language like XML, they have agreed on a
> protocol.  Is everyone with me so far?  With this 'definition' of a
> protocol, your XML parser should be 'unaware' of any specific protocol
> as it deals with the general aspects of XML.
>
> I propose adding a new keyword to XML, and I would like community
> feedback about it.  It would work like this:
>
> The tokenizer recognizes a special keyword attribute "oid" ONLY if it
> appears as the first attribute (because that is the only token we have
> parsed out yet in that element) Now the "Object ID" can be used to
> obtain the memory location (or application layer object instances)
> that the XML will parse directly into with no temporary memory copy
> into a tree or DOM structure.  This is not the syntax that my
> implementation uses but seems to convey the concept very well  (<foo
> @oid="123"/>)
>
> It's OVER twice as fast as the more traditional "memory copy design"
> naturally because the iterations to the temporary structure are
> eliminated, it goes beyond 2 times as fast because the tokenizer uses
> neither SAX nor DOM, but a more efficient alternative to SAX that
> avoids pushing a variable number of arguments depending on the token
> type via the SAX calls.  The non-SAX design only makes calls to
> getToken(token *p) to pull the data over a 1 argument call stack.
> Data that SAX would push via too many argument that compile down to
> needless push's ands pop's.  This implementation is about 3 times
> faster than the very best anyone can do with SAX, this makes it the
> most ideal solution for the massive sets used in a native BigData xml
> integration.
>
> The first priority is to understand this concept clearly.  Once
> clearly understood, it becomes clear that you could call this A) a
> protocol.   B) an application implementation   C) an extension to XML
> along a similar thought that added ETag into HTTP 1.1
>
> An interesting point of analogy with "oid"=="Etag" , is that there is
> a second keyword used with "oid" .  This is the ONLY other keyword
> used, it is "UpdateTime" and it is analogous to HTTP's
> "If-Modified-Since".  This HTTP analogy may help some with the
> conceptual summary of what we are attempting to summarize.
>
> Since this thing has a requirement of an attribute named "oid" it
> could equally conceptually be a protocol (A protocol that the XML
> tokenizer is aware of?)  There is no other way to implement "the
> protocol". If we call it  B) an implementation.  Now we have two XML's
> a fast one and a slow one.  A new one and an old one. The new XML is
> 100% backwards compatible.  Again - this is all a matter of view.  The
> important thing is to understand the concept.
>
> <Customer oid='1'>
> Normally we would call "oid" an attribute.  It is NOT Data in this
> case.  It's a positional keyword in the XML.  For example if an
> attribute named "oid" contains any upper case or the attribute is not
> in the 1st position - then it IS data - otherwise it is a key.
>
> The "oid" == the DBMS Index.  Just as a DBMS index can be keyed over
> multiple columns - likewise the "oid" can be a concatenation of
> several columns that make it a unique Object ID.  An application using
> an ConfigFile.xml would most likely never use an "oid".  It's not
> designed to be used in all applications.  Many XML Documents, unless
> they are indexed in by a DBMS would not be candidate for "oid" use.
>
> Finally, Suppose you have a list of "foos".  Suppose that list is very
> very long. 1 Terabyte. Suppose that you get updated XML source of that
> list every 15 minutes.  In the huge list, some "foos" are new, some
> foos() have been updated.  With an "oid" we can parse this entire
> update, and make no new memory allocations except of the new "foo's".
> The XML Parser never needs to allocate any memory storage if it can
> make a connection between the cached instance and an "oid".
>
> Polished Source:
> <https://onedrive.live.com/redir?resid=D7EC275E76D295CF%21923&authkey=%21AAnvh0CKDY4nuho&ithint=file%2c.zip>
> ----------------------------------------------------------------------
> Although they can be a little snooty at times (you've been warned),
> xml-dev also has lots of smart people who know lots about xml,
>
> *From:*apps-discuss [mailto:[email-masked]] *On Behalf
> Of *Brian Aberle
> *Sent:* March 20, 2014 02:06
> *To:* Bill Mills; [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: [apps-discuss] RFC for XMLObject Parsing
>
> Hello World,
>
> There was confusion about this being "A Protocol".  Initially, I had
> conceptually pictured it as an extra keyword in XML itself because
> it is handled by the XML tokenizer itself.  The tokenizer recognizes
> the special keyword attribute "oid" ONLY if it appears as the first
> attribute (because that is the only token we have parsed out yet in
> that element) Now the "Object ID" can be used to obtain the memory
> location (or application layer object instances) that the XML will
> parse directly into with no temporary memory copy into a tree like
> structure.  It's OVER twice as fast as the more traditional "memory
> copy design" naturally because the iterations to the temporary
> structure are eliminated, it goes beyond 2 times as fast because the
> tokenizer uses neither SAX nor DOM, but a more efficient alternative
> to SAX that avoids pushing a variable number of arguments depending on
> the token type via the SAX calls.  The non-SAX design only makes calls
> to getToken(token *p) to pull the data over a 1 argument call stack.
> Data that SAX would push via too many argument that compile down to
> needless push's ands pop's
>
> Since this new thing has a requirement of an attribute named "oid" it
> could equally conceptually be a protocol (A protocol that the XML
> tokenizer is aware of?)  There is no other way to implement "the
> protocol".  I have gone to much effort to try to communicate this
> clearly, and developed a simple little example that breaks it all down
> into numbers that you can see and understand.  The examples build on
> Linux and Windows,
>
> Polished Source:
> <https://onedrive.live.com/redir?resid=D7EC275E76D295CF%21923&authkey=%21AAnvh0CKDY4nuho&ithint=file%2c.zip>
>>On Mon, Mar 3, 2014 at 7:57 PM,<[email-masked] <mailto:[email-masked]>> wrote:
>>
>> On Tue, 4 Mar 2014 12:16:11, Hector Santos<[email-masked] <mailto:[email-masked]>> wrote:
>
>>
> ----------------------------------------------------------------------
>
> <mailto:[email-masked]>
>
> EAGAIN
>
> It's me again.  I'll just be honest here.  Ive never took the time in
> my whole career to be on an IETF list - but don't count me out for
> that.  Isn't this the place where the old school masters kick it?  All
> .com aside this is about .edu - and sirs, mind you that is where all
> this Internet stuff came from.  Now I know a forum of Peacock's is
> not impressed by another colorful cool guy. We have moderators because
> we know that cock fighting is real.  I don't know if ya'll are shy,
> just not real chatty, or are too busy, maybe just didn't notice the
> new guy, I don't know.  I put together a very complete example and
> implementation.  Forgive me for not supplying this direct link in my
> first posting:
> <https://onedrive.live.com/redir?resid=D7EC275E76D295CF%21923&authkey=%21AAnvh0CKDY4nuho&ithint=file%2c.zip>
>
> World - Would it be helpful if I put all this together into an
> Internet Draft to obtain feedback?  That is the new question.
> This overview in HTML is rough and rogue and was not intended for IETF
> Gurus, Bosses, Admins, and Chiefs, but for programmers using this
> stuff. http://www.codeproject.com/Articles/37850/XMLFoundation
>
> The NEW question is "Should this be put into an Internet Draft?"  Is
> that necessary? to get the attention of cocks that squawk in this
> spot? I asked the apps-discuss admins who said that it could be
> equally as effective to get good discussion going as it would an
> Internet Draft.  I believe them, so I turned up the color volume a bit.
>
> the example program ExIndexObjects.  If numbers were to get in a cock
> fight id put all my money on 777.
>
> ----------------------------------------------------------------------
>
> From: [email-masked]
> I am seeking community feedback regarding an official alternative to
> SAX and DOM.  I have put together several examples that show
> performance numbers which alone justify this alternative to SAX or
> DOM.  There are other reasons as well, primarily - the argument for
> "Object Oriented Design" in the application layer.  This issue in
> discussion here before the community is: Do we want an RFC for this?
> Maybe not.  Maybe so.  We don't all want to keep inventing the wheel.
> The concept is simple.  It is "XML Serialization".
>
> XMLObject Parsing?  We don't need to invent new words, but we must
> also note that "Serialization" includes neither Keyed XML Updates nor
> Object Instance Reference counting.  We also don't need fancy things
> that we just don't need, however I have prepared an example using
> CORBA that does need this(and we needed it on the $2B NCIS project).
> This concept was identified quickly by Bjarne Stroustrup in this
> thread: http://www.artima.com/forums/flat.jsp?forum=226&thread=204721
>
> Most recent reply
> <http://www.artima.com/forums/flat.jsp?forum=226&thread=204721&start=15#366941>:
> Feb 12, 2010 12:43 AM by Brian Aberle
> <http://www.artima.com/profile.jsp?user=70450>
>
> resolve to solve an identified need (for and RFC?)  That is the
> question. I have prepared a rough and rogue draft on this concept
> http://www.codeproject.com/Articles/37850/XMLFoundation-2I have
> received much valuable feedback in the public forum at the bottom of
> that article over the past decade++;  The roughness of the draft HTML
> doc describing this stuff, should not reflect on the polished and
> refined all encompassing open source implementation.
>
> I had developed/co-developed 2 XML Parsers prior to the finalization
> of XML 1.0.  That is rather simple stuff in terms of implementation -
> fact backed by the "Yet Another" factor in available XML Parsers.
> "XML Serialization" is perhaps slightly more complex in
> implementation.  We need to use the new word "XML Object Parsing" or
> perhaps "XML Serialization++" to describe the even more complex
> implementation which addresses the needs raised in the above two
> public threads over the past decade.
>
> re-inventing the wheel when we collectively can identify a need for
> it, (each of us would create our own cool version no doubt) but
> collectively we would roll nowhere that way - Should we have an RFC
> for this?  That is the question.
>

---

From: Brian Aberle <[email-masked]>
Date: Tue, 25 Mar 2014 08:16:20 -0600

Here's whats going on right now.  All threads at [xml-dev] are on this topic as I type.  For 2 days in a row I have not had any time to code because I spend every moment in [xml-dev] discussing this.  I am getting very good feedback from folks we might call an authority in XML.  
http://en.wikipedia.org/wiki/Michael_Howard_Kay
http://www.w3.org/People/Quin/
 
> enhancement or optimizer? or it just a better parser?

@[xml-dev] One person said "Holy Shit! this is not XML", another said "Yes it is XML", and another calls it XML 2.0 but Liam says "Not Likely"

> "sell, push, and/or market" a specific parser library called XMLFoundation.

It's free, open source, I am an engineer not a salesman.

> generically beneficial to all.

At the moment [xml-dev] has fully embraced this discussion.  The documentation is being produced almost as fast as I can type and folks can ask.  Many advanced topics have already been discussed, and the summary of the past two days is a great advancement in making this generically beneficial to all.  
 
> XML Parser Libraries can vary tremendously 
 
Yes. and the "hole" in XML 1.0/1.0 that allows an XML parser to retain or discard attribute order literally draws a line down the middle of XMLParser implementations that are available. Some are not even capable of being "extended" to support this fast parsing.  

> ... If you are 

IAM.  It is.
 
At this moment in time, if anyone at IETF wants to be involved with this I recommend joining the [xml-dev] discussion at least until there is another topic under discussion at [xml-dev] besides this very issue.

Brian
___________________________

---

From: Brian Aberle <[email-masked]>
Date: Wed, 26 Mar 2014 08:25:57 -0600

HELP!  STMP is failing.  Yesterday I put out in invitation for ya'll to jump on the thread at [xml-dev] but today I guess I got kicked off the forum because when I email the group it does not get delivered.  Today the servers at OASIS that host the open and unmoderated [xml-dev] mailing list failed to work.  The message in its entirety, complete with the SMTP headers is provided here so that honest internet admins can debug this failure.  It was just one message in a thread that was getting noisy.

At best, the servers failed to operate as designed, at worst this is censorship and the proof is published here.
 
-------------------->   I WAS KICKED OFF [xml-dev]     <--------------------------
I looked at their website, (for 5-10 minutes) and clearly I could see that they have someone who knows 
whats going on with XML in a variety of applications that works there.  I came to [xml-dev] in hopes of 
that exact thing, so I agree - I would be interested to hear their comments.  Is there a politically 
proper way to invite them in here for a comment?  Perhaps that they don't hang out in [xml-dev] being 
busy with their own forums and do not even know that we are talking about them behind their back here.  
 
I Believe what you are bringing up is that we need MORE AUTHORUTY INPUT.
 
Yesterday, I asked folks who hang out at [apps-discuss] at IETF to please take a look at the past few 
days at [xml-dev] for the same reason.  Can we assemble the chiefs for a pow wow?
 
Where are the chiefs?  Can we name them and call them out or is that not kosher?
 
Yesterday I saw someone question the reality of the NCIS (National Clinical Information System) project.  
Paul Fingerman left from NASA just to be CTO of the project.  He might remember me.  I was the guy who 
Paul interrupted while I was presenting this to the Board and all of project management.  He threw my 
whole scripted skit off, but I put on a live show instead.
 
Brian
-------------------->   I WAS KICKED OFF [xml-dev]     <--------------------------
 
_________________________________________________________
Note: the actions of one anonymous moderator may not reflect that of the group.
_________________________________________________________

X-TMN: [gZdIa+8JiF7i3f0xOjFLIdmgP7jSFnCk]
X-Originating-Email: [[email-masked]]
Message-ID: <[email-masked]>
Content-Type: multipart/alternative;
 boundary="_07bec19d-3456-48b3-adab-ba1ce525f2fa_"
From: Brian Aberle <[email-masked]>
To: Stephen Cameron <[email-masked]>
CC: "[email-masked]" <[email-masked]>
Subject: RE: [xml-dev] RFC for XML Object Parsing
Date: Wed, 26 Mar 2014 07:17:22 -0600
Importance: Normal
In-Reply-To:
 <CAG=ut6KUsEgQ18Ne8oBjSQ+Q7EFXMmNz3bJVeY4Bv4UKD=[email-masked]>
References: <[email-masked]>
 <113B01AA8D44482EA7AD098005ADD4CF@LenBullardPro>
 <[email-masked]>
 <[email-masked]>
 <[email-masked]>,<CAG=ut6KUsEgQ18Ne8oBjSQ+Q7EFXMmNz3bJVeY4Bv4UKD=[email-masked]>
MIME-Version: 1.0
--_07bec19d-3456-48b3-adab-ba1ce525f2fa_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
I looked at their website=2C (for 5-10 minutes) and clearly I could see tha=
t they have someone who knows whats going on with XML in a variety of appli=
cations that works there.  I came to [xml-dev] in hopes of that exact thing=
=2C so I agree - I would be interested to hear their comments.  Is there a =
politically proper way to invite them in here for a comment?  Perhaps that =
they don't hang out in [xml-dev] being busy with their own forums and do no=
t even know that we are talking about them behind their back here. =20
=20
I Believe what you are bringing up is that we need MORE AUTHORUTY INPUT.
=20
Yesterday=2C I asked folks who hang out at [apps-discuss] at IETF to please=
 take a look at the past few days at [xml-dev] for the same reason.  Can we=
 assemble the chiefs for a pow wow?
=20
Where are the chiefs?  Can we name them and call them out or is that not ko=
sher?
=20
Yesterday I saw someone question the reality of the NCIS (National Clinical=
 Information System) project.  Paul Fingerman left from NASA just to be CTO=
 of the project.  He might remember me.  I was the guy who Paul interrupted=
 while I was presenting this to the Board and all of project management.  H=
e threw my whole scripted skit off=2C but I put on a live show instead.
=20
Brian
=20
Date: Wed=2C 26 Mar 2014 16:29:09 +1100
From: [email-masked]
To: [email-masked]
CC: [email-masked]
Subject: Re: [xml-dev] RFC for XML Object Parsing
Sounds good to me=2C I wonder what the folks at DeltaXML think?
http://www.deltaxml.com/
             =
--_07bec19d-3456-48b3-adab-ba1ce525f2fa_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<html>
<head>
<style><!--
.hmmessage P
{
margin:0px=3B
padding:0px
}
body.hmmessage
{
font-size: 12pt=3B
font-family:Calibri
}
--></style></head>
<body class=3D'hmmessage'><div dir=3D'ltr'>I looked at their website=2C (fo=
r 5-10 minutes) and clearly I could see that they have someone who knows wh=
ats going on with XML in a variety of applications&nbsp=3Bthat works there.=
&nbsp=3B I came to [xml-dev] in hopes of that exact thing=2C so I agree - I=
 would be interested to hear their comments.&nbsp=3B&nbsp=3BIs there a&nbsp=
=3Bpolitically proper&nbsp=3Bway to invite them in here for a comment?&nbsp=
=3B Perhaps that they don't hang out&nbsp=3Bin [xml-dev]&nbsp=3Bbeing busy =
with their own forums and do not even know that we are talking about them b=
ehind their back here.&nbsp=3B <BR>&nbsp=3B<BR>I Believe what you are bring=
ing up is that we need MORE AUTHORUTY INPUT.<BR>&nbsp=3B<BR>Yesterday=2C I =
asked folks who hang out at [apps-discuss] at IETF to please take a look at=
 the past few days at [xml-dev] for the same reason.&nbsp=3B Can we assembl=
e the chiefs for a pow wow?<BR>&nbsp=3B<BR>Where are the chiefs?&nbsp=3B Ca=
n we name them and call them out or is that not kosher?<BR>&nbsp=3B<BR>Yest=
erday I saw someone question the reality of the NCIS (National Clinical Inf=
ormation System) project.&nbsp=3B Paul Fingerman left from NASA just to be =
CTO of the project.&nbsp=3B He might remember me.&nbsp=3B I was the guy who=
 Paul interrupted while I was presenting this to the Board and all of proje=
ct management.&nbsp=3B He threw my whole scripted skit off=2C but I put on =
a live show instead.<BR>&nbsp=3B<BR>Brian<BR>&nbsp=3B<BR><div><hr id=3D"sto=
pSpelling">Date: Wed=2C 26 Mar 2014 16:29:09 +1100<br>From: steve.cameron.6=
[email-masked]<br>To: [email-masked]<br>CC: [email-masked]<br>Su=
bject: Re: [xml-dev] RFC for XML Object Parsing<br><br><div dir=3D"ltr">Sou=
nds good to me=2C I wonder what the folks at DeltaXML think?<br><br><a href=
=3D"http://www.deltaxml.com/" target=3D"_blank">http://www.deltaxml.com/</a=
><br></div><div class=3D"ecxgmail_extra"><br>&nbsp=3B</div></div>          =
  </div></body>
</html>=
--_07bec19d-3456-48b3-adab-ba1ce525f2fa_--

 

> Date: Tue, 25 Mar 2014 08:54:25 -0400
> From: [email-masked]
> To: [email-masked]; [email-masked]
> CC: [email-masked]; [email-masked]

---

From: Brian Aberle <[email-masked]>
Date: Wed, 26 Mar 2014 10:52:15 -0600

The thread is archived here:
http://www.altova.com/list/xml-dev/201403/   see :  "RFC for XML Object Parsing"

Since I know that the OASIS server fails to deliver messages that I post, somebody else publish a summary of the "RFC for XML Object Parsing" thread from the above archive which should be mirrored at http://lists.xml.org/archives/xml-dev/ but who knows since SMTP stopped working, mirroring may have failed too.  Thank God there is more than 1 mirror.
 
Is it a felony or a misdemeanor net etiquette violation to censor via the SMTP gateway? 
 
Brian
 
From: [email-masked]
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [apps-discuss] Help!
Date: Wed, 26 Mar 2014 08:25:57 -0600

 

 

Brian

  </div></body>
</html>=

---

From: Julian Reschke <[email-masked]>
Date: Wed, 26 Mar 2014 21:56:26 +0100

On 2014-03-26 17:52, Brian Aberle wrote:
> Since I know that the OASIS server fails to deliver messages that I
> post, somebody else publish a summary of the "RFC for XML Object
> Parsing" thread from the above archive which should be mirrored at
> http://lists.xml.org/archives/xml-dev/ but who knows since SMTP stopped
> working, mirroring may have failed too.  Thank God there is more than 1
> mirror.
>
> ...

Or  maybe just a bug?

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 27 Mar 2014 07:07:39 -0700

On Wed, Mar 26, 2014 at 7:25 AM, Brian Aberle <[email-masked]> wrote:

> HELP!  STMP is failing.  Yesterday I put out in invitation for ya'll to
> jump on the thread at [xml-dev] but today I guess I got kicked off the
> forum because when I email the group it does not get delivered.  Today the
> servers at OASIS that host the open and unmoderated [xml-dev] mailing list
> failed to work.  The message in its entirety, complete with the SMTP
> headers is provided here so that honest internet admins can debug this
> failure.  It was just one message in a thread that was getting noisy.
> [...]
>

Brian,

It's been a month since you brought this topic to apps-discuss for its
consideration, a topic about which you are clearly passionate.  I have seen
feedback suggesting that this is really the purview of the W3C which has
domain over XML, and not the IETF; I have seen none that suggests there's
interest in taking up this work on our side of the fence, or that it would
be appropriate for us to do so.

It may be the case that you should take the time to write and submit an
Internet Draft with your proposal in it, which might demonstrate to people
here what you have in mind.  That might make it more clear that this is
work for the IETF.

Until that happens, I believe any interested parties should join the
relevant W3C lists and take up the discussion over there.

Browsing the relevant threads on the xml-dev archive, I don't see any
indication consistent with you being kicked off the list.  I think you may
have run into a glitch rather than censorship.

-MSK

---

From: Brian Aberle <[email-masked]>
Date: Thu, 27 Mar 2014 08:36:33 -0600

There was some interest here at IETF.  I had consulted the moderators here who suggested that a discussion could be equally as beneficial as formally preparing an Internet Draft.  However I agree with you that this concept should be summarized in a document.  Currently the summary exists in code and comments making it too inconvenient for many people to get the gist of the idea.  One person at [xml-dev] concluded this: 
 
"I now understand that you are attempting to optimize the management of individual instance data, across the web."
 
The OASIS list servers are still not functioning.  The thread at [xml-dev] is archived here:
http://www.altova.com/list/xml-dev/201403/   see :  "RFC for XML Object Parsing"
 
The timing of the malfunction at OASIS is critical in this discussion that you can see took over [xml-dev], ironically a warrant was issued for my arrest yesterday - about some lost court case numbers that suddenly were found.  I get suddenly and unexpectedly arrested far more than the average programmer - so I need to get this documented as much as possible before the bad guys come.
 
Censorship or Technical difficulties - we will never know.  It's not been resolved yet.  In my offline discussions someone relates it to how the government shuts down the stock market when its in an out of control state.  Regardless - the mirror contains enough of the discussion that was interrupted by this bug at OASIS that we are closer to an "Internet Draft" that can be written from a summary of that conversation rather than being forced to see code and examples here: http://1drv.ms/1jjcJub
 
Brian
 
Date: Thu, 27 Mar 2014 07:07:39 -0700
Subject: Re: [apps-discuss] Help!
From: [email-masked]
To: [email-masked]
CC: [email-masked]; [email-masked]; [email-masked]

[...]

Brian,

It's been a month since you brought this topic to apps-discuss for its consideration, a topic about which you are clearly passionate.  I have seen feedback suggesting that this is really the purview of the W3C which has domain over XML, and not the IETF; I have seen none that suggests there's interest in taking up this work on our side of the fence, or that it would be appropriate for us to do so.

It may be the case that you should take the time to write and submit an Internet Draft with your proposal in it, which might demonstrate to people here what you have in mind.  That might make it more clear that this is work for the IETF.

Until that happens, I believe any interested parties should join the relevant W3C lists and take up the discussion over there.

Browsing the relevant threads on the xml-dev archive, I don't see any indication consistent with you being kicked off the list.  I think you may have run into a glitch rather than censorship.

-MSK