Subject: Re: [apps-discuss] [Uri-review] Registration request for smtp:// and submit:// URI schemes (draft-melnikov-smime-msa-to-mda-04)

From: Dave Thaler <[email-masked]>
Date: Tue, 1 Apr 2014 17:33:11 +0000

Alexey Melnikov wrote:
> > My feedback is that the name "submit" is not a good name for the proposed
> use.
> > Specifically, RFC 4395 states:
> >> Avoid using names that are either very general purpose or associated
> >> in the community with some other application or protocol.
> >
> > There are many types of things you can "submit" (HTTP forms, etc.) and
> > since the proposed use here is specific to specific to SMTP, it should
> > not use a general purpose word like "submit" along.
> >
> > "smtpsubmit" or similar would be much more appropriate.
> 
> I would rather use the same label as used by DNS SRV for the same service:
> "submission". (I think keeping them different would be a bad thing.). Thoughts?

I didn't know about the SRV service type before this, but yes that sounds like a
reasonable goal.  

I'm thinking it would be good to add a sentence about this case
(service names and URI scheme names SHOULD be the same, when there exists
a 1:1 correspondence) to draft-ietf-appsawg-uri-scheme-reg.  Does that
sound reasonable?

-Dave

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Apr 2014 19:57:37 +0100

> On 1 Apr 2014, at 18:33, Dave Thaler <[email-masked]> wrote:
> 

It sounds reasonable to me.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 02 Apr 2014 10:14:47 +0900

>> "submission". (I think keeping them different would be a bad thing.). Thoughts?

If the SRV service name is "submission", and the proposed scheme name is 
"submit", aren't these two *different* labels?

> a 1:1 correspondence) to draft-ietf-appsawg-uri-scheme-reg.  Does that

Yes. I'm not sure it needs to be a SHOULD, something like "consider to 
make this the same as...".

Regards,   Martin.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 2 Apr 2014 07:10:10 +0100

Hi Martin,

> On 2 Apr 2014, at 02:14, "Martin J. Dürst" <[email-masked]> wrote:
> 
> If the SRV service name is "submission", and the proposed scheme name is "submit", aren't these two *different* labels?

I am suggesting of making them the same. I thought they were...
> Yes. I'm not sure it needs to be a SHOULD, something like "consider to make this the same as...".