Subject: [apps-discuss] Question on json-home status and future of Resource Hints

From: "Mark W. Foster" <[email-masked]>
Date: Thu, 10 Apr 2014 08:51:13 -0700

I notice there are a number of TBDs in the draft and it has been a while since there has been an update. Any information on a forthcoming revision?

Also, it would be useful for there to be a ‘name’ property on Resource Objects that would allow clients to select a Resource by name vs. using the (resolvable) link relation. Has this been discussed? Further, would that be considered a “Resource Hint” per TBD section 5 or just an attribute of a Resource Object.

Thanks,

Mark

---

From: Erik Wilde <[email-masked]>
Date: Thu, 10 Apr 2014 09:41:10 -0700

hello mark.

> I notice there are a number of TBDs in the draft and it has been a while since there has been an update. Any information on a forthcoming revision?

very true. please notice that the draft is expired, and that mark has 
published

http://tools.ietf.org/html/draft-nottingham-link-hint

in the meantime, which eventually should be synced with the home 
document draft. adding support for URI templates, there's something 
similar and a bit more ambitious at

http://tools.ietf.org/html/draft-wilde-link-desc

and i also wrote a brief blog post to put all these things in 
perspective (from my point of view, of course):

http://dret.typepad.com/dretblog/2013/10/link-information-design-time-runtime-and-on-demand.html

> Also, it would be useful for there to be a ‘name’ property on Resource Objects that would allow clients to select a Resource by name vs. using the (resolvable) link relation. Has this been discusse…

what would you consider such a name to be? ideally, everything should 
resolve around URI-based identifiers, right? as i understand the model, 
resource hints are intended to be something that helps to drive 
interactions with a resource, not a general model of all kinds of 
metadata about a resource. but maybe i am misunderstanding what you are 
proposing here. what's an example for how this 'name' would be used?

thanks and cheers,

dret.

-- 
erik wilde | mailto:[email-masked]  -  tel:+1-510-2061079 |
            | UC Berkeley  -  School of Information (ISchool) |
            | http://dret.net/netdret http://twitter.com/dret |