Subject: [apps-discuss] RelaxNG for JSON?

From: Jan Algermissen <[email-masked]>
Date: Sat, 3 May 2014 18:52:03 +0200

Hi,

is there an adaption of RelaxNG for JSON?

This seems such an obvious thing to do, I was shocked that searches yield no really good answers.

All I found so far:

https://www.ibm.com/developerworks/community/blogs/jasnell/entry/relax_ng_compact_for_json29?lang=en
https://github.com/eteeselink/relax-json

Jan

---

From: James M Snell <[email-masked]>
Date: Sat, 3 May 2014 11:40:25 -0700

Would love to get something going on this but never saw any interest.
On May 3, 2014 9:52 AM, "Jan Algermissen" <[email-masked]>
wrote:

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Sat, 3 May 2014 21:00:20 +0200

> This seems such an obvious thing to do, I was shocked that searches yield no really good answers.

FWIW, NETMOD WG is working towards using YANG for modelling configurations and state data expressed in JSON - see draft-ietf-netmod-yang-json-00.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Jan Algermissen <[email-masked]>
Date: Sun, 4 May 2014 11:43:26 +0200

> Would love to get something going on this but never saw any interest.
I used to just describe the JSON in my media types, but now I am facing a larger one and hence feel the need.

I am mostly interested in a stable model/syntax for documentation purposes, validation tools would be second on my list.

I’ll dig through your posting and come back with ideas/comments and hopefully it won’t be long to throw together an initial version.

Have you seen: https://github.com/eteeselink/relax-json

I found that pretty slick on first glance.

Thanks,

Jan

> On May 3, 2014 9:52 AM, "Jan Algermissen" <[email-masked]> wrote:
> Hi,
>

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 4 May 2014 08:37:05 -0700

This has been discussed off and on in the JSON WG. There was general agreement that it might be somewhat useful to have one or more schema languages for describing JSON in protocols, particularly if the schema language doesn't try to be complete but instead relies on prose for edge cases.

If you have a draft of a schema language for JSON, feel free to discuss it in the JSON WG. Such things can be published as Informational RFCs and used for describing future protocols.

--Paul Hoffman