Subject: Re: [apps-discuss] [Technical Errata Reported] RFC6901 (3981)

From: Mark Nottingham <[email-masked]>
Date: Wed, 7 May 2014 11:55:51 +1000

Hi David,

This seems like a request for a change to the RFC, not an errata.

Therefore, I think it should be rejected.

That said, I’ve been talking with a few people in the background about a possible revision to the spec (or a new format based upon it), and would love to have your input for that.

Cheers,

On 7 May 2014, at 4:00 am, RFC Errata System <[email-masked]> wrote:

> The following errata report has been submitted for RFC6901,
> "JavaScript Object Notation (JSON) Pointer".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6901&eid=3981
> 
> --------------------------------------
> Type: Technical
> Reported by: David Phillips <[email-masked]>
> 
> Section: 3
> 
> Original Text
> -------------
> See Notes
> 
> Corrected Text
> --------------
> The following two examples from section 5 are different:
> 
> Original: "/a~1b"
> Proposed: "/a//b"
> 
> Original: "/m~0n"
> Proposed: "/m~n"
> 
> The other examples are the same.
> 
> Notes
> -----
> The escape syntax seems weird and confusing. Rather than ~0 and ~1, why not use a repeated (double) slash to escape a slash? This is similar to how SQL escapes single quotes in string literals by using the single quote twice.
> 
> We have JSON functions in Presto (prestodb.io) that could benefit from an improved syntax (they currently use JSONPath), but I can't see understanding ~0 and ~1.
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC6901 (draft-ietf-appsawg-json-pointer-09)
> --------------------------------------
> Title               : JavaScript Object Notation (JSON) Pointer
> Publication Date    : April 2013
> Author(s)           : P. Bryan, Ed., K. Zyp, M. Nottingham, Ed.
> Category            : PROPOSED STANDARD
> Source              : Applications Area Working Group
> Area                : Applications
> Stream              : IETF
> Verifying Party     : IESG

--
Mark Nottingham   http://www.mnot.net/

---

From: "Paul C. Bryan" <[email-masked]>
Date: Tue, 06 May 2014 19:11:21 -0700

I concur with Mark. This is a substantive, breaking change. Therefore, I
also think it should be rejected. It should be considered in any future
revisions.

Paul

---

From: "Manger, James" <[email-masked]>
Date: Wed, 7 May 2014 16:03:23 +1000

Not only is the suggestion a change, not an errata, but it wouldn’t even work.

Consider the following valid JSON value:
  { "a":{"":{"b":1}},  "a/b":2 }
With the suggestion, "/a//b" would be a JSON pointer for the values 1 and 2!

--
James Manger

-----Original Message-----
From: apps-discuss [mailto:[email-masked]] On Behalf Of Mark Nottingham
Sent: Wednesday, 7 May 2014 11:56 AM
To: RFC Errata System
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [apps-discuss] [Technical Errata Reported] RFC6901 (3981)

Hi David,

Cheers,

_______________________________________________
apps-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: RFC Errata System <[email-masked]>
Date: Tue, 6 May 2014 11:00:37 -0700 (PDT)

Section: 3

Original Text
-------------
See Notes

Corrected Text
--------------

Original: "/a~1b"
Proposed: "/a//b"

Original: "/m~0n"
Proposed: "/m~n"

Notes
-----

Instructions:
-------------