Subject: [apps-discuss] Call for Adoption: draft-kucherawy-email-auth-codes

From: Salvatore Loreto <[email-masked]>
Date: Fri, 9 May 2014 06:09:09 +0000

This is a formal call for adoption of draft-kucherawy-email-auth-codes into APPSAWG.
The call will close on May 23, 2014.

The chairs note that there has already been some _expression_ of interest for adoption in a recent thread;
however more feedback is requested to make sure appsawg is the right venue for this draft

Please submit comments, concerns, support, etc. for this document's handling by APPSAWG in reply to this thread by May 23, 2014.
Note that this is not an indication of support for the document as-is, only for APPSAWG adopting it for further development.

As for the APPSAWG process you will find the mini-charter for the draft at the end of this message.
in order to adopt the draft we also need to secure a minimal set of reviewers and supporters for the document.
If you'd like to be added to that list, please say so in your reply.

cheers
/Salvatore

The "email-auth-codes" Mini-Charter
----------------------------------------------

The adoption of SPF and DKIM as emerging email authentication technologies has been significant.
Absent from these, an oversight at the time, is a way to indicate to an SMTP client the fact that a message is being rejected specifically because one of these mechanisms failed to authenticate the message.  Without these, only generic authentication error codes can be returned.

This short document registers new Email Enhanced Status Codes (see RFC 3643 and RFC 5248) so that this can be clearly indicated by SMTP servers.
No other work is proposed for this document

The following have committed to work on the document through to publication:

Reviewers: (please volunteer!)

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 13 May 2014 23:51:15 -0400

On Friday, May 09, 2014 06:09:09 Salvatore Loreto wrote:
> This is a formal call for adoption of draft-kucherawy-email-auth-codes into
> APPSAWG. The call will close on May 23, 2014.
> 
> The chairs note that there has already been some _expression_ of interest
> for adoption in a recent thread; however more feedback is requested to make
> sure appsawg is the right venue for this draft
> 
> Please submit comments, concerns, support, etc. for this document's handling
> by APPSAWG in reply to this thread by May 23, 2014. Note that this is not
> an indication of support for the document as-is, only for APPSAWG adopting
> it for further development.
> 
> As for the APPSAWG process you will find the mini-charter for the draft at
> the end of this message. in order to adopt the draft we also need to secure
> a minimal set of reviewers and supporters for the document. If you'd like
> to be added to that list, please say so in your reply.
> 
> cheers
> /Salvatore
> 
> 
> 
> The adoption of SPF and DKIM as emerging email authentication technologies
> has been significant. Absent from these, an oversight at the time, is a way
> to indicate to an SMTP client the fact that a message is being rejected
> specifically because one of these mechanisms failed to authenticate the
> message.  Without these, only generic authentication error codes can be
> returned.
> 
> This short document registers new Email Enhanced Status Codes (see RFC 3643
> and RFC 5248) so that this can be clearly indicated by SMTP servers. No
> other work is proposed for this document
> 

I volunteer.  I'm not 100% sure we need this, but I'm definitely willing to 
work on figuring out if we do and working on the document assuming we do.

Scott K