Subject: Re: [apps-discuss] New Version Notification for draft-ietf-appsawg-uri-scheme-reg-01.txt

From: Larry Masinter <[email-masked]>
Date: Fri, 4 Jul 2014 03:26:55 +0000

I don't think we're going far enough to simplify the process, to have any hope IANA will be more useful than Wikipedia or search for the scheme, for anything other than pedantic or legal purposes.

The 'guidelines' are ok, but the process is way too complicated, rate limited, doesn't help wanna-be's implement things compatibly,  and doesn't provide enough incentive to register for registration to be near-universally timely. Timely completeness is the requirement to be able to answer questions like "are there any schemes that do X" and the like, and also to know when the 'authoritative' information in the registry has been supplanted surreptitiously. 

I'm leaning toward recommended crowd-source technology-- get permission to give each scheme a page which people can 'Like' or 'Comment'. 

I understand there's a monarchy perspective which would prefer a single "Living Standard" list of platform scheme names rather than a registry. This would have the advantage for content creators of turning a combinatorial testing job into a linear one, which may be why it's popular. Are the two models reconcilable? 

Larry (Duke of Url)
--
http://larry.masinter.net

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 07 Jul 2014 15:29:37 +0900

> I don't think we're going far enough to simplify the process, to have any hope IANA will be more useful than Wikipedia or search for the scheme, for anything other than pedantic or legal purposes.

How successful is Wikipedia or search currently for some of the 
"long-tail" (i.e. not widely deployed) schemes?

> I'm leaning toward recommended crowd-source technology-- get permission to give each scheme a page which people can 'Like' or 'Comment'.

Crowd-sourcing technology has a lot of advantages. But it also comes 
with some burdens. What do we do if two people (or more) disagree about 
the information on a scheme and swap out each other's edits? What do we 
do against spambots? Please remember that every successful crow-sourcing 
technology comes with carefully designed management functions that often 
involve some heavy human work. Wikipedia would be the prime example.

> I understand there's a monarchy perspective which would prefer a single "Living Standard" list of platform scheme names rather than a registry. This would have the advantage for content creators of…

If all scheme pages are on the same site, or otherwise within "reach", I 
don't see any fundamental difficulty in updating an overall list in 
(linear or sublinear) real time. So I think there are no essential 
differences in terms of computability.

> Larry (Duke of Url)

Why not "Url of Masinter" (aka Earl of Masinter)?

Regards,   Martin.