Subject: [apps-discuss] I-D Action: draft-ietf-appsawg-uri-scheme-reg-01.txt

From: [email-masked]
Date: Thu, 03 Jul 2014 15:59:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Applications Area Working Group Working Group of the IETF.

        Title           : Guidelines and Registration Procedures for New URI Schemes
        Authors         : Dave Thaler
                          Tony Hansen
                          Ted Hardie
                          Larry Masinter
	Filename        : draft-ietf-appsawg-uri-scheme-reg-01.txt
	Pages           : 19
	Date            : 2014-07-03

Abstract:
   This document updates the guidelines and recommendations, as well as
   the IANA registration processes, for the definition of Uniform
   Resource Identifier (URI) schemes.  It obsoletes RFC 4395.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-appsawg-uri-scheme-reg/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-appsawg-uri-scheme-reg-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-appsawg-uri-scheme-reg-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 21 Jul 2014 22:00:49 +0200

On Thu, Jul 03, 2014 at 03:59:39PM -0700,
 [email-masked] <[email-masked]> wrote 

> 	Filename        : draft-ietf-appsawg-uri-scheme-reg-01.txt

During this discussion this morning on Toronto, about the lack of
stability of domain names and the risk that a domain name changes
hands, did anyone already suggest to use a solution similar to RFC
4151 (i.e. postfix the domain name with a date)?

---

From: Dave Thaler <[email-masked]>
Date: Mon, 21 Jul 2014 21:19:38 +0000

> -----Original Message-----
> From: apps-discuss [mailto:[email-masked]] On Behalf Of
> Stephane Bortzmeyer
> Sent: Monday, July 21, 2014 4:01 PM
> To: [email-masked]
> Subject: [apps-discuss] (Lack of) permanence of domain names (Was: I-D
> Action: draft-ietf-appsawg-uri-scheme-reg-01.txt
> 
> On Thu, Jul 03, 2014 at 03:59:39PM -0700,  [email-masked] <internet-
> [email-masked]> wrote  a message of 41 lines which said:
> 
> During this discussion this morning on Toronto, about the lack of stability of
> domain names and the risk that a domain name changes hands, did anyone
> already suggest to use a solution similar to RFC

No one suggested that during the discussion. 

I do know that people like shorter scheme names rather than longer ones 
(so Microsoft uses ms-... rather than com.microsoft... for example), and so
in my opinion it would be difficult to get people to do that just in case they
might lose the domain name in the future.  Remember the context of this 
question is about private use names for which they don't necessarily tell 
anyone else to begin with.

-Dave