Subject: [apps-discuss] Review of draft-ietf-appsawg-authres-ptypes-registry

From: Franck Martin <[email-masked]>
Date: Sun, 24 Aug 2014 19:19:30 -0500 (CDT)

I reviewed in full the document draft-ietf-appsawg-authres-ptypes-registry and I have the following comments: 

While the document indicates the limitation of the ptype, it does not explain why it needs to be extended. 

I propose the following text to be used in the introduction, to replace the last paragraph (but I can live without this change): 
-- 
[RFC7001] ptypes were defined based on the current authentication methods that are in use at the time of the creation of this specification. Since then, some new authentication methods have emerged or are becoming in use. For instance more emails are encrypted or sent over encrypted sessions. While encryption provides authorization, it also provides some forms of authentication. The properties of such authentication methods are sometimes outside current electronic mail message properties. 

This document updates the specification to allow for additional property types ("ptypes") beyond the original set, and creates a registry where new ones can be listed and their defining documents referenced. 
-- 

I also checked that this specification would allow draft-martin-authentication-results-tls if adopted. 

This document provides a minimal change to RFC7001, therefore my limited comments/review.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 24 Aug 2014 23:26:52 -0700

Hi Franck, thanks for your review.

On Sun, Aug 24, 2014 at 5:19 PM, Franck Martin <[email-masked]>
wrote:

> I propose the following text to be used in the introduction, to replace
> the last paragraph (but I can live without this change):
> [...]
>

Since you said you're okay with not making this change, I think I'm going
to leave it out.  While your proposed text is accurate, I don't think it's
necessary to include.  For one thing, if one looks at the contents of the
registry (shortly after it's created), it'll be obvious why the extension
was needed.

The rest of your proposal talks about the registry creation and what will
be in it, but that's already clear from IANA Considerations, and is
generally why we create keyword registries anyway.

-MSK