Subject: [apps-discuss] New Version Notification for draft-seantek-image-bmp-01.txt

From: Sean Leonard <[email-masked]>
Date: Thu, 23 Oct 2014 03:15:18 -0700

Colleagues:

draft-seantek-image-bmp-01 has been posted. It removes the problematic sentence about not containing text.

Note that there are embedded questions in the introduction: shall the .cur and .ani formats also be registered? And shall the .ico format be re-registered? (.cur is almost identical to .ico; .ani, not so much.)

Here is the registration template:
*******
Windows Bitmap Media Type Registration Application

   Type name: image

   Subtype name: bmp

   Required parameters: None.

   Optional parameters: None.

   Encoding considerations: Binary.

   Security considerations:

     Bitmaps have a mostly unremarkable security history.

     Because BMP data can encapsulate JPEG or PNG data (BI_JPEG, BI_PNG
     values of the Compression enumeration in Section 2.1.1.7 of [MS-
     WMF]), the security considerations of JPEG and PNG processing may
     also apply to BMP.

   Interoperability considerations:

     Uncompressed Windows Bitmaps can be rather large. If there is a
     need to compress an image, modern applications SHOULD consider
     emitting JPEG or PNG data instead of embedding them in BMP
     payloads.

   Published specification: [MS-WMF] and [BMPSTOR].

   Applications that use this media type:

     Office productivity applications; clip art applications; desktop
     publishing applications; Web browsers; graphics processing
     applications.

   Fragment identifier considerations: None.

   Additional information:

     Magic number(s): 42 4D ("BM"), meaning "bitmap". The next
                      field (BITMAPFILEHEADER bfSize) is a
                      little-endian DWORD indicating the size
                      of the bitmap content in bytes.
     File extension(s): .bmp, .dib
     Macintosh file type code(s):
       "BMP ", "BMPf", or "BMPp". Apple has promulgated a
       uniform type identifier (UTI) of "com.microsoft.bmp".

   Person & email address to contact for further information:

     Sean Leonard <[email-masked]>

   Restrictions on usage: None.

   Author/Change controller: Sean Leonard <[email-masked]>

   Intended usage: COMMON

   Provisional registration? No

*******

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-seantek-image-bmp-01.txt
> Date: October 23, 2014 at 3:06:50 AM PDT
> To: Sean Leonard <[email-masked]>, "Sean Leonard" <[email-masked]>
> 
> 
> A new version of I-D, draft-seantek-image-bmp-01.txt
> has been successfully submitted by Sean Leonard and posted to the
> IETF repository.
> 
> Name:		draft-seantek-image-bmp
> Revision:	01
> Title:		The Windows Bitmap Media Type
> Document date:	2014-10-23
> Group:		Individual Submission
> Pages:		5
> URL:            http://www.ietf.org/internet-drafts/draft-seantek-image-bmp-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-seantek-image-bmp/
> Htmlized:       http://tools.ietf.org/html/draft-seantek-image-bmp-01
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-seantek-image-bmp-01
> 
> Abstract:
>   This document registers the image/bmp media type for use with the
>   Windows Bitmap format (BMP), also known as Device-Independent Bitmap
>   (DIB). Originally designed for Microsoft Windows 2.0 and OS/2, these
>   bitmaps contain a single raster graphic in a variety of compressed or
>   uncompressed formats.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Henrik Andersson <[email-masked]>
Date: Thu, 23 Oct 2014 12:23:43 +0200

>    Provisional registration? No

Perhaps you want to note the problem of upside down images? Bitmaps and
icons have the pesky habit of commonly, but not always, being stored
bottom up.