Subject: [apps-discuss] text/markdown progress: recommended split

From: Sean Leonard <[email-masked]>
Date: Wed, 15 Oct 2014 16:00:21 -0700

Hi apps-discuss:

I finished the content of draft-03 of the text-markdown spec (draft-ietf-appsawg-text-markdown-03).

However, before posting, I would like to see how people feel about a proposed split in the document. Murray requested WG discussion and consensus on this before actually doing it.

I seriously tried to shorten the document, which has been shrunk about 25% (~18 pages instead of ~25 pages). However, adding additional registrations and Markdown-handling strategies would be beneficial. These additional registrations and strategies are NOT normative, but they help illustrate the diversity of use cases that we are *trying* to unify under the common text/markdown media type.

The additional registrations (7) and discussion are an additional 18 pages or so, including boilerplate. Thus I propose that the subsidiary content be split into draft-ietf-appsawg-text-markdown-use-cases-00 (for “use cases”). RFC 2119 key words will not be used in that document.

Thoughts folks?

Sean

---

From: Ira McDonald <[email-masked]>
Date: Wed, 15 Oct 2014 19:56:50 -0400

Hi Sean,

+1 to the split.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Oct 15, 2014 at 7:00 PM, Sean Leonard <[email-masked]> wrote:

> However, before posting, I would like to see how people feel about a
> proposed split in the document. Murray requested WG discussion and
> consensus on this before actually doing it.
>
> I seriously tried to shorten the document, which has been shrunk about 25%
> (~18 pages instead of ~25 pages). However, adding additional registrations
> and Markdown-handling strategies would be beneficial. These additional
> registrations and strategies are NOT normative, but they help illustrate
> the diversity of use cases that we are *trying* to unify under the common
> text/markdown media type.
>
> The additional registrations (7) and discussion are an additional 18 pages
> or so, including boilerplate. Thus I propose that the subsidiary content be
> split into draft-ietf-appsawg-text-markdown-use-cases-00 (for “use cases”).
> RFC 2119 key words will not be used in that document.
>
> Thoughts folks?
>
> Sean
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 15 Oct 2014 22:06:11 -0700

> RFC 2119 key words will not be used in that document.

My preference would be to focus on the reduced document first and make sure
it's self-sufficient.  I'm unclear just from your description here what
would go into a second document.  If it's ready, please post it as
draft-leonard-text-markdown-use-cases-00 so the WG can see what you have in
mind and then decide if we want to do both of them.  (The datatracker won't
let you post something as draft-ietf-appsawg-*.)

-MSK

---

From: Sean Leonard <[email-masked]>
Date: Thu, 16 Oct 2014 21:34:25 -0700

> - Ira

Ok.

To elaborate, the subsidiary document has (will have) the following 
sections:

1.  Dive Into Markdown
1.1. On Formats
1.2. Markdown Design Philosophy
1.3. Uses of Markdown
1.4. Uses of Labeling Markdown Content as text/markdown

2.  Strategies for Preserving Media Type and Parameters
…
    This section
    covers strategies for how an application might preserve this metadata
    information when it leaves the domain of IETF protocols.

3.  Registration Templates for Common Markdown Syntaxes

    The purpose of this section is to register certain syntaxes because
    they illustrate particularly interesting use cases or are broadly
    applicable to the Internet community; thus, these syntaxes would
    benefit from the level of review associated with publication as IETF
    documents.

3.1. MultiMarkdown
3.2. GitHub Flavored Markdown
3.3. Pandoc
3.4. Fountain (Fountain.io)
3.5. CommonMark
3.6. kramdown-rfc2629 (Markdown for RFCs)
3.7. rfc7328 (Pandoc2rfc)

4.  Examples for Common Markdown Syntaxes

    This section provides examples of the syntaxes registered in Section 3.

-Sean