Subject: [apps-discuss] uri-scheme-reg rules for updating a permanent scheme

From: Larry Masinter <[email-masked]>
Date: Fri, 2 Jan 2015 02:46:08 +0000

In talking about kerwin-file-scheme, it was claimed:
> The BCP for registering schemes appears not to require an RFC, only Expert Review.

but
http://tools.ietf.org/html/draft-ietf-appsawg-uri-scheme-reg-03#section-7.3

   Registrations can be updated in the registry by the same mechanism as
   required for an initial registration.  In cases where the original
   definition of the scheme is contained in an IESG-approved document,
   update of the specification also requires IESG approval.

IESG approval (usually) happens by approval of something for publication as an RFC.
Should this be more explicit? How else could someone ask for IESG approval?

Shouldn't there be guidelines for updates to a registration that
talks about review against widely deployed implementations?

For example, requirements that updates SHOULD
*  significantly improve the match with deployed implementations, and/or
*  note, as an interoperability consideration, wide deployments
    that don't match, and
* have evidence of review by those responsible for  with
   updates to current implementations, with confidence that
   they will conform to the new spec.

Larry
--
http://larry.masinter.net

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 04 Jan 2015 18:22:22 +0000

> Should this be more explicit? How else could someone ask for IESG approval?
IESG can issue Last Call and approve a URI update as a management item. 
For example if the updated document becomes a W3C document.
>     they will conform to the new spec.
I am not against that, but this sounds a bit of a rathole.