Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-text-markdown-05.txt

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 8 Jan 2015 16:37:58 -0800

Colleagues,

On Mon, Dec 22, 2014 at 3:21 PM, Sean Leonard <[email-masked]> wrote:

> Hello apps-discuss:
>
> Here is draft-05. Have at it.
>
> Cheers,
>
> Sean
>
> On Dec 22, 2014, at 3:01 PM, [email-masked] wrote:
>
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Applications Area Working Group Working
> Group of the IETF.
> >
> >       Title           : The text/markdown Media Type
> >       Author          : Sean Leonard
> >       Filename        : draft-ietf-appsawg-text-markdown-05.txt
> >       Pages           : 14
> >       Date            : 2014-12-22
> >
> > Abstract:
> >  This document registers the text/markdown media type for use with
> >  Markdown, a family of plain text formatting syntaxes that optionally
> >  can be converted to formal markup languages such as HTML.
> > [...]
>

There's been no feedback since this was posted.  Is that because of the
holidays, or because we think it's ready for a WGLC?

-MSK

---

From: Michel Fortin <[email-masked]>
Date: Fri, 9 Jan 2015 10:02:04 -0500

Le 8-janv.-2015 à 19:37, Murray S. Kucherawy <[email-masked]> a écrit :

> There's been no feedback since this was posted.  Is that because of the holidays, or because we think it's ready for a WGLC?

For my part, it's mostly because I still don't really know what to think of the whole thing.

The complexity has been scaled down from the earlier drafts, that's good.

Having a registry for variants remains unnecessary in my view, and, while I understand Sean personally has a use case for it, what remains unclear to me is how the registry is going to be populated. It seems to me that the only person that needs it is Sean and thus he'll either be the one populating it or it'll be left mostly empty. Perhaps I'm wrong, but who else has shown interest in the thing?

I don't feel like I'm in a good position to evaluate most of this spec. I have never been confronted with a problem where it'd have been useful to programatically detect which variant to use for a given Markdown document. Perhaps this makes me biased against any added layer trying to solve that problem. But it makes me feel like I've put a lot of energy trying to simplify a spec addressing a problem I have little experience with and that in the end doesn't appeal to me much.

It seems I don't have enough interest to spend the time necessary to further review this document. If this was a two-page spec simply adding a plain "text/markdown" media type registration then I could probably spare the time to look at it in details, but that's quite far from the current document.

-- 
Michel Fortin
[email-masked]
https://michelf.ca