Subject: Re: [apps-discuss] apps-discuss Digest, Vol 87, Issue 51

From: Nick Matavka <[email-masked]>
Date: Sat, 25 Apr 2015 18:15:42 -0400

> On Apr 25, 2015, at 3:00 PM, [email-masked] wrote:
> 
> Send apps-discuss mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.ietf.org/mailman/listinfo/apps-discuss
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of apps-discuss digest..."
> 
> 
> Today's Topics:
> 
>   1.  independent submission process for	draft-matavka-gopher-ii
>      (Nick Matavka)
>   2. Re:  List-ID vs. [list-id] (was Re: meta - removing list
>      banner?) (Dave Crocker)
>   3. Re:  independent submission process for
>      draft-matavka-gopher-ii (John C Klensin)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sat, 25 Apr 2015 03:21:22 -0400
> From: Nick Matavka <[email-masked]>
> To: [email-masked]
> Subject: [apps-discuss] independent submission process for
> 	draft-matavka-gopher-ii
> Message-ID:
> 	<CANroBD3jaeVVi_LiRivOW4Km2n=Sb9Px5y2u=[email-masked]>
> Content-Type: text/plain; charset="utf-8"
> 
> Hello, world!
> 
> I sent off an independent submission as a proposed standard, in regards to
> extensions to the Gopher WWIS.  Although the current iteration of the
> Gopher protocol is half-Informational and half-unofficial memo (by which I
> mean the optional Gopher+ extensions), it was recommended to me that I put
> my draft on the Standards Track.  I'm not opposed to this idea, which is
> why draft-matavka-gopher-ii is currently sitting on IETF servers on said
> Standards Track.
> 
> My concerns are mostly related to IETF process.  How are independent
> submissions handled?  Am I supposed to receive an eMail from one of the
> review people stating the nits that need to be corrected?  The structure is
> fine, I'm now curious as to how an Internet-Draft becomes a Standard.  I'm
> also curious as to how ongoing fixes are incorporated.  For instance, the
> informal workgroup that discusses Gopher is now floating the idea of Gopher
> over TLS, and they have reached the consensus that GopherS (as they have
> called it) would be a beneficial, but optional, part of the Gopher system.
> Perhaps a footnote to that effect would fit in the Internet-Draft, but I'm
> not sure how 00 becomes 01 and 02 and 03.
> 
> Anyway, any help you could give me is appreciated.
> 
> Edward Matavka
> 
> 
> 
> -- 
>       /^\/^\
>       \----|
>   _---'---~~~~-_
>    ~~~|~~L~|~~~~
>       (/_  /~~--
>     \~ \  /  /~
>   __~\  ~ /   ~~----,
>   \    | |       /  \
>   /|   |/       |    |
>   | | | o  o     /~   |
> _-~_  |        ||  \  /
> (// )) | o  o    \\---'
> //_- |  |          \
> //   |____|\______\__\
> ~      |   / |    |
>       |_ /   \ _|
>     /~___|  /____\
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://www.ietf.org/mail-archive/web/apps-discuss/attachments/20150425/d7934470/attachment.html>
> 
> ------------------------------
> 
> Message: 2
> Date: Sat, 25 Apr 2015 05:32:39 -0700
> From: Dave Crocker <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: Re: [apps-discuss] List-ID vs. [list-id] (was Re: meta -
> 	removing list banner?)
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=utf-8
> 
> 
>>> Do you mean search?  I don't think Gmail sorts on anything except
>>> received
>>> date.  We do have the list: and listid: operators, however.
>> 
>> I was using sort in the usual (among people who use procmail and similar
>> tools) sense of putting it into folders or the like, what Dave calls
>> filtering.
> 
>     The essential semantic point, for this thread, is that email
> software often has a convenient column-based mechanism for arranging the
> order of messages seen in the summary message list.  Clicking on a
> column makes it the primary key for organizing messages.  This is
> extremely convenient and useful.
> 
>     Having the [list-id] convention at the beginning of the Subject
> line permits easy organizing of messages in a folder, according to
> mailing list.  Losing that capability would be a significant downgrade
> in utility.
> 
>     For clarity, I suggest distinguishing this 'within folder' sorting
> from any mechanism that puts messages into folders, tabs, or the like.
> 
> 
> As for terminology...
> 
> Gmail uses the 'sort' term the way John is, but note it also uses
> 'filtering' (see below):
> 
>     "sorts messages into categories, or ?tabs.?
> 
> 
> Yahoo, Earthlink, Thunderbird, Outlook use the term the way I do (and
> the way the dictionary does):
> 
>      "You can sort your messages based on different kinds of
> information: the date you received them, who you received them from, or
> their subject. You can sort messages in a couple of ways: using the
> Actions menu or using the column headers."
> 
>     "Reading and Sorting Messages -- You can change the order by
> clicking one of the column titles at the top of the message list."
> 
>     "Sort Mail by the Order It Was Received in Mozilla Thunderbird"
> 
>     "So if you wanted to sort all mail by Thread, Descending (newest at
> top), the preferences in the config editor will look like this"
> 
>     "Click to sort"
> 
> 
> And I didn't invent the usage 'filtering'. Eg, Thunderbird, Wikipedia,
> Gmail:
> 
>     "Organize Your Messages by Using Filters"
> 
>     "Email filtering is the processing of email to organize it
> according to specified criteria."
> 
>     "Using filters, you can automatically send email to a label,
> archive, delete,"
> 
> 
> d/
> -- 
> Dave Crocker
> Brandenburg InternetWorking
> bbiw.net
> 
> 
> 
> ------------------------------
> 
> Message: 3
> Date: Sat, 25 Apr 2015 10:03:43 -0400
> From: John C Klensin <[email-masked]>
> To: Nick Matavka <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [apps-discuss] independent submission process for
> 	draft-matavka-gopher-ii
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=us-ascii
> 
> Nick,
> 
> It appears that circumstances have created a good deal of
> confusion here.  I'll try to clarify as much as I can inline
> below.  I believe everything not identified as "personal
> opinion" or the equivalent below accurately reflects IETF and
> RFC Editor procedures and processing rules. 
> 
> --On Saturday, April 25, 2015 03:21 -0400 Nick Matavka
> <[email-masked]> wrote:
> 
>> ...
>> I sent off an independent submission as a proposed standard,
> 
> First, I know this is confusing, but, to keep the confusion from
> getting worse, note that there are "independent submissions"
> that go through one review process (via the Independent
> Submission Editor) and "individual submissions" which are
> processed via the IETF Stream.   There is no such thing as an
> "independent submission as proposed standard" because only the
> IETF Stream can process standards track documents.
> 
>> in regards to extensions to the Gopher WWIS.  Although the
>> current iteration of the Gopher protocol is half-Informational
>> and half-unofficial memo (by which I mean the optional Gopher+
>> extensions), it was recommended to me that I put my draft on
>> the Standards Track.
> 
> I'm not sure what you mean by "half-unofficial" because I have
> no idea, in either the Independent Submission or IETF streams,
> what an "official memo" would be.  Personal opinion: bad advice
> (see below) or a misunderstanding.

What I mean is that Gopher as it exists today is "standardised" (I know it doesn't quite work that way) by two documents: the Gopher RFC, which has official status (that is, it's an IETF document), and the Gopher+ memo, which is internal work by the University of Minnesota and contains more spelling and grammar errors than you can shake a stick at.  There is no formal "standard" for Gopher, but it is informally "standardised" by those two documents.  

> 
>> I'm not opposed to this idea, which is
>> why draft-matavka-gopher-ii is currently sitting on IETF
>> servers on said Standards Track.
> 
> I don't even know what that means, unless you are just referring
> to a "proposed status" line in the Internet Draft.

Yeah, that's what I'm referring to.  This is my first time at this particular rodeo, so please forgive me if I act like a newbie, because I am.

> 
>> My concerns are mostly related to IETF process.  How are
>> independent submissions handled?  Am I supposed to receive an
>> eMail from one of the review people stating the nits that need
>> to be corrected?  The structure is fine, I'm now curious as to
>> how an Internet-Draft becomes a Standard.
> 
> To save you more time, I'll review the two options separately
> and add a third.
> 
> (i) For an individual submission of a standards track document,
> you need to get an AD to sign up to "sponsor" it, i.e., to take
> the lead in moving the document through the system.  It is not
> clear to me, especially after the Area reorganization started,
> who the best candidate would be, but I think it would be
> reasonable for you to send an inquiry to [email-masked] and hope
> someone responds.  If any of the current ADs have expressed
> interest, I'd start with a discussion with him or her.
> 
> Personal opinion: Unless you can find a sponsoring AD would is
> _really_ committed to the document and/or to you and your
> situation, successfully getting a document processed in this way
> is likely to be time-consuming and painful for anyone without a
> lot of IETF experience.   It may be worth noting that efforts to
> get FTP updates and extensions processed onto the standards
> track have rarely gotten significant traction and, whatever the
> other relationships may be, FTP has a much longer standards
> history and is far more widely deployed than gopher.

I did talk to Barry Leiba in January of '15, but totally forgot the salient points of the discussion.  I do remember you "had a full and frank exchange of views and opinions" with him about Proposed Standard v Informational then.

> 
> (ii) For an independent submission, remove anything "standards
> track" from the document and send a note to [email-masked]
> indicating that you would like to submit the document and asking
> for instructions as to how to proceed.
> 
> (iii) The third possibility is to ask the Applications Area WG,
> via this list and/or a note to the chairs, to take this on and
> process it as a standards track document.  I don't know if you
> can get that agreement, but, if you can, it would provide you
> with much more help and support with standards track mechanisms
> than the individual submission approach would.

What would you suggest, John?  You wrote me way back in January, "Initial versions of I-Ds are typically _very_informal.  It is entirely reasonable to post one that if [sic] full of both stylistic and substantive errors and then iterate on it as comments come in (certainly I have done so and had a -01 version be radically different from a -00).  Don't hesitate to post whatever you have as an I-D and don't assume that whatever you post will be final -- there are a fairly large population of dinosaurs around and some of them (us) are still in touch with the developers of that period."

"But, if this is a "live" protocol in active use and you are describing the current versions, why not just push for Proposed Standard?  Some of us would certainly support that action and status."

I think you advised me well the first time, just don't know how to proceed.  I think option (iii) would be the right one, but I don't know how, rather than if, I can get their agreement.  I assume there's some sort of boilerplate.  

> 
>> I'm also curious as
>> to how ongoing fixes are incorporated.  For instance, the
>> informal workgroup that discusses Gopher is now floating the
>> idea of Gopher over TLS, and they have reached the consensus
>> that GopherS (as they have called it) would be a beneficial,
>> but optional, part of the Gopher system. Perhaps a footnote to
>> that effect would fit in the Internet-Draft, but I'm not sure
>> how 00 becomes 01 and 02 and 03.
> 
> As long as this is an individual or independent submission, you
> are free to modify the I-D in any way that you find appropriate.
> Discussions, perhaps in an appendix, of what changes were made
> and, if it is not obvious, why, can be a great help to readers
> but there are no specific requirements.  There is no provision
> in the Internet-Draft format for footnotes although some of us
> have devised variation on endnotes on occasion.

I'm just wondering what the technical way to do that is.  Is there an "edit" link to click on?

> 
> Note that, as far as IETF Standards Track is concerned, there is
> no such thing as an "informal workgroup" or consensus within it.
> It is just you and some of your friends making an individual
> submission or trying to either form an IETF WG (a fourth option
> deliberately omitted above) or getting an existing WG to take
> the work on.

I know.

> 
>> Anyway, any help you could give me is appreciated.
> 
> Personal opinion/recommendation: put a solid document together
> that describes what has actually been implemented, deployed, and
> put into non-trivial use.   If you want to speculate about
> changes that should be made, do that, but treat it is
> speculation and maybe put it in an appendix.  Keep it
> descriptive rather than making normative and/or conformance
> statements.  Hand that off to the Independent Submission Editor
> and get it reviewed and published as a baseline.  Once you have
> accomplished that, you will have an informative document for the
> community and a better baseline for future work than the 20+
> year old (and also Informational) spec in RFC 1436.  Because
> 1436 was Informational, nothing prevents your new document from
> updating it or, if it is complete enough, obsoleting it, and you
> should specify one or the other unless the ISE recommends
> otherwise.  Then, if you want to, develop an IETF-stream,
> standards track, normative document that specifies, e.g.,
> interoperability requirements and applicability for modern
> Gopher.   

That's what I've already done.  The document I have put together describes the standard as it exists today.  I did use a few conformance statements, but only because what they're conforming with is consensus.  I want to formalise the consensus, that's all, not bring in new features and make Gopher as bloated as the Web is.  I simply wanted to add the sentence "Nothing in this document prevents Gopher from being used over SSL/TLS; the protocol, in this case, is Gophers://"

> 
> Others may disagree with that strategy.  In particular, I hope
> the people on this list who were more closely involved with
> Gopher development and deployment in the 1990s than I was (i.e.,
> more than zero) would at least comment and possibly offer
> support and guidance.
> 
>     john
> 
> 
> 
> ------------------------------
> 
> Subject: Digest Footer
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
> 
> 
> ------------------------------
> 
> End of apps-discuss Digest, Vol 87, Issue 51
> ********************************************

---

From: John C Klensin <[email-masked]>
Date: Sat, 25 Apr 2015 20:25:04 -0400

--On Saturday, April 25, 2015 18:15 -0400 Nick Matavka
<[email-masked]> wrote:

>> what an "official memo" would be.  Personal opinion: bad
>> advice (see below) or a misunderstanding.
> 
> What I mean is that Gopher as it exists today is
> "standardised" (I know it doesn't quite work that way) by two
> documents: the Gopher RFC, which has official status (that is,
> it's an IETF document),

It is an Information specification and has no "official" status
at all, at least as far as normal IETF procedures are concerned.

> and the Gopher+ memo, which is
> internal work by the University of Minnesota and contains more
> spelling and grammar errors than you can shake a stick at.
> There is no formal "standard" for Gopher, but it is informally
> "standardised" by those two documents.  

No, it is described by those two documents and some of the users
and implementers have chosen to treat those descriptions as a de
facto standard.  I'm sorry to keep pushing at this but, if you
want IETF Standards Track treatment for your document, the
distinctions are quite important.

>> I don't even know what that means, unless you are just
>> referring to a "proposed status" line in the Internet Draft.
> 
> Yeah, that's what I'm referring to.  This is my first time at
> this particular rodeo, so please forgive me if I act like a
> newbie, because I am.

That is why you are getting the careful explanations.

>...
>> (i) For an individual submission of a standards track
>> document, you need to get an AD to sign up to "sponsor" it,
>> i.e., to take the lead in moving the document through the
>> system. 
>...
>> situation, successfully getting a document processed in this
>> way is likely to be time-consuming and painful for anyone
>> without a lot of IETF experience.   It may be worth noting
>> that efforts to get FTP updates and extensions processed onto
>> the standards track have rarely gotten significant traction
>> and, whatever the other relationships may be, FTP has a much
>> longer standards history and is far more widely deployed than
>> gopher.
 
> I did talk to Barry Leiba in January of '15, but totally
> forgot the salient points of the discussion.  
>...

Then I suggest you try to work with Barry to reconstruct.
 
>> indicating that you would like to submit the document and
>> asking for instructions as to how to proceed.
>> 
>> (iii) The third possibility is to ask the Applications Area
>> WG, via this list and/or a note to the chairs, to take this
>> on and process it as a standards track document.  I don't
>> know if you can get that agreement, but, if you can, it would
>> provide you with much more help and support with standards
>> track mechanisms than the individual submission approach
>> would.
 
> What would you suggest, John?  You wrote me way back in
> January, "Initial versions of I-Ds are typically
> _very_informal.  It is entirely reasonable to post one that if
> [sic] full of both stylistic and substantive errors and then
> iterate on it as comments come in (certainly I have done so
> and had a -01 version be radically different from a -00).
> Don't hesitate to post whatever you have as an I-D and don't
> assume that whatever you post will be final -- there are a
> fairly large population of dinosaurs around and some of them
> (us) are still in touch with the developers of that period."
 
> "But, if this is a "live" protocol in active use and you are
> describing the current versions, why not just push for
> Proposed Standard?  Some of us would certainly support that
> action and status."
> 
> I think you advised me well the first time, just don't know
> how to proceed.  I think option (iii) would be the right one,
> but I don't know how, rather than if, I can get their
> agreement.  I assume there's some sort of boilerplate.  

Not really.  We are really a much less formal group than the
impressions that we cause sometimes.  Watch for a follow-up note
immediately after this one.

> there an "edit" link to click on?

Sorry.  I misunderstood your question.   Prepare a new draft
with your changes, give it the same name as the earlier one with
-00 replaced by -01, and submit it the same way.  There is no
option for editing documents in place.

best,
   john

p.s. _Please, if you are going to receive this mailing list as a
digest, trim everything not directly relevant to your response,
the text of especially completely unrelated messages, before
replying.  Fixing the subject line to reflect the actual message
thread is a good idea too -- something about "apps-discuss
digest" is really not helpful.