Subject: [apps-discuss] Proposal for adoption of Gopher document as an AppsAWG task

From: John C Klensin <[email-masked]>
Date: Sat, 25 Apr 2015 20:25:14 -0400

Murray and Alexey,

In order to shortcut some potential confusion and thrashing
around, consider this note a request, on the lead author's
behalf, to adopt Gopher-II: The Next Generation Gopher WWIS
(draft-matavka-gopher-ii) as a WG document with the intention of
processing it for standards track.

If there is interest in proceeding on that basis, I
recommend/request that you try to identify a shepherd or
equivalent now so that he or she can help Nick with technical
and procedural details.  For reasons which which you are both
familiar, relying on me to do that job in the time I have
available would be unwise and unfair to Nick although I'd be
happy to try to help someonw who was taking the lead if that
were needed.

If the WG takes this on, one of the decisions that will need to
be made early on is whether to go directly to a standards-track
spec or to first publish an informational "state of the protocol
in 2015" document and then build on it.

thanks,
    john

---

From: Larry Masinter <[email-masked]>
Date: Sun, 26 Apr 2015 15:39:05 +0000

I don't think there is sufficient evidence that this proposal has a serious audience. Appsawg should decline.

--
http://larry.masinter.net

> On Apr 26, 2015, at 2:25 AM, John C Klensin <[email-masked]> wrote:
> 
> Murray and Alexey,
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: "John Levine" <[email-masked]>
Date: 26 Apr 2015 15:57:12 -0000

>audience. Appsawg should decline.

Gopher got a full chapter in Internet for Dummies in 1993, but by the
third edition in 1995 it was down in the laundry list of other
applications.  It's 20 years later, Gopher lives on only for fans of
retrocomputing, and it's hard to see any benefit of us spending time
on it.

R's,
John

---

From: "Patrik Fältström" <[email-masked]>
Date: Sun, 26 Apr 2015 18:22:01 +0200

> retrocomputing, and it's hard to see any benefit of us spending time

I disagree and further think the wording you have chosen John is not optimal when someone regardless of popularity (or lack thereof) of a protocol tries to increase interoperability, and because of that approach IETF.

I want an inclusive IETF process.

I also think what is described here: <https://en.wikipedia.org/wiki/Gopher_(protocol)> describe more use than many other crazy ideas that are discussed in the IETF.

If you are worried about cycles used by busy officers of the IETF (or something else), which btw is a view I share, I think Klensin has come up with a good proposal on a path forward.

I further do think it is not correct to give this task to an HTTP related wg in the IETF but instead I suggest:

- The document is submitted as an individual submission.

- Help is given so that the document and process is followed correctly.

- IESG do add an appropriate note that point out the limited, but still use.

I.e. use minimal IETF energy, ensure process is followed, have IESG add a note about Gopher.

   Patrik

---

From: "John R Levine" <[email-masked]>
Date: 26 Apr 2015 12:54:37 -0400

> I want an inclusive IETF process.

So do I, but we do not have unlimited time, and appsawg has chronic 
problems handling drafts on topics in much wider use than gopher.

On the other hand, if you're volunteering to shepherd the gopher draft, 
nobody will object to that.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail.

---

From: "Patrik Fältström" <[email-masked]>
Date: Sun, 26 Apr 2015 19:09:47 +0200

On 26 Apr 2015, at 18:54, John R Levine wrote:

> So do I, but we do not have unlimited time, and appsawg has chronic problems handling drafts on topics in much wider use than gopher.

I agree with this.

> On the other hand, if you're volunteering to shepherd the gopher draft, nobody will object to that.

Fair, let me try to get the document in correct shape/format, without using any of your cycles.

We have the same goal here. Spend IETF time on what matters.

The only difference, as far as I see it, is that I think "saying no" is not the correct answer when someone want to do work.

No, I do not have any crystal clear response that I know works. But I *want* to have a different answer.

Thanks for this response John!

   Patrik

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 Apr 2015 13:34:21 -0400

--On Sunday, April 26, 2015 15:57 +0000 John Levine
<[email-masked]> wrote:

>> I don't think there is sufficient evidence that this proposal
>> has a serious audience. Appsawg should decline.
> 
> Gopher got a full chapter in Internet for Dummies in 1993, but
> by the third edition in 1995 it was down in the laundry list
> of other applications.  It's 20 years later, Gopher lives on
> only for fans of retrocomputing, and it's hard to see any
> benefit of us spending time on it.

In case it wasn't clear, I made the suggestion/request to help
Nick get clarity on whether it was better to pursue an
independent submission or some standards-track approach (and, if
so, which one), rather than having him waste his time and ours
trying to go in all directions at once and that is still my
position.

However, let me play devil's advocate for a moment.  The advent
and great success of the web, especially in combination with
powerful, advertising-enhanced, full-text search engines, swept
away a great deal of prior, function-specific, work and arguably
continues to do so.  That success has even worked against some
improvements to the web: legitimate concerns about backward
compatibility with whatever browsers or page authors are doing
has made it very hard to discuss and specify new but potentially
disruptive ideas and kludges are accumulating.  I suggest that
even work on and really creative thinking about the semantic web
has been impeded by the requirement to fit new ideas (and even a
few old, 1945-ish, ones) into the deployed model.  

IMO, homogeneity has costs and, e.g., the rather different
information models represented by systems based on authoritative
classification, managed identifiers, and/or intentionally
populated directories still have value and are likely to have
value far into the future.  Trying to stuff them all into the
same HTTP-constrained Procrustean bed really does the population
of Internet users no favors. 

For whatever it is worth, I believe it is inconsistent to argue
that the Internet is the home of permissionless innovation and
that the IETF is strongly committed to that idea and to try to
consign some protocols, without a hearing, to specific WGs where
the purpose of the assignment is to kill them.

Whether an updated version of Gopher is the right way to address
those issues is another question.  But, given that Nick has
argued that there is not only an active user community, but a
development one, I think they are entitled to try to demonstrate
that they are not just "fans of retrocomputing" and that, if
IETF review and interaction can add value to what they are
doing, it is reasonable to give them an opportunity to make the
case that we should invest the effort.

At least, unlike several of the proposals we have seen on this
list,  I don't think there is any risk that some people
developing and using an updated version of Gopher will cause
harm to the Internet or its other users.

best,
    john

---

From: "John R Levine" <[email-masked]>
Date: 26 Apr 2015 14:18:22 -0400

> harm to the Internet or its other users.

I think that Gopher is just dandy.  My concern is only that appsawg has 
limited cycles, and spending time on A makes it less likely we'll have 
time to do B.

Regards,

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 Apr 2015 14:30:49 -0400

--On Sunday, April 26, 2015 14:18 -0400 John R Levine
<[email-masked]> wrote:

> I think that Gopher is just dandy.  My concern is only that
> appsawg has limited cycles, and spending time on A makes it
> less likely we'll have time to do B.

I actually share that concern.  I just did not consider it
appropriate to have, or encourage Nick to have, a serious
discussion with the IESG about individual submission processing
without inquiring here first.   I do think the quality of
discussion and interaction that several things the WG agreed to
publish is such that I can't imagine Gopher getting much less.
This is ultimately up to Nick, but I don't personally see much
advantage in IETF standards track process (of any sort) unless
the IETF is actually able to add value.    On the other hand, I
suspect from your comment above that you and I would probably
agree that poor-quality review of earlier documents implies a
higher bar than we have been using rather than, e.g., getting
into a "the WG did X therefore it should do Y too" discussion.

FWIW, had you said "I don't care about it and don't imagine that
others on this list will either" I would have simply waited to
see if anyone disagreed with you and then moved on.  What set me
off was the much broader claim that appeared to be that everyone
with any interest in Gopher was somehow retrograde or retarded.

best,
     john

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sun, 26 Apr 2015 21:48:39 +0200

+1

If Nick can demonstrate rough consensus and running code (and I don't think 
there's real doubt about either of those, even if the running code is 
little-used) then that should be enough. In real life there's also a third 
condition: This is not the kind of draft that survives being a timesink for 
the IETF regulars.

Arnt

---

From: t.petch <[email-masked]>
Date: Tue, 28 Apr 2015 15:34:14 +0100

----- Original Message -----
From: "Arnt Gulbrandsen" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, April 26, 2015 8:48 PM

> condition: This is not the kind of draft that survives being a
timesink for

Not sure if I quite understand the third condition but, my personal form
of congestion control is such that I would want to see the work on file:
progress, perhaps to the sight of a Shepherd's write-up, before I commit
time to gopher:.

Tom Petch

---

From: joel jaeggli <[email-masked]>
Date: Wed, 29 Apr 2015 23:44:30 -0700

> in 2015" document and then build on it.

good lord, I hope that's not a hard decision...

gopher://gopher.floodgap.com/I/gophervr/gopherhd.png

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Thu, 30 Apr 2015 13:46:26 +0200

> progress, perhaps to the sight of a Shepherd's write-up, before I commit

Sorry. That was poorly phrased. I was just predicting that even if the 
gophers have running code and rough agreement on what it should do, they 
can still lose if they cause controversy and waste time _here_.

The draft will not survive controversy. I'm just predicting that
 - because it has rough consensus and running code, it can get to RFC
 - but if it wears out IETF people with quarrels of any sort, it'll die.

Arnt

---

From: John C Klensin <[email-masked]>
Date: Thu, 30 Apr 2015 11:13:32 -0400

--On Wednesday, April 29, 2015 23:44 -0700 joel jaeggli
<[email-masked]> wrote:

>> If the WG takes this on, one of the decisions that will need
>> to be made early on is whether to go directly to a
>> standards-track spec or to first publish an informational
>> "state of the protocol in 2015" document and then build on it.
> 

Joel,

Unless and unless someone picks up the windmill-charging spear,
I'm trying to be as much of a facilitator of, and as neutral
about, this as possible.  As a result, I'm more inclined to say
"this is a possibility" than "this is what we ought to do".
Even where bringing the "do you want it" question to AppsAWG is
concerned, I believed (and believe) it was procedurally correct
to ask independent of my opinions about what should be done and
how this should be handled.

However, as to what is a hard decision or not, even getting the
posted draft into a form that makes it easy to move forward (in
any stream) involved more than bit of work, work that wouldn't
be worth doing if neither the IETF nor the ISE had any interest.
Nick how has an xml2rfc conversion in hand and is presumably
working on/with it, but we (for some version of "we". appear to
need to choose among the following (exaggerating a few slightly):

(1) Note Gopher's location in the trashbin of history and
optionally make other suggestions about what people might do (or
where to find larger piles of sand to pound).

(2) Whip Nick's I-D into shape and ask the ISE to publish it as
a purely informational opinion piece about Gopher role and
status.

(3) Decide that some of the work that has been done on Gopher-2
already constitutes a standard from an external body and decide
that it (or pointers to it) should be published for the
information of the community (as either an individual submission
to the IETF or an independent submission).

(4) Decide that Gopher-2 really deserves to be standardized in
the IETF and that there is sufficient interest and willingness
to review to make an assertion of IETF consensus meaningful.
If we make that decision, we still need to decide among AppsAWG,
a separate WG, and an individual submission.  I have a bias
about that (and think it is consistent with Barry's initial
thoughts) but, for the moment, am keeping it mostly to myself.

Except for (1), to which I'm definitely opposed because I think
it is incorrect, I'm trying to remain fairly agnostic about the
options, preferring to see a consensus develop about what the
right thing is to do rather than to advocate for one approach.
I believe that Nick is in much the same situation although I
haven't discussed it with him explicitly.

best,
    john

---

From: John C Klensin <[email-masked]>
Date: Thu, 30 Apr 2015 11:37:13 -0400

--On Thursday, April 30, 2015 13:46 +0200 Arnt Gulbrandsen
<[email-masked]> wrote:

> Sorry. That was poorly phrased. I was just predicting that
> even if the gophers have running code and rough agreement on
> what it should do, they can still lose if they cause
> controversy and waste time _here_.
> 

Arnt,

At one level I completely agree with you, and do so from the
perspective of one person who is easily worn out by long,
repetitive or low-content threads.   However, if there is a
protocol that has active development and user communities (and,
by definition, running code, etc.) and people in the IETF
community who are sincerely interested in contributing to it and
adding value to it, it would say some very bad things about the
state of the IETF if a small group of people who either don't
like a protocol on aesthetic grounds or because they are
advocates for something else can kill IETF involvement with that
protocol by simply generating enough noise.

So I think there is something of a balance to be found and I'm
not sure we have it yet.

On the other hand, if a significant fraction of the community
wants a "modern Gopher" standard, then perhaps the risk of being
overwhelmed by noise is an argument for trying to do the work in
a tightly-focused WG whose leadership could more easily push
those whose interest is in disruption (by starting fights or
otherwise) off the mailing list to enable work to get done.

best,
   john

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Thu, 30 Apr 2015 19:12:57 +0200

I have to agree that we occasionally have problems with noisy rhetoric. 
(RFC6851 isn't very different from a draft someone posted in 2001, and I 
don't think that draft was the first one, either. Most of the delay was due 
to rhetoric.)

I'll review the gopher document. Don't care at all about its formal status 
so long as the status includes the letters "r", "f" and "c" and four 
digits.

Arnt

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 30 Apr 2015 13:21:02 -0400

> so long as the status includes the letters "r", "f" and "c" and four
 
For a moment, I thought I saw another DoS vector, but then I remembered that 
the number with five digits also has four.

Scott K