Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-uri-scheme-reg-05.txt

From: Mark Nottingham <[email-masked]>
Date: Fri, 3 Apr 2015 08:30:14 +1100

Just a bit of feedback —

* The new text in Section 3 ("A scheme definition cannot override…") seems like it's equally applicable to provisional schemes. I'd suggest moving this to 3.2 and then referring to it from Section 4 (as a MUST?).

* Section 4 constructs a conflicting requirement "… the following are REQUIRED: … The scheme definition SHOULD …"  This is confusing — is it REQUIRED or SHOULD? I'd suggest changing the start to "… the following requirements apply:".

Cheers,

> On 28 Mar 2015, at 3:33 am, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Applications Area Working Group Working Group of the IETF.
> 
>        Title           : Guidelines and Registration Procedures for URI Schemes
>        Authors         : Dave Thaler
>                          Tony Hansen
>                          Ted Hardie
>                          Larry Masinter
> 	Filename        : draft-ietf-appsawg-uri-scheme-reg-05.txt
> 	Pages           : 19
> 	Date            : 2015-03-27
> 
> Abstract:
>   This document updates the guidelines and recommendations, as well as
>   the IANA registration processes, for the definition of Uniform
>   Resource Identifier (URI) schemes.  It obsoletes RFC 4395.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-appsawg-uri-scheme-reg/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-appsawg-uri-scheme-reg-05
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-appsawg-uri-scheme-reg-05
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

--
Mark Nottingham   https://www.mnot.net/

---

From: Dave Thaler <[email-masked]>
Date: Wed, 8 Apr 2015 01:34:23 +0000

> -----Original Message-----
> From: apps-discuss [mailto:[email-masked]] On Behalf Of Mark
> Nottingham
> Sent: Thursday, April 2, 2015 2:30 PM
> To: IETF Apps Discuss
> Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-uri-scheme-reg-05.txt
> 
> Just a bit of feedback —
> 
> * The new text in Section 3 ("A scheme definition cannot override…") seems
> like it's equally applicable to provisional schemes. I'd suggest moving this to
> 3.2 and then referring to it from Section 4 (as a MUST?).

It may be applicable but it's not "equally" applicable because a provisional
scheme is no longer required to have a scheme defining document.
Also, in my opinion it's not a normative requirement (MUST) but rather 
a simple statement of fact... you cannot override what a generic parser
with no scheme-specific knowledge will do, by definition.

> * Section 4 constructs a conflicting requirement "… the following are
> REQUIRED: … The scheme definition SHOULD …"  This is confusing — is it
> REQUIRED or SHOULD? I'd suggest changing the start to "… the following
> requirements apply:".

Good point, this needs a grammatical fix as you suggest.  I agree with
your wording fix except that the first and third bullets need a grammatical
fix with the new wording, since they relied on the word REQUIRED.   I will
add MUST to those two bullets to retain the meaning.

Thanks,
Dave

> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >