Subject: [apps-discuss] independent submission process for draft-matavka-gopher-ii

From: Nick Matavka <[email-masked]>
Date: Sat, 25 Apr 2015 03:21:22 -0400

Hello, world!

I sent off an independent submission as a proposed standard, in regards to
extensions to the Gopher WWIS.  Although the current iteration of the
Gopher protocol is half-Informational and half-unofficial memo (by which I
mean the optional Gopher+ extensions), it was recommended to me that I put
my draft on the Standards Track.  I'm not opposed to this idea, which is
why draft-matavka-gopher-ii is currently sitting on IETF servers on said
Standards Track.

My concerns are mostly related to IETF process.  How are independent
submissions handled?  Am I supposed to receive an eMail from one of the
review people stating the nits that need to be corrected?  The structure is
fine, I'm now curious as to how an Internet-Draft becomes a Standard.  I'm
also curious as to how ongoing fixes are incorporated.  For instance, the
informal workgroup that discusses Gopher is now floating the idea of Gopher
over TLS, and they have reached the consensus that GopherS (as they have
called it) would be a beneficial, but optional, part of the Gopher system.
Perhaps a footnote to that effect would fit in the Internet-Draft, but I'm
not sure how 00 becomes 01 and 02 and 03.

Anyway, any help you could give me is appreciated.

Edward Matavka

-- 
       /^\/^\
       \----|
   _---'---~~~~-_
    ~~~|~~L~|~~~~
       (/_  /~~--
     \~ \  /  /~
   __~\  ~ /   ~~----,
   \    | |       /  \
   /|   |/       |    |
   | | | o  o     /~   |
 _-~_  |        ||  \  /
(// )) | o  o    \\---'
//_- |  |          \
//   |____|\______\__\
~      |   / |    |
       |_ /   \ _|
     /~___|  /____\

---

From: John C Klensin <[email-masked]>
Date: Sat, 25 Apr 2015 10:03:43 -0400

Nick,

It appears that circumstances have created a good deal of
confusion here.  I'll try to clarify as much as I can inline
below.  I believe everything not identified as "personal
opinion" or the equivalent below accurately reflects IETF and
RFC Editor procedures and processing rules. 

--On Saturday, April 25, 2015 03:21 -0400 Nick Matavka
<[email-masked]> wrote:

>...
> I sent off an independent submission as a proposed standard,

First, I know this is confusing, but, to keep the confusion from
getting worse, note that there are "independent submissions"
that go through one review process (via the Independent
Submission Editor) and "individual submissions" which are
processed via the IETF Stream.   There is no such thing as an
"independent submission as proposed standard" because only the
IETF Stream can process standards track documents.

> in regards to extensions to the Gopher WWIS.  Although the
> current iteration of the Gopher protocol is half-Informational
> and half-unofficial memo (by which I mean the optional Gopher+
> extensions), it was recommended to me that I put my draft on
> the Standards Track.

I'm not sure what you mean by "half-unofficial" because I have
no idea, in either the Independent Submission or IETF streams,
what an "official memo" would be.  Personal opinion: bad advice
(see below) or a misunderstanding.

> I'm not opposed to this idea, which is
> why draft-matavka-gopher-ii is currently sitting on IETF
> servers on said Standards Track.

I don't even know what that means, unless you are just referring
to a "proposed status" line in the Internet Draft.

> My concerns are mostly related to IETF process.  How are
> independent submissions handled?  Am I supposed to receive an
> eMail from one of the review people stating the nits that need
> to be corrected?  The structure is fine, I'm now curious as to
> how an Internet-Draft becomes a Standard.

To save you more time, I'll review the two options separately
and add a third.

(i) For an individual submission of a standards track document,
you need to get an AD to sign up to "sponsor" it, i.e., to take
the lead in moving the document through the system.  It is not
clear to me, especially after the Area reorganization started,
who the best candidate would be, but I think it would be
reasonable for you to send an inquiry to [email-masked] and hope
someone responds.  If any of the current ADs have expressed
interest, I'd start with a discussion with him or her.

Personal opinion: Unless you can find a sponsoring AD would is
_really_ committed to the document and/or to you and your
situation, successfully getting a document processed in this way
is likely to be time-consuming and painful for anyone without a
lot of IETF experience.   It may be worth noting that efforts to
get FTP updates and extensions processed onto the standards
track have rarely gotten significant traction and, whatever the
other relationships may be, FTP has a much longer standards
history and is far more widely deployed than gopher.

(ii) For an independent submission, remove anything "standards
track" from the document and send a note to [email-masked]
indicating that you would like to submit the document and asking
for instructions as to how to proceed.

(iii) The third possibility is to ask the Applications Area WG,
via this list and/or a note to the chairs, to take this on and
process it as a standards track document.  I don't know if you
can get that agreement, but, if you can, it would provide you
with much more help and support with standards track mechanisms
than the individual submission approach would.

>  I'm also curious as
> to how ongoing fixes are incorporated.  For instance, the
> informal workgroup that discusses Gopher is now floating the
> idea of Gopher over TLS, and they have reached the consensus
> that GopherS (as they have called it) would be a beneficial,
> but optional, part of the Gopher system. Perhaps a footnote to
> that effect would fit in the Internet-Draft, but I'm not sure
> how 00 becomes 01 and 02 and 03.

As long as this is an individual or independent submission, you
are free to modify the I-D in any way that you find appropriate.
Discussions, perhaps in an appendix, of what changes were made
and, if it is not obvious, why, can be a great help to readers
but there are no specific requirements.  There is no provision
in the Internet-Draft format for footnotes although some of us
have devised variation on endnotes on occasion.

Note that, as far as IETF Standards Track is concerned, there is
no such thing as an "informal workgroup" or consensus within it.
It is just you and some of your friends making an individual
submission or trying to either form an IETF WG (a fourth option
deliberately omitted above) or getting an existing WG to take
the work on.

> Anyway, any help you could give me is appreciated.

Personal opinion/recommendation: put a solid document together
that describes what has actually been implemented, deployed, and
put into non-trivial use.   If you want to speculate about
changes that should be made, do that, but treat it is
speculation and maybe put it in an appendix.  Keep it
descriptive rather than making normative and/or conformance
statements.  Hand that off to the Independent Submission Editor
and get it reviewed and published as a baseline.  Once you have
accomplished that, you will have an informative document for the
community and a better baseline for future work than the 20+
year old (and also Informational) spec in RFC 1436.  Because
1436 was Informational, nothing prevents your new document from
updating it or, if it is complete enough, obsoleting it, and you
should specify one or the other unless the ISE recommends
otherwise.  Then, if you want to, develop an IETF-stream,
standards track, normative document that specifies, e.g.,
interoperability requirements and applicability for modern
Gopher.   

Others may disagree with that strategy.  In particular, I hope
the people on this list who were more closely involved with
Gopher development and deployment in the 1990s than I was (i.e.,
more than zero) would at least comment and possibly offer
support and guidance.

     john

---

From: Larry Masinter <[email-masked]>
Date: Sun, 26 Apr 2015 15:44:15 +0000

Gopher is suitable for marking historic. 
I think this should be referred to httpbis.

--
http://larry.masinter.net

> On Apr 25, 2015, at 9:21 AM, Nick Matavka <[email-masked]> wrote:
> 
> Hello, world!
> 
> I sent off an independent submission as a proposed standard, in regards to extensions to the Gopher WWIS.  Although the current iteration of the Gopher protocol is half-Informational and half-unofficial memo (by which I mean the optional Gopher+ extensions), it was recommended to me that I put my draft on the Standards Track.  I'm not opposed to this idea, which is why draft-matavka-gopher-ii is currently sitting on IETF servers on said Standards Track.
> 
> My concerns are mostly related to IETF process.  How are independent submissions handled?  Am I supposed to receive an eMail from one of the review people stating the nits that need to be corrected?  The structure is fine, I'm now curious as to how an Internet-Draft becomes a Standard.  I'm also curious as to how ongoing fixes are incorporated.  For instance, the informal workgroup that discusses Gopher is now floating the idea of Gopher over TLS, and they have reached the consensus that GopherS (as they have called it) would be a beneficial, but optional, part of the Gopher system.  Perhaps a footnote to that effect would fit in the Internet-Draft, but I'm not sure how 00 becomes 01 and 02 and 03.
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 1 May 2015 12:15:58 +1000

Oh, no you don't.

APPSWG is more than appropriate for this.

Cheers,

> On 27 Apr 2015, at 1:44 am, Larry Masinter <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/