Subject: [apps-discuss] D-BRIEF 00

From: Mike O'Connell <[email-masked]>
Date: Tue, 23 Jun 2015 08:59:24 -0300

Hi Apps,

Thanks to Barry Leiba for guiding me along the process to submit this draft. 

I’ve submitted a draft for Dynamic Business-Rules Implementation and Execution Framework (D-BRIEF). 

Summary:

D-BRIEF is an XML framework built to contain a scriptable language which operates on business objects within a real-time system. 

Ideology:

The foundation concepts include:
Object -> Event mappings
Scriptable language container for running “micro" commands on a request based system
In real-time refresh of business rules, rapid turn-around time
UI Editable 
Unix style “micro” commands
By utilising a “cron” style system one can implement an asynchronous interface that executes Object -> Events at a later stage. 

Within the referenced libraries we wrote additional meta style calls which allowed us to manipulate the session as follows:
Invoke another Object -> Event synchronously which simplifies the layout of the business policy, we use it for derivative objects. 
Exit execution at any point
Queue a task for asynchronous processing

Unfortunately I’m not able to release the UI editor or the actual engine code that operates the framework due to IP concerns; however I will attempt again in a few weeks to release at least the engine code.

The framework is defined in: https://datatracker.ietf.org/doc/draft-oconnell-dbrief/ <https://datatracker.ietf.org/doc/draft-oconnell-dbrief/>

Thank you for your time.

Sincerely,

--

Mike O'Connell
Domain Name Services (Pty) Ltd
+27 11 568 2812

---

From: Barry Leiba <[email-masked]>
Date: Thu, 25 Jun 2015 14:29:16 -0300

> Thanks to Barry Leiba for guiding me along the process to submit this draft.

You're welcome, Mike.

To clarify things for the apps-discuss people:
Mike is planning to send this to the Independent Stream Editor (ISE)
after he gets some feedback.  What he's hoping for here is some review
and comment to improve the document before he does that.  I hope some
of us can find a bit of time to do that.  Thanks.

Barry

> D-BRIEF is an XML framework built to contain a scriptable language which
> operates on business objects within a real-time system.
>
>
> Ideology:
>
> By utilising a “cron” style system one can implement an asynchronous
> interface that executes Object -> Events at a later stage.
>
>
> Within the referenced libraries we wrote additional meta style calls which
> allowed us to manipulate the session as follows:
>
> Invoke another Object -> Event synchronously which simplifies the layout of
> the business policy, we use it for derivative objects.
> Unfortunately I’m not able to release the UI editor or the actual engine
> code that operates the framework due to IP concerns; however I will attempt
> again in a few weeks to release at least the engine code.
>
> The framework is defined in:
> https://datatracker.ietf.org/doc/draft-oconnell-dbrief/
>
> Thank you for your time.
>
> Sincerely,
>
> --
>
> Mike O'Connell
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>