Subject: [apps-discuss] Benoit Claise's Discuss on draft-ietf-appsawg-text-markdown-use-cases-02: (with DISCUSS and COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Mon, 06 Jul 2015 15:43:53 -0700

Benoit Claise has entered the following ballot position for
draft-ietf-appsawg-text-markdown-use-cases-02: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-appsawg-text-markdown-use-cases/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Easy to fix DISCUSS: The RFC 2119 boilerplate is missing:

       The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL
NOT",
       "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in
this
       document are to be interpreted as described in [RFC2119].

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- I was surprised by the RFC2119 keywords in a use cases document (which
I first thought of as an applicability document")
But, actually, according to the abstract, it's way more than a use cases
document: "Background information, local storage strategies, and
additional syntax registrations are supplied.", 
It's really the companion document of draft-ietf-appsawg-text-markdown.
Maybe the title is wrong, and should be something such as text/markdown
strategies and registrations?

" [MDMTREG] (draft-05) only defines two parameters:"
I guess there is nothing special about version 5. The latest version is
v8

Editorial:
- section 1, para 4. That confused me until I saw figure 1
OLD: On the formal end of the spectrum is markup
NEW: On the formal end of the formatted text spectrum is markup

- There are a couple of [CITE] reference, including this one: Character
set interoperability is well-studied territory [NB: CITE?]
To be completed I guess.

---

From: Sean Leonard <[email-masked]>
Date: Fri, 10 Jul 2015 20:45:06 -0700

> https://datatracker.ietf.org/doc/draft-ietf-appsawg-text-markdown-use-cases/

So to conclude here: the use-cases document needs RFC 2119 boilerplate and reference. Right?

> I guess there is nothing special about version 5. The latest version is

Already noted.

> NEW: On the formal end of the formatted text spectrum is markup

Ok, agreed.

{{
On the formal end of the formatted text spectrum is markup, a family of languages […]
}}

> set interoperability is well-studied territory [NB: CITE?]

I propose that those [CITE] / [NB: CITE?] pieces simply be removed, since they are not that big of a deal.

Sean

---

From: John C Klensin <[email-masked]>
Date: Sat, 11 Jul 2015 00:18:47 -0400

--On Friday, July 10, 2015 20:45 -0700 Sean Leonard
<[email-masked]> wrote:

>> - There are a couple of [CITE] reference, including this one:
>> Character set interoperability is well-studied territory [NB:
>> CITE?] To be completed I guess.
> 
> 
> I propose that those [CITE] / [NB: CITE?] pieces simply be
> removed, since they are not that big of a deal.

Sean,

I'm not following these two documents in detail and don't intend
to, but the above statement (with or without citations) is, for
lack of a better word, offensive.  It is almost like saying in
another context "While this specification requires a universal
solution to the PKI problem, that problem is well-studied
territory" or, if you are optimistic about that one, "Having
this work well depends on a solution to the halting problem,
which is well-studied territory".  

If you have a character set problem, or, as usually turns out to
be the case when people start talking about "character set
interoperability", an i18n problem, you really need to say
something specific (and probably provide references), not say
something that sounds like "it is a problem that others have
spent time on and therefore we can ignore".

Back to lurking.
   john

---

From: Sean Leonard <[email-masked]>
Date: Sat, 11 Jul 2015 14:09:10 -0700

On Jul 10, 2015, at 9:18 PM, John C Klensin <[email-masked]> wrote:

> spent time on and therefore we can ignore”.

Okay, okay…

The offending pieces are:
{{
There are communities that are using Markdown for
scholarly writing [CITE], for screenplays [FOUNTAIN], for
mathematical formulae [CITE], and even for music annotation [CITE].
}}

and:
{{
Character set interoperability is well-studied territory
[NB: CITE?] and so is not further covered here.
}}

Therefore, proposed changes are:
{{
There are communities that are using Markdown for
scholarly writing [OCCASION], for screenplays [FOUNTAIN], and even for
mathematical formulae [MATHDOWN].

…

[OCCASION]  http://blogs.law.harvard.edu/pamphlet/2014/08/29/switching-to-markdown-for-scholarly-article-production/

[MATHDOWN]  https://github.com/cben/mathdown/wiki/math-in-markdown

}}

(I searched for references for Markdown for musical notation, but was not satisfied with the results, so I dropped that part of the sentence. The references, of course, will be cleaned up when I insert them in the draft.)

{{
[RFC6657] provides guidance on character set parameter handling.
}}

Sean

---

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Jul 2015 12:36:27 +0200

> So to conclude here: the use-cases document needs RFC 2119 boilerplate and reference. Right?
Right.
And I understand, from some other email thread, that you plan on 
changing the document title. This is the right thing to do.

Regards, Benoit