Subject: [Autoconf] Simple MANET node model with new architecture

From: "Ruffino Simone" <[email-masked]>
Date: Wed, 8 Nov 2006 19:10:58 +0100

Hi all,
I was wondering how the architecture we discussed during the meeting can be applied, to model a very simple type of MANET deployment, where all nodes are laptops, with only one wireless interface (e.g 802.11). The laptops run a routing protocol and also run applications, like e-mail, browsing, IM etc. I assume here they are IPv6 only.
 
If I correctly understood, in this case, each MANET node should be modeled with a R(outer) with an attached virtual (H)ost. It is virtual, since no real host is attached to the laptop. Accordingly, one can say a virtual link connects R and H.
 
Now, my question is: how many addresses does the node need, in order for a host application to send and receive traffic to/from other nodes in the MANET ?
 
My temptative answer would be (not counting multicast addresses here):
 
On the MANET interface of R (the weird one):
 - One LLA and one non-link-local /128 address (maybe a MLA), to be used for joining the RP
 
On the link between the virtual Host and R (R--H):
- one /128 on H's interface, derived from prefix 'p', assigned to R. Every node own a unique prefix 'p'.
 
But, what about other addresses on this virtual link (R--H) ? Is it seen as a single entity, or should it be modeled as a traditional IPv6 link ? Or, in other words: are the following addresses needed ?
- one LLA on R's interface on the link and one LLA on H's interface on the link
- one /128 on R's interface on the link
 
I guess that some of these addresses are not needed, if the interfaces are virtual. The ones really needed, IMHO, are the two addresses on the MANET interface and one /128 for H, to be used by host applications.
 
Is this correct ? Am I missing anything ?
 
Thanks for your help,
Simone
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 8 Nov 2006 14:13:20 -0800

Hi Simone, 

> to be used for joining the RP

It seems like a non-link-local address-plus-prefix will be
useful for intra-MANET communications, but the prefix assigned
to the interface does not necessarily have to be a /128. It
could be, e.g., /64 *as long as no other MANET interface in
the MANET configures the same prefix*. I'm also not even sure
that an MLA is needed to operate the routing protocol; it
could just be some non-IP Router ID instead as long as it
is unique within the MANET. So, maybe link-local-only on
the MANET interface is fine too. 
 
> - one /128 on H's interface, derived from prefix 'p',
> assigned to R. Every node own a unique prefix 'p'.

That's OK, but I think your laptop's router function then
has to be responsible for the *rest* of the prefix 'p'
from which the /128 was taken. By that, I mean that it
needs to send, e.g., ICMP destination unreachable for pkts
destined to addresses covered by 'p' but not assigned to
an interface.

> But, what about other addresses on this virtual link (R--H) ?
> Is it seen as a single entity, or should it be modeled as a
> traditional IPv6 link ? Or, in other words: are the following
> addresses needed ?

It depends on the nature of the virtual link, but a loopback
interface is an example of an interface attached to a virtual
link that goes nowhere and could be used for communications
btw your laptop's router function and host function. Loopback
interfaces configure the single link-local address ::1.

Fred
[email-masked]
 
> I guess that some of these addresses are not needed, if
> the interfaces are virtual. The ones really needed, IMHO,
> are the two addresses on the MANET interface and one /128
> for H, to be used by host applications.
>
 
Thanks for your help,
Simone

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received the
message in error, be informed that any use of the content hereof is
prohibited. Please return it immediately to the sender and delete the
message. Should you have any questions, please contact us by replying to
[email-masked].

        Thank you

                                        www.telecomitalia.it

---

From: "Joe Macker" <[email-masked]>
Date: Tue, 14 Nov 2006 10:58:35 -0500

If non-overlapping uniqueness is satisfied you can assign.

It is not really a new model as was discussed at the meeting. 
It is perhaps better explained with specific addressing examples.

-Joe
>-----Original Message-----
>From: Templin, Fred L [mailto:[email-masked]] 
>Sent: Wednesday, November 08, 2006 5:13 PM
>To: Ruffino Simone; [email-masked]
>Subject: RE: [Autoconf] Simple MANET node model with new architecture
>
>Hi Simone, 
>
>could just be some non-IP Router ID instead as long as it is 
>unique within the MANET. So, maybe link-local-only on the 
>MANET interface is fine too. 
> 
>That's OK, but I think your laptop's router function then has 
>to be responsible for the *rest* of the prefix 'p'
>from which the /128 was taken. By that, I mean that it needs 
>to send, e.g., ICMP destination unreachable for pkts destined 
>to addresses covered by 'p' but not assigned to an interface.
>
>> - one LLA on R's interface on the link and one LLA on H's 
>interface on 
>> the link
>> I guess that some of these addresses are not needed, if the 
>interfaces 
>> are virtual. The ones really needed, IMHO, are the two addresses on 
>> the MANET interface and one /128 for H, to be used by host 
>> applications.
>>
>This message and its attachments are addressed solely to the 
>persons above and may contain confidential information. If you 
>have received the message in error, be informed that any use 
>of the content hereof is prohibited. Please return it 
>immediately to the sender and delete the message. Should you 
>have any questions, please contact us by replying to