Subject: RE: [Autoconf] MANET subnet model

From: "Ruffino Simone" <[email-masked]>
Date: Fri, 3 Nov 2006 10:01:33 +0100

Dear all,

I agree that is useful to enumerate all prefix assignment cases. 

I was wondering, if it would be possible to schedule a short presentation, during IETF67 AUTOCONF meeting, that explains the differences and implications of each approach (if it is not already in the agenda), maybe with examples for each one of them? 

I feel it would be beneficial for the group to have a common understanding, before proposing solutions that might be based on one/some/all of the alternatives. 

Do you think it is feasable/reasonable ?

Thanks,
Simone

 > -----Original Message-----
 > From: Joe Macker [mailto:[email-masked]] 
 > Sent: martedì 31 ottobre 2006 18.10
 > To: 'Templin, Fred L'; 'Jari Arkko'; 'Yi, Seung'
 > Cc: [email-masked]
 > Subject: RE: [Autoconf] MANET subnet model
 > 
 > Fred:
 > 
 > It's a good idea to enumerate prefix assignment cases to 
 > help scope the work.
 > 
 > Do we really need to REQUIRE multi-hop DAD for all 
 > deployments?  Having mechanisms TO SUPPORT IT defined is ok, 
 > but requiring it is not IMHO.  So can we talk about prefix 
 > assignment cases without DAD off-link issues for now. Just a thought.
 > 
 > -joe
 > 
 > >-----Original Message-----
 > >From: Templin, Fred L [mailto:[email-masked]]
 > >Sent: Tuesday, October 31, 2006 11:39 AM
 > >To: Jari Arkko; Yi, Seung
 > >Cc: [email-masked]
 > >Subject: RE: [Autoconf] MANET subnet model
 > >
 > >Jari,
 > >
 > >> If it is the case that you have a well understood approach
 > >that avoids
 > >> the multilink subnet issues you should go for that. You have a 
 > >> complicated enough problem in your hands even without having to 
 > >> support multiple ways to do things. If you have a solution
 > >that works
 > >> and has no major drawbacks, standardize that.
 > >
 > >Can you clarify what you mean by this? I believe Seung's post is 
 > >essentially listing the following options for prefix assignment to 
 > >MANET interfaces:
 > >
 > > 1) shared prefix for both address configuration and on-link
 > >    determination (i.e., prefix length shorter than 128) -
 > >    requires that all MANET interfaces that assign the prefix
 > >    and configure addresses from the prefix be attached to
 > >    the same link always and run DAD on the link
 > > 2) shared prefix for address configuration but not on-link
 > >    determination (i.e., prefix length = 128) - requires
 > >    MANET-wide proxy-DAD in case multiple MANET interfaces
 > >    configure duplicate addresses, but does not require
 > >    attachment to same link
 > > 3) unique prefix for each MANET interface - DAD avoidance
 > >    through operational assurance against duplication
 > > 4) link-local-only - requires MANET-wide proxy-DAD in case
 > >    multiple MANET interfaces that configure the same link-local
 > >    address might move onto the same link at some point in time.
 > >
 > >There would seem to be potential use-cases for all of these 
 > options, so 
 > >why do you say "pick one" when it seems like all may have their 
 > >appropriate use-cases?
 > >
 > >Note 1: option 4) also needs to be considered along with
 > >        options 1) thru 3) since all MANET interfaces must
 > >        configure a link-local address.
 > >Note 2: DAD can be avoided through operational assurance
 > >        against duplication in all cases, but that would
 > >        tend to negate SEND.
 > >
 > >Thanks - Fred
 > >[email-masked]
 > >
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Joe Macker" <[email-masked]>
Date: Fri, 3 Nov 2006 09:53:59 -0500

A few of us have discussed having a slide or two on some basic assumptions
and cases.
I think this is planned and your comment is well taken.  We would also
likely discuss the configuration/bahavior model for the MANET wireless
interface.

-Joe

>From: Ruffino Simone [mailto:[email-masked]] 
>Sent: Friday, November 03, 2006 4:02 AM
>To: [email-masked]
>Cc: Thomas Clausen; Shubhranshu
>I was wondering, if it would be possible to schedule a short 
>presentation, during IETF67 AUTOCONF meeting, that explains 
>the differences and implications of each approach (if it is 
>not already in the agenda), maybe with examples for each one of them? 
>
>I feel it would be beneficial for the group to have a common 
>understanding, before proposing solutions that might be based 
>on one/some/all of the alternatives. 
>
> > Subject: RE: [Autoconf] MANET subnet model  >  > Fred:
> >
> > It's a good idea to enumerate prefix assignment cases to  > 
>help scope the work.
> >
> > Do we really need to REQUIRE multi-hop DAD for all  > 
> > >Sent: Tuesday, October 31, 2006 11:39 AM  > >To: Jari 
>Arkko; Yi, Seung  > >Cc: [email-masked]  > >Subject: RE: 
>[Autoconf] MANET subnet model  > >  > >Jari,  > >  > >> If it 
>is the case that you have a well understood approach  > >that 
>avoids  > >> the multilink subnet issues you should go for 
>that. You have a  > >> complicated enough problem in your 
>hands even without having to  > >> support multiple ways to do 
>things. If you have a solution  > >that works  > >> and has no 
>major drawbacks, standardize that.
> > >
> > >Can you clarify what you mean by this? I believe Seung's 
>post is  > >essentially listing the following options for 
>prefix assignment to  > >MANET interfaces:
> > >
> > >There would seem to be potential use-cases for all of 
>these  > options, so  > >why do you say "pick one" when it 
>seems like all may have their  > >appropriate use-cases?
> > >
>This message and its attachments are addressed solely to the 
>persons above and may contain confidential information. If you 
>have received the message in error, be informed that any use 
>of the content hereof is prohibited. Please return it 
>immediately to the sender and delete the message. Should you 
>have any questions, please contact us by replying to 
>[email-masked].
>
>        Thank you
>
>                                        www.telecomitalia.it
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 7 Nov 2006 10:47:50 -0800

Hi,

Some follow-up on a couple of things I thought I heard during
the MANET architecture discussion in the Autoconf wg meeting
last nite:

1) For the case of the MANET router obtaining prefixes for
   assignment on non-MANET interfaces, the MR needs to have
   some sort of prefix delegation mechanism, e.g., DHCP PD.
   But, that would require some extra mechanism for MRs
   beyond what is specified in IPv6 node requirements. I'm
   OK with that, but does that cause problems for anyone?

2) For IPv6, it was suggested that the MR's MANET interface(s)
   will configure a link-local and may also configure a /128
   (non-link-local assumed). Again, I'm OK with that, but
   would assigning a /128 cause a problem for anyone?

3) For IPv4, it was suggested that the MR's MANET interface(s)
   would either be unnumbered or configure a /32 (again, non-
   link-local assumed). But, why not have the MANET interface
   configure an IPv4 link-local address/prefix per RFC3927?
   Can we consider that for the MANET architecture model?

Thanks - Fred

---

From: "Seung Yi" <[email-masked]>
Date: Tue, 7 Nov 2006 11:09:41 -0800

Hi, Fred,

On 11/7/06, Templin, Fred L <[email-masked]> wrote:
> <snip>

What would be the point for having this provision? I understand that a
link-local address MUST be configured for IPv6 case and also is used
for IPv6 ND but I don't see why one would want to configure RFC3927
address for a MANET interface. Do you see any particular use case?

Thanks,

- Seung

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 7 Nov 2006 11:13:28 -0800

Hi Seung,

> address for a MANET interface. Do you see any particular use case?

For the same reasons one would use an RFC3927 address on an
ordinary IPv4 node, i.e., to be able to do some basic networking
on the local link until a dynamically-assigned non-link-local
address is available via DHCP.

Thanks - Fred

---

From: "Joe Macker" <[email-masked]>
Date: Tue, 7 Nov 2006 14:36:08 -0500

re (3) I believe if address ambiguity conditions are met that seems to fit
the model.
I believe it is more challenging in practice to meet those conditions with
IPv4.
-Joe

>Sent: Tuesday, November 07, 2006 1:48 PM
>To: [email-masked]
>Subject: [Autoconf] MANET architecture discussion follow-up
>
>Hi,
>
>the MANET architecture discussion in the Autoconf wg meeting last nite:
>

---

From: "Seung Yi" <[email-masked]>
Date: Wed, 8 Nov 2006 07:26:12 -0800

Fred,

> address is available via DHCP.

My view on this is, both RFC3927 addresses and IPv6 link-local
addresses don't have much use in MANET since they can be only used to
communicate with transmission-range neighbors that can frequently
change. They fit the model but I'm not quite sure if one would want to
configure them. Rather, I think it is crucial to go for a MANET-wide
addresses (doesn't have to follow the MLA draft but some kind of
address that is supposed to be unique across the MANET). I can see the
need for IPv6 link-local for ND purpose but don't quite see the
similar cases for v4.

Thanks,

- Seung

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 8 Nov 2006 08:57:08 -0800

Hi Seung, 

> change.

Well, there is also the case in which the entire MANET is
represented as a single link, i.e., when the MANET routing
is based on L2 addresses or when using IP-in-IP tunneling.
So the scope of the link-locals would be the entire MANET
in that case.

> They fit the model but I'm not quite sure if one would want to
> configure them.

There is certainly a point to be made that random assignment
of IPv4 link locals is prone to collisions since there are
only 2^16 unique possibilities for identifers. I don't know
what the options are for some managed assignment scheme, but
I think RFC3927 has a duplicate address detection mechanism
that could ensure uniqueness when the entire MANET appears
as a single link.

> Rather, I think it is crucial to go for a MANET-wide

I'll certainly go with the need for MANET-wide (site-scoped?)
addresses. But, for IPv4 what would they be? And, could
RFC3927 addresses somehow be used to fit the need?

Fred

Thanks,

- Seung