Subject: [Autoconf] Comments on an initial starting point?

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 05 Mar 2009 18:58:25 +0100

Dear AUTOCONFers,

I would like to know your oppinion on the initial starting point for a
practical addressing architecture:

+--------+
|        | fe80::1/64    (the LL address-prefix)
| Router +--------------
|        | 2001:db8::1/64 (the address prefix configured on
+--------+                 this interface)

Teco and myself came up with this picture, thinking it may represent a
good starting point for planning a practical IPv6 addressing scheme for
ad-hoc networks.

I am interested to listen any kind of oppinion on this - is this good?
Can this lead to something good?  How?

Thanks in advance,

Alex

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 6 Mar 2009 09:32:07 +0100

Hi Alex,

I am an AUTOCONFer, so I respond.

As in the previous two postings, we may easy have different opinions on the
semantics / context of the diagram. The syntax is correct, and agreed on.

So what may be the difference? 
1) What is the delegated prefix to this router?
   2001:db8::/128?
   2001:db8::/64?
   2001:db8::/60?
2) Is the prefix-length on the interfaces limited to /64?
3) Is it mandatory to use the same prefix-length for all 
   addresses on an interface?

My opinion so far:
1) This is unknown, but 2001:db8::/64 at a minimum.
   No other router SHOULD advertize sub-prefixes out of 
   this delegated prefix.
2) It depends. If the interface is Ethernet or look-alike, 
   and SLAAC is supported, the answer is yes. If EUI-64
   is being used as InterfaceID, the answer is yes. If
   SLAAC and privacy extensions are used, the answer
   would be yes. When cryptographically generated addresses
   are used, the answer should be yes.
   But still, someone may say, the answer is no. 
   Ask Thomas Narten?
3) Not mandatory at all. But it may be "practical".

Here two "practical" examples of the same starting point:

2001:db8::/60             (the delegated prefix)
     |
     V
+--------+
|        | fe80::1/64     (the LL address-prefix)
| Router +--------------
|        | 2001:db8::1/64 (the address prefix configured on
+--------+                 this interface)

2001:db8::1/128            (the delegated prefix)   
     |
     V
+--------+
|        | fe80::1/64      (the LL address-prefix)
| Router +--------------
|        | 2001:db8::1/128 (the address prefix configured on
+--------+                  this interface)

I am not quite happy with the last one. As I mentioned before, I am not sure
on configuring a host prefix on an interface to a multi-access link. And the
LL InterfaceID is the same as the last 64 bits of the delegated prefix. This
is an extreme rare coincidence and very confusing. So we better not use this
in our examples. 

I think this one is invalid:

2001:db8::1/128           (the delegated prefix)   
     |
     V
+--------+
|        | fe80::1/64     (the LL address-prefix)
| Router +--------------
|        | 2001:db8::1/64 (the address prefix configured on
+--------+                 this interface)

Here, a prefix is configured that is larger than the delegated prefix.

Teco.

|-----Oorspronkelijk bericht-----
|Van: [email-masked] [mailto:[email-masked]] Namens
|Alexandru Petrescu
|Verzonden: donderdag 5 maart 2009 18:58
|Aan: [email-masked]
|Onderwerp: [Autoconf] Comments on an initial starting point?
|
|Dear AUTOCONFers,
|
|I would like to know your oppinion on the initial starting point for a
|practical addressing architecture:
|
|+--------+
||        | fe80::1/64    (the LL address-prefix)
|| Router +--------------
||        | 2001:db8::1/64 (the address prefix configured on
|+--------+                 this interface)
|
|Teco and myself came up with this picture, thinking it may represent a
|good starting point for planning a practical IPv6 addressing scheme for
|ad-hoc networks.
|
|I am interested to listen any kind of oppinion on this - is this good?
|Can this lead to something good?  How?
|
|Thanks in advance,
|
|Alex
|_______________________________________________
|Autoconf mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/autoconf