Subject: Re: [Autoconf] Regarding Baccelli/Townsley Internet-Draft

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 2 Nov 2009 12:55:19 -0800

Teco,

> -----Original Message-----
> From: Teco Boot [mailto:[email-masked]]
> Sent: Saturday, October 31, 2009 1:05 AM
> To: Templin, Fred L
> Cc: [email-masked]
> Subject: RE: [Autoconf] Regarding Baccelli/Townsley Internet-Draft
> 
> >Templin, Fred L wrote:
> 
> >Second, I want there to be flexibility to allow for
> >"tethered" hosts that are always single-hop neighbors
> >on a router's interface that otherwise has undetermined
> >connectivity properties. That may mean that the router's
> >interface may need to configure a prefix other than /32 or
> >/128.
> 
> Yes, I deploy this stuff.
> 
> But proponents on the baccelli draft would say this is
> supported, as there is some determined connectivity.
> I'm not sure this is valid argumentation, because I
> think the proponents know little of my MANETs.

Are you saying that we need a use case analysis of
the abundance of possible MANET scenarios?

Fred
[email-masked]
 
> But also for this case (same as LLs), I think it makes sense
> we Autoconf work on for a maximum-length, global / ULA prefix.
> But the practical addressing model for MANETs shall dot say
> these are preferred. These are needed if nothing else is
> available and can be a stepping stone to acquire other prefixes.
> 
> 
> Regards, Teco

---

From: "Teco Boot" <[email-masked]>
Date: Mon, 2 Nov 2009 22:48:23 +0100

Hi Fred,

>the abundance of possible MANET scenarios?

I'm not sure. I can't publish all my scenario's here.
But for sure the baccelli draft does not support all of them.
That is why I asked questions on "all" "general case" etc.

I have a few real world use cases by hand that could be made public.
Maybe I'll write those down some day. It would show the need for
multi-homing. An interesting one: Regional fire brigades: small 
MANETs connected to Internet with ADSL, 3G and two satcom systems.
It is deployed in a couple of months. Any idea on addressing model,
without NAPT / NAT66 or tunnels?
IPv6 is not realistic here and today anyway. But it would fit a nice
goal: an attached MANET without NAT or tunnels. And with a little 
effort on replacing default gateways, it would support multi-homing.

Regards, Teco