Subject: [bcause] My observations and recommendations from the mailing list discussions and BoF: Lets go to work!

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Wed, 27 Mar 2019 05:38:30 +0000

Team,

I have been listening to all arguments on this mailing list as well as what was discussed in the BoF.
If I can distill the conversations on this mailing list and BoF discussions as I understand them to the following points and my observations and recommendations with reasoning. I am trying to do this objectively and as a service to the community at large.

Point 1: Service providers have different views of the BNG needs for deployment in their networks.
These needs run from traditional fixed line BNG, to BNGs that have newer capabilities like HAGs to ultimately BNGs with converged wireless and wireline capabilities. This would warrant that we step back and capture these needs from the service provider community before we act IMHO. I realize that some believe that we already have enough information (requirements) at least for some deployments but frankly we will do the industry a disservice if we don't consider the larger context. We can easily have the situation that the solution selected just will not scale or be appropriate to be used in the larger context and from what I have heard from the various conversations there is a strong consensus in this community that we have 1 protocol to service both the traditional and larger scopes. I will concede that the community is not unanimous in this statement which is why I said strong consensus. - Enough so we should make sure the selection (which is what the BBF would specify) is correct.

Point 2: The service providers in the BoF at least have all mentioned the need for speed with expectations to do something in 2020 - for both traditional and converged deployments. I can't really say anything more here except that in whatever we do we need to be focused and committed. In my experience those 2 characteristics with a real target date will get results.

Point 3: Should the BBF be responsible for the requirements and architectures needed for the IETF.
I hope we can all agree that the BBF is the domain experts for the BNG work as Dave Sinicrope outlined in his BoF presentation. I realize that there are many of the same people, which goes to point 2 and the need for speed, are working on the same problem in both organizations - so frankly lets focus and commit to getting this work done so that the SPs can have a deployable solution for traditional and converged deployments in 2020. But honestly it needs to be done in the BBF for the requirements and architecture.

Point 4: Should the IETF wait on the BBF work to progress to a point that it can realistically work on a protocol that will meet the requirements that the service providers stated at the BoF. Well see point 2. Again lets focus our energies and commit to the work that meets the SP's stated deployments.

Point 5: PFCP and Extensions vs a new protocol: Honestly I keep hearing the solutions brought up before we even know really what SPs are deploying as a group - I will say we have heard from various service providers in the BBF as well as the ones that spoke up here in the IETF and they are all along the lines of point 1 - somewhere in that continuum. It seems like either of the solutions are more of a shoot, ready, aim approach - somewhat risky in my view but if really all this is driven by deployment dates in 2020. If we have to have a solution while we try to figure out what we are shooting at - I would go with the option that is already exists and has the chance to meet the service provider's requests in point 1. - That would be to choose PFCP and identify the extensions as you go and verify the solution against the requirements and architectures work as it progresses. I would think that an existing solution in the wireless network that has been deployed at scale and proven to that the extensions work for other use cases would be less risk than inventing something new or trying to extend a protocol that hasn't been proven to extend or would need modifications from vendors. However there is risk introduced here that as an engineer I loathe but sometimes you just have get over it...

Anyway  that's where I am at on these points.  My overall recommendation - lets all commit to focus and get this work done as quickly as possible knowing the SP have needs in 2020; let the BBF do its work; if you need to do something in a protocol use the PFCP extension route it's the least risky route toward 2020.

---

From: Gregory Dalle <[email-masked]>
Date: Wed, 27 Mar 2019 13:47:05 +0000

Thanks Tim, that's a good summary. The sooner we come together on point #1, the more likely we can meet criteria #2.
If requirements were all already captured and BBF had nothing new to add (as some suggested), we would not have these discussions today. There is no such thing as a "basic BNG" versus "an integrated BNG" (and a quantum leap in-between?) That's why a majority of the operators chiming in on this list expressed concerns on having a focus that is too narrow and siloed.
Lets fix that as quick as possible.
Greg

From: bcause <[email-masked]> On Behalf Of Carey, Timothy (Nokia - US)
Sent: Wednesday, March 27, 2019 1:39 AM
To: [email-masked]
Subject: [bcause] My observations and recommendations from the mailing list discussions and BoF: Lets go to work!

Team,