Subject: Re: [bcause] [Bcause] interest and scope?

From: "Dolganow, Andrew (Nokia - SG/Singapore)" <[email-masked]>
Date: Mon, 4 Mar 2019 16:27:25 +0000

Martin and others – comments in-line prefixed with AD>

Kind regards,
Andrew

On 2019-03-04, 9:22 PM, "Bcause on behalf of Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hello,

as you might know, the RTGWG has hosted, for some time now, a set of
documents that relate to the separation of the user plane and control
plane of Broadband Network Gateways.
These documents can be found at
https://datatracker.ietf.org/group/rtgwg/documents/ and start with
draft-cuspdt-* or draft-wadhwa-*

Please read them if you haven't already.

Recently, a group of persons has worked together and produced few
paragraphs in support of their willingness to see a working group on
this topic formed.

Considering this, I am sharing this text with the IETF community in
order to evaluate
* the wider interest in, and willingness to work on, this topic,

AD> interested
* the appropriateness of creating a focussed and short-lived working
group (as opposed to continuing in rtgwg).

AD> Providing a separate WG is in my opinion of a value as it will deliver required focus.

To that effect, please read and comment on the text further down, it is
here for being debated.
As a matter of clarification: me sharing it, instead of the authors
doing it, does not carry any special meaning.

Important note: this topic has its roots in BroadBand Forum (BBF) with
which IETF has exchanged few liaisons on the topic recently. These are
important reads:
https://datatracker.ietf.org/liaison/1619/
https://datatracker.ietf.org/liaison/1615/
https://datatracker.ietf.org/liaison/1600/
https://datatracker.ietf.org/liaison/1566/

---
Current Broadband Network Gateways (BNGs) that terminate residential
broadband subscribers at the edge of service provider networks run as an
integrated system where both the subscriber management control plane and
traffic forwarding user plane are combined in a single system. In a
large network,

AD> I would not say “large network”. What is large? -  and no matter how we define that
it will not be generally true, so instead we could maybe say that in some networks there may
be an operational or technical desire to separate control and user planes. Then we should task the WG
to define those use cases as part of the mandate. Defining a use case so specifically (as per below) in a charter
seems at minimum limiting. Some of the below text does try to be more general so let’s keep that.

where the subscriber density is high, it is better to
distribute and locate BNG systems closer to the subscribers, especially
when the content caches are distributed to reduce backhaul costs and
latency. In this scenario, as the BNG footprint grows, the subscriber
management control points also proliferate, increasing operational
complexity. This trend motivates the broadband network access industry
to adopt new architectures that take advantage of the increasing ability
to disaggregate and virtualize appropriate network access functions.
Additional benefits can be realized by separating subscriber management
control plane (CP) and traffic forwarding user plane (UP) for BNGs
(referred to as Control and User Plane Separation (CUPS)). That
simplifies operations, provides independent location, and scaling for CP
and UP functions. A single CP function, running as a centralized VNF,
can control and manage multiple UP instances, which may be distributed
and separated from the CP via a multi-hop L2 or L3 network.  CUPS
requires protocols for communication between CP and UP instances: from
the CP to the UP to create and manage subscriber state instances and
from the UP to the CP to handle relevant solicited or unsolicited events.
AD> I would say CUPS requires a mechanism (would not use a word “protocol”).

The proposed Working Group is a narrowly scoped WG tasked to specify
communication protocol(s) between the CP and UP of a BNG, a network
element whose functions are defined by BBF. A BNG can deliver broadband
services to subscriber over wireline access or over multiple access
types to accommodate different deployments. The goal of the WG is to
define protocol(s) for CUPS that may support multiple deployment
scenarios for the BNG.

The scope of the work covers protocol requirements, specification of the
communications protocol, the information elements to be transferred with
that protocol, and YANG data model(s) for Operations and Management as
well as security, operational, and transport considerations.
---
AD> why not say something more in line with other groups charters?

The proposed WG is focused on:

  1.  Defining use case where CP UP separation may be desired. The WG will produce a document

That clearly outlines the benefits of CP UP separation in general and for individual use cases

  1.  Specifying requirements for mechanisms to achieve CP and UP separation

to satisfy the above requirements

  1.  Defining new protocols or existing protocol extensions to achieve the above

Requirements. Each mechanism chosen shall include applicability statement that outlines

What requirements/use cases are being addressed

  1.  Manageability, OAM, Security – the WG will clearly describe how new method of centralised

CP changes those main operational aspects and, if required, define explicit mechanism

Required to deploy robust SP UP architectures

The scope of the WG covers work to achieve the above-stated objectives.

Andrew

Thank you
Martin
--
Bcause mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bcause

---

From: <[email-masked]>
Date: Tue, 5 Mar 2019 11:24:58 +0800 (CST)

Hi Martin and all,

I am interested in this work. There have been massive market deployment as well as pent-up demands for an industry-wide standard wrt disaggregated BNG, so I would like to see a focused and short-lived WG, and would like contribute to the subsequent drafts.

Best regards,

Daniel 

黄光平 huangguangping

算法标准部/有线研究院 Algorithm Standard  Dept./Wireline Product R&D Institute

南京市雨花区软件大道50号中兴通讯1号楼 
R&D Building, ZTE
Corporation Software Road No.50, 
Yuhua District, Nanjing, P..R.China, 210012 
M: +86 13770311052 
E: [email-masked] 
www.zte.com.cn

原始邮件

发件人：Dolganow,Andrew(Nokia-SG/Singapore) <[email-masked]>
收件人：Vigoureux, Martin (Nokia - FR/Paris-Saclay) <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年03月05日 00:27
主 题 ：Re: [bcause] [Bcause] interest and scope?

-- 
bcause mailing list
[email-masked]

 

Kind regards,

Andrew

 

On 2019-03-04, 9:22 PM, "Bcause on behalf of Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked] on behalf of [email-masked]> wrote:

Hello,

 

 

this topic formed.

order to evaluate

 

AD> interested

 

 

here for being debated.

 

important reads:

 

---

large network,

 

 

scenarios for the BNG.

---

 

Defining use case where CP UP separation may be desired. The WG will produce a document

Specifying requirements for mechanisms to achieve CP and UP separation

Defining new protocols or existing protocol extensions to achieve the above

Manageability, OAM, Security – the WG will clearly describe how new method of centralised

 

 

 

Andrew

Thank you

Martin

--

Bcause mailing list

[email-masked]