Subject: Re: [bcause] 答复: interest and scope?

From: KEN KO <[email-masked]>
Date: Mon, 25 Mar 2019 12:51:20 +0000

Several knowledgeable people on this thread have expressed their expectation that PFCP will support the extensions necessary for BNG CUPS. This is consistent with what I’ve heard at BBF and, given PFCP’s history and the variety of use cases in which it has been deployed, it seems a reasonable expectation.

I support exploring the use of PFCP extensions as the solution for BNG CUPS, and exploring other options only if PFCP is shown to be inadequate.

Unfortunately I am not in Prague this week, but I’ll continue to follow the bcause work on email.

Best regards,
Ken
This message has been classified General Business by KEN KO on Monday, March 25, 2019 at 8:51:20 AM.

From: bcause [mailto:[email-masked]] On Behalf Of Miaofuyou (Miao Fuyou)
Sent: Sunday, March 24, 2019 5:12 AM
To: Rajesh A Shinde; Gregory Dalle
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View); [email-masked]
Subject: Re: [bcause] 答复: interest and scope?

Hi Rajesh,

In principle, I agree. But, the problem is how much could be reused. If not much, it will hurt  rahter than benefit to implementation, deployment and operation. So, finally it depends on details, which is not revealed yet.

Miao
发件人：Rajesh A Shinde <[email-masked]>
收件人：Gregory Dalle <[email-masked]>;Miaofuyou (Miao Fuyou) <[email-masked]>
抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>;[email-masked] <[email-masked]>
时间：2019-03-24 08:07:30
主 题：RE: [bcause] 答复: interest and scope?

Hello All,
Basically, we should not have always new protocol, if we can manage with existing, well best fit protocol like PFCP as operationally it would be easier and skillset expectation would also meet from Telco perspective.
I will not be in Prague, however expect to have healthy discussions keeping telco perspective in mind.
~ Rajesh
From: Gregory Dalle <[email-masked]>
Sent: Saturday, March 23, 2019 7:16 PM
To: Miaofuyou (Miao Fuyou) <[email-masked]>
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>; [email-masked]
Subject: Re: [bcause] 答复: interest and scope?
Hi Miao,
I am confident that PFCP can also be used for BNG. If you look at 4G, PFCP is used in 3 different use cases (for reference, Sxa, Sxb and Sxc) - each with distinct set of requirements. Quite flexible.
I will not be in Prague but I hope you will have good discussions.
Greg

On Mar 22, 2019, at 1:57 PM, Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks for sharing the analysis is on-going!

My limited knowledge to 3GPP is WiFi is considered as a complement access technology for 3GPP technology, while BNG is not. I am not confident that BNG case could be supported by PFCP, that is why analysis is required and someone is working on it, as you said.

--------------------------------------------------
苗福友 Miao Fuyou
M: +86-18911316478<tel:+86-18911316478>(优先)
E: [email-masked]<mailto:[email-masked]>
产品与解决方案-网络标准专利部
Products & Solutions-Network Standard & Patent Dept
发件人：Gregory Dalle <[email-masked]<mailto:[email-masked]>>
收件人：Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>>
抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
时间：2019-03-22 16:28:33
主 题：Re: [bcause] 答复: interest and scope?
Hi Miao,

You are right about the need to analyze gaps in PFCP to support wireline access. BNG experts have started this analysis at BBF and we hope to hear back soon.

Thanks for sharing the Wikipedia article. So PFCP supports 4G, 5G and non-3GPP (wifi)? That’s quite a broad range of broadband scenarios. Doesn’t it make you confident that wireline can be added to the list?

Greg

> On Mar 22, 2019, at 5:34 AM, Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi Sanjay,
>
> Wikipedia says: "PFCP's scope is similar to that of OpenFlow, however it was engineered to serve the particular use-case of Mobile Core Networks. PFCP lacks the same general-purpose targets, describing well the 3GPP-specific functional basic blocks of packet forwarding used in 2G, 3G, 4G/LTE, Non-3GPP WiFi and 5G networks."
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_PFCP&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=v33MW1QfVNSlFntCd34LCmRjivIDxqexEzoS7I2lpNo&e=
>
> Even so, it doesn't mean PFCP could not to be extended or changed to do more. However, there have to be an thorough analysis to PFCP to figure out what extension or change is needed. Otherwise, it's only intention expression rather than facts statement, which is not helpful to progress the work.
>
> - Miao
>
> -----邮件原件-----
> 发件人: bcause [mailto:[email-masked]] 代表 Wadhwa, Sanjay (Nokia - US/Mountain View)
> 发送时间: 2019年3月21日 23:39
> 收件人: [email-masked]<mailto:[email-masked]>
> 主题: Re: [bcause] interest and scope?
>
> Hi
>> From most of the posts, it is quite clear convergence is an important consideration.
> To be specific, with the right interfaces and functions on BNG, one can use current BNG deployed base to offer existing residential services over any of fixed-access, fixed-wireless (e.g. with LTE, LTE/CBRS, 5G NSA) or hybrid-access. Additionally, as mentioned in another post there is ongoing work for integrating fixed-access with 5GC via an adaptation function (AGF) to use a multi-access SMF/UPF.
> Using a particular option at a given time may be a decision based on ROI, state of the network or other constraints. However, going from one access to another on BNGs or 5GC SMF/UPF should not require a new baseline CUPS protocol, but rather extensions to a common protocol. The extensions mainly confine to the state information carried by the protocol based on access-facing and network-facing interface encapsulations on the network-element. Network elements can include BNG, AGF, SGW/PGW, TDF, 5GC SMF/UPF. Some of the functions provided by these network elements may be combined or instantiated on the same platform.
> Therefore, an access or use-case specific CUPS protocol is a dead-end. A common CUPS protocol that enables convergence will provide flexibility to evolve the network without worrying about yet another variable. Extending an existing standard protocol that is already purpose built for large scale state exchange is a sound way forward for BNG CUPS. With above in mind, we have considered PFCP applicability for BNG CUPS (irrespective of access) for some time now, including required PFCP IEs. Existing IETF drafts have covered BNG CUPS architecture and requirements that are addressed by PFCP.
>
> Thanks
> -Sanjay
>
> --
> bcause mailing list
> [email-masked]<mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=
> --
> bcause mailing list
> [email-masked]<mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 25 Mar 2019 22:03:57 -0000

Ken, thanks for your mail. Since you won’t be in Prague at the meeting, can I ask you to clarify one point, please.

You say “explore using PFCP” which I understand. But where should that exploration be done in your opinion?

If not in the IETF, how will the IETF participate in that exploration and know when the exploration is complete so it could start on another option?

If in the IETF, how will we judge the completion of the exploration?

Thanks,

Adrian

From: bcause <[email-masked]> On Behalf Of KEN KO
Sent: 25 March 2019 12:51
To: Miaofuyou (Miao Fuyou) <[email-masked]>; Rajesh A Shinde <[email-masked]>; Gregory Dalle <[email-masked]>
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>; [email-masked]
Subject: Re: [bcause] 答复: interest and scope?

Best regards,

Ken

Cc: Wadhwa, Sanjay (Nokia - US/Mountain View); [email-masked] <mailto:[email-masked]> 

Hi Rajesh,

Miao

发件人：Rajesh A Shinde <[email-masked] <mailto:[email-masked]> >

收件人：Gregory Dalle <[email-masked] <mailto:[email-masked]> >;Miaofuyou (Miao Fuyou) <[email-masked] <mailto:[email-masked]> >

抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked] <mailto:[email-masked]> >;[email-masked] <[email-masked] <mailto:[email-masked]> >

时间：2019-03-24 08:07:30

Hello All,

~ Rajesh

From: Gregory Dalle <[email-masked] <mailto:[email-masked]> > 
Sent: Saturday, March 23, 2019 7:16 PM
To: Miaofuyou (Miao Fuyou) <[email-masked] <mailto:[email-masked]> >
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [bcause] 答复: interest and scope?

Hi Miao,

Greg

On Mar 22, 2019, at 1:57 PM, Miaofuyou (Miao Fuyou) <[email-masked] <mailto:[email-masked]> > wrote:

Hi,

--------------------------------------------------
苗福友 Miao Fuyou
M: +86-18911316478 <tel:+86-18911316478> (优先)
E: [email-masked] <mailto:[email-masked]> 
产品与解决方案-网络标准专利部
Products & Solutions-Network Standard & Patent Dept

发件人：Gregory Dalle <[email-masked] <mailto:[email-masked]> >

收件人：Miaofuyou (Miao Fuyou) <[email-masked] <mailto:[email-masked]> >

抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked] <mailto:[email-masked]> >;[email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >

时间：2019-03-22 16:28:33

Hi Miao,

Greg

> On Mar 22, 2019, at 5:34 AM, Miaofuyou (Miao Fuyou) <[email-masked] <mailto:[email-masked]> > wrote:
> 
> Hi Sanjay,
> 
> https://protect-us.mimecast.com/s/bGFrCn56P9cGrnj2i96cRy?domain=urldefense.proofpoint.com <https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_PFCP&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=v33MW1QfVNSlFntCd34LCmRjivIDxqexEzoS7I2lpNo&e=> 
> 
> 收件人: [email-masked] <mailto:[email-masked]> 
> [email-masked] <mailto:[email-masked]> 
> https://protect-us.mimecast.com/s/PNWgCo2XPgFX6kZRczaAOu?domain=urldefense.proofpoint.com <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=> 
> -- 
> bcause mailing list
> [email-masked] <mailto:[email-masked]> 
> https://protect-us.mimecast.com/s/PNWgCo2XPgFX6kZRczaAOu?domain=urldefense.proofpoint.com <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=>

---

From: KEN KO <[email-masked]>
Date: Tue, 26 Mar 2019 12:15:22 +0000

Adrian,

That’s a very good set of questions. I suspect this was discussed in the BoF and I’m looking forward to listening to the recording. Having said that, I’ll respond anyway …  I would note that the BBF indicated in a liaison to IETF dated 17 December 2018 that they had already initiated work investigating the applicability of PFCP with extensions to FMC CUPS. I would expect that a similar investigation regarding BNG CUPS could reuse a substantial part of that work. And as noted in a different thread, BBF is currently defining requirements for the disaggregated BNG including specification of appropriate CUPS protocols by reference. So speaking for myself, I think there is already some momentum within BBF for this work.

Speaking of liaisons - BBF and IETF have a healthy liaison relationship and regardless of where this work is performed, I would expect that to continue. I think that speaks to how the two organizations would communicate status and issues. And – of course – most of the interested parties are already working within both organizations, and all are welcome to join.

Ken
This message has been classified General Business by KEN KO on Tuesday, March 26, 2019 at 8:15:21 AM.

From: bcause [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Monday, March 25, 2019 6:04 PM
To: KEN KO; 'Miaofuyou (Miao Fuyou)'; 'Rajesh A Shinde'; 'Gregory Dalle'
Cc: 'Wadhwa, Sanjay (Nokia - US/Mountain View)'; [email-masked]
Subject: Re: [bcause] 答复: interest and scope?

Thanks,
Adrian

Best regards,
Ken

Cc: Wadhwa, Sanjay (Nokia - US/Mountain View); [email-masked]<mailto:[email-masked]>

Hi Rajesh,

Miao
发件人：Rajesh A Shinde <[email-masked]<mailto:[email-masked]>>
收件人：Gregory Dalle <[email-masked]<mailto:[email-masked]>>;Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>>
抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>
时间：2019-03-24 08:07:30
主 题：RE: [bcause] 答复: interest and scope?

Hello All,
Basically, we should not have always new protocol, if we can manage with existing, well best fit protocol like PFCP as operationally it would be easier and skillset expectation would also meet from Telco perspective.
I will not be in Prague, however expect to have healthy discussions keeping telco perspective in mind.
~ Rajesh
From: Gregory Dalle <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, March 23, 2019 7:16 PM
To: Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>>
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bcause] 答复: interest and scope?
Hi Miao,
I am confident that PFCP can also be used for BNG. If you look at 4G, PFCP is used in 3 different use cases (for reference, Sxa, Sxb and Sxc) - each with distinct set of requirements. Quite flexible.
I will not be in Prague but I hope you will have good discussions.
Greg

Greg

> https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_PFCP&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=v33MW1QfVNSlFntCd34LCmRjivIDxqexEzoS7I2lpNo&e=<https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_PFCP&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=v33MW1QfVNSlFntCd34LCmRjivIDxqexEzoS7I2lpNo&e=>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=>
> --
> bcause mailing list
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=>