Subject: Re: [bcause] PFCP not equal to FMC, Why not choose PFCP

From: David Sinicrope <[email-masked]>
Date: Fri, 29 Mar 2019 16:22:10 +0000

(IETF Liaison Manager to the BBF hat on)

As I emphasized in the presentation during the BoF, the Broadband Forum is a membership organization. As such,  BBF contributions and work in progress are restricted to members except where the material is liaised (via BBF process) to other organizations.  The BBF contribution material and meeting proceedings information in the email below has not been liaised by BBF to IETF.  Any statements concerning the BBF meetings, contributions, work in progress, etc. do not represent statements from the BBF unless conveyed in a liaison from the BBF or via authorized BBF liaison representatives.

Please, when discussing the BBF and its work, those who are affiliated with BBF member companies should be mindful of the information they distribute, respecting and adhering to their BBF membership agreement that has granted them access to the BBF information.   Each organization works according to its own rules, agreements, processes and procedures – please respect this.

Thank-you,
Dave

From: bcause <[email-masked]> on behalf of "Songjun (Network)" <[email-masked]>
Date: Friday, March 29, 2019 at 2:24 PM
To: "[email-masked]" <[email-masked]>
Subject: [bcause] PFCP not equal to FMC, Why not choose PFCP

1.       PFCP is not important for FMC

Mobile core is keeping evolution. PFCP must follow on it.

The CUPS interfaces are different between mobile core and BNG.

vBNG-UP and vEPC-UP will run in VM or Container independently. We can do FMC now basing on large-scale deployed protocols (PFCP and S-CUSP), and keep smooth evolution following the development of mobile network and fixed network.

We can guarantee there is PFCP in 6G and 7G. The latest information from 3GPP, they are discussing to change the mechanism between UPF and SMF.

Using PFCP is not equal to implement FMC.

2.       Why not choose PFCP
Why 3GPP not reuse Openflow?

ü  PFCP use the openflow mechanism, openflow was a mature protocol then.

ü  3GPP has its own requirements, using UDP for high throughput.

ü  Defining mobile standard in ONF makes no sense.
Why we did not choose PFCP?

ü  In 2016, we studied Openflow and PFCP, and discussed with PFCP editor (Peter from Huawei).

ü  We found that nearly all requirements of BNG were needed to extended in current protocol. That seems to rewrite a new protocol.

ü  Reusing Openflow and PFCP, the CUSP will be heavily affected by ONF and 3GPP. Discussing BNG in ONF and 3GPP makes no sense.

ü  We decided to define a new protocol with good points from Openflow and PFCP in IETF for BNG.

ü  Mobile core can not use PFCP for interworking with different vendors now in technical reason.

ü  When talking about using PFCP, let me recall the story of T-MPLS(MPLS-TP).  IETF asked ITU-T to stop using MPLS or standardize T-MPLS in IETF.  ITU-T lost the control of T-MPLS, and the standard process was delayed.

3.       DBNG story in BBF

ü  I attended last two BBF meetings.  I found that they want to put everything into MS-BNG, as the following picture. According to Nokia’s IETF Draft, EPC and 5GC will also be input into it.

ü  If just put all function together without any changes of outside interfaces and protocols, it is an implementation issues, not a standard issues. We can do it now because we have all related products.

ü  If needing converging functions and changing protocols, someone said that the work could be finished in 5 month.  I do not believe that it can be finished based on running code instead of paperwork.

ü  There are about 20 people attend ATA meeting, with more than 1/3 from Huawei and ZTE.

BTW, this picture was rejected in BBF. It is not easy to draw a clear picture including all functions, even to me.

4.       Suggest IETF  start CUPS protocols for BNG

ü  CU separation is an internal mechanism, unaware to outside, without adding new functions and changing current protocols. TR-384 shows how to separate the functions into CP and UP, it is enough to start the protocols design, basing on running code and scale deployment.

ü  Most BNG in current and in near future, will be used for fixed network users. Requirements on fixed BNG is clear and urgent. How to do FMC is still in discussion, with multiple ways to support it.

ü  S-CUSP’s running code is 1/10 of PFCP, because of the different service requirement. CUSP for BNG is a very lightweight protocol, because fixed user does not migrate, always on line, very simple billing. BNG-UP can still forwarding, without BNG-CP. Mobile core reverses. Of cause, we can absorb the good points of Openflow and PFCP.

ü  IETF is the right place to define a protocol for BNG, 3GPP is the right place to extend PFCP.

ü  If using PFCP and including unclear FMC functions, we will mesh 3 SDOs together, many device functions(BNG,AC,TWAF,HAG,EPC,5GC) together. When can we meet the real IP network requirements?

5.       How to deal with FWA requirements, such as HAG?

ü  HAG can be deployed independently or with BNG. CUPS HAG can be added in WT378, with its owner CUSP..

ü  Venders can provide independent HAG or integrated HAG with BNG according Carrier’s requirements.

ü  Optimization on integrated HAG is a kind of vendor’s implementation, not standard issues.

ü  CUSP for HAG can be defined according to HAG requirements, with smooth independent evolution.

Simple and Flexible are the keys for success of IP network, when you think about Ethernet/IP against ATM.

---

From: "Songjun (Network)" <[email-masked]>
Date: Fri, 29 Mar 2019 17:28:52 +0000

Got your points.  I just want everyone think it over the fact. I also hope that we discuss only the IETF issues in IETF.

I will only post public TR of BBF. Thank for your notification.

I forgot posting the CUPS BNG architecture in published TR384, which  clearly defined the functions in CP and UP. No changes in north interfaces and data interfaces of BNG.

发件人: David Sinicrope [mailto:[email-masked]]
发送时间: 2019年3月30日 0:22
收件人: Songjun (Network)
抄送: [email-masked]; Brian Trammell (IETF)
主题: Re: [bcause] PFCP not equal to FMC, Why not choose PFCP

Thank-you,
Dave

2.       Why not choose PFCP

•  PFCP use the openflow mechanism, openflow was a mature protocol then.

•  3GPP has its own requirements, using UDP for high throughput.

•  Defining mobile standard in ONF makes no sense.
Why we did not choose PFCP?

•  In 2016, we studied Openflow and PFCP, and discussed with PFCP editor (Peter from Huawei).

•  We found that nearly all requirements of BNG were needed to extended in current protocol. That seems to rewrite a new protocol.

•  Reusing Openflow and PFCP, the CUSP will be heavily affected by ONF and 3GPP. Discussing BNG in ONF and 3GPP makes no sense.

•  We decided to define a new protocol with good points from Openflow and PFCP in IETF for BNG.

•  Mobile core can not use PFCP for interworking with different vendors now in technical reason.

•  When talking about using PFCP, let me recall the story of T-MPLS(MPLS-TP).  IETF asked ITU-T to stop using MPLS or standardize T-MPLS in IETF.  ITU-T lost the control of T-MPLS, and the standard process was delayed.

3.       DBNG story in BBF

•  I attended last two BBF meetings.  I found that they want to put everything into MS-BNG, as the following picture. According to Nokia’s IETF Draft, EPC and 5GC will also be input into it.

•  If just put all function together without any changes of outside interfaces and protocols, it is an implementation issues, not a standard issues. We can do it now because we have all related products.

•  If needing converging functions and changing protocols, someone said that the work could be finished in 5 month.  I do not believe that it can be finished based on running code instead of paperwork.

•  There are about 20 people attend ATA meeting, with more than 1/3 from Huawei and ZTE.

•  CU separation is an internal mechanism, unaware to outside, without adding new functions and changing current protocols. TR-384 shows how to separate the functions into CP and UP, it is enough to start the protocols design, basing on running code and scale deployment.

•  Most BNG in current and in near future, will be used for fixed network users. Requirements on fixed BNG is clear and urgent. How to do FMC is still in discussion, with multiple ways to support it.

•  S-CUSP’s running code is 1/10 of PFCP, because of the different service requirement. CUSP for BNG is a very lightweight protocol, because fixed user does not migrate, always on line, very simple billing. BNG-UP can still forwarding, without BNG-CP. Mobile core reverses. Of cause, we can absorb the good points of Openflow and PFCP.

•  IETF is the right place to define a protocol for BNG, 3GPP is the right place to extend PFCP.

•  If using PFCP and including unclear FMC functions, we will mesh 3 SDOs together, many device functions(BNG,AC,TWAF,HAG,EPC,5GC) together. When can we meet the real IP network requirements?

•  HAG can be deployed independently or with BNG. CUPS HAG can be added in WT378, with its owner CUSP..

•  Venders can provide independent HAG or integrated HAG with BNG according Carrier’s requirements.

•  Optimization on integrated HAG is a kind of vendor’s implementation, not standard issues.

•  CUSP for HAG can be defined according to HAG requirements, with smooth independent evolution.

---

From: "Songjun (Network)" <[email-masked]>
Date: Mon, 1 Apr 2019 01:09:42 +0000

I will only post public TR of BBF.

I forgot posting the CUPS BNG architecture in TR384, which  clearly defined the functions in CP and UP. No changes in north interfaces and data interfaces of BNG.

Thank-you,
Dave

2.       Why not choose PFCP

3.       DBNG story in BBF