Subject: Re: [bcause] 答复: interest and scope?

From: <[email-masked]>
Date: Fri, 22 Mar 2019 23:06:27 +0800 (CST)

it makes more sense addressing the dominantuse cases and clarify requirements wrt DBNG at this moment to see what expertise could be leveraged in IETF. The idea of one size fits all of course would be fantastic, but convergence means far beyond unifying everything when it comes to various senarios. Bng and the additional capabilities this wg is expected to address bring a huge portfolio of requirements which do not have to be under one protocol which is neither the industry practice nor buseniss sensible, when there exists strong market deployment wrt DBNG while viability of pfcp extension to encapsulate all is far from being defined.

发自我的zMail

原始邮件

发件人：Miaofuyou(MiaoFuyou)<[email-masked]>;
收件人：Wadhwa, Sanjay (Nokia - US/Mountain View)<[email-masked]>;[email-masked]<[email-masked]>;
日期：2019-03-22 10:34:17
主题：[bcause] 答复: interest and scope?

Hi Sanjay,

Wikipedia says: "PFCP's scope is similar to that of OpenFlow, however it was engineered to serve the particular use-case of Mobile Core Networks. PFCP lacks the same general-purpose targets, describing well the 3GPP-specific functional basic blocks of packet forwarding used in 2G, 3G, 4G/LTE, Non-3GPP WiFi and 5G networks." 

https://en.wikipedia.org/wiki/PFCP

Even so, it doesn't mean PFCP could not to be extended or changed to do more. However, there have to be an thorough analysis to PFCP to figure out what extension or change is needed. Otherwise, it's only intention expression rather than facts statement, which is not helpful to progress the work.

- Miao

-----邮件原件-----
发件人: bcause [mailto:[email-masked]] 代表 Wadhwa, Sanjay (Nokia - US/Mountain View)
发送时间: 2019年3月21日 23:39
收件人: [email-masked]
主题: Re: [bcause] interest and scope?

Hi
>From most of the posts, it is quite clear convergence is an important consideration.
To be specific, with the right interfaces and functions on BNG, one can use current BNG deployed base to offer existing residential services over any of fixed-access, fixed-wireless (e.g. with LTE, LTE/CBRS, 5G NSA) or hybrid-access. Additionally, as mentioned in another post there is ongoing work for integrating fixed-access with 5GC via an adaptation function (AGF) to use a multi-access SMF/UPF. 
Using a particular option at a given time may be a decision based on ROI, state of the network or other constraints. However, going from one access to another on BNGs or 5GC SMF/UPF should not require a new baseline CUPS protocol, but rather extensions to a common protocol. The extensions mainly confine to the state information carried by the protocol based on access-facing and network-facing interface encapsulations on the network-element. Network elements can include BNG, AGF, SGW/PGW, TDF, 5GC SMF/UPF. Some of the functions provided by these network elements may be combined or instantiated on the same platform. 
Therefore, an access or use-case specific CUPS protocol is a dead-end. A common CUPS protocol that enables convergence will provide flexibility to evolve the network without worrying about yet another variable. Extending an existing standard protocol that is already purpose built for large scale state exchange is a sound way forward for BNG CUPS. With above in mind, we have considered PFCP applicability for BNG CUPS (irrespective of access) for some time now, including required PFCP IEs. Existing IETF drafts have covered BNG CUPS architecture and requirements that are addressed by PFCP. 

Thanks
-Sanjay

-- 
bcause mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bcause
-- 
bcause mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bcause

---

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Sun, 24 Mar 2019 09:11:40 +0000

Hi Rajesh,

In principle, I agree. But, the problem is how much could be reused. If not much, it will hurt  rahter than benefit to implementation, deployment and operation. So, finally it depends on details, which is not revealed yet.

Miao
发件人：Rajesh A Shinde <[email-masked]>
收件人：Gregory Dalle <[email-masked]>;Miaofuyou (Miao Fuyou) <[email-masked]>
抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>;[email-masked] <[email-masked]>
时间：2019-03-24 08:07:30
主 题：RE: [bcause] 答复: interest and scope?

Hello All,
Basically, we should not have always new protocol, if we can manage with existing, well best fit protocol like PFCP as operationally it would be easier and skillset expectation would also meet from Telco perspective.
I will not be in Prague, however expect to have healthy discussions keeping telco perspective in mind.
~ Rajesh
From: Gregory Dalle <[email-masked]>
Sent: Saturday, March 23, 2019 7:16 PM
To: Miaofuyou (Miao Fuyou) <[email-masked]>
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>; [email-masked]
Subject: Re: [bcause] 答复: interest and scope?
Hi Miao,
I am confident that PFCP can also be used for BNG. If you look at 4G, PFCP is used in 3 different use cases (for reference, Sxa, Sxb and Sxc) - each with distinct set of requirements. Quite flexible.
I will not be in Prague but I hope you will have good discussions.
Greg

On Mar 22, 2019, at 1:57 PM, Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks for sharing the analysis is on-going!

My limited knowledge to 3GPP is WiFi is considered as a complement access technology for 3GPP technology, while BNG is not. I am not confident that BNG case could be supported by PFCP, that is why analysis is required and someone is working on it, as you said.

--------------------------------------------------
苗福友 Miao Fuyou
M: +86-18911316478<tel:+86-18911316478>(优先)
E: [email-masked]<mailto:[email-masked]>
产品与解决方案-网络标准专利部
Products & Solutions-Network Standard & Patent Dept
发件人：Gregory Dalle <[email-masked]<mailto:[email-masked]>>
收件人：Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>>
抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
时间：2019-03-22 16:28:33
主 题：Re: [bcause] 答复: interest and scope?
Hi Miao,

You are right about the need to analyze gaps in PFCP to support wireline access. BNG experts have started this analysis at BBF and we hope to hear back soon.

Thanks for sharing the Wikipedia article. So PFCP supports 4G, 5G and non-3GPP (wifi)? That’s quite a broad range of broadband scenarios. Doesn’t it make you confident that wireline can be added to the list?

Greg

> On Mar 22, 2019, at 5:34 AM, Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi Sanjay,
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_PFCP&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=v33MW1QfVNSlFntCd34LCmRjivIDxqexEzoS7I2lpNo&e=
>
> 收件人: [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=
> --
> bcause mailing list
> [email-masked]<mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bcause&d=DwIGoQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=VhX0NAIO1d7yQxdURKFPY59GAxttnQcfkn45tfRnREs&m=gOeAY5qlTZQYncH2IgwljFZF9fv348WkEwyxOr9dtm4&s=4-NoEEHrIaJhrv1W6ZcntpGAspFt-yPgcVI53rwnsNM&e=

---

From: "Muley, Praveen (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 25 Mar 2019 05:25:13 +0000

Hi :
      Having worked on proto-type I can only say that we could re-use 90% of PFCP constructs for BNG. What you need is more extensions for existing IEs to carry some matching criteria and L2 specific parts.  The benefit one gets is there are already constructs  to program uplink and downlink cross-connect and to generically program match criteria and to stitch the forwarding to right context based on slice and VPRNS using PDI/PDRs/FARs.  It also has all the details to collect statistics to carry information needed for offline/online charging using URRs .   As others commented just like Sxa/b/c . We can have Sxd for BNG.   Details can be discussed once we pass through initial architecture issue.
                While discussing CUPS for BNG , I don’t think we should discuss this from limited use case point of view because FMC is an important use case  and CUPS helps in achieving it much cleaner while leveraging existing BNG deployment.  All the policy/charging/authentication  interfaces can be converged.
                 The other use case is the hybrid access where you have both 3GPP and non-3GPP access bonded together and this makes it more so important to make the choice of protocol to be more compatible to both access types. PFCP in that sense makes it more obvious choice for BNG CUPS.
                        Being author of hybrid access draft, we will cover the CUPS scenario  in the updated version of our draft.  Link to current version of draft.
https://tools.ietf.org/html/draft-muley-network-based-bonding-hybrid-access-03

Thanks,
Praveen

From: bcause <[email-masked]> On Behalf Of Miaofuyou (Miao Fuyou)
Sent: Sunday, March 24, 2019 2:12 AM
To: Rajesh A Shinde <[email-masked]>; Gregory Dalle <[email-masked]>
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>; [email-masked]
Subject: Re: [bcause] 答复: interest and scope?

Hi Rajesh,

Miao
发件人：Rajesh A Shinde <[email-masked]<mailto:[email-masked]>>
收件人：Gregory Dalle <[email-masked]<mailto:[email-masked]>>;Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>>
抄 送：Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>
时间：2019-03-24 08:07:30
主 题：RE: [bcause] 答复: interest and scope?

Hello All,
Basically, we should not have always new protocol, if we can manage with existing, well best fit protocol like PFCP as operationally it would be easier and skillset expectation would also meet from Telco perspective.
I will not be in Prague, however expect to have healthy discussions keeping telco perspective in mind.
~ Rajesh
From: Gregory Dalle <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, March 23, 2019 7:16 PM
To: Miaofuyou (Miao Fuyou) <[email-masked]<mailto:[email-masked]>>
Cc: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bcause] 答复: interest and scope?
Hi Miao,
I am confident that PFCP can also be used for BNG. If you look at 4G, PFCP is used in 3 different use cases (for reference, Sxa, Sxb and Sxc) - each with distinct set of requirements. Quite flexible.
I will not be in Prague but I hope you will have good discussions.
Greg

Greg