Subject: [Ietf-calsify] RDATE vs. DTEND/DURATION clarification

From: tantek at technorati.com (Tantek Çelik)
Date: Thu May 12 14:39:50 2005

In my opinion it is not clear in the spec (either RFC2445 or the  
iCal-BASIC draft) what a CUA is supposed to do when it sees *both* an  
RDATE and DTEND in a VEVENT, or both an RDATE and DURATION in a VEVENT.

E.g.:

BEGIN:VEVENT
LOCATION:University of Technology Sydney (UTS)\, Sydney\, Australia
SUMMARY:Web Essentials 05
DTEND:20050930T093000Z
DTSTART:20050928T230000Z
URL:http://we05.com/
RDATE;VALUE=PERIOD:20050928T230000Z/20050929T0800Z,20050929T213000Z/ 
20050930T0930Z
END:VEVENT

The RDATE is saying this event takes place in two discrete chunks over  
the course of two days.

The DTSTART/DTEND combo is saying the event takes place for 34.5 hours  
straight.

Which should the CUA "choose" from those two options?

Is this an invalid VEVENT?

Thanks,

Tantek

--
Tantek ?elik
Senior Technologist, Technorati, Inc.
[email-masked]

--
Tantek ?elik
Technorati, Inc.
[email-masked]
415-254-9656 (Mobile)

---

From: Doug at Royer.com (Doug Royer)
Date: Thu May 12 15:14:18 2005

Skipped content of type multipart/mixed-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 4696 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050512/d02b761c/smime.bin

---

From: tantek at technorati.com (Tantek Çelik)
Date: Thu May 12 15:43:02 2005

But look at the times.

The first instance overlaps the other two entirely.

Are you saying that is valid?

And if so, how is a CUA possibly expected to represent that in some 
meaningful form to the user?

Warn them that two or more instances of the same meeting are occurring 
at the same time?

The spec says that exact RRULE/RDATE event instance duplicates are 
supposed to be tossed, but says nothing about having the same meeting 
take place twice at the same time which makes no sense.  Why is it 
useful for the spec to allow this?

How do implementations handle/display/edit this VEVENT?

Thanks,

Tantek

On May 13, 2005, at 7:14 AM, Doug Royer wrote:

>
> It has 3 instances, not 2.
>
> iCal-Basic deprecated DTEND, so it would be (assuming I
> did my time math correctly:
>
>  BEGIN:VEVENT
>  DURATION:+PT34H30M
>  RDATE;VALUE=PERIOD:20050928T230000Z/PT9H,20050929T213000Z/PT20H30M
>  END:VEVENT
>
> The first instance starts at 0050928T230000Z and ends 34.5 hours later.
> The second instance starts at 20050928T230000Z and ends 9.0 hours 
> later.
> The third instance starts at 20050929T213000Z and ends 20.5 hours 
> later.
>
> Tantek ?elik wrote:
>> The RDATE is saying this event takes place in two discrete chunks 
>> over  the course of two days.
>> The DTSTART/DTEND combo is saying the event takes place for 34.5 
>> hours  straight.
>> _______________________________________________
>> Ietf-calsify mailing list
>> [email-masked]
>> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify
>
> -- 
>
> Doug Royer                     | http://INET-Consulting.com
> -------------------------------|-----------------------------
>
>               We Do Standards - You Need Standards
>
> <Doug.vcf>_______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify
>

---

From: Doug at Royer.com (Doug Royer)
Date: Thu May 12 17:29:48 2005

Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050512/3d4e7d17/smime-0001.bin

---

From: tantek at technorati.com (Tantek Çelik)
Date: Thu May 12 17:47:34 2005

Thanks for the answers Doug.  Some follow up below.

On May 12, 2005, at 5:29 PM, Doug Royer wrote:

> Yes.
> Odd - yes. Valid - yes.
>> Warn them that two or more instances of the same meeting are 
>> occurring at the same time?
>
> That's up to the CUA.
>
> I do not recall there being a discussion on this topic.
>
> Might be a good discussion.
>
> Where iCal-Basic says (4.10.3  Recurrence Date/Times,
> page 82):
>
>
>   ...Where duplicate instances are generated by the "RDATE"
>   properties, only one recurrence is considered. ...
>
>
> If iCal-Basic said:
>
>   ...Where duplicate instances are generated by the "RDATE"
>   properties, only one recurrence is considered.
>   All instance times in a "VEVENT" component with the
>   same "UID" property value MUST NOT overlap each other.
>   ...
>
> (I need to spend more time on the exact language)
>
> Would anyone object?

Reinhold said something that made it immediately obvious to me why this 
made sense.

On May 12, 2005, at 3:53 PM, Reinhold Kainhofer wrote:

> Am Freitag, 13. Mai 2005 00:42 schrieb Tantek ?elik:
>> take place twice at the same time which makes no sense. ?Why is it
> Because an event is not neccessarily a meeting, where you can only 
> attend
> once...
>
> Reinhold

Thanks Reinhold.  Your explanation made me think of the following 
example:

A museum tour that leaves on the hour every hour while the museum is 
open, from the information desk, and lasts two hours, with the last one 
of the day leaving two hours before the museum closing time.

Doug, what do you think, would that be a reasonable use of overlapping 
repeating event times?

> You would have to try different CUA's to find out.

Well I tried MacOSX iCal.app 1.5.5 (v670) and was disheartened to learn 
that it looks like it has NO SUPPORT FOR RDATE.  :(

I'm beginning to understand the pain some of the veterans of this list 
have been dealing with.

Tantek

---

From: Doug at Royer.com (Doug Royer)
Date: Thu May 12 21:33:55 2005

Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050512/b8b31c41/smime.bin

---

From: sroberts at uniserve.com (Sam Roberts)
Date: Fri May 13 16:31:17 2005

> I'm beginning to understand the pain some of the veterans of this list 

Some of those veterans are trying to deprecate RRULE (which iCal.app
does support) in favor of always using RDATE. Its not clear that this
will cause a decrease in pain.

Cheers,
Sam

---

From: Doug at Royer.com (Doug Royer)
Date: Fri May 13 16:38:35 2005

Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050513/3f5b41af/smime.bin

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Fri May 13 17:44:16 2005

> will cause a decrease in pain.

KOrganizer also doesn't support RDATE (it simply doesn't fit the typical 
recurrence pattern that an ordinary user would use).

Reinhold
-- 
------------------------------------------------------------------
Reinhold Kainhofer, Vienna, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at
 * K Desktop Environment, http://www.kde.org/, KOrganizer / KPilot maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050514/14e83d9c/attachment.bin