Subject: [Ietf-calsify] [Fwd: icalendar feeds for network/tech meeting calendar]

From: lear at cisco.com (Eliot Lear)
Date: Fri Jun 9 11:35:21 2006

FYI
-------------- next part --------------
An embedded message was scrubbed...
From: Joe Abley <[email-masked]>
Subject: icalendar feeds for network/tech meeting calendar
Date: Fri, 9 Jun 2006 12:40:53 -0400
Size: 5360
Url: http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20060609/53914fce/techmeetingcalendar.mht

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Fri Jun 9 14:08:38 2006

Am Freitag, 9. Juni 2006 20:35 schrieb Eliot Lear:
> Encapsulated message
>   icalendar feeds for network/tech meeting calendar
>   To: IETF Discussion <[email-masked]>
>   Date: Today 18:40:53
>   ?
> This is not especially on-topic here, but since (a) there are ?
> probably more people here who have an interest in debugging/reviewing ?
> RFC 2445 documents than anywhere else and (b) there are probably more ?
> people here for whom a maintained calendar of meetings is a wildly ?
> useful thing, I thought I'd forward it.
>
> Hervey Allen is the programmer responsible for the code, and I know ?
> he would love to receive feedback. 

Thanks a lot for the links. Unfortunately the files are not entirely correct 
iCalendar. I admit it's only a small flaw, and doesn create any problems as 
far as I can see, but they use local-time values for DTSTAMP:

DTSTAMP:20060609T041633

RFC 2445, however, clearly says that DTSTAMP MUST be in UTC (see "4.8.7.2 
Date/Time Stamp"):
" Description: The value MUST be specified in the UTC time format."

> I believe all testing to date has  
> been done with Apple's iCal and Mozilla Sunbird.

I opened the wrc-all.ics calendar with korganizer and it seems to work just 
fine (at least the dates coincide with the table on the web page, and the 
titles seem correct, too).

And an additional suggestion:
As each workshop has its own information page, you can attach the 
corresponding URL to the event:
ATTACH:http://ws.edu.isoc.org/helpfiles/workshop_info_main.php?id=175

Several calendaring applications (e.g. korganizer) then show a link to this 
page in the preview pane for the event.

Cheers,
Reinhold
- -- 
- ------------------------------------------------------------------
Reinhold Kainhofer, Vienna, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at
 * K Desktop Environment, http://www.kde.org/, KOrganizer maintainer
 * Chorvereinigung "Jung-Wien", http://www.jung-wien.at/

---

From: hervey at nsrc.org (Hervey Allen)
Date: Mon Jun 12 09:57:24 2006

Reinhold Kainhofer wrote:

>> Hervey Allen is the programmer responsible for the code, and I know  

Thank you Reinhold! So, I dug a bit deeper. It appears that 
what I was basically missing is the "Z" designator at the 
end of the UTC timestamp for DTSTAMP and that seconds don't 
appear to be necessary according to the samples given in the 
RFC:

http://www.ietf.org/rfc/rfc2445.txt

Currently DTSTAMP looks like this (as an example):

DTSTAMP:20060609T1535Z

Does this look OK to you?

> titles seem correct, too).

Cool. I had not tested with Korganizer and was hoping to 
find someone who would.

> page in the preview pane for the event.

I've added the ATTACH field per your suggestion. Is this 
working for you?

Thank you for the feedback. Very helpful.

Sincerely,
	Hervey
-- 
-------------------------------------------------
Hervey Allen      Network Startup Resource Center
[email-masked] GPG Key Fingerprint:
AC08 31CB E453 6C65 2AB3 4EDB CEEB 5A74 C6E5 624F