Subject: Survey of RRULE/COUNT behavior, was Re: [Ietf-calsify] RRULE's and COUNT

From: cyrus at daboo.name (Cyrus Daboo)
Date: Fri Oct 13 06:46:56 2006

Hi Reinhold,

--On October 13, 2006 10:12:13 AM +0200 Reinhold Kainhofer 
<[email-masked]> wrote:

>> We certainly have variation in implementations of this, I'd lean towards
>> following what 2445 said originally, rather than changing the meaning of
>> COUNT.
>
> Hehe, that's the problem: We have an argument about what 2445 originally
> said!  Apparently, I have a different opinion about that than you.

At this point maybe we need to get a count of which way implementations 
have gone in dealing with this before making a final decision. However, I 
do believe we must pick one way of doing it and make the new spec clear on 
that.

So I propose a survey:

1. Does your implementation treat the DTSTART instance as the first 
instance in a RRULE set, even if it does not match the RRULE itself?

 yes/no

2. What is the name/version of that implementation?

 ------

Assuming the above questions will solicit the right information we need, 
perhaps the chairs could formally ask this and tabulate the result?

-- 
Cyrus Daboo

---

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Fri Oct 13 08:03:41 2006

I propose a different survey.

1- Import the attached iCalendar object.

2- Report the dates of the recurrence instances generated by
    your calendar application:

    a) Monday,  October 16, 2006
       Tuesday, October 17, 2006
       Tuesday, October 24, 2006

    b) Monday,  October 16, 2006
       Tuesday, October 17, 2006
       Tuesday, October 24, 2006
       Tuesday, October 31, 2006

    c) Tuesday, October 17, 2006
       Tuesday, October 24, 2006
       Tuesday, October 31, 2006

Thanks,
Bernard

Cyrus Daboo wrote:
> have gone in dealing with this before making a final decision. However, 
> I do believe we must pick one way of doing it and make the new spec 
> clear on that.
> 
> So I propose a survey:
> 
-------------- next part --------------
BEGIN:VCALENDAR
PRODID:-//Bernard//vi//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Eastern Time (US & Canada)
BEGIN:STANDARD
DTSTART:20051030T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:Standard Time
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:20060402T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=1SU;BYMONTH=4
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:Daylight Savings Time
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
ORGANIZER:MAILTO:[email-masked]
DTSTART;TZID="Eastern Time (US & Canada)":20061016T173000
DTEND;TZID="Eastern Time (US & Canada)":20061016T180000
RRULE:FREQ=WEEKLY;COUNT=3;INTERVAL=1;BYDAY=TU;WKST=SU
TRANSP:OPAQUE
SEQUENCE:0
UID:[email-masked]
DTSTAMP:20061013T142548Z
SUMMARY:Test
PRIORITY:5
CLASS:PUBLIC
END:VEVENT
END:VCALENDAR

---

From: douglm at rpi.edu (Mike Douglass)
Date: Fri Oct 13 08:16:58 2006

For bedework I get option c

Bernard Desruisseaux wrote:
>> At this point maybe we need to get a count of which way 
>> implementations have gone in dealing with this before making a final 
>> decision. However, I do believe we must pick one way of doing it and 
>> make the new spec clear on that.
>>
>> So I propose a survey:
>>
>> Assuming the above questions will solicit the right information we 
>> need, perhaps the chairs could formally ask this and tabulate the 
>> result?
>>
> ------------------------------------------------------------------------
>
> BEGIN:VCALENDAR
> ------------------------------------------------------------------------
>
> _______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify
>   

-- 

Mike Douglass                           [email-masked]
Senior Systems Programmer
Communication & Collaboration Technologies      518 276 6780(voice) 2809
(fax)
Rensselaer Polytechnic Institute 110 8th Street, Troy, NY 12180

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Fri Oct 13 08:17:59 2006

Am Freitag, 13. Oktober 2006 17:01 schrieb Bernard Desruisseaux:
> ? ? your calendar application:

-) KOrganizer 3.5.5 (all versions behave the same): B
-) Evolution 2.6.3: B
-) Mozilla Sunbird 0.3: C
-) Google Calendar: B
-) Chandler 0.6.1: B
-) Chandler 0.7.1 (pre-release alpha): C
-) (php|e)Groupware: Don't support these events

Cheers,
Reinhold
-- 
------------------------------------------------------------------
Reinhold Kainhofer, Vienna University of Technology, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at/
 * K Desktop Environment, http://www.kde.org, KOrganizer maintainer
 * Chorvereinigung "Jung-Wien", http://www.jung-wien.at/

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Fri Oct 13 08:29:48 2006

> 1- Import the attached iCalendar object.

Outlook gives an error message... 
If anything, I think Outlook generates option C (if you try to create this 
object in the GUI, the DTSTART will not be used and the dialog shows that the 
recurrence is effectie Oct 17-Oct 31).

Cheers,
Reinhold

---

From: cyrus at daboo.name (Cyrus Daboo)
Date: Fri Oct 13 08:39:23 2006

Hi Bernard,

>        Tuesday, October 31, 2006

Apple iCal: a

Mulberry:   a

Apple Calendar Server (internal recurrence indexer) : a
(uses vobject python library)

-- 
Cyrus Daboo

---

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Fri Oct 13 09:56:18 2006

You need to add "METHOD:PUBLISH" in the iCalendar object to
import it with Outlook.

You are correct that Outlook generates option C.

Cheers,
Bernard