Subject: [Ietf-calsify] Wrong ABNF?

From: cyrus at daboo.name (Cyrus Daboo)
Date: Sat Feb 24 07:59:50 2007

Hi,
In 2445bis we have:

      QSAFE-CHAR    = WSP / %x21 / %x23-7E / NON-US-ASCII
      ; Any character except CONTROL, DQUOTE, ";", ":", ","

but in 2445 we had:

     QSAFE-CHAR = WSP / %x21 / %x23-7E / NON-US-ASCII
     ; Any character except CTLs and DQUOTE

Looks to me like the comment in 2445bis is wrong - it certainly does not 
agree with the character range specified by the ABNF.

Proposal: change the comment to the one in 2445.

BTW It still bothers me that you can't have a double-quote character in a 
parameter value, but I guess we have to live with that.

-- 
Cyrus Daboo

---

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Mon Feb 26 10:46:04 2007

Cyrus,

Good catch!  My mistake.  Will be fixed in -06.

Thanks,
Bernard

Cyrus Daboo wrote:
> BTW It still bothers me that you can't have a double-quote character in 
> a parameter value, but I guess we have to live with that.
>