Subject: [Ietf-calsify] Issue 27: DURATION/DTEND ?

From: Arnaud.Quillaud at Sun.COM (Arnaud Quillaud)
Date: Tue Apr 10 09:23:58 2007

Hello,

I have finally made the link between my comment regarding the latest draft (http://lists.osafoundation.org/pipermail/ietf-calsify/2007-April/001665.html) and Issue 27: DURATION/DTEND.

The main scenario that was discussed before changing the text for DTSTART/DTEND was (http://lists.osafoundation.org/pipermail/ietf-calsify/2006-October/001306.html):

<<
Example 2:

   DTSTART;TZID=America/Montreal:20070311T000000
   DTEND;TZID=America/Montreal:20070312T000000
   RRULE:FREQ=DAILY;COUNT=2

   The first instance start at midnight on March 11th, 2007 and is
   specified to end at midnight on March 12th, 2007. Given that on
   that day there is shift from standard time to daylight saving time,
   this instance will actually last 23 hours.

   I believe the duration of the recurrence instance on March 12th,
   2006 should be the "computed duration of the first instance",
   that is, 23 hours.

While this scenario helps to explain what problem we are trying to clarify, it is nevertheless a corner case since the first instance is on a DST boundary. 
Most of the time (more or less 99% of the time), people create recurring events starting on a day where no DST change occurs, and if they specify a start/end time, they expect this start/end time to be the same for all occurrences.

With the new rule (use the "computed duration of the first instance" for all instances), one can no longer create a recurring event that *always* starts at 22:00 and always ends at 6:00 the next day.

My feedback may come really late but I think this is fairly important + from my testing, the new text would also "break" Microsoft Outlook and Apple iCal.

Arnaud Q

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Tue Apr 10 09:39:02 2007

Am Dienstag, 10. April 2007 schrieb Arnaud Quillaud:
> With the new rule (use the "computed duration of the first instance" for
> all instances), one can no longer create a recurring event that *always*
> starts at 22:00 and always ends at 6:00 the next day.

That has never been possible anyway! It is not a new rule, but has always been 
the case. 
E.g. how would you determine the events for
   DTSTART;TZID=America/Montreal:20070311T000000
   DTEND;TZID=America/Montreal:20070312T000000
   RRULE:FREQ=HOURLY;COUNT=5;INTERVAL=12
if not by taking the duration of the initial event as the event for all 
remaining occurrences?

Cheers,
Reinhold

- -- 
- ------------------------------------------------------------------
Reinhold Kainhofer, Vienna University of Technology, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at/
 * K Desktop Environment, http://www.kde.org, KOrganizer maintainer
 * Chorvereinigung "Jung-Wien", http://www.jung-wien.at/