Subject: [Ietf-calsify] Proposal of "Collections of events"

From: lorenzo.detomasi at gmail.com (Lorenzo De Tomasi)
Date: Thu Aug 2 04:01:04 2007

I have read the draft and I think that it needs the support of
Collections of events.
Often, an event, especially when lasts more than one day, includes
other smaller events, contemporary or sequential, that can be
organized as chinese boxes.
Something like
<exhibition>
 <conference>
  <talk />
  <talk />
  ?
 </conference>
 <presentation>
  <movie />
  <talk />
  ?
 </presentation>
</exhibition>

or

<championship>
  <inauguration />
  <match />
  <match />
  ?
 <winner_proclamation />
</championship>

I think that should be possible to embed directly each child-event
into the father-event (as illustrated before in a simplified way) or
to describe separately each child-event and to link it to the
father-event, by a mutual (<->) relationship, like, for example, in
xfn [ http://en.wikipedia.org/wiki/XHTML_Friends_Network ]:

<event id="match1">
 ?
 <a rel="child_of" href="#championship" />
</event>
<event id="championship">
 ?
 <a href="parent_of" href="#match1" />
</event>

Also a single relationship (->) can be permitted,

<event id="match1">
 ?
</event>
<event id="championship">
 ?
 <a href="parent_of" href="#match1" />
</event>

or

<event id="match1">
 ?
 <a rel="child_of" href="#championship" />
</event>
<event id="championship">
 ?
</event>

but a mutual relationship is a stronger link, that offers a guarantee,
a  trusted certification of the link, especially if the informations
about the events are stored in different uris/urls.

In the future, webapps o apps will be able to automatically include
infos about child-events in the father-event, getting them directly
from other ical files, also through ajax technologies.

What do you think about this proposal?

Best regards

Ps: Tomorrow I'll leave for vacation and I'll come back on 19/08.
-- 
Lorenzo De Tomasi
Designer multimodale
http://www.ipernico.it
http://www.isotype.org (in costruzione)

---

From: TimHare at comcast.net (Tim Hare)
Date: Thu Aug 2 05:49:32 2007

This proposal, while interesting, is probably outside the scope of the WG.
The purpose of the WG was to try to simplify iCalendar and remove
impediments to interoperability between implementations. I don't think that
introducing new items will help interoperability at this time. (Note: I'm
not a member of the WG, just stating my opinion). 

Tim Hare
Interested Bystander, Non-Inc.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Lorenzo De
Tomasi
Sent: Thursday, August 02, 2007 7:00 AM
To: [email-masked]
Subject: [Ietf-calsify] Proposal of "Collections of events"

I have read the draft and I think that it needs the support of Collections
of events.
Often, an event, especially when lasts more than one day, includes other
smaller events, contemporary or sequential, that can be organized as chinese
boxes.
Something like
<exhibition>
 <conference>
  <talk />
  <talk />
  .
 </conference>
 <presentation>
  <movie />
  <talk />
  .
 </presentation>
</exhibition>

or

<championship>
  <inauguration />
  <match />
  <match />
  .
 <winner_proclamation />
</championship>

I think that should be possible to embed directly each child-event into the
father-event (as illustrated before in a simplified way) or to describe
separately each child-event and to link it to the father-event, by a mutual
(<->) relationship, like, for example, in xfn [
http://en.wikipedia.org/wiki/XHTML_Friends_Network ]:

<event id="match1">
 .
 <a rel="child_of" href="#championship" /> </event> <event
id="championship">  .  <a href="parent_of" href="#match1" /> </event>

<event id="match1">
 .
</event>
 .

or

<event id="match1">
 .
 <a rel="child_of" href="#championship" /> </event> <event
id="championship">  . </event>

but a mutual relationship is a stronger link, that offers a guarantee, a
trusted certification of the link, especially if the informations about the
events are stored in different uris/urls.

In the future, webapps o apps will be able to automatically include infos
about child-events in the father-event, getting them directly from other
ical files, also through ajax technologies.

Best regards

Ps: Tomorrow I'll leave for vacation and I'll come back on 19/08.
--
Lorenzo De Tomasi
Designer multimodale
http://www.ipernico.it
http://www.isotype.org (in costruzione)
_______________________________________________
Ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify