Subject: [ietf-calsify] FREEBUSY property in VFREEBUSY component

From: Ciny Joy <[email-masked]>
Date: Thu, 02 Apr 2009 10:56:18 -0700

Hi,
   What is the minimum number of FREEBUSY property fields required in a 
VFREEBUSY component? 0 or 1? iTIP says 1+ 
(http://tools.ietf.org/html/rfc2446#section-3.3.3) but Calsify says 0+ 
(http://tools.ietf.org/html/draft-ietf-calsify-2446bis-08#section-3.3.3).
    If it is 1, what should a FREEBUSY response look like if there are 
no events that take up time, during the time period? A freebusy property 
of type FREE for the entire slot?
    Today our server gives a response validation error on the following 
response. Wondering if it is valid.

HTTP/1.0 200
Date: Tue, 31 Mar 2009 00:22:34 GMT
Content-type: application/xml; charset=UTF-8
Content-length: 729
Last-modified: Tue, 31 Mar 2009 00:22:34 GMT
Pragma: no-cache
Expires: 0
Cache-Control: no-cache

<?xml version="1.0" encoding="utf-8" ?>
<C:schedule-response xmlns:D="DAV:"
       xmlns:C="urn:ietf:params:xml:ns:caldav">
<C:response>
 <C:recipient>
   <D:href>mailto:[email-masked]</D:href>
 </C:recipient>
 <C:request-status>2.0;Success</C:request-status>
 <C:calendar-data>BEGIN:VCALENDAR
PRODID:-//Sun/Calendar Server//EN
VERSION:2.0
METHOD:REPLY
BEGIN:VFREEBUSY
DTSTAMP:20040901T200200Z
ORGANIZER;mailto:[email-masked]
DTSTART:20090902T000000Z
DTEND:20090903T000000Z
UID:[email-masked]
ATTENDEE;CN="Praveen1 CN":mailto:[email-masked]
END:VFREEBUSY
END:VCALENDAR
</C:calendar-data>
</C:response>
</C:schedule-response>

Thanks,
Ciny
_______________________________________________
ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify

---

From: Cyrus Daboo <[email-masked]>
Date: Thu, 02 Apr 2009 13:58:40 -0400

Hi Ciny,

> response. Wondering if it is valid.

We (calsify) have decided that the original "1+" value was wrong, hence the 
change to "0+". I would suggest you change your implementation accordingly.

-- 
Cyrus Daboo

---

From: Ciny Joy <[email-masked]>
Date: Thu, 02 Apr 2009 11:10:34 -0700

Hi Cyrus,
    Thank you for clarifying that!

Ciny

On 04/02/09 10:58, Cyrus Daboo wrote:
> We (calsify) have decided that the original "1+" value was wrong, 
> hence the change to "0+". I would suggest you change your 
> implementation accordingly.