Subject: [calsify] Calendar discovery?

From: "Tim Hare" <[email-masked]>
Date: Mon, 12 Sep 2011 07:30:05 -0400

I haven't seen it, but I may have missed it.  

Have we developed a standard that allows an application to discover if a
particular site or URL has:

1. a calendar and its URL?
2. a free-busy calendar and its URL?

In my opinion,  there are use cases for discovery ("find a barber with an
appointment opening this afternoon" for example) that enable 'intelligent
agents' (or, more likely, smartphone apps ) to do their jobs for us .

Tim Hare
Interested Bystander, Non-Inc.

---

From: "Tim Hare" <[email-masked]>
Date: Mon, 12 Sep 2011 07:30:05 -0400

Tim Hare

_______________________________________________
calsify mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/calsify

---

From: "Tim Hare" <[email-masked]>
Date: Mon, 12 Sep 2011 09:43:03 -0400

I think (but I'm not 100% on this), that the discovery needs to be
independent of "protocols" like CalWS, CalDAV, etc.  - it would provide URLs
and capabilities perhaps, or URLs per protocol.

-----Original Message-----
From: Toby Considine [mailto:[email-masked]] On Behalf Of Toby
Considine
Sent: Monday, September 12, 2011 8:50 AM
To: 'Tim Hare'; [email-masked]; 'Calsify'
Subject: RE: [caldeveloper-l] Calendar discovery?

Don't forget a vavailability  and its url...
http://tools.ietf.org/id/draft-daboo-calendar-availability-02.txt

There are two parts of if this. CalWs (under development in both REST and
SOAP variants) should be able to handle (2) if you have (1).

There is another variant, the option of a registrar, i.e., a standards-based
doodle poll where the barbers in town could post these XML documents and
something else. I say something else, because it is unlikely that the
barbers want to convert themselves to pure commodities...

tc

"A designer knows he has achieved perfection not when there is nothing left
to add, but when there is nothing left to take away."
-Antoine de Saint-Exupery

Toby Considine
TC9, Inc
TC Chair: oBIX & WS-Calendar
TC Editor: EMIX, EnergyInterop
U.S. National Inst. of Standards and Tech. Smart Grid Architecture Committee

Email: [email-masked]
Phone: (919)619-2104
http://www.tcnine.com/
blog: www.NewDaedalus.com

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Tim Hare
Sent: Monday, September 12, 2011 7:30 AM
To: [email-masked]; 'Calsify'
Subject: [caldeveloper-l] Calendar discovery?

Tim Hare

_______________________________________________
caldeveloper-l mailing list
[email-masked]
http://lists.calconnect.org/mailman/listinfo/caldeveloper-l

---

From: "Tim Hare" <[email-masked]>
Date: Mon, 12 Sep 2011 09:43:03 -0400

-----Original Message-----

tc

Toby Considine
TC9, Inc

-----Original Message-----

Tim Hare