Subject: [calsify] [Technical Errata Reported] RFC5545 (3883)

From: RFC Errata System <[email-masked]>
Date: Wed, 5 Feb 2014 09:42:57 -0800 (PST)

The following errata report has been submitted for RFC5545,
"Internet Calendaring and Scheduling Core Object Specification (iCalendar)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5545&eid=3883

--------------------------------------
Type: Technical
Reported by: Bruce Florman <[email-masked]>

Section: 3.8.5.3

Original Text
-------------
      Every 3 hours from 9:00 AM to 5:00 PM on a specific day:

       DTSTART;TZID=America/New_York:19970902T090000
       RRULE:FREQ=HOURLY;INTERVAL=3;UNTIL=19970902T170000Z

       ==> (September 2, 1997 EDT) 09:00,12:00,15:00

Corrected Text
--------------
      Every 3 hours from 9:00 AM to 5:00 PM on a specific day:

       DTSTART;TZID=America/New_York:19970902T090000
       RRULE:FREQ=HOURLY;INTERVAL=3;UNTIL=19970902T190000Z

       ==> (September 2, 1997 EDT) 09:00,12:00,15:00

Notes
-----
The UNTIL rule part is specified with UTC time, which was four hours ahead of America/New_York on 19970902. So 170000Z would only be 1:00 PM on that day.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5545 (draft-ietf-calsify-rfc2445bis-10)
--------------------------------------
Title               : Internet Calendaring and Scheduling Core Object Specification (iCalendar)
Publication Date    : September 2009
Author(s)           : B. Desruisseaux, Ed.
Category            : PROPOSED STANDARD
Source              : Calendaring and Scheduling Standards Simplification
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Bernard Desruisseaux <[email-masked]>
Date: Wed, 5 Feb 2014 19:07:19 -0500

Issue is also in RFC2445.

I would specify UNTIL=19970902T210000Z to match the description (i.e., 5:00PM America/New_York)

Corrected Text
--------------

      DTSTART;TZID=America/New_York:19970902T090000
      RRULE:FREQ=HOURLY;INTERVAL=3;UNTIL=19970902T210000Z

Cheers,
Bernard