Subject: [calsify] Question re: DESCRIPTION and FMTTYPE

From: "Tim Hare" <[email-masked]>
Date: Tue, 6 May 2014 16:21:56 -0400

I am trying to build an .ics file which is standards compliant, using  a
non-calendaring tool which will write into a directory on my (mainframe)
server.   Ideally the description would contain HTML as it needs to contain
some links. The target audience uses Outlook so I saved an Outlook
appointment as an iCalendar file to see if there were any nuances I needed
to worry about - and I discovered that the DESCRIPTION contains only '\n'
and there is an X-ALT-DESC  property containing the HTML:

----------------------------------------------------------------------------
-------------------------------------------------------------

X-ALT-DESC;FMTTYPE=text/html:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//E

      N">\n<HTML>\n<HEAD>\n<META NAME="Generator" CONTENT="MS Exchange
Server ve

      rsion 08.00.0681.000">\n<TITLE></TITLE>\n</HEAD>\n<BODY>\n<!--
Converted f

      rom text/rtf format -->\n\n<P DIR=LTR><SPAN LANG="en-us"></SPAN><SPAN
LANG

      ="en-us"></SPAN><SPAN LANG="en-us"><FONT
FACE="Calibri"></FONT></SPAN><SPA

      N LANG="en-us"></SPAN><SPAN LANG="en-us"></SPAN><SPAN
LANG="en-us">&nbsp\;

      </SPAN></P>\n\n</BODY>\n</HTML>

----------------------------------------------------------------------------
----------

Reading RFC 5545 I thought that DESCRIPTION;FMTTYPE=text/html:  was possible
- but perhaps I read it wrong? Or is this a Microsoft-specific thing to
allow Outlook to render HTML within an appointment / meeting?

Any insights would be appreciated.

Thanks

Tim Hare

Hare Systems Support

[email-masked]

---

From: "Tim Hare" <[email-masked]>
Date: Tue, 6 May 2014 17:27:35 -0400

Hmmm it appears that there actually was no value in the DESCRIPTION field -
but Outlook still creates all of this HTML.   When I updated the description
both properties were populated.

From: calsify [mailto:[email-masked]] On Behalf Of Tim Hare
Sent: Tuesday, May 06, 2014 4:22 PM
To: [email-masked]
Subject: [calsify] Question re: DESCRIPTION and FMTTYPE

Thanks

Tim Hare

Hare Systems Support

---

From: "Tim Hare" <[email-masked]>
Date: Tue, 6 May 2014 17:42:41 -0400

More info.  In the DESCRIPTION  the hyperlinks I inserted into just show as
display text followed by <http://some_url_>  - example:  

First Report
<http://tlhost01t.dot.state.fl.us/dbatest/Report1_20140505.html> \n

While X-ALT-DESC: appears to have a full HTML 3.2 document and there is an
anchor tag for each so it looks like

<A href="
http://tlhost01t.dot.state.fl.us/dbatest/Report1_20140505.html">First
Report</A>

What is the correct way to put HTML into DESCRIPTION ?  Do I have to use
ALTREP and figure out how to put Content-Type into the file (note that I am
not e-mailing it, I'm writing it in a directory for someone else to "find")

Tim Hare

Hare Systems Support

  

From: Tim Hare [mailto:[email-masked]] 
Sent: Tuesday, May 06, 2014 5:28 PM
To: 'Tim Hare'; [email-masked]
Subject: RE: [calsify] Question re: DESCRIPTION and FMTTYPE

Thanks

Tim Hare

Hare Systems Support

---

From: Helge Hess <[email-masked]>
Date: Wed, 7 May 2014 10:24:53 +0200

Hi Tim,

first: I would be surprised if Outlook does RFC 5545 for iCalendar or will any time soon, it doesn’t even do vCard 3.0 ...

> Reading RFC 5545 I thought that DESCRIPTION;FMTTYPE=text/html:  was possible

interesting question - this is new in RFC 5545. Adding other-param and thereby iana-param to DESCRIPTION now seems to allow FMTTYPE on DESCRIPTION.
https://tools.ietf.org/html/rfc5545#section-3.8.1.5

Hence the X-ALT-DESC workaround of Outlook to be able to directly embed HTML descriptions in RFC 2445 … RFC 2445 didn’t have FMTTYPE on DESCRIPTION (https://tools.ietf.org/html/rfc2445#section-4.8.1.5).

I highly doubt that Outlook (or any other client) is going to resolve http or file URIs in the ALTREP parameter. I guess ALTREP was a way for Outlook and Notes to exchange rich comments as part of invitations sent via multipart MIME emails (with ALTREP pointing to CID URIs as described in the RFC).

You said the 'target audience uses Outlook’: How do you plan to deliver the iCalendar to the audience? By email, a subscribed calendars, iCloud? If it’s by email, crafting a multipart email might work for you.

As a small side note, Outlook itself stores up to three versions of the textfield internally (1) and keeps them in sync. (Depending on the store) RTF is the primary one, HTML an option to this, and it usually also stores a plaintext rendering alongside the rich formats. Which is why I’m surprised it doesn’t render the DESCRIPTION for you. Probably a bug in the Outlook exporter code.
(http://msdn.microsoft.com/en-us/library/office/cc839574(v=office.15).aspx is a good starting point if you are interested in this).

Summary: I think you are right, this is the proper RFC 5545 way to do what you want to do:

  DESCRIPTION:Hello World
  DESCRIPTION;FMTTYPE=text/html:<p>Hello <b>World</b></p>

But it is not yet going to produce the desired result in any of the major clients.

hh

(1) Right now few (none?) CalDAV clients support HTML descriptions.
(2) For any message type but notes - funny enough those can do RTF on Macs but only plaintext in Outlook, completely the reverse to contacts/calendars :-)

On May 6, 2014, at 10:21 PM, Tim Hare <[email-masked]> wrote:
> I am trying to build an .ics file which is standards compliant, using  a non-calendaring tool which will write into a directory on my (mainframe) server.   Ideally the description would contain HTML as it needs to contain some links. The target audience uses Outlook so I saved an Outlook appointment as an iCalendar file to see if there were any nuances I needed to worry about - and I discovered that the DESCRIPTION contains only '\n' and there is an X-ALT-DESC  property containing the HTML:
> -----------------------------------------------------------------------------------------------------------------------------------------
>       N">\n<HTML>\n<HEAD>\n<META NAME="Generator" CONTENT="MS Exchange Server ve
>       rsion 08.00.0681.000">\n<TITLE></TITLE>\n</HEAD>\n<BODY>\n<!-- Converted f
>       rom text/rtf format -->\n\n<P DIR=LTR><SPAN LANG="en-us"></SPAN><SPAN LANG
>       ="en-us"></SPAN><SPAN LANG="en-us"><FONT FACE="Calibri"></FONT></SPAN><SPA
>       N LANG="en-us"></SPAN><SPAN LANG="en-us"></SPAN><SPAN LANG="en-us">&nbsp\;
> --------------------------------------------------------------------------------------
>  
> Reading RFC 5545 I thought that DESCRIPTION;FMTTYPE=text/html:  was possible - but perhaps I read it wrong? Or is this a Microsoft-specific thing to allow Outlook to render HTML within an appointment / meeting?
>  
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify

---

From: "Tim Hare" <[email-masked]>
Date: Wed, 7 May 2014 08:37:43 -0400

I will read your MSDN reference, thanks for the tip.  I am "delivering" this
calendar by writing the .ics file .   The file will exist on the mainframe,
which runs an internal web server, making it accessible to those who want it
(similar to a ball team's published schedule). 

There's no user interaction, really - I am trying to use the .ics file to
organize references to reports which are produced daily, taking advantage of
the client's UI to provide a calendar interface that the users are already
familiar with.

Tim

-----Original Message-----
From: Helge Hess [mailto:[email-masked]] 
Sent: Wednesday, May 07, 2014 4:25 AM
To: Tim Hare
Cc: [email-masked]
Subject: Re: [calsify] Question re: DESCRIPTION and FMTTYPE

Hi Tim,

first: I would be surprised if Outlook does RFC 5545 for iCalendar or will
any time soon, it doesn't even do vCard 3.0 ...

> Reading RFC 5545 I thought that DESCRIPTION;FMTTYPE=text/html:  was
possible

interesting question - this is new in RFC 5545. Adding other-param and
thereby iana-param to DESCRIPTION now seems to allow FMTTYPE on DESCRIPTION.
https://tools.ietf.org/html/rfc5545#section-3.8.1.5

Hence the X-ALT-DESC workaround of Outlook to be able to directly embed HTML
descriptions in RFC 2445 . RFC 2445 didn't have FMTTYPE on DESCRIPTION
(https://tools.ietf.org/html/rfc2445#section-4.8.1.5).

I highly doubt that Outlook (or any other client) is going to resolve http
or file URIs in the ALTREP parameter. I guess ALTREP was a way for Outlook
and Notes to exchange rich comments as part of invitations sent via
multipart MIME emails (with ALTREP pointing to CID URIs as described in the
RFC).

You said the 'target audience uses Outlook': How do you plan to deliver the
iCalendar to the audience? By email, a subscribed calendars, iCloud? If it's
by email, crafting a multipart email might work for you.

As a small side note, Outlook itself stores up to three versions of the
textfield internally (1) and keeps them in sync. (Depending on the store)
RTF is the primary one, HTML an option to this, and it usually also stores a
plaintext rendering alongside the rich formats. Which is why I'm surprised
it doesn't render the DESCRIPTION for you. Probably a bug in the Outlook
exporter code.
(http://msdn.microsoft.com/en-us/library/office/cc839574(v=office.15).aspx
is a good starting point if you are interested in this).

Summary: I think you are right, this is the proper RFC 5545 way to do what
you want to do:

  DESCRIPTION:Hello World

But it is not yet going to produce the desired result in any of the major
clients.

hh

(1) Right now few (none?) CalDAV clients support HTML descriptions.
(2) For any message type but notes - funny enough those can do RTF on Macs
but only plaintext in Outlook, completely the reverse to contacts/calendars
:-)

and there is an X-ALT-DESC  property containing the HTML:
Server ve
Converted f
LANG="en-us">&nbsp\;
>  
> Reading RFC 5545 I thought that DESCRIPTION;FMTTYPE=text/html:  was
possible - but perhaps I read it wrong? Or is this a Microsoft-specific
thing to allow Outlook to render HTML within an appointment / meeting?

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 07 May 2014 10:18:23 -0400

Hi Helge,

--On May 7, 2014 at 10:24:53 AM +0200 Helge Hess 
<[email-masked]> wrote:

> (2) For any message type but notes - funny enough those can do RTF on
> Macs but only plaintext in Outlook, completely the reverse to
> contacts/calendars :-)
>

CalConnect has been working on trying to come up with a standards based 
approach to this: 
<http://tools.ietf.org/html/draft-douglass-calendar-extension-04>.

The proposed STYLED-DESCRIPTION property covers the case of rich text for 
the description. Comments on that spec are welcome...

-- 
Cyrus Daboo

---

From: Helge Hess <[email-masked]>
Date: Wed, 7 May 2014 16:53:16 +0200

On May 7, 2014, at 4:18 PM, Cyrus Daboo <[email-masked]> wrote:
> --On May 7, 2014 at 10:24:53 AM +0200 Helge Hess <[email-masked]> wrote:
> CalConnect has been working on trying to come up with a standards based approach to this: <http://tools.ietf.org/html/draft-douglass-calendar-extension-04>.
> 
> The proposed STYLED-DESCRIPTION property covers the case of rich text for the description. Comments on that spec are welcome...

Right, I'll come back to you on this in the CalConnect list.

I missed before that RFC 5545 now allows for FMTTYPE on DESCRIPTION (an unfortunate mistake?). Maybe for this forum, should draft-douglass-calendar-extension-04 revert that (add a SHOULD or MUST NOT?) and have a small section explaining on why DESCRIPTION+FMTTYPE should not be used (backwards compat, representation-syncing, etc).

hh