Subject: [calsify] draft-douglass-timezone-service-11: Include tzid in response?

From: Mike Douglass <[email-masked]>
Date: Mon, 14 Jul 2014 09:52:19 -0400

I've been taking another look at action=expand and the response. 
Currently we have it like this

  {
     "dtstamp": "2009-10-11T09:32:11Z",
     "observances": [
       {
         "name": "Standard",
         "onset": "2008-01-01T00:00:00",
         "utc-offset-from": -18000,
...

I think it would be helpful to have the tzid in the response making the 
data completely self describing.

---

From: Ken Murchison <[email-masked]>
Date: Mon, 14 Jul 2014 14:02:01 -0400

Hi Mike,

On 7/14/14, 9:52 AM, Mike Douglass wrote:
> I think it would be helpful to have the tzid in the response making 
> the data completely self describing.
>

So, I assume you are thinking of adding tzid before the observances 
array, correct?  I wouldn't have a problem with that.

-- 
Kenneth Murchison
Principal Systems Software Engineer
Carnegie Mellon University

---

From: Mike Douglass <[email-masked]>
Date: Mon, 14 Jul 2014 14:45:08 -0400

Yes - that was my thinking.